发起问题

steinuser53 的档案 - activity

2020-07-16 02:57:38 -0500 评论问题 Openstack Stein (OSA)

Also I don't know how significant it is but my leases file is not being populated so I could still be looking in the wrong place!!!

2020-07-16 02:55:50 -0500 评论问题 Openstack Stein (OSA)

So it seems (after a little more understanding) the requests are going out the br-vlan interface on the compute but I am not getting a reply, in dnsmasq logs I can see it and in dhcp logs. It just never reaches the compute. Any ideas or next step suggestions?

2020-07-15 04:38:53 -0500 评论问题 Openstack Stein (OSA)

Hi @Bernd as you can see from my answer below I have done a tcpdump on both sides. I have a "bad udp cksum" on the reply, have you any information relating to this? Please

2020-07-15 03:10:21 -0500 获得奖牌  粉丝
2020-07-06 10:54:38 -0500 获得奖牌  著名问题 (source)
2020-07-06 10:35:58 -0500 获得奖牌  编辑 (source)
2020-07-06 09:36:50 -0500 评论回答 Openstack Stein (OSA)

That's ok, yep I noticed you did that for me :) I changed the mode on the NIC but still not working. If I do get to the end of the issue I will post back and let you know or if I can narrow it down I might ask for some more advice. Thanks for the help so far

2020-07-06 07:38:06 -0500 评论回答 Openstack Stein (OSA)

Two other things I've seen in other answers that you might be able to shed some light on is, iptables not having the correct rules and the NIC not being in promiscuous mode, could either of those be the issue? Sorry for the randomness but I'm worried I'm focusing on the wrong thing

2020-07-06 07:38:06 -0500 获得奖牌  评论员
2020-07-06 07:26:41 -0500 评论回答 Openstack Stein (OSA)

Yep I find it weird, I can view the rabbitmq logs when I log into the container but I cannot locate the service to restart it, so I went back to my ansible config to make sure it was there and it is. I can see it opening connections with user 'nova' authenticated and granted access to vhost '/nova'

2020-07-06 04:57:15 -0500 评论问题 Openstack Stein (OSA)

Hi Bernd, ok I will look into that soon, I'm not too sure how/what to do at the moment but I'll do some reading on the tcpdump suggestion. Thanks

2020-07-06 04:49:40 -0500 评论回答 Openstack Stein (OSA)

Ok tnx I'll take a look into that as well, also I came across something just now that could well be the issue, rabbitmq is not running on the controller and I can't find the service running (I logged into the container but it's not there either) am I right in thinking it should be on the controller?

2020-07-06 03:48:18 -0500 评论回答 Openstack Stein (OSA)

DHCP: tag:tag0,option:classless-static-route,169.254.169.254/32,MY_PRIVATE_NETWORK_FIRST_ALLOCATED_IP,0.0.0.0/0,MY_PRIVATE_NETWORK_GATEWAY tag:tag0,249,169.254.169.254/32,MY_PRIVATE_NETWORK_FIRST_ALLOCATED_IP,0.0.0.0/0,MY_PRIVATE_NETWORK_GATEWAY tag:tag0,option:router,MY_PRIVATE_NETWORK_GATEWAY

2020-07-06 03:47:59 -0500 评论回答 Openstack Stein (OSA)

Sorry I can't add another answer: DHCP - DHCP configuration for ports set([u'6a48a683-c1e3-4eba-848c-53efe1450eae']) is completed. fixed_ips=[{u'subnet_id': u'0a917da2-3446-47a0-b66d-72c572120daa', u'ip_address': u'MY_PRIVATE_IP'}],

2020-07-06 03:45:22 -0500 评论回答 Openstack Stein (OSA)

Hi eblock, yes DHCP is enabled on the subnet. I have checked the dhcp logs and the dnsmasq logs and both look to me like they are handing out the address. I will attach the output below. What I haven't done yet is use tcpdump, I'm not really sure how to do that but I will look it up today.

2020-07-05 15:27:20 -0500 评论回答 Openstack Stein (OSA)

Hi eblock, when I ran that (before signing up) it shows no routes at all. As I said, I have spent a long time trying to resolve this so I have tried a lot, as a last resort I thought I'd reach out here for some help. Thanks

2020-07-05 15:27:20 -0500 评论问题 Openstack Stein (OSA)

Also the dnsmasq logs show that the IP address is given out (also seen on the horizon dashboard) but the instance has no IP address configured when I log into it. I'm not very experienced with it but from all the logs I've been looking at it looks like it's all working fine

2020-07-05 15:27:20 -0500 评论问题 Openstack Stein (OSA)

Hi Bernd, when I say they have no IP address I'm talking about the instances that I spin up. The controller has it's management IP and if I replace 169.254.169.254 with the management IP of my controller then the curl command works fine from both compute nodes.

2020-07-05 13:44:17 -0500 获得奖牌  热门的问题 (source)
2020-07-04 23:06:04 -0500 获得奖牌  受欢迎的问题 (source)
2020-07-03 09:00:01 -0500 回答问题 Openstack Stein (OSA)

Hi eblock, my apologies for the lack of information, I have now updated my question and thanks for the reply. Yes I've been searching for days now and all the posts where it has been resolved I have checked my config and it was already there.

+--------------------------------------+--------------------+------------------------+-------------------+-------+-------+------------------------
---+
| ID                                   | Agent Type         | Host                   | Availability Zone | Alive | State | Binary                    |
+--------------------------------------+--------------------+------------------------+-------------------+-------+-------+---------------------------+
| 091349c2-6bae-41d5-92fb-9eb832217788 | Metering agent     | cloud2020l4-controller | None              | :-)   | UP    | neutron-metering-agent    |
| 17aed236-8e91-4dd1-9212-aa751ef6790a | Metadata agent     | cloud2020l4-controller | None              | :-)   | UP    | neutron-metadata-agent    |
| 1d108d6c-42e5-439d-8dbc-ed0b21d61cd5 | L3 agent           | cloud2020l4-controller | nova              | :-)   | UP    | neutron-l3-agent          |
| 4c5c7fa0-7be9-4561-908d-d393068a4af9 | Linux bridge agent | cloud2020l4-compute1   | None              | :-)   | UP    | neutron-linuxbridge-agent |
| 54c79dbb-2807-4183-bfa7-1bf24121ce46 | Linux bridge agent | cloud2020l4-compute2   | None              | :-)   | UP    | neutron-linuxbridge-agent |
| 85aa94d3-b1a8-47bd-9bc2-d5a6352ebfb3 | DHCP agent         | cloud2020l4-controller | nova              | :-)   | UP    | neutron-dhcp-agent        |
| e269d937-30b5-4883-acda-938db426dccd | Linux bridge agent | cloud2020l4-controller | None              | :-)   | UP    | neutron-linuxbridge-agent |
+--------------------------------------+--------------------+------------------------+-------------------+-------+-------+---------------------------+

DHCP

DHCP configuration for ports set([u'6a48a683-c1e3-4eba-848c-53efe1450eae']) is completed. fixed_ips=[{u'subnet_id': u'0a917da2-3446-47a0-b66d-72c572120daa', u'ip_address': u'MY_PRIVATE_IP'}],
tag:tag0,option:classless-static-route,169.254.169.254/32,MY_PRIVATE_NETWORK_FIRST_ALLOCATED_IP,0.0.0.0/0,MY_PRIVATE_NETWORK_GATEWAY tag:tag0,249,169.254.169.254/32,MY_PRIVATE_NETWORK_FIRST_ALLOCATED_IP,0.0.0.0/0,MY_PRIVATE_NETWORK_GATEWAY tag:tag0,option:router,MY_PRIVATE_NETWORK_GATEWAY

Update:

I have compared my install to a fellow colleagues install (he didn't use ansible, we are testing at the moment) in /var/lib/neutron/dhcp/ID/leases he has an entry for every instance he has spun up through horizon, my leases file is empty so maybe this might help in pointing to my issue, I will investigate a bit more in the morning but if anyone has any advice I'd appreciate it.

TCPDUMP (compute br-vlan)

09:25:04.458939 fa:16:3e:06:c4:13 > ff:ff:ff:ff:ff:ff, ethertype 802.1Q (0x8100), length 346: vlan 441, p 0, ethertype IPv4, (tos 0x0, ttl 64, id 0, offset 0, flags [none], proto UDP (17), length 328)
0.0.0.0.68 > 255.255.255.255.67: [udp sum ok] BOOTP/DHCP, Request from fa:16:3e:06:c4:13, length 300, xid 0xf93c270d, secs 121, Flags [none] (0x0000)
  Client-Ethernet-Address fa:16:3e:06:c4:13
  Vendor-rfc1048 Extensions
    Magic Cookie 0x63825363
    DHCP-Message Option 53, length 1: Discover
    Client-ID Option 61, length 7: ether fa:16:3e:06:c4:13
    MSZ Option 57, length 2: 576
    Parameter-Request Option 55, length 9: 
      Subnet-Mask, Default-Gateway, Domain-Name-Server, Hostname
      Domain-Name, MTU, BR, NTP
      Classless-Static-Route
    Vendor-Class Option 60, length 12: "udhcp 1.29.3"
    Hostname Option 12, length 6: "cirros"

TCPDUMP (controller lxcbr0 & nova-api-container eth0)

09:24:21.715134 fe:05:91:48:23:de > 00:16:3e:0e:fb:39, ethertype IPv4 (0x0800), length 342: (tos 0xc0, ttl 64, id 32644, offset 0, flags [none], proto UDP (17), length 328)
10.0.3.1.67 > 10.0.3.230.68: [bad udp cksum 0x1c2c -> 0x9d6c!] BOOTP/DHCP, Reply, length 300, xid 0x5463e7c8, secs 11797, Flags [none] (0x0000)
  Client-IP 10.0.3.230
  Your-IP 10.0.3.230
  Server-IP 10.0.3.1
  Client-Ethernet-Address 00:16:3e:0e:fb:39
  Vendor-rfc1048 Extensions
    Magic Cookie 0x63825363
    DHCP-Message Option 53, length 1: ACK
    Server-ID Option 54, length 4: 10.0.3.1
    Lease-Time Option 51, length 4: 3600
    RN Option ...
(more)
2020-07-03 07:32:02 -0500 问了问题 Openstack Stein (OSA)

Instances do not get an IP address and can't connect to htp://169.254.169.254

Sorry, some more info.

I have installed openstack stein on 3 dell servers (1 controller ad 2 computes) using ansible. I log into the horizon dashboard and create a network, subnet etc (also done from cli) which all goes fine and I can list them from the cli. When I spin up an instance (cirros) it spins up fine and is assigned an IP address (I can see this in horizon and the dhcp and dnsmasq logs) but when I log into the instance it has no IP address and in the logs on horizon it says the following:

checking http://169.254.169.254/2009-04-04/instance-id (http://169.254.169.254/2009-04-04/ins...) failed 1/20: up 0.73. request failed failed 2/20: up 12.75. request failed failed 3/20: up 24.76. request failed

I have checked (from reading other posts) enable_isolated_metadata in dhcp_agent.ini and this is set to true. Also in l3_agent.ini enable_metadata_proxy = True.

If I curl to http://169.254.169.254/ from either compute it fails, but if I replace 169.254.169.254 with the IP address of my controller it works fine. I have also confirmed that all the services are up and running

I have tried almost everything and this is also my first deploy of openstack so I might have overlooked something. Any advice would be appreciated