发起问题

Daryl 的档案 - activity

2020-09-02 23:49:36 -0500 获得奖牌  著名问题 (source)
2020-06-01 02:00:55 -0500 获得奖牌  著名问题 (source)
2020-05-10 05:12:21 -0500 获得奖牌  著名问题 (source)
2020-05-10 03:32:00 -0500 获得奖牌  热门的问题 (source)
2020-04-25 14:54:47 -0500 获得奖牌  著名问题 (source)
2020-04-22 06:13:30 -0500 获得奖牌  热门的问题 (source)
2020-04-22 06:13:30 -0500 获得奖牌  受欢迎的问题 (source)
2020-01-13 00:04:07 -0500 获得奖牌  受欢迎的问题 (source)
2020-01-07 10:05:59 -0500 评论问题 cannot remove host from aggregate

Thanks! That looks really useful.

2020-01-06 13:57:55 -0500 评论问题 cannot remove host from aggregate

My error.log file has one line in it. And just to make sure I'm looking in the right place, the log files are in /opt/stack/log. This bothers me because none of the files there have a data of today, except for dstat-csv.log. OS_USERNAME, OS_TENANT_NAME, and OS_PROJECT_NAME are all "admin".

2020-01-06 11:56:18 -0500 问了问题 cannot remove host from aggregate

This is on Stein. I had two aggregates and deleted one; now I can't delete the other, because I can't remove the host from it:

stack@devstack:~/devstack$ openstack aggregate list
+----+------+-------------------+
| ID | Name | Availability Zone |
+----+------+-------------------+
|  2 | agg2 | AZ2               |
+----+------+-------------------+
stack@devstack:~/devstack$ openstack aggregate show agg2
+-------------------+----------------------------+
| Field             | Value                      |
+-------------------+----------------------------+
| availability_zone | AZ2                        |
| created_at        | 2019-12-19T17:11:17.000000 |
| deleted           | False                      |
| deleted_at        | None                       |
| hosts             | [u'compute-01']            |
| id                | 2                          |
| name              | agg2                       |
| properties        |                            |
| updated_at        | None                       |
+-------------------+----------------------------+
stack@devstack:~/devstack$ openstack aggregate remove host agg2 compute-01
Cannot remove host compute-01 in aggregate 2 (HTTP 404) (Request-ID: req-0c968aa5-d16a-41d7-ada7-46e165d17905)
stack@devstack:~/devstack$ openstack compute service list
+----+------------------+------------+----------+---------+-------+----------------------------+
| ID | Binary           | Host       | Zone     | Status  | State | Updated At                 |
+----+------------------+------------+----------+---------+-------+----------------------------+
|  2 | nova-scheduler   | devstack   | internal | enabled | up    | 2020-01-06T17:36:05.000000 |
|  4 | nova-consoleauth | devstack   | internal | enabled | up    | 2020-01-06T17:36:14.000000 |
|  6 | nova-conductor   | devstack   | internal | enabled | up    | 2020-01-06T17:36:09.000000 |
|  1 | nova-conductor   | devstack   | internal | enabled | up    | 2020-01-06T17:36:08.000000 |
|  2 | nova-compute     | devstack   | nova     | enabled | up    | 2020-01-06T17:36:07.000000 |
|  3 | nova-compute     | compute-01 | AZ2      | enabled | up    | 2020-01-06T17:36:09.000000 |
+----+------------------+------------+----------+---------+-------+----------------------------+

"openstack server list" returns empty, so I know the instance that was running on compute-01 is no more. Searching on this problem returned some older issues that were resolve using direct database queries, which I am not afraid of, but it seems this should be simpler. Any help would be appreciated.

2019-12-31 06:47:49 -0500 获得奖牌  热门的问题 (source)
2019-12-18 20:48:31 -0500 获得奖牌  著名问题 (source)
2019-12-11 13:02:21 -0500 获得奖牌  热门的问题 (source)
2019-12-05 11:12:56 -0500 问了问题 Stein not a valid heat_template_version

I finally have a working All-in-one Stein installation complete with Heat (which I need to study at some detail. On my first "create stack" I got an error on the template version:

$ openstack stack create -t basic_1.yaml basic_1 ERROR: The template version is invalid: "heat_template_version: 2019-12-05". "heat_template_version" should be one of: 2013-05-23, 2014-10-16, 2015-04-30, 2015-10-15, 2016-04-08, 2016-10-14, 2017-02-24, 2017-09-01, 2018-03-02, 2018-08-31, newton, ocata, pike, queens, rocky

I understand the overall purpose of this, but I'm curious why "stein" is not at the end of the list, since it's a stable/stein installation.

2019-12-03 15:38:11 -0500 获得奖牌  热门的问题 (source)
2019-12-03 15:07:54 -0500 回答问题 Fixing Nova configuration (Devstack)

I found a five year old post where someone had resolved a nova-compute problem by allocating more RAM to his virtual host. If I'd only known that six weeks ago. :)

Thanks to all the people who have helped me learn a lot about Devstack and OpenStack installation. Just remember: 8GB RAM is better than 4.

2019-12-03 11:47:24 -0500 评论问题 Fixing Nova configuration (Devstack)

And further back up the journalctl display I found this:

ProgrammingError: (pymysql.err.ProgrammingError) (1146, u"Table 'nova_cell0.services' doesn't exist")

And then further still, after a lot of DEBUG lines this:

AMQP server on 192.168.2.192:5672 is unreachable: Too many heartbeats

2019-12-03 11:39:16 -0500 评论问题 Fixing Nova configuration (Devstack)

I changed four files in /etc/nova to reference 'controller' instead of '127.0.0.1'. Now at the end of ./stack.sh, I get "g-api did not start and a series of "Service N could not be found", where N is a small integer. "openstack service list" does not show nova-compute. Where should I look next?

2019-12-03 10:42:50 -0500 问了问题 Fixing Nova configuration (Devstack)

I've been struggling getting Devstack to run to completion, both Stein and Rocky. Yesterday I discovered "journalctl" and it tells me that I'm having trouble with DBConnection using 127.0.0.1 as the address.

ERROR nova.servicegroup.drivers.db DBConnectionError: (pymysql.err.OperationalError) (2003, "Can't connect to MySQL server on '127.0.0.1'

When I was trying to install every component by hand, the connection was always to the named host ("controller"), so this is surprising to me. What's the best way to fix this (if in fact, it's fixable)?

2019-11-28 10:10:44 -0500 获得奖牌  受欢迎的问题 (source)
2019-11-28 06:49:07 -0500 获得奖牌  著名问题 (source)
2019-11-27 11:16:25 -0500 评论问题 Devstack Stein install fails

Here is the final several lines of the install:

http://paste.openstack.org/show/786814/

I will now dig into the logs and see if there is anything I can decipher there.

2019-11-27 11:07:43 -0500 评论问题 Devstack Stein install fails

Thanks. I had unsuccessfully tried a regular clone followed by checkout. So with this attempt, after about 45 minutes of installation, I got this:

http://paste.openstack.org/show/786812/

The sequence above is followed by an "openstack flavor create..." which is not complete after ten minutes.

2019-11-26 11:29:10 -0500 评论问题 Devstack Stein install fails

After the log full message I got this:

Error on exit
nova-compute: no process found
neutron-dhcp-agent: no process found
neutron-l3-agent: no process found
neutron-metadata-agent: no process found
neutron-openvswitch-agent: no process found
2019-11-26 10:20:35 -0500 问了问题 Devstack Stein install fails

I have been struggling to get a Stein installation working (minimal, Cinder, Senlin, and Heat), and yesterday I tried using Devstack. That also failed, with some odd messages:

  1. Two occurrences of "More than one SecurityGroup exists with the name 'default'."

  2. stack.sh failed: full log in /opt/stack/logs/stack.sh.log.2019-11-25-223447 I have over 9 GB available on the drive; how can a log file be full?

To make sure I got Stein functionality, I started the process with this:

 $ git clone https://git.openstack.org/openstack-dev/devstack
 $ cd devstack
 $ git checkout stable/stein

To be clear, I'm not married to Stein, but I want something stable and recent that I can experiment with.

I know Devstack's purpose is to get the current state of the repository, but I was hoping that I could do the above to get a recent stable release. Is that not the case? If Devstack does not propagate the "stable/stein" parameter to its own cloning operations, I will end up with a mix of versions and I wouldn't expect it to work as I wanted.

I have attached my local.conf file here: http://paste.openstack.org/show/786736/

2019-11-26 10:00:28 -0500 获得奖牌  热门的问题 (source)
2019-11-25 12:24:25 -0500 评论回答 "openstack cluster ..." commands not found after Senlin installed

I've been putting out other fires, and I'm now back on this. python-senlinclient installed with no reported problems. I have a console running senlin-api and one running senlint-engine. I ran 'openstack help cluster' and got 'Unknown command ['cluster']' for response.

2019-11-22 02:18:43 -0500 获得奖牌  热门的问题 (source)
2019-11-21 11:45:34 -0500 回答问题 Keystone not available after Cinder install

I"m putting this in an answer because the character count limit on comments is too low.

I'm convinced I have an authentication problem and I'm worried it's because of domain name. When I created the 'cinder' user it was with '--domain default'. When I list my domains I have a domain with ID = 'default' and name = 'Default'. So my questions are:

  1. Is domain name matching case sensitive?
  2. Is domain name matching on the name or the ID?
  3. Should I be looking elsewhere?
  4. Can I coerce Keystone into telling me exactly why the authentication failed?
2019-11-21 11:19:50 -0500 评论问题 Keystone not available after Cinder install

So it looks like an authentication error, not an availability problem?

2019-11-21 11:19:22 -0500 评论问题 Keystone not available after Cinder install

2019-11-21 17:17:28.583 1877 WARNING keystone.server.flask.application [req-6c45f877-5a30-42a3-af03-b895db3dadb0 - - - - -] Authorization failed. The request you have made requires authentication. from 192.168.56.3: keystone.exception.Unauthorized: The request you have made requires authentication.

2019-11-21 10:57:56 -0500 评论问题 Keystone not available after Cinder install

Thanks. Now I have a trail to follow. The actually helpful log file is cinder-scheduler.log (cinder-api.log doesn't exist). It points me to an "OperationalError" with a reference to http://sqlalche.me/e/e3q8. I also have a warning that controller@lvm is down, so I guess that's two trails.

2019-11-20 12:43:55 -0500 获得奖牌  受欢迎的问题 (source)
2019-11-20 10:50:03 -0500 评论问题 Keystone not available after Cinder install

$ openstack user list $ openstack service list $ openstack role list

This works (empty list returned): $ openstack volume list

But this fails: $ openstack volume service list

I pasted the output of $ openstack --debug volume service listhere: http://paste.openstack.org/show/786438/

2019-11-20 10:42:33 -0500 评论问题 Keystone not available after Cinder install

I ran $ sudo grep auth_url sudo find /etc -name "*.conf"and all the auth_url entries are identical: http://controller:5000/v3. This matches OS_AUTH_URL in my environment. I can't find a list of Keystone commands, but the following all work correctly: (To be continued...)

2019-11-19 16:05:03 -0500 评论回答 Keystone not available after Cinder install

I made them all end in /v3, because the Verify step in the Keystone install guide included it. The bothersome part is the comment in keystone.conf to the effect that that part of the URL appears to be ignored, or at least that's what I saw on first reading. Thanks for the help; I am continuing.

2019-11-19 16:00:49 -0500 评论回答 Keystone not available after Cinder install

Keystone V3, http. openstack-cinder-api.service and openstack-cinder.scheduler.service are not found, but "cinder.scheduler.service" is. The auth_url question was bothersome. The various config files had a mix: http://controller:5000 and http://controller/v3. (to be continued...)

2019-11-19 10:41:50 -0500 问了问题 Keystone not available after Cinder install

When I install Cinder (Stein release) all goes well until I get to the verify step:

openstack volume service list

That command reports that "The Keystone service is temporarily unavailable." and that I should try again later. I have verified everything I can think of (spelling, capitalization, etc.) in the config files and installation commands. I've also run the same command with the --debug option and captured the output, and I've looked at that until my eyes defocus. I've reviewed several other "Keystone service unavailable" posts, but none of them seem to have any bearing on my symptoms.

Any suggestions would be appreciated. If someone would like to see the captured output, I'd be glad to post it, but it's 23KB and the attachment feature on this forum won't accept anything but image files.

2019-11-19 03:45:15 -0500 获得奖牌  受欢迎的问题 (source)
2019-11-15 13:38:47 -0500 获得奖牌  受欢迎的问题 (source)
2019-11-05 13:18:39 -0500 问了问题 "openstack cluster ..." commands not found after Senlin installed

After installing Senlin into a Stein stack, and launching senlin-engine and senlin-api in their own consoles, none of the "openstack cluster ..." commands work. I get a response proposing alternative commands:

$ openstack cluster list
openstack: 'cluster list' is not an openstack command. See 'openstack --help'.
Did you mean one of these?
  consumer create
  consumer delete
  consumer list
  consumer set
  consumer show

Where would be the best place to start looking for the cause of this?