发起问题

ZCTZ 的档案 - activity

2020-05-13 10:54:27 -0500 获得奖牌  著名问题 (source)
2019-10-15 03:23:15 -0500 获得奖牌  著名问题 (source)
2019-07-02 09:55:07 -0500 获得奖牌  热门的问题 (source)
2019-07-02 09:55:07 -0500 获得奖牌  热门的问题 (source)
2019-07-01 14:20:51 -0500 获得奖牌  热门的问题 (source)
2019-07-01 03:39:05 -0500 获得奖牌  受欢迎的问题 (source)
2019-06-27 10:29:53 -0500 问了问题 flavors table in nova_api empty

Hello,

I am working through the install of Stein for my own personal education and I got Horizon installed and when I go to create an instance I noticed that the flavors table in nova_api is empty. I saw there is another post about the flavors table being empty but I haven't been able to figure out why mine is empty in my case. Also if that table is empty incorrectly are other tables also empty incorrectly?

Is there a way to find out why the "nova-manage api_db sync" command isn't working in my case?

There is nothing in nova-manage.log when I run nova-manage api_db sync

2019-06-27 10:29:53 -0500 评论回答 No credentials specified for placement API in nova.conf

I added info to the post any more advice is appreciated.

2019-06-27 09:04:32 -0500 获得奖牌  受欢迎的问题 (source)
2019-06-26 13:04:35 -0500 问了问题 No credentials specified for placement API in nova.conf

Hello, I was following these instructions on setting up Nova:

https://docs.openstack.org/nova/latest/install/verify.html (https://docs.openstack.org/nova/lates...)

When I run:

nova-status upgrade check

It says:

+-------------------------------------------------------------------+ | Upgrade Check Results | +-------------------------------------------------------------------+ | Check: Cells v2 | | Result: Success | | Details: None | +-------------------------------------------------------------------+ | Check: Placement API | | Result: Failure | | Details: No credentials specified for placement API in nova.conf. | +-------------------------------------------------------------------+ | Check: Ironic Flavor Migration | | Result: Success | | Details: None | +-------------------------------------------------------------------+ | Check: Request Spec Migration | | Result: Success | | Details: None | +-------------------------------------------------------------------+ | Check: Console Auths | | Result: Success | | Details: None | +-------------------------------------------------------------------+

In nova.conf on both the controller and the compute node I have [placement] configured. Does anyone know WHAT EXACTLY that error is telling me to do? this has been driving me a bit crazy.

Details: No credentials specified for placement API in nova.conf.

thanks

Update:

Is that message talking about the configuration on the controller node or the compute node?

Also in /etc/nova/nova.conf on the controller node I have:

[placement]
os_region_name = RegionOne
project_domain_name = Default
project_name = service
user_domain_name = Default
password = removedbutdoesntmatteranyway
username = placement
auth_url = http://controller:5000/v3
auth_type = password

In /etc/placement/placement.conf on the controller node I have:

auth_strategy = keystone

[keystone_authtoken]
auth_url = http://controller:5000/v3
memcached_servers = controller:11211
auth_type = password
project_domain_name = Default
user_domain_name = Default
project_name = service
username = placement
password = removedbutdoesntmatteranyway

anyone know what else I can check or look at???