发起问题

marcus.frenkel 的档案 - activity

2020-09-02 13:02:30 -0500 获得奖牌  著名问题 (source)
2020-04-14 04:26:55 -0500 获得奖牌  著名问题 (source)
2019-05-20 01:30:43 -0500 获得奖牌  热门的问题 (source)
2019-05-20 01:29:58 -0500 获得奖牌  热门的问题 (source)
2019-05-15 17:55:13 -0500 评论问题 DHCP to assign IP address with a netmask of 255.255.255.255

@Bernd Bausch, unfortunately, the /32 mask does not work in all OSs. For instance, cirros loses connection with this kind of IP config.

2019-05-15 17:53:18 -0500 评论问题 DHCP to assign IP address with a netmask of 255.255.255.255

@Bernd Bausch, thanks a lot. I added "dhcp-option=1,255.255.255.255" in a custom config file - instances get /32 mask now. Problem: how to add option for broadcast address as the last address without specifying the exact address?

2019-05-14 06:24:56 -0500 获得奖牌  粉丝
2019-05-12 17:14:05 -0500 问了问题 DHCP to assign IP address with a netmask of 255.255.255.255

The VPSs provided by the hosting providers OVH and Hetzner have IP with a netmask of 255.255.255.255 assigned by DHCP. Both providers use Openstack.

I assume they do that to: a) prevent broadcast storms caused by large broadcast domains and b) prevent users to scan the same L2 broadcast domain for neighbor hosts.

My goal is to create a /24 network in Openstack and still have the DHCP assign IP to instances with broadcast address same as the IP and a netmask of 255.255.255.255. If instances need to communicate between them, they should be able to do that over L3, meaning through the gateway.

Does someone know how to do it with Openstack?

In Hyper-V this could be achieved with PVLAN feature, which similarly to the way it works on physical switches, creates an environment where VMs may only interact with the Internet and not have visibility for neighbor VMs.

2019-05-12 16:50:19 -0500 获得奖牌  受欢迎的问题 (source)
2019-05-12 15:28:29 -0500 获得奖牌  学者 (source)
2019-05-12 15:28:21 -0500 回答问题 Network interface could not be raised for external network of vlan/flat type

I found a solution in a post on ask.cloudbase.it. The controller node was installed in Hyper-V VM. I enabled MAC address spoofing in Hyper-V VM settings for the second interface which is the provider interface for the controller node. Without this option enabled, there was no communication between the provider interfaces on the controller and compute node, preventing DHCP agent to deliver IP for the instance.

2019-05-11 07:02:53 -0500 获得奖牌  编辑 (source)
2019-05-11 07:01:49 -0500 问了问题 Network interface could not be raised for external network of vlan/flat type

I installed Openstack on Ubuntu Server 18.04.2 LTS following the official manual for Queens. The network service is configured for Self-service networks. My setup involves one controller and one compute node, each with two network interfaces, one used as management and the other as provider interface. I use horizon for configuration.

What I need is to have public fixed IPs assigned to instances, allowing them to have Internet connectivity through gateway set on the external physical network. I also need public floating IPs for some instances, in addition to the public fixed IPs. I do not need private IPs/network for projects/instances. The reason why I decided for the Self-service network option is to benefit from the floating IPs feature.

The last physical switch port facing the provider interface on the compute node is configured as access (not trunk).

I created a network in the Admin section, with these parameters:

  • Project: Test Project
  • Provider Network Type: flat
  • Physical Network: provider
  • Enable Admin State: checked
  • Shared: checked
  • External Network: checked
  • Create Subnet: checked
  • Network Address: X.X.X.X/24
  • Gateway IP: The gateway IP set on external physical router
  • Enable DHCP: checked
  • DNS Name Servers: Y.Y.Y.Y

I created an image with official Debian cloud image for Openstack, specifically this one.

I launched an instance with above network and image. The problem is that the network interface could not be raised. From the log: Starting Raise network interfaces... A start job is running for Raise network interfaces (30s / 5min 1s)

The same issue happens if I create a network of type "vlan", using specific VLAN tag (Segmentation ID), as well as using trunk port type with the VLAN tag passed on the physical switch port facing the provider interface on the compute node.

However, if I create the network from the project section, in which case there is no option to select "Provider Network Type" and "Physical Network", then when I boot the instance with this network and image specified above the interface is raised and a fixed IP and route to the gateway is setup in debian. There is no connectivity to external network (Internet) with this setup though, because the network is not setup as external, but I did it just to test if the interface will be raised.

Any help?

2019-05-10 14:47:16 -0500 获得奖牌  拥护者 (source)
2019-05-09 05:56:06 -0500 获得奖牌  受欢迎的问题 (source)
2019-05-05 23:44:17 -0500 获得奖牌  学生 (source)
2019-05-04 12:03:02 -0500 评论问题 Openstack install on Ubuntu Server 18.04.2 LTS installs rocky version instead of queens

@Bernd Bausch, you are right, I actually thought I'm looking at this page https://docs.openstack.org/releasenotes/python-openstackclient/ (https://docs.openstack.org/releasenot...) to map the cloud's Openstack release. Great mistake, sorry to take your time!

2019-05-04 11:02:34 -0500 问了问题 Openstack install on Ubuntu Server 18.04.2 LTS installs rocky version instead of queens

My goal was to install Openstack Queens on 18.04.2 LTS (Bionic Beaver).

The openstack install https://docs.openstack.org/install-guide/environment-packages-ubuntu.html (guide) points that OpenStack Queens is available directly using Ubuntu 18.04 LTS without having to enable the Ubuntu Cloud Archive repository. The Ubuntu Cloud Archive https://wiki.ubuntu.com/OpenStack/CloudArchive (page) also points that Bionic Beaver includes Queens by default.

With that in mind, I did this:

  1. Installed Ubuntu Server 18.04.2 LTS.
  2. Setup network and installed NTP services.
  3. Installed openstack client with these commands:
  4. apt update && apt dist-upgrade
  5. apt install python-openstackclient
  6. I purposelessly did not add cloud archive to the repository, expecting that Openstack Queens will be installed by default.

After installation I run Openstack --version to find out the version is 3.14.2, which https://docs.openstack.org/puppet-openstack-guide/latest/install/releases.html (maps) to Openstack Rocky.

I do not explicitly mind Rocky over Queens, but I already undergo the entire Openstack installation (keystone, glance, nova, neutron, horizon) based on Queens guide, only to find at the very end that the Openstack version is actually Rocky.

Is something changed in the Ubuntu 18.04.2 LTS that includes Rocky instead of Queens release, as stated on the download https://www.ubuntu.com/download/server (page)?