发起问题

VarunNair 的档案 - activity

2020-05-21 06:29:06 -0500 获得奖牌  受欢迎的问题 (source)
2020-05-21 06:29:06 -0500 获得奖牌  著名问题 (source)
2020-05-21 06:29:06 -0500 获得奖牌  热门的问题 (source)
2020-02-21 07:14:10 -0500 评论问题 vxlan peers not being created on compute node (vm not getting dhcp)

Hi, I am getting a similar issue (no VXLAN peer created in controller/network node, whereas it was present in the compute node) with kolla-ansible rocky release. This happens The IPs started getting assigned after I restarted the neutron-openvswitch-agent in the controller node.

2018-12-04 09:05:26 -0500 评论问题 Get meters SDN with Ceilometer and gnocchi Openstack Queens

Hi, I have the same question but could not find any helpful resources for this. Have you been able to figure out the solution ? Thanks.

2018-11-26 11:37:50 -0500 评论回答 Neutron net-create: Unable to create the network. No tenant network is available for allocation.

Yes, same mistake here

2018-11-26 11:37:49 -0500 评论问题 Keystone error : CRITICAL keystone [-] NoSuchModuleError: Can't load plugin: sqlalchemy.dialects:ql.pymysql

Hi I am getting the same module error with Queens release. How to solve this ?

2018-11-26 11:37:49 -0500 评论问题 Problem installation Keystone(queens)

Hi, as per the Queens installation guide in https://docs.openstack.org/keystone/q..., OS_AUTH_URL=http://controller:5000/v3. Did you try setting this option ?

2018-11-26 11:37:48 -0500 问了问题 Keystone issue (HTTP 500)- Queens release

Hi all, I am new to Openstack and attempting a manual installation of Queens release on Ubuntu 16.04 LTS. I am following the installation guide at https://docs.openstack.org/install-gu.... I have been able to setup the environment, i.e. install and configure etcd, mariadb, memcached, etc.

I was trying to install the keystone service based on the instructions in https://docs.openstack.org/keystone/q.... In the next page, after running the command:

$ openstack domain create --description "An Example Domain" example

I get an error:

An unexpected error prevented the server from fulfilling your request. (HTTP 500) (Request-ID: req-12285842-14d8-45d4-9b31-8573482856e3)

I have seen existing posts in the forum (such as https://ask.openstack.org/en/question... and https://ask.openstack.org/en/question... ) about a similar error but I haven't found a clear solution. Moreover, the root cause in my case may be different based on the error logs I observed. I checked keystone-wsgi-public.log and here is a brief output:

2018-07-18 15:46:04.919 8678 INFO keystone.common.wsgi [req-5e68136c-6c75-4bd7-af06-4c559b5c584b - - - - -] GET http://controller:5000/v3/
2018-07-18 15:46:04.933 8677 INFO keystone.common.wsgi [req-6a85f472-f4f3-4e2d-a1dc-69e86148f2ee - - - - -] POST http://controller:5000/v3/auth/tokens
2018-07-18 15:46:04.941 8677 ERROR keystone.common.wsgi [req-6a85f472-f4f3-4e2d-a1dc-69e86148f2ee - - - - -] Can't load plugin: sqlalchemy.dialects:mysql.pymsql: NoSuchModuleError: Can't load plugin: sqlalchemy.dialects:mysql.pymsql
2018-07-18 15:46:04.941 8677 ERROR keystone.common.wsgi   File "/usr/lib/python2.7/dist-packages/keystone/common/wsgi.py", line 226, in __call__
2018-07-18 15:46:04.941 8677 ERROR keystone.common.wsgi     result = method(req, **params)
2018-07-18 15:46:04.941 8677 ERROR keystone.common.wsgi   File "/usr/lib/python2.7/dist-packages/keystone/auth/controllers.py", line 113, in authenticate_for_token
    2018-07-18 15:46:04.941 8677 ERROR keystone.common.wsgi     auth_info = core.AuthInfo.create(auth=auth)
...
...

It seems that the plugin "sqlalchemy.dialects:mysql.pymsql" could not be loaded.

Could anyone point out the reason for this issue and any suggestion to resolve it ?

Thanks

2018-11-14 07:49:32 -0500 获得奖牌  老师 (source)
2018-11-14 07:46:25 -0500 回答问题 OpenStack networking option

Although Option 1 is the least complex networking option, since all L3 (and above) services are outside the Openstack enviroment, Option 2 gives you the most flexibility since it augments Option 1 and allows both self-service and provider network creation. See the note given in the: https://docs.openstack.org/neutron/queens/install/controller-install-ubuntu.html#configure-networking-options (Openstack documentation (Queens)), which says "Option 2 also supports attaching instances to provider networks".

In terms of manually installation steps, there is not much difference in complexity in the two options. So I would recommend going for Option 2.

2018-11-14 03:44:33 -0500 获得奖牌  粉丝
2018-11-13 06:34:11 -0500 回答问题 gnocchi 500 internal server error

I faced the same 500 Internal Server Error, as posted above, for the same platform :Openstack Queens multi-node setup on Ubuntu 16.04.4 LTS. Gnocchi version: 4.2.4.

The Apache logs for gnocchi-api (/var/log/apache2/gnocchi_error.log) showed a Python import error:

root@OSControllerTest:/home/osctest# tail -f /var/log/apache2/gnocchi_error.log
2018-11-13 11:17:25.590909 Traceback (most recent call last):
2018-11-13 11:17:25.591242   File "/usr/bin/gnocchi-api", line 20, in <module>
2018-11-13 11:17:25.592009     from gnocchi.cli import api
2018-11-13 11:17:25.592167 ImportError: No module named gnocchi.cli
2018-11-13 12:49:21.263089 mod_wsgi (pid=2049): Target WSGI script '/usr/bin/gnocchi-api' cannot be loaded as Python module.
2018-11-13 12:49:21.263512 mod_wsgi (pid=2049): Exception occurred processing WSGI script '/usr/bin/gnocchi-api'.
2018-11-13 12:49:21.263560 Traceback (most recent call last):
2018-11-13 12:49:21.263605   File "/usr/bin/gnocchi-api", line 20, in <module>
2018-11-13 12:49:21.263762     from gnocchi.cli import api
2018-11-13 12:49:21.263823 ImportError: No module named gnocchi.cli

The import issue was resolved by installing the python-gnocchi package, as suggested by the author above:

apt install python-gnocchi

However, there was still an issue related to authentication (HTTP 401):

osctest@OSControllerTest:~$ gnocchi status
The request you have made requires authentication. (HTTP 401)

This was resolved by setting the environment variable OS_AUTH_TYPE=password in the admin-openrc file. The additional GNOCCHI_ENDPOINT variable as suggested by the author was not required, The final admin-openrc file looks like this:

export OS_USERNAME=admin
export OS_PASSWORD=test123
export OS_PROJECT_NAME=admin
export OS_USER_DOMAIN_NAME=Default
export OS_PROJECT_DOMAIN_NAME=Default
export OS_AUTH_URL=http://controller:5000/v3
export OS_IDENTITY_API_VERSION=3
export OS_IMAGE_API_VERSION=2
export OS_AUTH_TYPE=password

After sourcing the updated openrc file, the gnocchi API seems to be working correctly:

osctest@OSControllerTest:~$ gnocchi status
+-----------------------------------------------------+-------+
| Field                                               | Value |
+-----------------------------------------------------+-------+
| storage/number of metric having measures to process | 0     |
| storage/total number of measures to process         | 0     |
+-----------------------------------------------------+-------+

osctest@OSControllerTest:~$ gnocchi server version
+---------+-------+
| Field   | Value |
+---------+-------+
| version | 4.2.4 |
+---------+-------+
2018-07-23 14:12:08 -0500 获得奖牌  拥护者 (source)