发起问题

kibnelbachyr 的档案 - activity

2020-07-21 05:59:55 -0500 获得奖牌  著名问题 (source)
2020-07-21 05:59:55 -0500 获得奖牌  热门的问题 (source)
2020-07-21 05:59:55 -0500 获得奖牌  受欢迎的问题 (source)
2017-04-10 17:03:43 -0500 回答问题 Ocata: server instance stuck in BUILD state

Firstly, ensure that :

  • Rabbitmq server is running and configured !

Then,

-On the controller :

 * MariaDB [(none)]> CREATE DATABASE nova_cell0;
   MariaDB [(none)]> GRANT ALL PRIVILEGES ON nova_cell0.* TO 'nova'@'localhost'  IDENTIFIED BY 'NOVA_DBPASS';
   MariaDB [(none)]> GRANT ALL PRIVILEGES ON nova_cell0.* TO 'nova'@'%'  IDENTIFIED BY 'NOVA_DBPASS';

&

 * $ openstack user create --domain default --password-prompt placement
   $ openstack role add --project service --user placement admin 
   $ openstack service create --name placement --description "Placement API" placement
   $ openstack endpoint create --region RegionOne placement public http://controller/placement
   $ openstack endpoint create --region RegionOne placement admin http://controller/placement
   $ openstack endpoint create --region RegionOne placement internal http://controller/placement

&,

# apt install nova-placement-api

then,

  • In '/etc/nova/nova.conf' , add this section :

[placement]

os_region_name = RegionOne

project_domain_name = Default

project_name = service

auth_type = password

user_domain_name = Default

auth_url = http://controller:35357/v3

username = placement

password = PLACEMENT_PASS

Finally,

# su -s /bin/sh -c "nova-manage cell_v2 map_cell0" nova

# su -s /bin/sh -c "nova-manage cell_v2 create_cell --name=cell1 --verbose" nova


# service nova-api restart

# service nova-consoleauth restart

# service nova-scheduler restart

# service nova-conductor restart

# service nova-novncproxy restart

2017-04-10 04:20:53 -0500 回答问题 Horizon dashboard runs without styles

Did you have some kind of "Internal server ERRORS" before?

Can you verify if you have some themes already installed in /usr/share/openstack-dashboard/openstack_dashboard/themes ?!

2017-04-05 19:57:58 -0500 获得奖牌  著名问题 (source)
2017-04-05 14:02:09 -0500 评论回答 Customizing Dashboard

@rbowen

I have an 'inconsistent' appearance of Horizon dashboard, what should I do ?

P.S. : I've resolved some "Internal Server Errors" before, related to the Apache2 and the wsgi module ..)

2017-04-05 13:59:50 -0500 回答问题 Changing hostname in Devstack two nodes setup
  • . /devstack/clean.sh
  • . /devstack/unstack.sh
  • change hosts names in /etc/hosts
  • reboot
  • . /devstack/stack.sh
2017-04-05 13:56:50 -0500 回答问题 status: Please try again later [Error: Unknown]. (Ocata) (CLOSED)

Please check what's in /var/log/nova/nova-api.log, /var/log/nova/nova-conductor.log, /var/log/nova/nova-scheduler.log, /var/log/nova/nova-compute.log

2017-04-05 08:25:27 -0500 评论回答 ERROR launching instances in OCATA

I have checked it before, no ERRORs :) ..

-- Resolved by :

Using the OFFICIAL "nova.conf" file and I have also changed the VM dedicated to the compute

Thank you @timi !

2017-04-05 04:41:23 -0500 回答问题 ERROR launching instances in OCATA

Resolved by :

  • Using the OFFICIAL "nova.conf" file

  • Changing the compute VM (moving from 2GB to in 8GB RAM)

2017-04-04 18:35:07 -0500 获得奖牌  热门的问题 (source)
2017-04-04 16:16:19 -0500 评论回答 ERROR launching instances in OCATA

Running qemu..

nova-conductor, nova-api, nova-scheduler, nova-consoleauth, nova-vnc. are UP (Controller node) nova-compute is UP (Compute node)

same for the network agents !

2017-04-04 16:14:34 -0500 获得奖牌  受欢迎的问题 (source)
2017-04-04 14:19:47 -0500 评论回答 ERROR launching instances in OCATA

| ID | Hypervisor Hostname | Hypervisor Type | Host IP | State |

| 1 | compute1 | QEMU | 10.10.10.190 | up |

++++ ++++

Everything seems good.

2017-04-04 08:46:36 -0500 问了问题 ERROR launching instances in OCATA

I am following Ocata installation guide. I have create controller, and compute1 I have set up the network, I have set up horizon. Nova Services are UP & RUNNING, Network Agents also .. I can do EVERYTHING (list images, create instances, etc.) - but I can't get it ACTIVE. I ALWAYS get "Failed to compute_task_build_instances: No valid host was found. There are not enough hosts available." in the nova-conductor.log file, exactly after launching an instance..

https://ibb.co/bw2NLa (image description)

-------- Nova-conductor.log ---------------http://paste.openstack.org/show/605407/---------------------------------- 2017-04-04 09:22:16.278 6477 WARNING nova.scheduler.utils [req-ab5d99dc-cf52-4bf8-b615-f101bfdf284f 2aee1ca4e57643e984cc7f8c0bfe992d b827f2aca45246f8989c0d053cafe115 - - -] Failed to compute_task_build_instances: No valid host was found. There are not enough hosts available. Traceback (most recent call last):

File "/usr/lib/python2.7/dist-packages/oslo_messaging/rpc/server.py", line 218, in inner return func(args, *kwargs) File "/usr/lib/python2.7/dist-packages/nova/scheduler/manager.py", line 98, in select_destinations dests = self.driver.select_destinations(ctxt, spec_obj) File "/usr/lib/python2.7/dist-packages/nova/scheduler/filter_scheduler.py", line 79, in select_destinations raise exception.NoValidHost(reason=reason)

NoValidHost: No valid host was found. There are not enough hosts available.

Any help please!? ..

2017-04-04 05:32:45 -0500 评论回答 No valid host was found. There are not enough hosts available.

@Jay Montoya, Did you resolve the problem, I am facing exactly the same issue !?

2017-03-28 03:26:01 -0500 获得奖牌  粉丝
2017-03-27 11:50:50 -0500 获得奖牌  编辑 (source)
2017-03-27 11:45:20 -0500 回答问题 Can not launch an instance, stuck in scheduling, status build (Ocata)

Exactly the same problem here !! (Ubuntu 16.04 LTS + Ocata)

  • Instance stuck in BUILD status
  • In nova-api.log :

2017-03-27 10:10:46.879 3510 ERROR nova.compute.api [req-c2d1f712-e119-4522-9fc7-b1ebf6dbab6b - - - - -] *No cells are configured, unable to list instances* 2017-03-27 10:10:57.269 3511 ERROR nova.compute.api [req-ed3061c4-14e3-4269-9290-c838a61372e9 - - - - -] No cells are configured, unable to list instances 2017-03-27 10:11:36.643 3510 ERROR nova.compute.api [req-ef7a6b91-3e57-469f-8beb-4af4adacf475 - - - - -] No cells are configured, unable to list instances 2017-03-27 10:11:37.518 3510 ERROR nova.compute.api [req-8c543e67-6119-4b99-88f7-bfd91190c086 - - - - -] No cells are configured, unable to list instances 2017-03-27 10:16:03.321 3511 ERROR nova.compute.api [req-6ac808ab-7c54-4782-88c8-c2af92c4d376 - - - - -] No cells are configured, unable to list instances 2017-03-27 10:20:33.164 3511 ERROR nova.compute.api [req-f3291e4e-a920-4350-8907-ffa8e0e4bbf6 - - - - -] No cells are configured, unable to list instances 2017-03-27 10:20:37.035 3511 ERROR nova.compute.api [req-2999029f-79b6-47b2-8901-29f3b09b98fe - - - - -] No cells are configured, unable to list instances 2017-03-27 10:23:28.103 3511 ERROR nova.compute.api [req-af6ae7bb-ae91-4e0a-9759-122e774f689a - - - - -] No cells are configured, unable to list instances 2017-03-27 10:23:52.310 3511 ERROR nova.api.openstack.extensions [req-617a44ca-daa1-49d7-8c65-95173a18e50c - - - - -] Unexpected exception in API method

2017-03-14 12:48:30 -0500 问了问题 Hi, after launching an instance we've always the statut stucks on the BUILD or scheduling!! after hours and hours .. any solution please??!
  • Logs doesn't countain any ERRORS messages, and all services ( Nova, Keystone, Neutron, Glance, Horizon) are UP and RUNNING.
    • Version of Openstack: OCATA , OS = Linux Ubuntu 16.04 LTS
    • 3 Node architecture
2017-02-21 08:23:29 -0500 获得奖牌  拥护者 (source)