发起问题

ctomas 的档案 - activity

2017-08-07 21:58:45 -0500 获得奖牌  著名问题 (source)
2017-08-04 11:20:20 -0500 获得奖牌  市民侦察兵 (source)
2017-08-04 11:14:38 -0500 回答问题 can't type some needed characters to access cirros image (novnc bug)

Hi Logax

Try using spice client in the insted of novnc client to compare/reproduce the problem.

2017-08-04 11:06:02 -0500 回答问题 Newton release docs

Hi GTIM

First you need choose the pike release and the user guides will appears.

If you are in the Netwon or Ocata release, the following message appears:

"The central user guides managed by the OpenStack Documentation team were deprecated and removed during the Pike release cycle. The content was moved to the individual project documentation trees . Because of the timing of that change, there is no separate Ocata version of the user guides. Please refer either to the version of the guides created for Pike, or the most recent series in development, instead."

2017-08-04 10:55:26 -0500 回答问题 my network topolgy seems odd, help me fix it

Hi Iogax, with only the topology picture is difficult to discover the problem. The selfservice network is not appers in the picture and the vrouter is connected only to the provider network. The instance can been connected with any networks. Verify with the openstack cli commands the interfaces/ports connectivity beetwen the networks and the vrouter, and the same to the instance with the network.

2017-03-10 09:58:32 -0500 获得奖牌  热门的问题 (source)
2017-02-15 16:42:51 -0500 获得奖牌  受欢迎的问题 (source)
2017-02-10 12:54:45 -0500 回答问题 "sudo service neutron-server start" gives neutron-server: unrecognized service error

Hi Suresh Nagaraj

Check the following links where you will find an answer to your question:

http://stackoverflow.com/questions/23...

https://ask.openstack.org/en/question...

http://blog.coolsvap.net/2014/09/16/o...

2017-02-09 09:21:17 -0500 评论回答 devstack: openstack service list (and most other OS commands) -> __init__() got an unexpected keyword argument 'project_name'

According with the bug reported, this issue was fixed in the openstack/python-openstackclient 3.8.0 release.

2017-02-08 12:13:05 -0500 问了问题 Instance associated with private network does not receive ip address after restarting server

Hi,

My environment is: Openstack Newton with 1 controller node, 1 compute node and 1 storage node, each running inside a VM.

Apparently it is related to shutting down the server. Then when I go to turn on the server, OpenStack goes up but with the VM in "shutdown" mode and forces me to restart the VM. Upon reactivation of the VM, the instance rises without an assigned IP address. However if I recreate the instance, it goes up with an IP correctly and I notice that only happens in VMs that are in a private network (in my setup called 'selfservice')

The problem described above does not occur for VMs that are in my external network (in my setup called 'provider').

Here are some commands to clarify my setup:

os@controller:~$ openstack server list

| ID          | Name              | Status | Networks                 | Image Name |
+--------------------------------------+------------------------------+--------+-----------
| d1... | mystack1-server     | ACTIVE | selfservice=172.16.1.8, 192.168.100.15 | cirros |
| 79... | provider-instance   | ACTIVE | provider=192.168.100.4                 | cirros |

os@controller:~$ openstack network list

| ID                                   | Name        | Subnets                              |
+--------------------------------------+-------------+--------------------------------------+
| 2db21c16-75e6-4492-9159-41d73479fcf5 | provider    | e43f081b-523b-479a-b1ae-9e394009f2c1 |
| d1a405be-c64a-4c6b-90bc-fbece1e82af9 | selfservice | d473989e-92a4-4cd5-9531-460333d785f5 |
+--------------------------------------+-------------+--------------------------------------+

I also discarded that it is the rules of firewall. Put them here:

Security Groups Default

ALLOW IPv4 22 / tcp from 0.0.0.0/0
ALLOW IPv6 from default
ALLOW IPv6 to :: / 0
ALLOW IPv4 from default
ALLOW IPv4 icmp from 0.0.0.0/0
ALLOW IPv4 to 0.0.0.0/0

The "Instance Console Log" (Part of the log where error messages are displayed)

info: initramfs: up at 11.71
NOCHANGE: partition 1 is size 2072385. it cannot be grown
info: initramfs loading root from /dev/vda1
info: /etc/init.d/rc.sysinit: up at 17.21
info: container: none
Starting logging: OK
modprobe: module virtio_blk not found in modules.dep
modprobe: module virtio_net not found in modules.dep
WARN: /etc/rc3.d/S10-load-modules failed
Initializing random number generator... done.
Starting acpid: OK
cirros-ds 'local' up at 26.51
no results found for mode=local. up 28.20. searched: nocloud configdrive ec2
Starting network...
udhcpc (v1.20.1) started
Sending discover...
Sending discover...
Sending discover...
Usage: /sbin/cirros-dhcpc <up|down>
No lease, failing
WARN: /etc/rc3.d/S40-network failed
cirros-ds 'net' up at 211.58
checking http://169.254.169.254/2009-04-04/instance-id
failed 1/20: up 211.87. request failed
failed 2/20: up 214.39. request failed
failed 3/20: up 216.52. request failed
failed 4/20: up 218.72. request failed
failed 5/20: up 220.85. request failed
failed 6/20: up 222.95. request failed
failed 7/20: up 225.19. request failed
failed 8/20: up 227.51. request failed
failed 9/20: up 229.61. request failed
failed 10/20: up 231.86. request failed
failed 11/20: up 234.01. request failed
failed 12/20: up 236.17. request failed
failed 13/20: up 238.48. request failed
failed 14/20: up 240.70. request failed
failed 15/20: up 242.94. request failed
failed 16/20: up 245.28 ...
(more)
2017-02-01 12:13:33 -0500 评论回答 Multi node installation on Openstack

Okay, consider it for your planning.

2017-02-01 08:35:00 -0500 回答问题 Multi node installation on Openstack

Hi @vgeorga

I used the following guide for installation on Ubuntu distribution 16.04 server: https://docs.openstack.org/newton/ins.... I have installed 3 nodes (controller, compute and storage), each node running inside a VM being controlled with virt-manager and hosted on a single server. I recommend following this guide for a test environment. There is a section called "environment" within the guide that shows a reference architecture to start.

2017-01-27 21:53:41 -0500 获得奖牌  老师 (source)
2017-01-27 21:53:41 -0500 获得奖牌  复兴的问题 (source)
2017-01-27 11:12:33 -0500 评论回答 External instances L3 connectivity to physical network failing due to SNAT

I was having the same problem in my virtualized environment with libvirt and I ran the procedure indicated by @gianpietro and it worked for me. Excellent!

2017-01-27 08:27:27 -0500 回答问题 devstack: openstack service list (and most other OS commands) -> __init__() got an unexpected keyword argument 'project_name'

This question is the same that: openstack client: "__init__() got an unexpected keyword argument 'project_name'"

The answer for this is: The problem is a bug in the python-openstackclient project: https://bugs.launchpad.net/python-openstackclient/+bug/1650026 (https://bugs.launchpad.net/python-ope...). The last comment in the bug was: "This issue was fixed in the openstack/python-openstackclient 3.8.0 release".

2017-01-27 08:22:34 -0500 获得奖牌  编辑 (source)
2017-01-24 14:15:58 -0500 评论回答 ceilometer cli commands returns 403

The procedure indicated by @gianpietro works very well (installation for Ubuntu)

2017-01-10 15:31:21 -0500 获得奖牌  粉丝
2017-01-03 22:08:52 -0500 评论问题 devstack: openstack service list (and most other OS commands) -> __init__() got an unexpected keyword argument 'project_name'

Hi twotwo, What is your OSC version? Please search the question: openstack client: "__init__() got an unexpected keyword argument 'project_name'"

2017-01-03 15:44:38 -0500 获得奖牌  自传作者
2017-01-03 14:08:06 -0500 回答问题 openstack client: "__init__() got an unexpected keyword argument 'project_name'"

The problem is a bug in the python-openstackclient project: https://bugs.launchpad.net/python-openstackclient/+bug/1650026 (https://bugs.launchpad.net/python-ope...).

The last comment in the bug was: "This issue was fixed in the openstack/python-openstackclient 3.8.0 release".

This is it.

2017-01-03 14:08:06 -0500 评论问题 openstack client: "__init__() got an unexpected keyword argument 'project_name'"

Hi all, I am using openstack version 3.4.1 and the problem persist. Also it occurs with the command openstack help security group rule create or openstack security group rule create -h

2017-01-03 10:31:08 -0500 获得奖牌  拥护者 (source)