发起问题

Cristiano 的档案 - activity

2019-05-20 15:49:57 -0500 获得奖牌  著名问题 (source)
2019-05-20 15:49:57 -0500 获得奖牌  热门的问题 (source)
2017-09-14 08:57:28 -0500 获得奖牌  受欢迎的问题 (source)
2017-09-13 15:53:18 -0500 问了问题 multiple tenant network on multiple physical networks

Hi, I have two separated physical networks and I want use them to provide vlan tenants networks on Openstack Juno. These are the physical networks: physnet1 and heartbeat corresponding to two NIC eth0 and eth1. My configuration is:

[ml2_type_vlan]
network_vlan_ranges = physnet1:976:1000,heartbeat:786:793

[ovs]
tenant_network_type = vlan
network_vlan_ranges = physnet1:976:1000,heartbeat:786:793

bridge_mappings = physnet1:br-eth0, heartbeat:br-eth1

I mapped the bridges through:

ovs-vsctl add-br br-eth0
ovs-vsctl add-port br-eth0 eth0

ovs-vsctl add-br br-eth1
ovs-vsctl add-port br-eth1 eth1

As admin I created the two tenant networks:

Network Type: vlan
Physical Network: physnet1
Segmentation ID: 976

and

Network Type: vlan
Physical Network: heartbeat
Segmentation ID: 786

When I create a VM attached to heartbeat network the ifconfig command shows the tagged interface eth0.786. This behavior is unexpected because I should have eth1.786. What's wrong?

2017-09-12 07:32:07 -0500 回答问题 multiple vlan tenant networks?

Hi, I have the same problem on Openstack Juno. Two separated physical networks: physnet1 and heartbeat corresponding to two NIC eth0 and eth1. My configuration is:

[ml2_type_vlan]
network_vlan_ranges = physnet1:976:1000,heartbeat:786:793

[ovs]
tenant_network_type = vlan
network_vlan_ranges = physnet1:976:1000,heartbeat:786:793

bridge_mappings = physnet1:br-eth0, heartbeat:br-eth1

I mapped the bridges through:

ovs-vsctl add-br br-eth0
ovs-vsctl add-port br-eth0 eth0

ovs-vsctl add-br br-eth1
ovs-vsctl add-port br-eth1 eth1

As admin I created the two tenant networks:

Network Type: vlan
Physical Network: physnet1
Segmentation ID: 976

and

Network Type: vlan
Physical Network: heartbeat
Segmentation ID: 786

When I create a VM attached to heartbeat network the ifconfig command shows the tagged interface eth0.786. This behavior is unexpected because I should have eth1.786. What's wrong?

2017-04-06 07:49:36 -0500 评论问题 periodic failure to authenticate services in juno

Hi, I have the same issue, did you resolve it?

2017-02-13 21:07:20 -0500 获得奖牌  著名问题 (source)
2017-01-16 06:29:10 -0500 回答问题 Openstackclient uninstall

Solved. python-openstackclient installation caused the upgrade of python-requests library and this is in conflicts with python-glanceclient. I solved by downgrading the requests library to 2.7.0, which was the previous release.

2016-12-29 19:49:35 -0500 获得奖牌  热门的问题 (source)
2016-12-19 08:04:05 -0500 评论回答 Openstackclient uninstall

can any one help?

2016-12-19 02:20:46 -0500 获得奖牌  受欢迎的问题 (source)
2016-12-19 02:20:43 -0500 获得奖牌  粉丝
2016-12-17 04:41:40 -0500 获得奖牌  编辑 (source)
2016-12-17 04:40:50 -0500 评论回答 Openstackclient uninstall

Thank you for your reply. Please read the update.

2016-12-14 12:34:02 -0500 问了问题 Openstackclient uninstall

Hi, I installed python-openstackclient in Juno and it did the following actions:

> Installing collected packages:
> keystoneauth1, python-keystoneclient,
> python-glanceclient,
> python-openstackclient                
> Found existing installation:
> python-keystoneclient 0.11.1          
> 
>     Uninstalling python-keystoneclient-0.11.1:         
> 
>       Successfully uninstalled python-keystoneclient-0.11.1          
> Found existing installation:
> python-glanceclient 0.15.0            
> 
>     Uninstalling python-glanceclient-0.15.0:           
> 
>       Successfully uninstalled python-glanceclient-0.15.0            
> Successfully installed
> keystoneauth1-2.16.0
> python-glanceclient-2.5.0
> python-keystoneclient-3.8.0
> python-openstackclient-3.4.1

Now I urgently need to completely uninstall python-openstackclient and restore the previous version (and behavior) of keystone and glance. Can you help me?


UPDATE: To avoid the use of api v3 and rollback to api v2, in the controller nodes I uninstalled all openstack python packets and reinstalled them following this procedure http://docs.openstack.org/juno/install-guide/install/yum/content/ch_overview.html (http://docs.openstack.org/juno/instal...).

I uninstalled packets through:

for dep in $(pip show python-openstackclient | grep Requires | sed 's/Requires: //g; s/,//g') ; do echo $dep ; done
for dep in $(pip show python-openstackclient | grep Requires | sed 's/Requires: //g; s/,//g') ; do sudo pip uninstall -y $dep ; done

pip uninstall -y python-openstackclient

yum remove openstack-keystone python-keystoneclient openstack-glance python-glanceclient python-glance-store.noarch openstack-nova-api openstack-nova-cert openstack-nova-conductor openstack-nova-console openstack-nova-novncproxy openstack-nova-scheduler python-novaclient openstack-neutron openstack-neutron-ml2 python-neutronclient openstack-dashboard httpd mod_wsgi memcached python-memcached openstack-swift-proxy python-swiftclient python-keystonemiddleware openstack-heat-api openstack-heat-api-cfn openstack-heat-engine python-heatclient openstack-ceilometer-api openstack-ceilometer-collector openstack-ceilometer-notification openstack-ceilometer-central openstack-ceilometer-alarm python-ceilometerclient python-six python-babel python-cliff python-cinderclient.noarch openstack-cinder python-cinderclient python-oslo-db openstack-swift openstack-swift-plugin-swift3 python-ceilometer

But when I launch glance image-show ID-image I had the following error:

raise AttributeError(k)
AttributeError: id
id

and I can't figure out why in the /glance/api.log appears INFO keystonemiddleware.auth_token [-] Auth Token confirmed use of v3.0 apis despite the default Juno installation uses api v2. I assume the problems are related to each other. What do you think?