发起问题

semka_mesilov 的档案 - activity

2019-12-20 07:51:02 -0500 获得奖牌  著名问题 (source)
2019-12-20 07:51:02 -0500 获得奖牌  热门的问题 (source)
2019-12-20 07:51:02 -0500 获得奖牌  受欢迎的问题 (source)
2016-11-22 14:47:53 -0500 问了问题 OVS failed port after live migration

Hi Team, I'm using Mitaka cluster driver for Hyper-V with OVS 2.5 Windows port. When I perform live migration, an instance loses network connection but succesfully goes to another hosts. There was a bug in Liberty where ovs port had not been migrated to target hosts but now it is seems to be okay, ovs port is on target host but adds with errors.

vswitchd.log (migration time) https://paste.ubuntu.com/23510786/

nova-compute.log (migration time) https://paste.ubuntu.com/23510782/

nova.conf https://paste.ubuntu.com/23510815/

neutron-ovs-agent.conf https://paste.ubuntu.com/23510816/

If I execute the command (ovs-vsctl --timeout=120 -- --if-exists del-port 4b26fd63-e779-49c9-b419-ac2c53ef8c9a ....) logged in nova manually then I get network connection even without restarting the services.

I've also logged OVS debug rpc (another migration) and it contains "protocols":"OpenFlow10","datapath_version":"<unknown>"}

2016-11-21T13:10:55.017Z|04642|netdevwindows|DBG|construct device 4b26fd63-e779-49c9-b419-ac2c53ef8c9a, ovstype: 0. 2016-11-21T13:10:55.017Z|04643|dpif|WARN|system@ovs-system: failed to add 4b26fd63-e779-49c9-b419-ac2c53ef8c9a as port: Invalid argument

Another try:

2016-11-21T12:48:21.789Z|00444|dpif|DBG|system@ovs-system: device br-tun is on port 5 2016-11-21T12:48:21.789Z|00445|netlinksocket|DBG|received NAK error=0 (No such device) 2016-11-21T12:48:21.789Z|00446|netdevwindows|DBG|construct device 4b26fd63-e779-49c9-b419-ac2c53ef8c9a, ovstype: 0. 2016-11-21T12:48:21.789Z|00447|netlinksocket|DBG|received NAK error=0 (No such device) 2016-11-21T12:48:21.789Z|00448|netlink_socket|DBG|received NAK error=0 (Invalid argument) 2016-11-21T12:48:21.789Z|00449|dpif|WARN|system@ovs-system: failed to add 4b26fd63-e779-49c9-b419-ac2c53ef8c9a as port: Invalid argument

https://paste.ubuntu.com/23511010/

Please, help to investigate it.

2016-09-05 21:07:16 -0500 问了问题 nova.virt.hyperv.cluster.driver.HyperVClusterDriver

Is there any nova.virt.hyperv.cluster.driver.HyperVClusterDriver release for Openstack Liberty? Is it possible to adapt mitaka driver for liberty release?