发起问题

user123 的档案 - activity

2019-02-18 04:59:06 -0500 获得奖牌  著名问题 (source)
2019-02-18 04:59:06 -0500 获得奖牌  热门的问题 (source)
2016-06-02 23:18:06 -0500 获得奖牌  著名问题 (source)
2016-05-18 11:03:46 -0500 获得奖牌  著名问题 (source)
2016-04-18 21:43:42 -0500 获得奖牌  热门的问题 (source)
2016-02-22 01:01:13 -0500 获得奖牌  受欢迎的问题 (source)
2016-02-05 19:58:05 -0500 问了问题 Manila : Failed to create share : No valid host found (GPFS )

Currently I am trying to create share using Manila. I have two nodes, one node (IP-ADDR1) has Keystone-Manila installed on to it and the other node (IP-ADDR2) has GPFS installed and GPFS mounted on /mnt/gpfs1.

Following is my Manila config file settings :

[DEFAULT]
logging_exception_prefix = %(asctime)s.%(msecs)d TRACE %(name)s %(instance)s
logging_debug_format_suffix = from (pid=%(process)d) %(funcName)s %(pathname)s:%(lineno)d
logging_default_format_string = %(asctime)s.%(msecs)d %(color)s%(levelname)s %(name)s [-%(color)s] %(instance)s%(color)s%(message)s
logging_context_format_string = %(asctime)s.%(msecs)d %(color)s%(levelname)s %(name)s [%(request_id)s %(user_id)s %(project_id)s%(color)s] %(instance)s%(color)s%(message)s
log_dir = /var/log/stack/manila/
# Set auth strategy for usage of Keystone
auth_strategy = keystone

# Set message bus creds
rabbit_userid = openstack
rabbit_password = xxxxx
rabbit_hosts = 127.0.0.1
rpc_backend = rabbit

# Following opt is used for definition of share backends that should be enabled.
# Values are conf groupnames that contain per manila-share service opts.
enabled_share_backends = gpfs

# Enable protocols ‘NFS’ and ‘CIFS’ as those are the only supported
# by Generic driver that we are configuring in this set up.
# All available values are (‘NFS’, ‘CIFS’, ‘GlusterFS’, ‘HDFS’)
enabled_share_protocols = NFS,CIFS

default_share_type = gpfs

state_path = /opt/stack/data/manila
osapi_share_extension = manila.api.contrib.standard_extensions
rootwrap_config = /etc/manila/rootwrap.conf
api_paste_config = /etc/manila/api-paste.ini
share_name_template = share-%s

# scheduler_driver = manila.scheduler.filter_scheduler.FilterScheduler

verbose = True
debug = True

[gpfs]
share_driver = manila.share.drivers.ibm.gpfs.GPFSShareDriver
gpfs_share_export_ip = <IP_ADDR2>
driver_handles_share_servers = false
# GPFS backend credentials
gpfs_ssh_login = root
gpfs_ssh_private_key = <KEY PATH>
gpfs_mount_point_base = /mnt/gpfs1/
gpfs_nfs_server_list = <IP_ADDR2>
gpfs_nfs_server_type = KNFS
# GNFS - for Ganesha NFS
ssh_conn_timeout = 60
ssh_min_pool_conn = 1
ssh_max_pool_conn = 10
gpfs_share_helpers = KNFS=manila.share.drivers.ibm.gpfs.KNFSHelper
gpfs_ssh_port = 22
knfs_export_options = rw
# Custom name for share backend.
share_backend_name = GPFS

When I issue command :

manila create --share-type gpfs --name testshare NFS 1

I get this error in scheduler logs : No valid hosts found. I also had created a type as gpfs using

manila type-create gpfs False

Can someone please help me debug this issue? I am using Ubuntu 14.04.

2016-01-29 13:19:37 -0500 获得奖牌  受欢迎的问题 (source)
2016-01-13 00:14:13 -0500 获得奖牌  粉丝
2016-01-12 18:40:42 -0500 评论回答 ERROR: openstackclient.shell Exception raised: (pbr 0.11.0 (/usr/local/lib/python2.7/dist-packages), Requirement.parse('pbr>=1.6')

I get this error :
ERROR: openstackclient.shell Exception raised: (pbr 1.6.0 (/usr/local/lib/python2.7/dist-packages), Requirement.parse('pbr!=0.7,<1.0,>=0.6'), set(['oslo.i18n', 'python-novaclient', 'oslo.utils', 'oslo.config', 'python-neutronclient', 'oslo.serialization', 'py

2016-01-12 18:39:20 -0500 获得奖牌  学者 (source)
2016-01-12 18:38:03 -0500 获得奖牌  热门的问题 (source)
2016-01-06 16:52:01 -0500 获得奖牌  组织者 (source)
2016-01-06 16:45:03 -0500 问了问题 When I start manila-api service, I get wsgi starting up on http://0.0.0.0:8786/ and it waits here and never proceeds further.

I am following http://docs.openstack.org/developer/manila/adminref/quick_start.html (this) guide for manila installation : When I start manila-api as below:

 manila-api \
    --config-file /etc/manila/manila.conf & \
    echo $! >/opt/stack/status/stack/m-api.pid; \
    fg || echo "m-api failed to start" | \
    tee "/opt/stack/status/stack/m-api.failure"

Bunch of log lines appear on console and after the following point , it waits and nothing happens.

    2016-01-06 14:15:41.955 11060 DEBUG manila.service [-] keystone_authtoken : <oslo_config.cfg.GroupAttr object at 0x7f280ea94450> wait /usr/local/lib/python2.7/dist-packages/manila/service.py:618
    2016-01-06 14:15:41.955 11060 DEBUG manila.service [-] oslo_concurrency : <oslo_config.cfg.GroupAttr object at 0x7f280ea947d0> wait /usr/local/lib/python2.7/dist-packages/manila/service.py:618
    2016-01-06 14:15:41.956 11060 DEBUG manila.service [-] database : <oslo_config.cfg.GroupAttr object at 0x7f280ea94750> wait /usr/local/lib/python2.7/dist-packages/manila/service.py:618
    2016-01-06 14:15:41.956 11060 INFO manila.wsgi [-] Started osapi_share on 0.0.0.0:8786
2016-01-06 14:15:41.957 11060 INFO eventlet.wsgi.server [-] (11060) wsgi starting up on http://0.0.0.0:8786/

I am using Virtual Box on Windows with Ubuntu 14.04 installed on it. Any help in this case will be very helpful.

2016-01-06 16:34:16 -0500 获得奖牌  拥护者 (source)
2016-01-06 16:34:12 -0500 获得奖牌  受欢迎的问题 (source)
2016-01-05 11:38:27 -0500 问了问题 ERROR: openstackclient.shell Exception raised: (pbr 0.11.0 (/usr/local/lib/python2.7/dist-packages), Requirement.parse('pbr>=1.6')

I am installing Manila on Ubuntu 14.04. I am following this: http://docs.openstack.org/developer/manila/adminref/quick_start.html (http://docs.openstack.org/developer/m...) and have set up keystone using http://docs.openstack.org/kilo/install-guide/install/apt/content/ch_keystone.html (http://docs.openstack.org/kilo/instal...). I am very new to OpenStack community. Any help would be really appreciated. I created user in openstack for Manila. After that I executed following set of commands : git clone -b stable/kilo https://github.com/openstack/manila sudo python setup.py install sudo pip install python-manilaclient>=1.0.4 When I create new role / add user I get error : ERROR: openstackclient.shell Exception raised: (pbr 0.11.0 (/usr/local/lib/python2.7/dist-packages), Requirement.parse('pbr>=1.6'), set(['python-keystoneclient', 'stevedore', 'oslo.utils']))

After reading existing threads on similar issue. I executed : pip install --upgrade setuptools However, the problem still exists.