在ubuntu14.04 中devstack安装kilo版 出现ValueError: need more than 1 value to unpack

提问于 2015-12-14 09:36:01 -0500

wjp 图像

updated 2015-12-14 09:40:07 -0500

在ubuntu14.04 中 使用devstack安装kilo版 localrc里面enable了heat 和ceilometer两个服务 出现ValueError: need more than 1 value to unpack

localrc添加这两行:
enable_service ceilometer-acentral,ceilometer-collector,ceilometer-api,ceilometer-acompute,ceilometer-alarm-singleton,ceilometer-alarm-notifier
enable_service heat,h-api,h-api-cfn,h-api-cw,h-eng

出现的错误:
2015-12-14 11:28:51.279 | Requirement already satisfied (use --upgrade to upgrade): tox in /usr/local/lib/python2.7/dist-packages
2015-12-14 11:28:51.282 | Requirement already satisfied (use --upgrade to upgrade): virtualenv>=1.11.2 in /usr/local/lib/python2.7/dist-packages (from tox)
2015-12-14 11:28:51.284 | Requirement already satisfied (use --upgrade to upgrade): py>=1.4.17 in /usr/local/lib/python2.7/dist-packages (from tox)
2015-12-14 11:28:51.285 | Requirement already satisfied (use --upgrade to upgrade): pluggy<0.4.0,>=0.3.0 in /usr/local/lib/python2.7/dist-packages (from tox)
2015-12-14 11:28:51.582 | ++ local test_req=tox/test-requirements.txt
2015-12-14 11:28:51.582 | ++ [[ -e tox/test-requirements.txt ]]
2015-12-14 11:28:51.583 | ++ pushd /opt/stack/tempest
2015-12-14 11:28:51.583 | /opt/stack/tempest ~/devstack
2015-12-14 11:28:51.583 | ++ tox --notest -efull
2015-12-14 11:28:51.840 | Traceback (most recent call last):
2015-12-14 11:28:51.840 | File "/usr/local/bin/tox", line 11, in <module>
2015-12-14 11:28:51.840 | sys.exit(cmdline())
2015-12-14 11:28:51.840 | File "/usr/local/lib/python2.7/dist-packages/tox/session.py", line 38, in main
2015-12-14 11:28:51.840 | config = prepare(args)
2015-12-14 11:28:51.840 | File "/usr/local/lib/python2.7/dist-packages/tox/session.py", line 26, in prepare
2015-12-14 11:28:51.840 | config = parseconfig(args)
2015-12-14 11:28:51.840 | File "/usr/local/lib/python2.7/dist-packages/tox/config.py", line 229, in parseconfig
2015-12-14 11:28:51.840 | parseini(config, inipath)
2015-12-14 11:28:51.840 | File "/usr/local/lib/python2.7/dist-packages/tox/config.py", line 729, in __init__
2015-12-14 11:28:51.840 | self.make_envconfig(name, section, reader._subs, config
2015-12-14 11:28:51.840 | File "/usr/local/lib/python2.7/dist-packages/tox/config.py", line 760, in make_envconfig
2015-12-14 11:28:51.840 | res = meth(env_attr.name, env_attr.default)
2015-12-14 11:28:51.841 | File "/usr/local/lib/python2.7/dist-packages/tox/config.py", line 893, in getdict_setenv
2015-12-14 11:28:51.841 | definitions = self._getdict(value, default=default, sep=sep)
2015-12-14 11:28:51.841 | File "/usr/local/lib/python2.7/dist-packages/tox/config.py", line 904, in _getdict
2015-12-14 11:28:51.841 | name, rest = line.split('=', 1)
2015-12-14 11:28:51.841 | ValueError: need more than 1 value to unpack
2015-12-14 11:28:51.848 | + exit_trap
2015-12-14 11:28:51.848 | + local r=1
2015-12-14 11:28:51.849 | ++ jobs -p
2015-12-14 11:28:51.849 | + jobs=
2015-12-14 11:28:51.849 | + [[ -n '' ]]
2015-12-14 11:28:51.849 | + kill_spinner
2015-12-14 11:28:51.850 | + '[' '!' -z '' ']'
2015-12-14 11:28:51.850 | + [[ 1 -ne 0 ]]
2015-12-14 11:28:51.850 | + echo 'Error on exit'
2015-12-14 11:28:51.850 | Error on exit
2015-12-14 11:28:51.850 | + [[ -z /opt/stack/logs ]]
2015-12-14 ...






































(更多)

edit retag flag offensive close merge delete