发起问题
0

Ocata openvswitch compute no syn network setting form controller node

提问于 2017-03-05 09:44:29 -0600

hb.deng 图像

Hi, I have try to install Ocata follow by offical guide use openvswitch. Openvswitch seems works on controller node. ovs-vsctl show like this:
[root@controller openvswitch]# ovs-vsctl show
f37a1999-b2a0-401e-b8f6-6bd61e880633
Manager "ptcp:6640:127.0.0.1"
is_connected: true
Bridge br-provider
Controller "tcp:127.0.0.1:6633"
is_connected: true
fail_mode: secure
Port phy-br-provider
Interface phy-br-provider
type: patch
options: {peer=int-br-provider}
Port "ens33"
Interface "ens33"
Port br-provider
Interface br-provider
type: internal
Bridge br-int
Controller "tcp:127.0.0.1:6633"
is_connected: true
fail_mode: secure
Port int-br-provider
Interface int-br-provider
type: patch
options: {peer=phy-br-provider}
Port "tape9969dd7-2b"
Interface "tape9969dd7-2b"
type: internal
Port "tap0824674a-b3"
tag: 1
Interface "tap0824674a-b3"
type: internal
Port br-int
Interface br-int
type: internal
Port "tapa211f5af-4e"
tag: 2
Interface "tapa211f5af-4e"
type: internal
ovs_version: "2.6.1"
[root@controller openvswitch]#


But compute node ovs-vsctl show no port like this 'Port "tapa211f5af-4e" '

[root@compute1 openvswitch]# ovs-vsctl show
30926e12-c13c-4213-add4-bdbf8fc2ae68
Manager "ptcp:6640:127.0.0.1"
is_connected: true
Bridge br-provider
Controller "tcp:127.0.0.1:6633"
is_connected: true
fail_mode: secure
Port phy-br-provider
Interface phy-br-provider
type: patch
options: {peer=int-br-provider}
Port br-provider
Interface br-provider
type: internal
Port "ens33"
Interface "ens33"
Bridge br-int
Controller "tcp:127.0.0.1:6633"
is_connected: true
fail_mode: secure
Port int-br-provider
Interface int-br-provider
type: patch
options: {peer=phy-br-provider}
Port br-int
Interface br-int
type: internal
ovs_version: "2.6.1"
[root@compute1 openvswitch]#



Service seems running on both node:


[root@compute1 openvswitch]# service neutron-openvswitch-agent status
Redirecting to /bin/systemctl status neutron-openvswitch-agent.service
● neutron-openvswitch-agent.service - OpenStack Neutron Open vSwitch Agent
Loaded: loaded (/usr/lib/systemd/system/neutron-openvswitch-agent.service; enabled; vendor preset: disabled)
Active: active (running) since 日 2017-03-05 20:22:32 CST; 3h 2min ago
Process: 1238 ExecStartPre=/usr/bin/neutron-enable-bridge-firewall.sh (code=exited, status=0/SUCCESS)
Main PID: 1258 (neutron-openvsw)
CGroup: /system.slice/neutron-openvswitch-agent.service
├─1258 /usr/bin/python2 /usr/bin/neutron-openvswitch-agent --config-file /usr/share/neutron/neut...
├─1447 sudo neutron-rootwrap-daemon /etc/neutron/rootwrap.conf
├─1448 /usr/bin/python2 /usr/bin/neutron-rootwrap-daemon /etc/neutron/rootwrap.conf
└─1458 ovsdb-client monitor tcp:127.0.0.1:6640 Interface name,ofport,external_ids --format=json

3月 05 20:22:32 compute1 neutron-enable-bridge-firewall.sh[1238]: net.bridge.bridge-nf-call-iptables = 1
3月 05 20:22:32 compute1 neutron-enable-bridge-firewall.sh[1238]: net.bridge.bridge-nf-call-ip6tables = 1
3月 05 20:22:32 compute1 systemd[1]: Started OpenStack Neutron Open vSwitch Agent.
3月 05 20:23:27 compute1 neutron-openvswitch-agent[1258]: Guru meditation now registers SIGUSR1 and SIG...ts.
3月 05 20:24:03 compute1 neutron-openvswitch-agent[1258]: Option "verbose" from group "DEFAULT" is depr...re.
3月 05 20:24:13 compute1 neutron-openvswitch-agent[1258]: Option "notification_driver" from group "DEFA...s".
3月 05 20:24:13 compute1 neutron-openvswitch-agent[1258]: Could not load neutron.openstack.common.notif...ier
3月 05 20:24:39 compute1 neutron-openvswitch-agent[1258]: /usr/lib/python2.7/site-packages/oslo_messaging/...
3月 05 20:24:39 compute1 neutron-openvswitch-agent[1258]: access_policy)
3月 05 20:24:43 compute1 sudo[1447]: neutron : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/bin/neutro....conf
Hint: Some lines were ellipsized, use -l to show in full.

any one can help to fix this.I just ... (更多)

edit retag flag offensive close merge delete

Comments

By the way:
my managment NIC is ens32,Controller node:10.10.10.108,compute node:10.10.10.109
my provider NIC is ens33,no ip address for this NIC.

hb.deng 图像hb.deng ( 2017-03-05 09:47:21 -0600 )edit
0

回答 2017-03-09 08:54:45 -0600

hb.deng 图像

updated 2017-03-09 08:56:59 -0600

Hello,I am here to update this issue. Last time I fllow this guide:
https://docs.openstack.org/ocata/networking-guide/deploy-ovs-selfservice.html (https://docs.openstack.org/ocata/netw...)
Configure example in this guide "openvswitch_agent.ini"

[agent]
tunnel_types = vxlan
l2_population = True


I look for solution many days and found when enable "l2_population " VLXAN ports of openvswitch missing.So my solution is :

[agent]
tunnel_types = vxlan
l2_population = False


And it work now.Both controller and Compute node need change this config.

edit flag offensive delete link 更多

你的回答

Please start posting anonymously - your entry will be published after you log in or create a new account.

开始回答

提问工具

统计

已提问: 2017-03-05 09:44:29 -0600

已查看: 736 次

最后更新: Mar 09 '17