Ask Your Question

MrZog's profile - activity

2015-06-11 17:05:24 -0500 received badge  Famous Question (source)
2015-03-20 12:06:19 -0500 received badge  Notable Question
2015-03-18 16:52:05 -0500 commented answer demo instances fail to build on Ubuntu 14.04.2/Juno

My network node's ifconfig. http://paste.openstack.org/show/193274/

2015-03-18 14:33:42 -0500 commented answer demo instances fail to build on Ubuntu 14.04.2/Juno

I ran 'ovs-vsctl add-port br-ex' then 'ovs-vsctl add-port br-ex eth0' where eth0 is my net node's management interface. Then I restarted all my neutron services and there was no eth0-br.

2015-03-16 22:47:03 -0500 commented answer demo instances fail to build on Ubuntu 14.04.2/Juno

Also tried them in the [neutron] section. Did not work. Here is my nova.conf http://paste.openstack.org/show/192789/

2015-03-16 21:07:37 -0500 commented answer demo instances fail to build on Ubuntu 14.04.2/Juno

Thanks. I tried adding those two lines to the DEFAULT section of my nova.conf file on the controller machine. The build is stuck in Task State 'spawning'.

2015-03-16 20:03:17 -0500 received badge  Famous Question (source)
2015-03-16 09:56:45 -0500 commented question demo instances fail to build on Ubuntu 14.04.2/Juno
2015-03-16 02:32:59 -0500 received badge  Notable Question (source)
2015-03-15 16:35:28 -0500 received badge  Popular Question (source)
2015-03-14 19:28:58 -0500 asked a question demo instances fail to build on Ubuntu 14.04.2/Juno

I'm following http://docs.openstack.org/juno/instal... . I have a compute node, a neutron network node and a controller. I noticed that when I've sourced demo-openrc.sh I can't see the dotted quad for the external network: http://pastie.org/10026701 <-- (If you click the arrows in the top-right corner the formatting gets fixed.)

I set up the external network thus:

neutron subnet-create ext-net --name ext-subnet --allocation-pool start=192.168.10.21,end=192.168.10.44 --disable-dhcp --disable-dhcp --gateway 192.168.10.1 192.168.10.0/24

And the tenant net like so:

neutron subnet-create demo-net0 --name demo-subnet0 --gateway 192.168.1.1 192.168.1.0/24

So far the only error I see is in nova-api.log.

2015-03-14 23:57:35.359 6056 INFO nova.api.openstack.wsgi [req-a1c12d79-a661-4e89-8d56-914fd04ad725 None] HTTP exception thrown: The resource could not be found.
2015-03-13 12:47:00 -0500 received badge  Notable Question (source)
2015-03-12 12:32:49 -0500 received badge  Popular Question
2015-03-10 16:24:01 -0500 commented question Why can't cinder-scheduler authenticate to rabbitmq?

I had misconfigured my cinder.conf. The rabbit credentials were not in the [DEFAULT] section.

2015-03-10 16:22:51 -0500 received badge  Popular Question (source)
2015-03-06 18:44:59 -0500 answered a question Why can't cinder-scheduler authenticate to rabbitmq?

Yes. I have the password configured for guest properly. I just enabled the rabbitmq web interface and logged in as the guest user so I know the account works.

2015-03-05 12:45:58 -0500 commented question Why can't cinder-scheduler authenticate to rabbitmq?

I reinstalled rabbitmq and now the cinder-scheduler can connect to rabbitmq @127.0.0.1 but cinder-volume is not able authenticate from the foreign block service node.

2015-03-05 12:37:50 -0500 commented answer why is the cinder-volume service down ?

What did you do to fix the rabbitmq issue?

2015-03-04 22:42:48 -0500 asked a question Why can't cinder-scheduler authenticate to rabbitmq?

While setting up an iSCSI host (using http://docs.openstack.org/juno/install-guide/install/apt/content/cinder-verify.html (http://docs.openstack.org/juno/instal...) ) I discovered that cinder-scheduler is not running on my controller node. So I tailed the /var/log/cinder/cinder-scheduler log on the controller and saw,

2015-03-04 22:07:18.104 17613 INFO oslo.messaging._drivers.impl_rabbit [req-d76e8a3c-4cac-4711-81f4-8f7a93a095e4 - - - - -] Delaying reconnect for 1.0 seconds... 2015-03-04 22:07:19.106 17613 INFO oslo.messaging._drivers.impl_rabbit [req-d76e8a3c-4cac-4711-81f4-8f7a93a095e4 - - - - -] Connecting to AMQP server on localhost:5672 2015-03-04 22:07:22.121 17613 ERROR oslo.messaging._drivers.impl_rabbit [req-d76e8a3c-4cac-4711-81f4-8f7a93a095e4 - - - - -] AMQP server localhost:5672 closed the connection. Check login credentials: Socket closed

Also, my /etc/rabbit directory is completely empty. I have reset the rabbitmq guest account password to what I know is correct and other services are able to authenticate using these credentials.

2015-03-04 14:18:45 -0500 received badge  Enthusiast