Ask Your Question

Meghna's profile - activity

2019-03-07 12:23:02 -0500 received badge  Famous Question (source)
2016-12-22 11:31:12 -0500 commented question gnocchi-api fails with 403 Forbidden

Thanks Eduardo. The commands were really helpful. I am using file as a backend for gnocchi. The problem was the install_type was not binary it was source.

2016-12-02 09:09:40 -0500 received badge  Famous Question (source)
2016-11-30 09:11:15 -0500 received badge  Notable Question (source)
2016-11-28 03:28:06 -0500 received badge  Popular Question (source)
2016-11-24 08:18:05 -0500 asked a question gnocchi-api fails with 403 Forbidden

Hi I am using kolla for deploying openstack services. I was able to deploy keystone, nova, cinder, neutron services successfully. Then I enabled gnocchi service and re-deployed all the containers with it. The gnocchi containers for services gnocchi-api, gnocchi-metricd and gnocchi-statsd are up. But when I try to use the gnocchi command line/apis it fails with 403 error.

<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>403 Forbidden</title>
</head><body>
<h1>Forbidden</h1>
<p>You don't have permission to access /v1/resource/generic
on this server.</p>
</body></html>

Can you please help me.

2016-10-15 09:31:44 -0500 received badge  Notable Question (source)
2015-12-29 00:57:18 -0500 received badge  Scholar (source)
2015-12-29 00:52:15 -0500 received badge  Popular Question (source)
2015-12-08 08:25:17 -0500 commented answer Ceilometer : add new plugin and meter

Thanks for the response. This worked for me - systemctl restart openstack-ceilometer-central.service

2015-12-08 08:22:34 -0500 asked a question [Barbican] Barbican devstack installation failing

I tried installing Barbican using the steps mentioned in https://wiki.openstack.org/wiki/Barbi.... I am using juno branch.

Devstack got installed but the service entries and endpoint was not registered in keystone. So I did that manually and after that I tried rejoining the screen but I get an error that the service is not reachable.

My localrc file -

[[local|localrc]]

disable_all_services
enable_service rabbit mysql key barbican
KEYSTONE_TOKEN_FORMAT=UUID
DATABASE_PASSWORD=password
RABBIT_PASSWORD=password
SERVICE_TOKEN=password
SERVICE_PASSWORD=password
ADMIN_PASSWORD=secretadmin

Can you please help me with this.

2015-12-08 08:21:50 -0500 commented answer Ceilometer : meter list not getting updated

Thanks for the response. The problem was with the data, the project_id was wrong.

2015-11-14 07:18:46 -0500 received badge  Popular Question (source)
2015-11-06 11:51:00 -0500 received badge  Famous Question (source)
2015-10-19 21:56:01 -0500 received badge  Notable Question (source)
2015-10-19 08:57:31 -0500 asked a question Ceilometer : meter list not getting updated

I am using Openstack juno setup (using packstack). OS - RHEL 7. I add a new plugin in central, deployed the code and I can see the logs generated for the new plugin. Also the samples are created, but when I do Ceilometer meter-list , no new plugin is added.

Steps that I followed after adding new plugin in Ceilometer - 1) Added the new plugin in setup.cfg/entry_points.txt 2) Restarted the central service.

Can you please help me or provide me any pointers.

2015-10-19 08:47:01 -0500 received badge  Popular Question (source)
2015-09-29 01:45:44 -0500 received badge  Enthusiast
2015-09-28 11:43:53 -0500 asked a question Ceilometer : add new plugin and meter

Hi

I have installed devstack juno. I wanted to add a new pollster to ceilometer. This pollster will just call some API's which will return data that I need to store it in collector.

I tried adding a class inheriting centralPollster and added name in setup.cfg. and then restarted the services with ./rejoin-stack.sh But this didn't work.

The ceilometer meter-list returns nothing except the existing meters.

Can anyone please help me how I can achieve this in Juno using devstack setup.

2015-05-19 05:10:11 -0500 received badge  Famous Question (source)
2015-02-27 09:28:33 -0500 received badge  Notable Question (source)
2015-02-27 03:41:08 -0500 answered a question Running keystone in httpd

Thanks for the reply. I verified I already have the keystone-paste.ini at the /etc/keystone, but it still fails. I saw that the config_file parameter in the keystone.conf refers to the keystone-paste.ini file. Can you please verify if the content of the keystone.py/admin/main files I'm using is correct. cat /var/www/cgi-bin/keystone/keystone.py

import os from keystone import config from paste import deploy import logging from keystone.common import utils from keystone.common import wsgi

CONF = config.CONF config_files = ['/etc/keystone/keystone.conf'] CONF(project='keystone', default_config_files=config_files)

conf = CONF.config_file[0] name = os.path.basename(__file__)

options = deploy.appconfig('config:%s' % CONF.config_file[0]) application = deploy.loadapp('config:%s' % conf, name=name)

2015-02-26 03:03:41 -0500 commented question Running keystone in httpd
3)  cat /etc/httpd/conf.d/wsgi-keystone.conf
WSGIScriptAlias /keystone/main  /var/www/cgi-bin/keystone/main
WSGIScriptAlias /keystone/admin  /var/www/cgi-bin/keystone/admin
<location "="" keystone"="">
 NSSRequireSSL
 Authtype none
</location>
2015-02-26 03:01:41 -0500 commented question Running keystone in httpd

2) ls -al /etc/keystone -rw-r-----. 1 keystone keystone 1504 Dec 5 10:33 default_catalog.templates -rwxrwxrwx+ 1 keystone keystone 52500 Feb 25 19:12 keystone.conf -rw-r-----. 1 keystone keystone 1046 Dec 5 10:33 logging.conf -rw-r-----. 1 keystone keystone 8051 Dec 5 10:33 policy.json

2015-02-26 02:58:45 -0500 commented question Running keystone in httpd

1) ls -al /va/www/cgi-bin/keystone drwxr-xr-x. 2 root root 4096 Feb 26 14:26 . drwxr-xr-x. 3 root root 21 Jan 12 18:53 .. -rw-r--r--. 3 root root 505 Feb 26 14:23 admin -rw-r--r--. 3 root root 505 Feb 26 14:23 keystone.py -rw-r--r--. 3 root root 505 Feb 2

2015-02-26 00:35:45 -0500 received badge  Popular Question (source)
2015-02-25 08:38:31 -0500 asked a question Running keystone in httpd

I'm trying to run keystone in httpd. I have done the setup on centos 7, Junos. I made changes as mentioned in http://docs.openstack.org/developer/k... . but when I try to test it.( https://server.com/keystone/admin ) it fails and prompts an error in the httpd error logs.

[Wed Feb 25 19:37:04.312040 2015] [:error] [pid 17770] No handlers could be found for logger "keystone.openstack.common.versionutils"
[Wed Feb 25 19:37:04.322164 2015] [:error] [pid 17770] [remote 192.168.10.1:51971] mod_wsgi (pid=17770): Target WSGI script '/var/www/cgi-bin/keystone/admin' cannot be loaded as Python module.
[Wed Feb 25 19:37:04.322193 2015] [:error] [pid 17770] [remote 192.168.10.1:51971] mod_wsgi (pid=17770): SystemExit exception raised by WSGI script '/var/www/cgi-bin/keystone/admin' ignored.
[Wed Feb 25 19:37:04.322218 2015] [:error] [pid 17770] [remote 192.168.10.1:51971] Traceback (most recent call last):
[Wed Feb 25 19:37:04.322236 2015] [:error] [pid 17770] [remote 192.168.10.1:51971]   File "/var/www/cgi-bin/keystone/admin", line 25, in <module>
[Wed Feb 25 19:37:04.322299 2015] [:error] [pid 17770] [remote 192.168.10.1:51971]     application = deploy.loadapp('config:%s' % conf, name=name)
[Wed Feb 25 19:37:04.322310 2015] [:error] [pid 17770] [remote 192.168.10.1:51971]   File "/usr/lib/python2.7/site-packages/paste/deploy/loadwsgi.py", line 247, in loadapp
[Wed Feb 25 19:37:04.322346 2015] [:error] [pid 17770] [remote 192.168.10.1:51971]     return loadobj(APP, uri, name=name, **kw)
[Wed Feb 25 19:37:04.322346 2015] [:error] [pid 17770] [remote 192.168.10.1:51971]   File "/usr/lib/python2.7/site-packages/paste/deploy/loadwsgi.py", line 272, in loadobj
[Wed Feb 25 19:37:04.322346 2015] [:error] [pid 17770] [remote 192.168.10.1:51971]     return context.create()
[Wed Feb 25 19:37:04.322346 2015] [:error] [pid 17770] [remote 192.168.10.1:51971]   File "/usr/lib/python2.7/site-packages/paste/deploy/loadwsgi.py", line 710, in create
[Wed Feb 25 19:37:04.322346 2015] [:error] [pid 17770] [remote 192.168.10.1:51971]     return self.object_type.invoke(self)
[Wed Feb 25 19:37:04.322346 2015] [:error] [pid 17770] [remote 192.168.10.1:51971]   File "/usr/lib/python2.7/site-packages/paste/deploy/loadwsgi.py", line 144, in invoke
[Wed Feb 25 19:37:04.322346 2015] [:error] [pid 17770] [remote 192.168.10.1:51971]     **context.local_conf)
[Wed Feb 25 19:37:04.322346 2015] [:error] [pid 17770] [remote 192.168.10.1:51971]   File "/usr/lib/python2.7/site-packages/paste/deploy/util.py", line 56, in fix_call
[Wed Feb 25 19:37:04.322383 2015] [:error] [pid 17770] [remote 192.168.10.1:51971]     val = callable(*args, **kw)
[Wed Feb 25 19:37:04.322912 2015] [:error] [pid 17770] [remote 192.168.10.1:51971]   File "/usr/lib/python2.7/site-packages/paste/urlmap ...
(more)