Ask Your Question

ALU.RDC's profile - activity

2016-02-29 14:55:50 -0500 marked best answer Keystone Unable to Establish Connection

Hello everyone. I'd like to provide you with a very clear concise description of what I have set up, so there is no ambiuguity.

I have 1 single server, with 1 active network interface. I'm running OpenSuSE 13.1. I'm trying to install Openstack-keystone. I have the option of running through a proxy, but at the moment, I have it set to disabled in /etc/sysconfig/proxy.   My export list has no proxy variables set. but I did have a no_proxy="localhost, 127.0.0.1, <myip"  variable set at one time during testing.  

Ok, so with that background, onto my problem.  I have set up openstack-keystone, mysql-python (which uses mariadb) 

My first issue is this when I start keystone I get this output:

>  Loaded: loaded (/etc/init.d/openstack-keystone)
   Active: active (exited) since Tue 2015-02-17 04:44:02 EST; 7min ago
  Process: 4262 ExecStop=/etc/init.d/openstack-keystone stop (code=exited, status=0/SUCCESS)
  Process: 4272 ExecStart=/etc/init.d/openstack-keystone start (code=exited, status=0/SUCCESS)

The status is Active (Exited). As opposed to other processes that have Active (running). I thought this may be normal, but in running netstat -atp or netstat -tulpen I see nothing that shows that the keystone process is listening for connections. My /etc/keystone/keystone.conf (which i'll post shortly) has it's bind address to 0.0.0.0 and it listening on ports 35357 and 5000.

Yet when I go to run or start openstack-keystone, while it recieves a real process ID, it shows no listening port. I've grepped for it, and everything. There is nothing listening on 35357 or 5000. Now before this issue comes up, I have opened up the ports in SuSEfirewall. In fact, I actually disabled the entire firewall itself, unloaded all rules. Currently, the system is wide open, no firewall rules exist.

So this leads to the next issue. I'm not sure if they are related. After I even start openstack-keystone (when it is in active (exited)), I try to connect to the mysql database. From the terminal i can issue 'mysql -u root -p" and enter the database no problem. In fact, I ran a keystone-manage db_sync keystone, and it populated the keystone table with 18 entries. So I'm assuming that all is correct....

The problem is when I take it a step further. I use the command 'keystone tenant-create --name admin --description 'admin-tenant'

This is where things get really hairy. The error I'm getting is:

Unable to establish connection to http://127.0.0.1:35357/v2.0/tenants

That's the error I receive if I set the OS_SERVICE_ENDPOINT equal to 127.0.0.1. I've tried many options such as localhost, controller, and my own interface's IP address. The results are the same. It is unable to establish a connection. I can only assume this is linked to the fact that I see nothing listening on ports 35357 and 5000.

Also ... (more)

2015-06-29 01:12:57 -0500 received badge  Famous Question (source)
2015-04-03 14:57:13 -0500 received badge  Famous Question (source)
2015-04-03 00:29:36 -0500 received badge  Notable Question (source)
2015-04-03 00:29:36 -0500 received badge  Notable Question (source)
2015-04-03 00:28:51 -0500 received badge  Popular Question (source)
2015-03-03 08:54:02 -0500 received badge  Famous Question (source)
2015-02-26 11:19:01 -0500 commented answer Glance Commands: Invalid Credentials

Thanks! My email is steven.fowlkes@alcatel-lucent.com Will the Juno documentation be updated?

2015-02-26 10:57:39 -0500 commented answer Keystone user-role-add : HTTP 409

hmm ok you're right in that using the --user glance --tenant service shows the role..but why doesn't doing just a keystone user-role-list' show all user's roles?

2015-02-26 10:51:27 -0500 received badge  Notable Question (source)
2015-02-26 01:34:30 -0500 received badge  Popular Question (source)
2015-02-25 20:19:21 -0500 asked a question Keystone user-role-add : HTTP 409

Hey everyone, I have another ticket open, but I'm not sure if the two issues are related... This is my issue. I have keystone setup, but my glance setup has been giving me a lot of grief.

Basically when I run glance commands such as: glance index ID Name Disk Format Container Format Size


Request returned failure status. Invalid OpenStack Identity credentials.

I get the identity credentials error...

My first question is this...I am running OpenSuSE 13.1. I have run an update on all my repos. But whenever I uninstall and then reinstall openstack-keystone with the newest most up to date version, I get the keystone.conf that is in this format:

[DEFAULT]
[DEFAULT]
verbose = True
log_file = keystone.log
log_dir = /var/log/keystone
# A "shared secret" between keystone and other openstack services
admin_token = 63d9bcc957b5bc12c568
# The IP address of the network interface to listen on
bind_host = 0.0.0.0

# The port number which the public service listens on
public_port = 5000

# The port number which the public admin listens on
admin_port = 35357

# The base endpoint URLs for keystone that are advertised to clients
# (NOTE: this does NOT affect how keystone listens for connections)
#public_endpoint = http://localhost:%(3306)s/
#admin_endpoint = http://localhost:%(3306)s/

# The port number which the OpenStack Compute service listens on
compute_port = 8774

# Path to your policy definition containing identity actions
policy_file = policy.json

# Rule to check if no matching policy definition is found
# FIXME(dolph): This should really be defined as [policy] default_rule
policy_default_rule = admin_required

# Role for migrating membership relationships
# During a SQL upgrade, the following values will be used to create a new role
# that will replace records in the user_tenant_membership table with explicit
# role grants.  After migration, the member_role_id will be used in the API
# add_user_to_project, and member_role_name will be ignored.
# member_role_id = 9fe2ff9ee4384b1894a90878d3e92bab
# member_role_name = _member_

# enforced by optional sizelimit middleware (keystone.middleware:RequestBodySizeLimiter)
# max_request_body_size = 114688

# limit the sizes of user & tenant ID/names
# max_param_size = 64

# similar to max_param_size, but provides an exception for token values
# max_token_size = 8192

# === Logging Options ===
# Print debugging output
# (includes plaintext request logging, potentially including passwords)
debug = True

# Print more verbose output
verbose = True

# Name of log file to output to. If not set, logging will go to stdout.
log_file = keystone.log

# The directory to keep log files in (will be prepended to --logfile)
log_dir = /var/log/keystone

# Use syslog for logging.
# use_syslog = False

# syslog facility to receive log lines
# syslog_log_facility = LOG_USER

# If this option is specified, the logging configuration file specified is
# used and overrides any other logging options specified. Please see the
# Python logging module documentation for details on logging configuration
# files.
# log_config = logging.conf

# A logging.Formatter log message format string which may use any of the
# available logging.LogRecord attributes.
# log_format = %(asctime)s %(levelname)8s [%(name)s] %(message)s

# Format string for %(asctime)s in log records.
# log_date_format = %Y-%m-%d %H:%M:%S

# onready allows you to send a notification when the process is ready to serve
# For example, to have it notify using systemd ...
(more)
2015-02-25 11:09:35 -0500 commented answer Glance Commands: Invalid Credentials

Yashpal, I have edited my original post with your requests. The keystone user-list indeed does not show the glance user. I posted the --debug information in the original post, under today's date.

2015-02-25 11:05:37 -0500 received badge  Editor (source)
2015-02-25 10:51:03 -0500 commented answer Glance Commands: Invalid Credentials

Hmmm I only see admin here...no sign of glance user role...

2015-02-25 10:36:59 -0500 commented answer Glance Commands: Invalid Credentials

I have a limit of like 300 characters, so I'll post the glance-api.conf and registry.conf files in the original post. I will post the results of keystone user-list there as well. I will uncomment the auth_host etc.. And no, no tables in glance db...glance db_sync doesn't appear to work...Thanks!

2015-02-25 10:16:37 -0500 received badge  Enthusiast
2015-02-25 00:01:20 -0500 received badge  Famous Question (source)
2015-02-24 22:54:02 -0500 received badge  Notable Question (source)
2015-02-24 13:04:20 -0500 commented answer Glance Commands: Invalid Credentials

yet I have this:

What protocol to use when connecting to the registry server?

Set to https for secure HTTP communication

registry_client_protocol = http

2015-02-24 13:03:01 -0500 commented answer Glance Commands: Invalid Credentials

hmmm looking at this...it seems to be trying https instead of http? could this be part of the issue?

2015-02-24 12:56:55 -0500 commented answer Glance Commands: Invalid Credentials

ound) oslo.config.cfg.ConfigFilesNotFoundError: Failed to read some config files: /etc/glance/glance-registry.conf

2015-02-24 12:56:41 -0500 commented answer Glance Commands: Invalid Credentials

tions] <cmd>") File "/usr/lib/python2.7/site-packages/glance/common/config.py", line 107, in parse_args default_config_files=default_config_files) File "/usr/lib/python2.7/site-packages/oslo/config/cfg.py", line 1634, in __call__ raise ConfigFilesNotFoundError(self._namespace.files_not_f

2015-02-24 12:56:28 -0500 received badge  Commentator
2015-02-24 12:56:28 -0500 commented answer Glance Commands: Invalid Credentials

still nothing.. this is what i get: su -s /bin/sh -c "glance-manage db_sync" glance Traceback (most recent call last): File "/usr/bin/glance-manage", line 10, in <module> sys.exit(main()) File "/usr/lib/python2.7/site-packages/glance/cmd/manage.py", line 121, in main usage="%(prog)s [op

2015-02-24 12:47:34 -0500 commented answer Glance Commands: Invalid Credentials

Which glance log should I be posting, api.log or registry.log?

2015-02-24 12:46:46 -0500 commented answer Glance Commands: Invalid Credentials

I don't think it's the endpoint, I've run through that series of commands a few times already: I have a brand new service I create with the name glance, then I create the new endpoint, and use the id of that service... The only thing I did was use 127.0.0.1:9292 instead of controller name

2015-02-24 12:24:48 -0500 commented answer Glance Commands: Invalid Credentials

Yep, The output was included in my original post... Is there a command to verify it just incase? Doing a keystone user-list just shows that the user exists. Is there a way to show which role each one has?

2015-02-24 00:54:47 -0500 received badge  Popular Question (source)
2015-02-24 00:54:47 -0500 received badge  Popular Question (source)
2015-02-23 21:00:16 -0500 asked a question Glance Commands: Invalid Credentials

Ok, so before I punch a hole into my laptop, let me open up a question for you all... I'll try to provide as much background, up front to prevent a long dialogue. I'm trying to run Openstack on one single device. I have keystone installed, and it's running fine. I can get tokens, add services, tenants, users etc... I went to install and configure glance, and it's giving me a ton of issues. I'm running Opensuse 13.1, trying to install the juno series of openstack.

I installed glance successfully, and configured the glance-api and glance-registry conf files according to the documentation. But everytime I run any glance based command such as ' glance index ' or ' glance image-list ' Basically any glance based command will give me the same error. So I can't create any images. Now before you jump to assume it's a username/password issue, let me give you the full logs and errors.

Ok so first off these are my environment variables:

OS_AUTH_URL="http://127.0.0.1:5000/v2.0"
OS_PASSWORD="<passwordforadmin>"
OS_TENANT_NAME="admin"
OS_USERNAME="admin"

My api / registry configs are pretty much mirrors of the auth_token section

This is the /etc/glance/glance-api.conf

[keystone_authtoken]
#auth_host = 127.0.0.1
#auth_port = 35357
#auth_protocol = http
auth_uri = http://localhost:5000/v2.0
identity_uri = http://localhost:35357
admin_tenant_name = service
admin_user = admin
admin_password = <passwordforglance>

Note which ones are commented out and which ones are active

Below is my /etc/glance/glance-registry.conf

[keystone_authtoken]
#auth_host = 127.0.0.1
#auth_port = 35357
#auth_protocol = http
identity_uri = http://localhost:35357
auth_uri = http://localhost:5000/v2.0
admin_tenant_name = service
admin_user = glance
admin_password = <passwordforglance>

Please note which ones are commented out and the the passwords, which differ from the environment variable. Hopefully it's correct so far.

Ok, so let's move onto a big question... in the documentation for Juno it says that the connection = mysql statement should be under the [database] header. Well the problem with that....is that there is NO [database] header. In both glance-api.conf and glance-registry.conf there is a [sql] header. Should I put my connection = mysql:// in the [sql] section, or create the [database] header and put the connection statement in there?

here's what my file looks like:

[sql]
connection = mysql://glance:csc3gadm@localhost/glance
#connection = sqlite:////var/lib/glance/glance.db

Note that I commented out the previous connection. Should I do this? Or should I add the connection = mysql:// and leave the connection = sqlite statement in as well?

Okay, so there's also the following error...whenever I try to do a glance db_sync, it sends and creates a file called. /var/lib/glance/glance.sqlite Should this happened? There is NOTHING inside the mysql glance table. But yet my glance confs have all of the default sqlite statements, commented out. How is this still happening? On both conf files i have my mysql commands set, yet it doesn't seem to matter.

So finally my main question ... (more)

2015-02-22 23:42:56 -0500 received badge  Notable Question (source)
2015-02-22 03:22:26 -0500 received badge  Popular Question (source)
2015-02-20 14:54:20 -0500 answered a question glance-api fails to start and establish port connection

Got it working. I'm not 100% sure on the issue maybe someone can explain what happened, but I had to run :

glance-manage db_sync

Running this gave me the following output:

2015-02-20 05:58:23.524 4635 DEBUG migrate.versioning.util [-] Constructing engine construct_engine /usr/lib/python2.7/site-packages/migrate/versioning/util/__init__.py:136 2015-02-20 05:58:23.528 4635 DEBUG migrate.versioning.repository [-] Loading repository /usr/lib/python2.7/site-packages/glance/db/sqlalchemy/migrate_repo... __init__ /usr/lib/python2.7/site-packages/migrate/versioning/repository.py:76 2015-02-20 05:58:23.529 4635 DEBUG migrate.versioning.script.base [-] Loading script /usr/lib/python2.7/site-packages/glance/db/sqlalchemy/migrate_repo/versions/001_add_images_table.py... __init__ /usr/lib/python2.7/site-packages/migrate/versioning/script/base.py:26 2015-02-20 05:58:23.530 4635 DEBUG migrate.versioning.script.base [-] Script /usr/lib/python2.7/site-packages/glance/db/sqlalchemy/migrate_repo/versions/001_add_images_table.py loaded successfully __init__ /usr/lib/python2.7/site-packages/migrate/versioning/script/base.py:29 2015-02-20 05:58:23.530 4635 DEBUG migrate.versioning.script.base [-] Loading script /usr/lib/python2.7/site-packages/glance/db/sqlalchemy/migrate_repo/versions/002_add_image_properties_table.py... __init__ /usr/lib/python2.7/site-packages/migrate/versioning/script/base.py:26 2015-02-20 05:58:23.530 4635 DEBUG migrate.versioning.script.base [-] Script /usr/lib/python2.7/site-packages/glance/db/sqlalchemy/migrate_repo/versions/002_add_image_properties_table.py loaded successfully __init__ /usr/lib/python2.7/site-packages/migrate/versioning/script/base.py:29 2015-02-20 05:58:23.530 4635 DEBUG migrate.versioning.script.base [-] Loading script /usr/lib/python2.7/site-packages/glance/db/sqlalchemy/migrate_repo/versions/003_sqlite_upgrade.sql... __init__ /usr/lib/python2.7/site-packages/migrate/versioning/script/base.py:26 2015-02-20 05:58:23.531 4635 DEBUG migrate.versioning.script.base [-] Script /usr/lib/python2.7/site-packages/glance/db/sqlalchemy/migrate_repo/versions/003_sqlite_upgrade.sql loaded successfully __init__ /usr/lib/python2.7/site-packages/migrate/versioning/script/base.py:29 2015-02-20 05:58:23.531 4635 DEBUG migrate.versioning.script.base [-] Loading script /usr/lib/python2.7/site-packages/glance/db/sqlalchemy/migrate_repo/versions/003_sqlite_downgrade.sql... __init__ /usr/lib/python2.7/site-packages/migrate/versioning/script/base.py:26 2015-02-20 05:58:23.531 4635 DEBUG migrate.versioning.script.base [-] Script /usr/lib/python2.7/site-packages/glance/db/sqlalchemy/migrate_repo/versions/003_sqlite_downgrade.sql loaded successfully __init__ /usr/lib/python2.7/site-packages/migrate/versioning/script/base.py:29 2015-02-20 05:58:23.531 4635 DEBUG migrate.versioning.script.base [-] Loading script /usr/lib/python2.7/site-packages/glance/db/sqlalchemy/migrate_repo/versions/003_add_disk_format.py... __init__ /usr/lib/python2.7/site-packages/migrate/versioning/script/base.py:26 2015-02-20 05:58:23.531 4635 DEBUG migrate.versioning.script.base [-] Script /usr/lib/python2.7/site-packages/glance/db/sqlalchemy/migrate_repo/versions/003_add_disk_format.py loaded successfully __init__ /usr/lib/python2.7/site-packages/migrate/versioning/script/base.py:29 2015-02-20 05:58:23.532 4635 DEBUG migrate.versioning.script.base [-] Loading script /usr/lib/python2.7/site-packages/glance/db/sqlalchemy/migrate_repo/versions/004_add_checksum.py... __init__ /usr/lib/python2.7/site-packages/migrate/versioning/script/base.py:26 2015-02-20 ... (more)

2015-02-20 14:42:49 -0500 commented question glance-api fails to start and establish port connection

I also have this error upon restart, hope it helps: Feb 20 03:53:25 csc-openstack-160 openstack-glance-api[4192]: 2015-02-20 03:53:25.156 4201 TRACE glance OperationalError: (OperationalError) unable to open database file None None

2015-02-20 13:28:48 -0500 commented question glance-api fails to start and establish port connection

2015-02-20 04:37:10.905 4332 DEBUG glance.common.config [-] ************************** log_opt_values /usr/lib/python2.7/site-packages/oslo/config/cfg.py:1951

2015-02-20 13:27:40 -0500 commented question glance-api fails to start and establish port connection

Because now, once I killed the hanging glance-api program, and the 9292 port is no longer being used by it. I try to start a new glance-api process...and it just hangs here:

2015-02-20 04:37:10.905 4332 DEBUG glance.common.config [-] ********************

2015-02-20 13:24:57 -0500 commented question glance-api fails to start and establish port connection

Ok, I may have mis-diagnosed my problem. I saw that 9292 port as listening on netstat because that was the glance-api program... So it gets as far enough along to bring up the port to a listening state, but fails after that.

2015-02-20 13:09:55 -0500 commented question glance-api fails to start and establish port connection

my auth section of /etc/glance/glance-api.conf: auth_uri = http://127.0.0.1:5000/v2.0 identity_uri = http://127.0.0.1:35357 admin_tenant_name = service admin_user = glance admin_password

It looks good to me, everything checks out.. and I can connect to the keystone db

2015-02-20 13:02:40 -0500 answered a question glance-api fails to start and establish port connection

Ok, I may have mis-diagnosed my problem. I saw that 9292 port as listening on netstat because that was the glance-api program...

So it gets as far enough along to bring up the port to a listening state, but fails after that. This is what a stack trace gave me:

************* log_opt_values /usr/lib/python2.7/site-packages/oslo/config/cfg.py:1951 ) = 213 setpgid(4222, 4222) = 0 socket(PF_NETLINK, SOCK_RAW, 0) = 5 bind(5, {sa_family=AF_NETLINK, pid=0, groups=00000000}, 12) = 0 getsockname(5, {sa_family=AF_NETLINK, pid=4222, groups=00000000}, [12]) = 0 sendto(5, "\24\0\0\0\26\0\1\3:\367\346T\0\0\0\0\0\0\0\0", 20, 0, {sa_family=AF_NETLINK, pid=0, groups=00000000}, 12) = 20 recvmsg(5, {msg_name(12)={sa_family=AF_NETLINK, pid=0, groups=00000000}, msg_iov(1)=[{"L\0\0\0\24\0\2\0:\367\346T~\20\0\0\2\10\200\376\1\0\0\0\10\0\1\0\177\0\0\1"..., 4096}], msg_controllen=0, msg_flags=0}, 0) = 160 recvmsg(5, {msg_name(12)={sa_family=AF_NETLINK, pid=0, groups=00000000}, msg_iov(1)=[{"\24\0\0\0\3\0\2\0:\367\346T~\20\0\0\0\0\0\0", 4096}], msg_controllen=0, msg_flags=0}, 0) = 20 close(5) = 0 gettimeofday({1424422714, 346556}, NULL) = 0 gettimeofday({1424422714, 346629}, NULL) = 0 socket(PF_INET, SOCK_STREAM, IPPROTO_IP) = 5 fcntl(5, F_GETFL) = 0x2 (flags O_RDWR) fcntl(5, F_SETFL, O_RDWR|O_NONBLOCK) = 0 setsockopt(5, SOL_SOCKET, SO_REUSEADDR, [1], 4) = 0 bind(5, {sa_family=AF_INET, sin_port=htons(9292), sin_addr=inet_addr("0.0.0.0")}, 16) = 0 listen(5, 4096) = 0 setsockopt(5, SOL_SOCKET, SO_REUSEADDR, [1], 4) = 0 setsockopt(5, SOL_SOCKET, SO_KEEPALIVE, [1], 4) = 0 setsockopt(5, SOL_TCP, TCP_KEEPIDLE, [600], 4) = 0 umask(027) = 022 rt_sigaction(SIGTERM, {0x7f0327df7460, [], SA_RESTORER, 0x7f0327b499f0}, {SIG_DFL, [], 0}, 8) = 0 rt_sigaction(SIGINT, {0x7f0327df7460, [], SA_RESTORER, 0x7f0327b499f0}, {0x7f0327df7460, [], SA_RESTORER, 0x7f0327b499f0}, 8) = 0 rt_sigaction(SIGHUP, {0x7f0327df7460, [], SA_RESTORER, 0x7f0327b499f0}, {SIG_DFL, [], 0}, 8) = 0 clone(child_stack=0, flags=CLONE_CHILD_CLEARTID|CLONE_CHILD_SETTID|SIGCHLD, child_tidptr=0x7f032831b9d0) = 4226 wait4(-1,

It ends there, not sure if this means anything...

my auth section of /etc/glance/glance-api.conf

auth_uri = http://127.0.0.1:5000/v2.0 identity_uri = http://127.0.0.1:35357 admin_tenant_name = service admin_user = glance admin_password = [paste_deploy]

Name of the paste configuration file that defines the available pipelines

#config_file = glance-api-paste.ini

Partial name of a pipeline in your paste configuration file with the

service name removed. For example, if your paste section name is

[pipeline:glance-api-keystone], you would configure the flavor below

as 'keystone'.

flavor= keystone

2015-02-20 11:59:50 -0500 asked a question glance-api fails to start and establish port connection

Hello everyone. Let me get you the background for my set up first: I have 1 single server, with 1 active network interface. I'm running OpenSuSE 13.1. I'm trying to install Openstack-glance. I have the option of running through a proxy, but at the moment, I have it set to disabled in /etc/sysconfig/proxy. My export list has no proxy variables set. but I did have a no_proxy="localhost, 127.0.0.1, <myip" variable="" set="" at="" one="" time="" during="" testing.="" <="" p="">

  1. Now I have keystone running but the state is in Active (exited), what does this mean exactly? Will the the fact that it's "exited" effect certain connections?

  2. I installed glance, and made the neccessary changes. But upon set up, only glance-registry starts. glance-api fails. I checked the logs and received this after running glance-api --config-file /etc/glance/glance-api.conf --debug

    2015-02-20 03:02:31.056 3932 DEBUG glance.store [-] Attempting to import store glance.store.filesystem.Store _get_store_class /usr/lib/python2.7/site-packages/glance/store/__init__.py:146 2015-02-20 03:02:31.057 3932 DEBUG glance.store [-] Registering store <class 'glance.store.filesystem.store'=""> with schemes ('file', 'filesystem') create_stores /usr/lib/python2.7/site-packages/glance/store/__init__.py:176 2015-02-20 03:02:31.057 3932 DEBUG glance.store.base [-] Late loading location class glance.store.filesystem.StoreLocation get_store_location_class /usr/lib/python2.7/site-packages/glance/store/base.py:82 2015-02-20 03:02:31.058 3932 DEBUG glance.store.location [-] Registering scheme file with {'store_class': <class 'glance.store.filesystem.store'="">, 'location_class': <class 'glance.store.filesystem.storelocation'="">} register_scheme_map /usr/lib/python2.7/site-packages/glance/store/location.py:86 2015-02-20 03:02:31.058 3932 DEBUG glance.store.location [-] Registering scheme filesystem with {'store_class': <class 'glance.store.filesystem.store'="">, 'location_class': <class 'glance.store.filesystem.storelocation'="">} register_scheme_map /usr/lib/python2.7/site-packages/glance/store/location.py:86 2015-02-20 03:02:31.058 3932 DEBUG glance.store [-] Attempting to import store glance.store.http.Store _get_store_class /usr/lib/python2.7/site-packages/glance/store/__init__.py:146 2015-02-20 03:02:31.059 3932 DEBUG glance.store [-] Registering store <class 'glance.store.http.store'=""> with schemes ('http', 'https') create_stores /usr/lib/python2.7/site-packages/glance/store/__init__.py:176 2015-02-20 03:02:31.059 3932 DEBUG glance.store.base [-] Late loading location class glance.store.http.StoreLocation get_store_location_class /usr/lib/python2.7/site-packages/glance/store/base.py:82 2015-02-20 03:02:31.059 3932 DEBUG glance.store.location [-] Registering scheme http with {'store_class': <class 'glance.store.http.store'="">, 'location_class': <class 'glance.store.http.storelocation'="">} register_scheme_map /usr/lib/python2.7/site-packages/glance/store/location.py:86 2015-02-20 03:02:31.059 3932 DEBUG glance.store.location [-] Registering scheme https with {'store_class': <class 'glance.store.http.store'="">, 'location_class': <class 'glance.store.http.storelocation'="">} register_scheme_map /usr/lib/python2.7/site-packages/glance/store/location.py:86 2015-02-20 03:02:31.060 3932 DEBUG glance.store [-] Attempting to import store glance.store.rbd.Store _get_store_class /usr/lib/python2.7/site-packages/glance/store/__init__.py:146 2015-02-20 ...

(more)
2015-02-20 10:27:43 -0500 commented answer Keystone Unable to Establish Connection

Thanks for the response madhank. I have two questions. Before I drop the keystone database and do as you say, will this cause all of my service Id's, tenants, and users from glance to be removed?

Also I'm having trouble starting the openstack-glance-api process. Could this be related to it?

2015-02-19 23:01:03 -0500 received badge  Student (source)
2015-02-19 06:56:29 -0500 received badge  Famous Question (source)
2015-02-18 11:19:32 -0500 answered a question Keystone Unable to Establish Connection

Thanks! I actually found out the issue. According the Juno install docs for opensuse, it says to add the .persistence. keyword to the [token] portion of the /etc/keystone/keystone.conf file. Like this: ... [token] # Provides token persistence. driver = keystone.token.persistence.backends.sql.Token ....

After removing the persistence word, I had no issue. I restarted openstack-keystone, it brought the ports up, I was able to connect to them, and I finished the keystone install last night... Again I removed the word persistence from the drive parameter, and it worked.

driver = keystone.token.backends.sql.Token

They ask you to place the keyword "persistence" in between token and backends. It causes the keystone.conf file to not be fully loaded, and the port's listed in the same file, will not be opened up.