Ask Your Question

koryk's profile - activity

2016-06-24 16:02:21 -0500 received badge  Supporter (source)
2015-02-27 02:52:28 -0500 received badge  Self-Learner (source)
2015-02-27 02:52:28 -0500 received badge  Teacher (source)
2015-02-27 02:51:47 -0500 received badge  Famous Question (source)
2015-02-22 04:44:05 -0500 answered a question 503 Internal Server Error

I verified everything working fine. I even checked every swift related services on controller node and storage nodes and they were running all okay with no single error.

I found firewall is running on centOS 7, and since I disabled it (I just did systemctl stop/disable firewalld.service) and swift stat/list commands perfectly working with no problems.

No 503 errors either.

2015-02-22 04:39:38 -0500 received badge  Notable Question (source)
2015-02-22 03:22:26 -0500 received badge  Enthusiast
2015-02-19 01:05:52 -0500 received badge  Famous Question (source)
2015-02-18 03:11:54 -0500 received badge  Popular Question (source)
2015-02-16 03:21:33 -0500 asked a question 503 Internal Server Error

Hello expert,

I have problems with "swift stat" command and I wonder if anyone can assist me in troubleshooting the issue.

I 've got the error "INFO:swiftclient:RESP STATUS: 503 Internal Server Error" when run the command "Swift stat" with debug options. I understand there are several similar cases already addressed in this site, however, it really did not help to resolve my problem.

Here are my finding so far.

  • there is a case with the same error/same command but error is slightly different with mine..the error I am facing does include only single 8080 not double such as 8080/8080.

  • I have tried to change the bind_ip on storage nodes in every account/object/container conf files to "0.0.0.0" but stills same issue.

  • From controller node, when doing swing-ring-builder command for account/object/container, it passes okay with no problems.

  • systemctl status on all the services from controller node/storage nodes look perfectly okay. No failures found. (I checked "proxy-server, memcache on controller and account/container/object services on storage nodes")

  • Have tried to delete endpoint from keystone and recreate it but did not help.

  • Have attempted to use new proxy-server.conf file but did not fix it either.

############ The errors I am getting when running swift --debug stat. ##########

@controller /]$ swift --debug stat DEBUG:keystoneclient.auth.identity.v2:Making authentication request to http://controller:5000/v2.0/tokens INFO:urllib3.connectionpool:Starting new HTTP connection (1): controller DEBUG:urllib3.connectionpool:"POST /v2.0/tokens HTTP/1.1" 200 3519 DEBUG:iso8601.iso8601:Parsed 2015-02-16T10:09:45Z into {'tz_sign': None, 'second_fraction': None, 'hour': u'10', 'daydash': u'16', 'tz_hour': None, 'month': None, 'timezone': u'Z', 'second': u'45', 'tz_minute': None, 'year': u'2015', 'separator': u'T', 'monthdash': u'02', 'day': None, 'minute': u'09'} with default timezone DEBUG:iso8601.iso8601:Got u'2015' for 'year' with default None DEBUG:iso8601.iso8601:Got u'02' for 'monthdash' with default 1 DEBUG:iso8601.iso8601:Got 2 for 'month' with default 2 DEBUG:iso8601.iso8601:Got u'16' for 'daydash' with default 1 DEBUG:iso8601.iso8601:Got 16 for 'day' with default 16 DEBUG:iso8601.iso8601:Got u'10' for 'hour' with default None DEBUG:iso8601.iso8601:Got u'09' for 'minute' with default None DEBUG:iso8601.iso8601:Got u'45' for 'second' with default None INFO:urllib3.connectionpool:Starting new HTTP connection (1): controller

DEBUG:urllib3.connectionpool:"HEAD /v1/AUTH_eb479d640e874c4ab0131f1f8c31efba HTTP/1.1" 503 0 INFO:swiftclient:REQ: curl -i http://controller:8080/v1/AUTH_eb479d640e874c4ab0131f1f8c31efba (http://controller:8080/v1/AUTH_eb479d...) -I -H "X-Auth-Token: ed4e8cbf6ced46f9b1e643a6513ef383" INFO:swiftclient:RESP STATUS: 503 Internal Server Error

INFO:swiftclient:RESP HEADERS: [('date', 'Mon, 16 Feb 2015 09:09:46 GMT'), ('content-length', '0'), ('content-type', 'text/html; charset=UTF-8'), ('x-trans-id', 'txe9101653babb4e57ace58-0054e1b3d9')] DEBUG:urllib3.connectionpool:"HEAD /v1/AUTH_eb479d640e874c4ab0131f1f8c31efba HTTP/1.1" 503 0 INFO:swiftclient:REQ: curl -i http://controller:8080/v1/AUTH_eb479d640e874c4ab0131f1f8c31efba (http://controller:8080/v1/AUTH_eb479d...) -I -H "X-Auth-Token: ed4e8cbf6ced46f9b1e643a6513ef383" INFO:swiftclient:RESP STATUS: 503 Internal Server Error INFO:swiftclient:RESP HEADERS ... (more)

2015-02-15 23:43:35 -0500 commented answer Not able to start swift proxy server.

I fixed the problem by re-installing openstack-swift-proxy package!!. Thanks guys all!!.

2015-02-15 15:08:39 -0500 commented answer Not able to start swift proxy server.

The errors in status says "swift-proxy-server[8694]: Error trying to load config from /etc/swift/proxy-server.conf: No loader given in section 'app...-server'

2015-02-15 15:06:52 -0500 commented answer Not able to start swift proxy server.

after that, I noticed proxy-server did not start successfully, which is the reason of why I am investigating it... I tried to correct the config file as advise however, it's not still statable yet..

2015-02-15 15:02:08 -0500 commented answer Not able to start swift proxy server.

Hi, I have configured storage node with no issues and verified everything working fine. I was also able to create the rings and rebalance it fine. since then, I did "systemctl start openstack-swift-proxy.service memcached.service" followed by "swift stat" and found the command "swift stat" failing

2015-02-15 08:52:27 -0500 received badge  Notable Question (source)
2015-02-15 03:01:07 -0500 answered a question Not able to start swift proxy server.

Thanks Varsha and sfcloudman ..really appreciate your comments on it.

I have followed them up but I am still having the problems... Looking at /var/log/messages file, I see following errors...and it does not seem to be parameter related I guess.. Googling it, it seems to be bug, which I am still not quite sure about....I have tried to re-install the controller from scratch again however still having the same issue... I am using cents 7 now, maybe I need to try lower version of it..

Anyways, thanks for your help again. :) please provide any advise if you suspect anything else from below logs,

Feb 14 17:46:26 controller systemd: Starting OpenStack Object Storage (swift) - Proxy Server... Feb 14 17:46:26 controller systemd: Started OpenStack Object Storage (swift) - Proxy Server. Feb 14 17:46:26 controller python: detected unhandled Python exception in '/usr/bin/swift-proxy-server' Feb 14 17:46:26 controller swift-proxy-server: error: cannot open Packages database in /var/lib/rpm Feb 14 17:46:26 controller swift-proxy-server: Traceback (most recent call last): Feb 14 17:46:26 controller swift-proxy-server: File "/usr/bin/swift-proxy-server", line 23, in <module>

2015-02-14 21:00:11 -0500 received badge  Popular Question (source)
2015-02-13 22:24:36 -0500 asked a question Not able to start swift proxy server.

Hello expert.

I am having problems starting up swift proxy server on controller node. Can you please have a look at the logs and let me know what can be done? I have been following the link http://docs.openstack.org/juno/install-guide/install/yum/content/swift-install-controller-node.html (http://docs.openstack.org/juno/instal...) for the configurations however, I am still not able to really start it up despite of multiple confirmations of proxy-server.conf file.

[root@controller swift]# id uid=0(root) gid=0(root) groups=0(root) context=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 [root@controller swift]# [root@controller swift]# [root@controller swift]# uname -a Linux controller 3.10.0-123.20.1.el7.x86_64 #1 SMP Thu Jan 29 18:05:33 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux [root@controller swift]# [root@controller swift]# [root@controller swift]# systemctl start openstack-swift-proxy.service [root@controller swift]# [root@controller swift]# systemctl status openstack-swift-proxy.service openstack-swift-proxy.service - OpenStack Object Storage (swift) - Proxy Server Loaded: loaded (/usr/lib/systemd/system/openstack-swift-proxy.service; enabled) Active: failed (Result: exit-code) since Fri 2015-02-13 17:53:02 PST; 7s ago Process: 7452 ExecStart=/usr/bin/swift-proxy-server /etc/swift/proxy-server.conf (code=exited, status=1/FAILURE) Main PID: 7452 (code=exited, status=1/FAILURE)

Feb 13 17:53:02 controller swift-proxy-server[7452]: for name in pipeline[:-1]] Feb 13 17:53:02 controller swift-proxy-server[7452]: File "/usr/lib/python2.7/site-packages/swift/common/wsgi.py", line 61, in get_context Feb 13 17:53:02 controller swift-proxy-server[7452]: object_type, name=name, global_conf=global_conf) Feb 13 17:53:02 controller swift-proxy-server[7452]: File "/usr/lib/python2.7/site-packages/paste/deploy/loadwsgi.py", line 458, in get_context Feb 13 17:53:02 controller swift-proxy-server[7452]: section) Feb 13 17:53:02 controller swift-proxy-server[7452]: File "/usr/lib/python2.7/site-packages/paste/deploy/loadwsgi.py", line 514, in _context_from_explicit Feb 13 17:53:02 controller swift-proxy-server[7452]: "No loader given in section %r" % section) Feb 13 17:53:02 controller swift-proxy-server[7452]: LookupError: No loader given in section 'filter:cache' Feb 13 17:53:02 controller systemd[1]: openstack-swift-proxy.service: main process exited, code=exited, status=1/FAILURE Feb 13 17:53:02 controller systemd[1]: Unit openstack-swift-proxy.service entered failed state.

The last conf file I tried is as followings. [root@controller swift]# cat proxy-server.conf [DEFAULT] bind_port=8080 user=swift swift_dir=/etc/swift

[pipeline:main] pipeline=authtoken cache healthcheck keystoneauth proxy-logging proxy-server

[app:proxy-server] use=egg:swift#proxy allow_account_management=true account_autocreate=true

[filter:keystoneauth] use=egg:swift#keystoneauth #operator_roles=admin,_member_

[filter:authtoken] paste.filter_factory=keystonemiddleware.auth_token:filter_factory auth_uri=http://controller:5000/v2.0 identity_uri=http://controller:35357 admin_tenant_name=service admin_user=swift admin_password=SWIFT_PASS delay_auth_decision=true

[filter:cache] memcache_servers=127.0.0.1:11211