Ask Your Question

zetret's profile - activity

2018-06-25 23:34:40 -0600 received badge  Popular Question (source)
2018-03-01 22:09:06 -0600 asked a question What is the best way to move from Keystone v3 to Keystone v2? (OpenStack RDO)

I am being asked to move to Keystone v2 as v3 is incompatible with a product I am using. Is it possible to do that without a reinstallatoin? Should I just use v2 and re-run the setup?

Thanks Regards

2018-02-12 18:25:44 -0600 received badge  Famous Question (source)
2018-02-12 18:25:44 -0600 received badge  Notable Question (source)
2017-10-27 04:26:45 -0600 received badge  Notable Question (source)
2017-10-27 04:26:45 -0600 received badge  Famous Question (source)
2017-09-26 23:25:50 -0600 received badge  Taxonomist
2017-07-28 15:03:09 -0600 commented answer What is the equivalent command for user-role-list in openstack client for V3 api ?

Good answer. The warning doesn't specify the 'openstack' prefix for the role assignment list.

2017-06-09 23:28:03 -0600 commented question Hi my openstack installation steps runs forever and doesn't complete Please help

Did this complete or did you fix this? Same issue running on CentOS "server with GUI" version.

2017-06-09 18:57:16 -0600 received badge  Popular Question (source)
2017-06-08 23:41:47 -0600 asked a question How to configure Horizon for HTTPS in the DevStack release? (PLEASE answer - confusing files)

Hi, Here is the horizon.conf file;

<VirtualHost *:80> 
WSGIScriptAlias /dashboard /opt/stack/horizon/openstack_dashboard/wsgi/django.wsgi
WSGIDaemonProcess horizon user=stack group=stack processes=3 threads=10 home=/opt/stack/horizon display-name=%{GROUP}
WSGIApplicationGroup %{GLOBAL}
SetEnv APACHE_RUN_USER stack
SetEnv APACHE_RUN_GROUP stack
WSGIProcessGroup horizon

DocumentRoot /opt/stack/horizon/.blackhole/
Alias /dashboard/media /opt/stack/horizon/openstack_dashboard/static
Alias /dashboard/static /opt/stack/horizon/static
RedirectMatch "^/$" "/dashboard/"

<Directory />
Options FollowSymLinks
AllowOverride None
</Directory>

<Directory /opt/stack/horizon/>
Options Indexes FollowSymLinks MultiViews
AllowOverride None
# Apache 2.4 uses mod_authz_host for access control now (instead of
#  "Allow")
<IfVersion < 2.4>
Order allow,deny
Allow from all
</IfVersion>
<IfVersion >= 2.4>
Require all granted
</IfVersion>
</Directory>
<IfVersion >= 2.4>
ErrorLogFormat "%{cu}t %M"
</IfVersion>
ErrorLog /var/log/apache2/horizon_error.log
LogLevel warn
CustomLog /var/log/apache2/horizon_access.log combined
</virtualhost>
WSGISocketPrefix /var/run/apache2

I have generated certificates for SSL and HTTPS seems to be working.

However, I DON'T UNDERSTAND how to set the Document root for the Horizon dashboard and there seems to be no documentation on it. I copy-pasted the same from above (port 80) to my default-ssl.conf file, and enabled it - but it doesn't work. Can someone explain what to set as the document root for HTTPS?

2017-06-07 23:41:56 -0600 received badge  Popular Question (source)
2017-06-06 19:57:45 -0600 asked a question Where to find openstack-dashboard.conf in the latest DevStack release?

I have tried searching for it everywhere but is not present.

find /etc -iname "openstack-dashboard.conf"

returns nothing. According to the documentation, it's supposed to be here: /etc/apache2/conf.d/openstack-dashboard.conf

But, I don't have a directory called "conf.d" under apache2. I am running devstack as the default user called "stack".

I am trying to make Horizon use "https" instead of "http". Any other good documentation instead of the one on openstack.org?

EDIT: Found horizon.conf but still don't understand what should be the values for port 443 under the virtualhosts tag.

Thanks

2017-02-14 06:47:16 -0600 received badge  Student (source)
2015-02-12 02:12:47 -0600 received badge  Famous Question
2015-02-11 11:03:16 -0600 commented answer Failed to schedule_migrate_volume_to_host: No valid host was found.

Can you please expand on your answer and how "cinder retype" helped?

2015-02-11 11:02:19 -0600 received badge  Notable Question
2015-02-11 11:02:14 -0600 received badge  Enthusiast
2015-02-11 11:02:14 -0600 received badge  Enthusiast
2015-02-11 03:32:10 -0600 received badge  Popular Question
2015-02-10 23:11:23 -0600 received badge  Organizer
2015-02-09 01:43:17 -0600 received badge  Famous Question (source)
2015-02-09 00:44:51 -0600 received badge  Supporter (source)
2015-02-09 00:43:13 -0600 answered a question Volume-attach fails - ERROR No initiators or wwpns supplied.

Solved this issue by using iSCSI instead of FC.

2015-02-05 11:41:12 -0600 commented question Unable to attach volume to instance

Did u find the solution?

2015-02-05 11:39:26 -0600 received badge  Notable Question (source)
2015-02-04 15:43:01 -0600 received badge  Popular Question (source)
2015-02-04 13:16:09 -0600 commented question Volume-attach fails - ERROR No initiators or wwpns supplied.

I have edited the question to reflect what you asked. I've also posted new errors in volume log. Please take a look. Thanks.

2015-02-03 13:31:38 -0600 received badge  Editor (source)
2015-02-03 13:30:05 -0600 asked a question Volume-attach fails - ERROR No initiators or wwpns supplied.

I have a block storage configured using Cinder (on Juno). A new volume was created and its state shows as "available". I have a nova instance (a test Cirros instance) configured. I want to attach this existing cinder volume to the nova instance. After trying nova volume-attach "instance ID" "volume ID" "/dev/vdb" OR nova volume-attach "instance ID" "volume ID" "auto" , the state of the volume changes from "attaching" and then back to "available" and the "attached to" field is blank. Nothing on 'fdisk -l' on the cirros instance. This cirros is running on a KVM (on a virtual machine) - and this virtual machine is running on VMware Esxi. So, this is sort of a nested virtualization.

OUTPUT of lvs and vgs on RHEL65.


[root@rhel65-03 nova]# lvs
  LV      VG          Attr       LSize  Pool Origin Data%  Move Log Cpy%Sync Convert
  lv_root vg_rhel6501 -wi-ao---- 44.65g
  lv_swap vg_rhel6501 -wi-ao----  4.86g

[root@rhel65-03 nova]# vgs
  VG             #PV #LV #SN Attr   VSize  VFree
  cinder-volumes   1   0   0 wz--n- 40.00g 40.00g
  vg_rhel6501      1   2   0 wz--n- 49.51g     0

[root@rhel65-03 nova]# vgchange -a y cinder-volumes
  0 logical volume(s) in volume group "cinder-volumes" now active

Boot from Image(Create Volume) Error in volume.log

2015-02-04 14:12:20.961 21245 ERROR cinder.volume.drivers.ibm.storwize_svc.helpers [req-a9780d29-e87f-46af-9f28-7f27a55c7b17 2c37f6bd55b8402bae2ab04402562e4f 4cf6d19846284f4bb5cb3731395de51b - - -] create_host: No initiators or wwpns supplied.
2015-02-04 14:12:20.962 21245 ERROR cinder.volume.driver [req-a9780d29-e87f-46af-9f28-7f27a55c7b17 2c37f6bd55b8402bae2ab04402562e4f 4cf6d19846284f4bb5cb3731395de51b - - -] Unable to fetch connection information from backend: create_host: No initiators or wwpns supplied.
2015-02-04 14:12:20.964 21245 ERROR cinder.volume.flows.manager.create_volume [req-a9780d29-e87f-46af-9f28-7f27a55c7b17 2c37f6bd55b8402bae2ab04402562e4f 4cf6d19846284f4bb5cb3731395de51b - - -] Failed to copy image 744788c2-7783-46d5-973b-c6fc549f9874 to volume: 4a3ddb09-6342-4cfc-96c5-03e6fff93c36, error: Bad or unexpected response from the storage volume backend API: Unable to fetch connection information from backend: create_host: No initiators or wwpns supplied.
2015-02-04 14:12:20.967 21245 WARNING cinder.volume.manager [req-a9780d29-e87f-46af-9f28-7f27a55c7b17 2c37f6bd55b8402bae2ab04402562e4f 4cf6d19846284f4bb5cb3731395de51b - - -] Task 'cinder.volume.flows.manager.create_volume.CreateVolumeFromSpecTask;volume:create' (9342ce99-ef5c-4f2f-a9ee-bc115f8aa6b6) transitioned into state 'FAILURE'

EDIT ATTACHMENT (cinder volume to nova instance) error in volume.log:

2015-02-04 16:53:52.594 21245 INFO cinder.volume.manager [-] Updating volume replication status.
2015-02-04 16:54:16.010 21245 ERROR cinder.volume.drivers.ibm.storwize_svc [req-7537dce4-fa77-4abe-9e3f-22d98fd83133 2c37f6bd55b8402bae2ab04402562e4f fa6f9dd011df404b963141baf7547181 - - -] The connector does not contain the required information.
2015-02-04 16:54:16.012 21245 ERROR cinder.volume.manager [req-7537dce4-fa77-4abe-9e3f-22d98fd83133 2c37f6bd55b8402bae2ab04402562e4f fa6f9dd011df404b963141baf7547181 - - -] Unable to fetch connection information from backend: The connector does not contain the required information.
2015-02-04 16:54:16.056 21245 ERROR oslo.messaging.rpc.dispatcher [req-7537dce4-fa77-4abe-9e3f-22d98fd83133 2c37f6bd55b8402bae2ab04402562e4f fa6f9dd011df404b963141baf7547181 - - -] Exception during message handling: Bad or unexpected response from the storage volume backend API: Unable to fetch connection information from backend: The connector does not contain the required information.
2015-02-04 16:54:16.056 21245 TRACE oslo.messaging.rpc.dispatcher Traceback (most recent call last):
2015-02-02 23:55:34 -0600 received badge  Famous Question
2015-02-01 22:09:45 -0600 received badge  Notable Question
2015-02-01 18:41:00 -0600 received badge  Popular Question
2015-01-31 19:24:03 -0600 commented question Internal Server Error

How did u resolve this?

2015-01-31 19:24:03 -0600 commented question horizon authentication fails

Rebooting the controller should fix this.