Ask Your Question

Waid's profile - activity

2016-06-07 09:30:49 -0600 received badge  Student (source)
2015-12-25 08:33:45 -0600 received badge  Necromancer (source)
2015-10-28 05:33:00 -0600 asked a question horizon template get js variable

when I look at client_side/_balloon_container.html in network_topology, I saw some notations which is not django template, but rendering the javascript variable. for example,

       [[> table1]]


        <a href="[[url]][[console]]" class="vnc_window">罈 [[open_console_label]]</a>

I am not quite so sure what they means. But here I have a question.

Can I add some logic like a django template style:

        [[if console_id == 'abc' ]]
          <p> the console id is 'abc'</p>
          <p> not 'abc'</p>

Of course this will not work because I don't know the correct notation.

Any help? thanks!

2015-09-13 02:15:35 -0600 answered a question Nova-compute can't connect to Nova-controller

I got the same problem few days ago. And find no answer. I've tried to move the rabbit authentication options to 'DEFAULT' but it did not work. Find the log(/var/log/nova/nova-compute.log) on compute node and it shows err msg about Host Compute not found something like that..

And also changed the rabbitmq version back to 3.2.4 but nothing changed.

Solved this problem by finding that my compute node did not install the correct nova-compute version. I find no such file "/etc/apt/sources.list.d/cloudarchive-kilo.list". So I missed this step when installing compute node. So I reinstall the nova-compute by specifying the correct package and finally it works.(check out the official installation guide: Hope this helps.

2015-07-22 07:43:44 -0600 received badge  Famous Question (source)
2015-05-28 02:38:02 -0600 received badge  Famous Question (source)
2015-05-25 20:13:40 -0600 received badge  Notable Question (source)
2015-05-25 01:57:47 -0600 received badge  Popular Question (source)
2015-05-25 00:52:03 -0600 commented answer what is the status shown in nova list

Thanks for your response. My question is: how to map the vm states into the status shown in nova list?(esp. for SHUTOFF) There are vm states like PAUSED, SUSPENDED, STOPPED, BUILDING..( How do we map them into the status?

2015-05-24 22:06:21 -0600 asked a question what is the status shown in nova list

when command in:

$nova list

we get three states: | Status | Task State | Power State |

but the vm state is not shown in here.

Not sure how the value 'Status' here maps to the vm status.

Any idea?

Thank you!

2015-04-05 03:22:11 -0600 received badge  Famous Question (source)
2015-03-06 12:01:42 -0600 received badge  Notable Question (source)
2015-03-06 00:59:23 -0600 received badge  Enthusiast
2015-03-05 23:06:44 -0600 received badge  Popular Question (source)
2015-03-05 19:53:46 -0600 answered a question where does nova.conf comes in for nova services?

Got the answer: if we run the nova services without assigning --config-file=/etc/nova/nova.conf like:

service nova-scheduler start

Then in /usr/share/pyshared/nova/cmd/ will run with nova.conf.

Actually yes, the entry is config.parse_args(sys.argv) in, lets trace parse_args() in /usr/share/pyshared/nova/


Well if we don't manually assign default_config_file when running nova service, then this value is None. So let's find out the entry of nova.con in cfg.CONF:


 CONF = ConfigOpts()

let's see the caller in ConfigOpts(), first note that we have this pre_setup to assign the config_file(s):

    prog, default_config_files = self._pre_setup(project,

We can find that the nova.conf enters in:

    if default_config_files is None:
        default_config_files = find_config_files(project, prog)

If we trace the find_config_file, we can see that it will find the nova.conf in the directories:

2015-03-04 21:48:22 -0600 asked a question where does nova.conf comes in for nova services?

When I read the source code of nova-scheduler, I don't find the entry where the nova.con comes in. Here is my searching path:

/etc/init.d/nova-scheduler : nothing, just run nova-scheduler(in /usr/bin/nova-scheduler)

/usr/bin/nova-scheduler : run nova.cmd.scheduler main()


Well, I guess this code is where nova.conf comes in. And the most probably entry is:


if we assign --config-file=/etc/nova/nova.conf option when running nova-scheduler, then this is the entry where nova.conf comes in manually

The reason why I emphasise "manually" is because when we run the service, we don't need to assign such option.(We can see the openstack installation guide of with version icehouse, that when executing the nova services, we just only run:service nova-xxxx restart)

Well, this is not a big deal since when creating nova services, all of the options has the default values:(for instance, /usr/share/pyshared/nova/, we can see that there are settings of default options at the beginning of the file). But even if so, then that seems there are no entry of nova.conf for the nova services. Then why do we need it?

Anyone has any idea?

2015-02-16 04:06:24 -0600 commented answer where are the conf. of service agent


Moe, thanks for your reply. Here what I were saying is the case of we install service agent on remote computer, which is not belong to any node which has been installed the openstack service. So in this case there are no dir. of /etc/nova or /etc/neutron for the remote computer

2015-02-15 04:47:09 -0600 received badge  Famous Question (source)
2015-02-12 22:03:43 -0600 received badge  Notable Question (source)
2015-02-12 17:48:22 -0600 received badge  Popular Question (source)
2015-02-12 03:53:20 -0600 asked a question where are the conf. of service agent

Very simple question, but I just cannot find it.

If we want to launch an instance from a remote IP, we must configure the IP for each service agent conf files after installing the service agent (novaclient, keystonecleint....etc). it is not enough to do it with only OS_* variables.

For example, from a remote host:

$nova flavor-list

ERROR (ConnectionError): ('Connection aborted.', gaierror(-2, 'Name or service not known'))

but I've already export OS_* variables, apparently, the agent cannot do it with only OS_*, say, OS_AUTH_URL.

We can see it by using neutron:

$neutron net-list

Unable to establish connection to http://controller:9696/v2.0/networks....

So it has used the conf file with some variable defined by http://controller:9696/v2.0/networks.... . But so far, I cannot find the conf file by grep.

Here is my solution to do it:

  1. add hosts name 'controller' with its IP

  2. export OS_* varaibles

But the question is still not answered. Anyone know it? Where are the conf files(for service client agent)

2015-02-10 03:53:11 -0600 answered a question cannot start the neutron-plugin-openvswitch-agent service

I also has the same problem today. And I totally solve the problem. I will leave here my solution as a reference.

The first very thing to aware of is that we should not leave any space for each line in a configure file of openstack.

For example, the conig. file: ml2_conf.ini when installing the openvswitch on network and compute1 node: if we just uncomment a line like this:

   tenant_network_types = gre

Then we will end up with a problem. And we will find that when we restart a service, soonly we will find it stop after few seconds.

So we should not only uncomment a line, but also remove the space like this:


For openvswitch problem like this thread, there's an additional problem that we may found in the log file:/var/log/neutron/openvswitch-agent.log

It is a problem due to the neutron-rootwrap.

So the solution for this could be solved by:

cp -a /usr/lib/python2.7/dist-packages/oslo/rootwarp /usr/local/lib/python2.7/dist-packages/oslo

For the compute1 node, we should mkdir /usr/local/lib/python2.7/dist-packages/oslo before the above cp

2015-02-06 01:55:06 -0600 received badge  Self-Learner (source)
2015-02-06 01:55:06 -0600 received badge  Teacher (source)
2015-01-31 22:11:54 -0600 received badge  Notable Question (source)
2015-01-31 10:34:34 -0600 answered a question dashboard can't retrieve anything or do anything

Now the problem is solved, I give my solution as a reference:

The problem occurred when I set my localrc as the following:



FLOATING_RANGE={-...not important for this case}

(module passwords....)

Here, my network setting is actually: eth0:dhcp(Virtualbox NAT give it IP), eth1: static IP: host-only network)

The problem is solved by setting localrc as the following:




FLOATING_RANGE={-...not important for this case}

(module passwords....)

In this setting, I changed my /etc/network/interfaces as:

eth0:dhcp, br100+eth1:static IP:

I guess the problem is solved because I changed FLAT_INTERFACE from eth0 to eth1. eth1 is the entry to the openstack host.

2015-01-31 07:42:54 -0600 received badge  Popular Question (source)
2015-01-31 00:06:10 -0600 received badge  Editor (source)
2015-01-30 23:49:50 -0600 asked a question dashboard can't retrieve anything or do anything

Hi there, I'd installed the OpenStack by devStack successfully(installed in VirtualBox Ubuntu 12.04).

After that , I can connect to the dashboard by the Chrome browser.

But the first warning jumped out 'Error: Unable to retrieve usage information' after I logged in.

Then I press 'Project' and it showed 'Error: Unable to retrieve usage information.'

I found that no matter what I pressed, it always get the messages to inform me that it can't retrieve anything.

And when I press 'image', a page show up with title: CommunicationError at /project/images/ Error finding address for htt p:// 9292/v1/images/detail?sort_key=created_at&sort_dir=desc&limit=1000: ('Connection aborted.', error(111, 'Connection refused'))

I am a newbie don't know where to check.

Not sure what's wrong with it. Any help? I am glad to provide further info. if you like.