Ask Your Question

foster's profile - activity

2015-05-16 09:41:33 -0500 commented question vm going to error state while migration

No..You just need a shared filesystem that is mounted to both systems (I believe) /var/lib/nova/instances. That should allow you to migrate from one machine to the other.

http://docs.openstack.org/admin-guide...

2015-05-16 06:42:02 -0500 commented question /var/lib/nova/instances on GlusterFS

I would avoid using gluster for the backend for the images for my vm's and go with NFS for my shared storage (for ephemeral vms) and Ceph for backend storage long-term vm's. I am currently using GlusterFS for Glance which works out pretty well

2015-05-16 06:34:01 -0500 commented question vm going to error state while migration

Are you using a shared filesystem? I would look at the systems log files where you are trying to move the vm to during the process (tail -f )..look at both really during the process(the errors are straight forward).

2015-05-16 06:26:47 -0500 commented question deploying a cluster using open stack heat

You would have to modify this heat script to get what you want: http://docs.openstack.org/kilo/instal...

2015-05-16 06:06:15 -0500 commented question CirrOS is not assigned floating ip

Connect the vm to the private network,then tail /var/log/messages when the system is booting to see if the dhcp agent is requesting an IP address. If you don't see it in the logs requesting an IP then some is wrong with your network.

2015-05-06 22:19:28 -0500 received badge  Famous Question (source)
2015-03-25 07:38:38 -0500 commented question How can I use a vlan interface as an external network?

I don't know if you still need help, but you seemed to have left out some information. For instance you want to use vlans but your neutron.conf file does not have the [ml2_type_vlan] configuration. I currently have the same setup and I have internal networks on 192 and external on my vlan networks.

2015-03-17 04:34:06 -0500 commented answer Unable to get DHCP lease in Juno

Possibly firewall on neutron. Also, you can watch to see if you are receiving the request by looking at /var/log/messages while creating an instance. If you dont see any dhcp request then it means you need to check your tenant network tunnel if properly configured.

Check the router 'ip netns'

2015-03-09 08:35:43 -0500 received badge  Commentator
2015-03-09 08:35:43 -0500 commented answer Openstack live migration ssh issue

Can you post the log file for nova?

2015-03-09 03:23:45 -0500 commented question ImportError: No module named auth.identity

I don't think there is a section called auth.identity in the glance configuration. If you follow the guide: http://docs.openstack.org/icehouse/install-guide/install/yum/content/glance-install.html (http://docs.openstack.org/icehouse/in...)

2015-03-09 03:14:58 -0500 commented question vm connection error between vms on different hosts (vxlan tunnels)

it looks like the interface that is used to configure communication between compute nodes are not configured correctly. You should try and look at the neutron configuration on the new compute node and see if it matches the controller node

2015-03-09 03:10:06 -0500 commented answer Openstack live migration ssh issue

run ls -ltr on /var/log/nova/ and tail -f the last file when you run a live migration. see what that gives you

2015-03-09 02:56:13 -0500 commented answer Openstack live migration ssh issue

Just to be clear..you are talking about 2 different issues. 1. is live migration which happens at the compute node (which requires shared filesytem). 2. is ssh access to the instance with passwordless ssh.

You need to solve the first problem in order to move forward with the second problem.

2015-03-09 02:45:35 -0500 commented answer Openstack live migration ssh issue

i have the same setup and i don't have this problem when migrating instances between compute nodes. I also didn't have to change my settings for sshd. If you think its a problem with ssh try verifying your permissions on ~/.ssh. Problem could be that you have /dev/null instead of a file.

2015-03-09 02:37:33 -0500 answered a question ImportError: No module named auth.identity

I don't think there is a section called auth.identity in the glance configuration. If you follow the guide: http://docs.openstack.org/icehouse/install-guide/install/yum/content/glance-install.html (http://docs.openstack.org/icehouse/in...)

2015-03-09 02:28:38 -0500 answered a question how to configure vlan neutron network with physical_network

I don't think the --provider:physical_network physnet1 is correct...Can you post neutron net-list?

2015-03-09 02:17:32 -0500 answered a question Openstack live migration ssh issue

Live migration should have a shared file-system between the compute nodes you are trying to migrate between.

2015-03-09 01:46:47 -0500 answered a question Volume creation fails with error InvalidBDM: Block Device Mapping is Invalid.

Issue is resolved by verifying that the mount point for the glance service is mounted to the controller node. This setup was using glusterfs as the mount point for glance and when the system rebooted that mount point was not mounted. Configured autofs for the mount point.

2015-03-01 04:49:15 -0500 commented answer swift containers disappear in less than 1 min

UPDATE: zaitcev was correct. It was the time on the system that was off.

2015-02-24 08:53:43 -0500 commented answer swift containers disappear in less than 1 min

I had the same issue, and I found that if you stop the replicator service for all (container, object and account) that I don't see this issue any longer. Does anyone know what the replicator service is supposed to do? I am running Juno on CentOS 7

2015-01-23 08:20:14 -0500 received badge  Enthusiast
2015-01-14 11:31:32 -0500 answered a question BadRequest: Specifying 'tenant_id' other than authenticated tenant neutron

I fixed this issue. The problem was not following the guide..I was missing some important data inside the neutron and keystone file.

Thanks!

2015-01-14 11:30:41 -0500 received badge  Notable Question (source)
2015-01-13 19:40:48 -0500 received badge  Popular Question (source)
2015-01-13 08:48:27 -0500 commented question BadRequest: Specifying 'tenant_id' other than authenticated tenant neutron

I have also tried to recreate the user using the user-id, tenant-id and project-id and still the same issue..using link: https://ask.openstack.org/en/question/53124/keystone-user-role-add-gives-error-could-not-find-user-admin/ (https://ask.openstack.org/en/question...)

2015-01-13 08:47:22 -0500 commented question BadRequest: Specifying 'tenant_id' other than authenticated tenant neutron

It looks like somethings wrong with keystone, but I don't know how to troubleshoot this problem. When I run the keystone user-list I can see my users, but when I run keystone user-role-list --user <name> I get nothing, and when I look in the keystone.log file I see could not find user <name>.

2015-01-12 21:55:37 -0500 asked a question BadRequest: Specifying 'tenant_id' other than authenticated tenant neutron

I am getting this error BadRequest: Specifying 'tenant_id' other than authenticated tenant neutron) when creating instance (juno) on centos 7.

Output of keystone user-list:

+----------------------------------+---------+---------+-------------------+
|                id                |   name  | enabled |       email       |
+----------------------------------+---------+---------+-------------------+
| 11acab4a34134c48983f67f0b71a7ca8 |  admin  |   True  | vtladmin@noaa.gov |
| 4863b19205f24801ba6d07fea1911860 |   demo  |   True  |  vtldemo@noaa.gov |
| df6b07fbfe5244a5b063d166fbe4170d |  glance |   True  |                   |
| f7d7a44fbb1148bbb36589eab729072d | neutron |   True  |                   |
| b999fe55e6064dcca0970209ddd7f69e |   nova  |   True  |                   |
+----------------------------------+---------+---------+-------------------+

output of keystone tenant-list:

+----------------------------------+---------+---------+
|                id                |   name  | enabled |
+----------------------------------+---------+---------+
| 369017fe38824263ab65187748fa0939 |  admin  |   True  |
| 02179cc1b30f41aab0df1f1819c97af6 |   demo  |   True  |
| 3886a88ba0dc4996a775a4ff34b7c5ce | service |   True  |
+----------------------------------+---------+---------+

output of keystone role-list:

+----------------------------------+----------+
|                id                |   name   |
+----------------------------------+----------+
| 9fe2ff9ee4384b1894a90878d3e92bab | _member_ |
| 842d5520961148879d44dbfce7098d5c |  admin   |
+----------------------------------+----------+

I turned on debugging and get the following in the keystone log:

2015-01-12 11:08:13.370 24013 DEBUG keystone.middleware.core [-] RBAC: auth_context: {'is_delegated_auth': False, 'access_token_id': None, 'user_id': u'df6b07fbfe5244a5b063d166fbe4170d', 'roles': [u'admin'], 'trustee_id': None, 'trustor_id': None, 'consumer_id': None, 'token': <KeystoneToken (audit_id=Mkm4bsbZQJK57vjc3LhnGw, audit_chain_id=Mkm4bsbZQJK57vjc3LhnGw) at 0x4ac9cf0>, 'project_id': u'3886a88ba0dc4996a775a4ff34b7c5ce', 'trust_id': None} process_request /usr/lib/python2.7/site-packages/keystone/middleware/core.py:280
2015-01-12 11:08:13.400 24013 DEBUG keystone.common.wsgi [-] arg_dict: {} __call__ /usr/lib/python2.7/site-packages/keystone/common/wsgi.py:191
2015-01-12 11:08:13.400 24013 DEBUG keystone.common.controller [-] RBAC: Authorizing identity:validate_token() _build_policy_check_credentials /usr/lib/python2.7/site-packages/keystone/common/controller.py:55
2015-01-12 11:08:13.400 24013 DEBUG keystone.common.controller [-] RBAC: using auth context from the request environment _build_policy_check_credentials /usr/lib/python2.7/site-packages/keystone/common/controller.py:60
2015-01-12 11:08:13.403 24013 DEBUG keystone.common.kvs.core [-] KVS lock acquired for: os-revoke-events acquire /usr/lib/python2.7/site-packages/keystone/common/kvs/core.py:380
2015-01-12 11:08:13.404 24013 DEBUG keystone.common.kvs.core [-] KVS lock released for: os-revoke-events release /usr/lib/python2.7/site-packages/keystone/common/kvs/core.py:399
2015-01-12 11:08:13.405 24013 DEBUG keystone.policy.backends.rules [-] enforce identity:validate_token: {'is_delegated_auth': False, 'access_token_id': None, 'user_id': u'df6b07fbfe5244a5b063d166fbe4170d', 'roles': [u'admin'], 'trustee_id': None, 'trustor_id': None, 'consumer_id': None, 'token': <KeystoneToken (audit_id=Mkm4bsbZQJK57vjc3LhnGw, audit_chain_id=Mkm4bsbZQJK57vjc3LhnGw) at 0x4ac9cf0>, 'project_id': u'3886a88ba0dc4996a775a4ff34b7c5ce', 'trust_id': None} enforce /usr/lib/python2.7/site-packages/keystone/policy/backends/rules.py:100
2015-01-12 11:08:13.408 24013 DEBUG keystone.common.controller [-] RBAC: Authorization granted inner /usr/lib/python2.7/site-packages/keystone/common/controller.py:155
@

I looked at one other post on this issue but I don't know if that solution applies to Juno.

Any help would be appreciated.