DelightD's profile - activity

2017-06-29 08:27:27 -0600 received badge  Popular Question (source)
2017-06-29 08:27:27 -0600 received badge  Famous Question (source)
2017-06-29 08:27:27 -0600 received badge  Notable Question (source)
2016-05-04 13:38:20 -0600 received badge  Famous Question (source)
2016-05-04 13:38:20 -0600 received badge  Notable Question (source)
2015-07-08 08:33:35 -0600 received badge  Famous Question (source)
2015-07-08 07:02:01 -0600 asked a question How do I use python to call "neutron net-list"?

I am running Devstack

I need some script to help me get the information

so in python how do I run the "source openrc admin demo" first? then using python os.system("neutron net-list")?

2015-06-18 05:37:14 -0600 received badge  Popular Question (source)
2015-06-17 06:12:59 -0600 asked a question How to add-flow rule to enable ssh to Compute node br-int

Hi, I use devstack to build my OpenStack environment, the network i choose VLAN, and it work very well! I can ping VM from outside public network and I am able to ssh in VM from public network.

I found that the Compute node Open vSwitch br-int has this flow rule, to make all internet action can work , OpenStack use

table=0,priority=1,actions=NORMAL

if I delete this rule, I can not ping or ssh from outside. If I want to ssh from outside, and I don't want to use original flow rule,

what flow should I add? I have tried this before

sudo ovs-ofctl add-flow br-int table=0,tcp,tcp_dst=22,actions=NORMAL
sudo ovs-ofctl add-flow br-int table=0,tcp,tcp_src=22,actions=NORMAL

I still can not ssh in VM. Do I set up wrong?

Please help me :D! very thank you!

2015-05-27 18:25:02 -0600 received badge  Notable Question (source)
2015-05-27 18:25:02 -0600 received badge  Famous Question (source)
2015-05-27 18:25:02 -0600 received badge  Popular Question (source)
2015-04-27 05:11:07 -0600 received badge  Notable Question (source)
2015-04-27 04:38:05 -0600 commented answer Build devstack and ODL - VLAN setup problem

I follow this before but my boss told me to use VLAN mode instead of tunnel mode , so I change to use VLAN mode, when I get q-agt out something wrong.On Tunnel mode if I enable q-agt on controller and compute node , they will create patch-tun port Unlimited...i think it is conflict OVSDB :(

2015-04-27 04:13:54 -0600 received badge  Popular Question (source)
2015-04-26 12:50:50 -0600 asked a question Build devstack and ODL - VLAN setup problem

HI, I have one question about VLAN between Openstack and Opendaylight.

I use Devstack to deploy my Openstack environment.(three physical compute: one Openstack controller node , one Compute node , one Opendaylight node)

One question I want to ask , if I use Opendaylight OVSDB to control my OVS so do I need to use "q-agt" and add "Q_AGENT=openvswitch" in local.conf ? this confuse me for a while.

this is my #ovs-vsctl when my devstack stack.sh complete

openstack@openstack:~/devstack$ sudo ovs-vsctl show
e60acaaf-63e8-4eeb-abf6-f5c4b4eb19d9
    Manager "tcp:192.168.5.23:6640"
        is_connected: true
    Bridge br-int
        Controller "tcp:192.168.5.23:6633"
            is_connected: true
        fail_mode: secure
        Port br-int
            Interface br-int
        Port "tap9a4f626f-60"
            Interface "tap9a4f626f-60"
                type: internal
    Bridge br-ex
        Controller "tcp:192.168.5.23:6633"
            is_connected: true
        Port br-ex
            Interface br-ex
                type: internal
           ovs_version: "2.0.2"

I notice that my ovs didnt build up the Bridge "br-eth2" (my eth2 use for vlan , didnt assign ip on it)

is it correctly??

here is my local.conf:

[[local|localrc]]
LOGFILE=/opt/stack/logs/stack.sh.log
SCREEN_LOGDIR=/opt/stack/logs
LOG_COLOR=False
RECLONE=no
OFFLINE=Yes
VERBOSE=True
SYSLOG=True

disable_service n-cpu
disable_service n-net

enable_service n-novnc
enable_service horizon
enable_service q-svc
enable_service q-dhcp
enable_service q-l3
enable_service q-meta
enable_service neutron
enable_service rabbit
enable_service odl-compute odl-neutron

HOST_NAME=openstack
HOST_IP=192.168.5.203
HOST_IP_IFACE=eth0
VLAN_INTERFACE=eth2

SERVICE_HOST_NAME=${HOST_NAME}
SERVICE_HOST=192.168.5.203


PHYSICAL_NETWORK=physnet1
ML2_VLAN_RANGES=physnet1:1000:1010
OVS_PHYSICAL_BRIDGE=br-eth2
MULTI_HOST=True
OVS_BRIDGE_MAPPINGS=physnet1:br-eth2
ODL_PROVIDER_MAPPINGS=physnet1:eth2


Q_HOST=$SERVICE_HOST
Q_PLUGIN=ml2
ODL_MGR_IP=192.168.5.23
Q_ML2_PLUGIN_MECHANISM_DRIVERS=openvswitch,opendaylight
Q_ML2_PLUGIN_TYPE_DRIVERS=vlan,local
Q_ML2_TENANT_NETWORK_TYPE=vlan

ENABLE_TENANT_TUNNELS=False
ENABLE_TENANT_VLANS=True


MYSQL_HOST=$SERVICE_HOST
RABBIT_HOST=$SERVICE_HOST
GLANCE_HOSTPORT=$SERVICE_HOST:9292
KEYSTONE_AUTH_HOST=$SERVICE_HOST
KEYSTONE_SERVICE_HOST=$SERVICE_HOST

MYSQL_PASSWORD=teststack
RABBIT_PASSWORD=teststack
SERVICE_TOKEN=service
SERVICE_PASSWORD=admin
ADMIN_PASSWORD=admin

[[post-config|/etc/neutron/plugins/ml2/ml2_conf.ini]]
[ml2_odl]
url=http://192.168.5.23:8080/controller/nb/v2/neutron
username=admin
password=admin

[[post-config|/etc/nova/nova.conf]]
[DEFAULT]
firewall_driver=nova.virt.firewall.NoopFirewallDriver
novncproxy_host=0.0.0.0
novncproxy_port=6080
novncproxy_base_url=http://192.168.5.203:6080/vnc_auto.html

and this is mt Compute local.conf:

[[local|localrc]]
LOGFILE=/opt/stack/logs/stack.sh.log
SCREEN_LOGDIR=/opt/stack/logs
LOG_COLOR=False
VERBOSE=True
RECLONE=no
OFFLINE=Yes
SYSLOG=True

disable_all_services
enable_service neutron
enable_service n-cpu
enable_service odl-compute
enable_service n-novnc

HOST_NAME=compute
HOST_IP=192.168.5.83
HOST_IP_IFACE=eth0
SERVICE_HOST_NAME=openstack
SERVICE_HOST=192.168.5.203


#Q_AGENT=openvswitch
Q_PLUGIN=ml2
Q_ML2_PLUGIN_MECHANISM_DRIVERS=opendaylight,openvswitch
Q_ML2_PLUGIN_TYPE_DRIVERS=vlan
Q_HOST=$SERVICE_HOST
ODL_MGR_IP=192.168.5.23

ENABLE_TENANT_TUNNELS=False
ENABLE_TENANT_VLANS=True

Q_ML2_TENANT_NETWORK_TYPE=vlan
PHYSICAL_NETWORK=physnet1
ML2_VLAN_RANGES=physnet1:1000:1010
OVS_PHYSICAL_BRIDGE=br-eth1
OVS_BRIDGE_MAPPING=physnet1:eth1
MULTI_HOST=True

MYSQL_HOST=$SERVICE_HOST
RABBIT_HOST=$SERVICE_HOST
GLANCE_HOSTPORT=$SERVICE_HOST:9292
KEYSTONE_AUTH_HOST=$SERVICE_HOST
KEYSTONE_SERVICE_HOST=$SERVICE_HOST

MYSQL_PASSWORD=teststack
RABBIT_PASSWORD=teststack
SERVICE_TOKEN=service
SERVICE_PASSWORD=admin
ADMIN_PASSWORD=admin

[[post-config|/etc/neutron/plugins/ml2/ml2_conf.ini]]
[ml2_odl]
url=http://192.168.5.23:8080/controller/nb/v2/neutron
username=admin
password=admin

[[post-config|/etc/nova/nova.conf]]
[DEFAULT]
firewall_driver=nova.virt.firewall.NoopFirewallDriver
vnc_enabled=True
novncproxy_base_url=http://192.168.5.203:6080/vnc_auto.html
vncserver_listen=0.0.0.0
vncserver_proxyclient_address ...
(more)
2015-04-14 20:35:03 -0600 commented answer Devstack build Compute Node , the ./stack.sh ignore the Neutron setup

OVSUUID=$(ovs-vsctl get Open_vSwitch . _uuid)

ovs-vsctl set Open_vSwitch $OVSUUID other_config:local_ip=<host_ip>

I don't understand this two command, can you teach me in detail? thank you very much :)

2015-04-14 20:31:18 -0600 received badge  Famous Question (source)
2015-04-14 01:30:06 -0600 received badge  Notable Question (source)
2015-04-14 00:05:52 -0600 received badge  Enthusiast
2015-04-13 20:50:39 -0600 commented answer Devstack build Compute Node , the ./stack.sh ignore the Neutron setup

Hi sripriya, nothing change , I think it miss neutron so it will fail , I am confused at I am sure that I already enable the service neutron but the ./stack.sh script ignore it , thank you for answer me :)

2015-04-13 20:45:59 -0600 commented answer Devstack build Compute Node , the ./stack.sh ignore the Neutron setup

The Second link I saw before too, but that wiki local.conf github's link is dead , I can't get them. thank you for answer me :).

2015-04-13 20:43:37 -0600 commented answer Devstack build Compute Node , the ./stack.sh ignore the Neutron setup

hi omar, I have seen the first wiki before , but my ovs is controlled by OpenDaylight OVSDB,so I think my openstack don't need q-agt , last time I add q-agt in my environment it will create and delete path-tunnel port infinite , so I rebuild this environment.

2015-04-13 20:40:06 -0600 received badge  Popular Question (source)
2015-04-13 13:49:36 -0600 asked a question Devstack build Compute Node , the ./stack.sh ignore the Neutron setup

I am using this link to build my environment

http://networkstatic.net/updated-devstack-opendaylight-vm-image-for-openstack-icehouse/?hc_location=ufi

The little different is I am using 3 entity computer(not VM build this lab) , ODL using karaf and openstack controller setup well without problem. but when I setup my compute node , I am sure that I enable the neutron service on compute node local.conf here is my compute node local.conf:

ODL IP:192.168.5.23

OpenStack Controller IP & Hostname: 192.168.5.203 & openstack

OpenStack Compute IP & Hostname: 192.168.5.83 & compute

[[local|localrc]]
LOGFILE=stack.sh.log
LOG_COLOR=True
SCREEN_LOGDIR=/opt/stack/data/log
RECLONE=yes

disable_all_services
enable_service nova n-cpu neutron n-novnc rabbit 
enable_service odl-compute

HOST_NAME=compute
HOST_IP=192.168.5.83
SERVICE_HOST_NAME=openstack   #controller hostname
SERVICE_HOST=192.168.5.203
VNCSERVER_PROXYCLIENT_ADDRESS=192.168.5.83
VNCSERVER_LISTEN=0.0.0.0

Q_PLUGIN=ml2
ODL_MGR_IP=192.168.5.23
Q_ML2_PLUGIN_MECHANISM_DRIVERS=opendaylight,logger
ENABLE_TENANT_TUNNELS=True
Q_HOST=$SERVICE_HOST

MYSQL_HOST=$SERVICE_HOST
RABBIT_HOST=$SERVICE_HOST
GLANCE_HOSTPORT=$SERVICE_HOST:9292
KEYSTONE_AUTH_HOST=$SERVICE_HOST
KEYSTONE_SERVICE_HOST=$SERVICE_HOST

MYSQL_PASSWORD=jizzbear
RABBIT_PASSWORD=jizzbear
SERVICE_TOKEN=service
SERVICE_PASSWORD=admin
ADMIN_PASSWORD=admin

[[post-config|/etc/neutron/plugins/ml2/ml2_conf.ini]]
[agent]
minimize_polling=True

[ml2_odl]
url=http://192.168.5.23:8080/controller/nb/v2/neutron
username=admin
password=admin

looking good so far, then ./stack.sh , it will setup successful and print the Compute node IP but it is wrong here , below is the " sudo ovs-vsctl show":

compute@compute:/var/log$ sudo ovs-vsctl show
648b2c72-f78d-4d03-8c47-ff39b257cc89
    Manager "tcp:192.168.5.23:6640"
        is_connected: true
    ovs_version: "2.0.2"

it miss the br-int , here is my /opt/stack , it without neutron and below /etc without neutron too:

compute@compute:/opt/stack$ ls
data  logs  nova  noVNC  requirements  status
compute@compute:/opt/stack$

Does anyone meet this problem before? Please help me , it show nothing error , but fail to setup correctly. thanks for reading my problem.

2015-03-30 11:55:24 -0600 received badge  Famous Question (source)
2015-03-10 07:42:33 -0600 commented answer Neutron service not starting(q-svc failed to start)

I solve this problem :)

My ODL is on Fedora20 but Devstack is on Ubuntu Notebook

so I change my ODL os to Ubuntu 14.04 then it pass!

2015-03-10 07:40:23 -0600 received badge  Notable Question (source)
2015-03-05 18:11:37 -0600 received badge  Popular Question (source)
2015-03-04 02:40:53 -0600 received badge  Editor (source)
2015-03-04 02:35:19 -0600 asked a question Neutron service not starting(q-svc failed to start)

I am installing control node with Devstack (SDN controller is OpenDaylight) os: Ubuntu14.04. In my local.conf I've added Q_PLUGIN=ml2 . I can't install successful always stuck at "Neutron service is not starting"(first is q-svc failed to start) , I hope you guys can help me please, thank you. error message:

2015-03-04 08:02:55.936 | + screen -S stack -p q-svc -X stuff 'python /usr/local/bin/neutron-server --config-file /etc/neutron/neutron.conf --config-file /etc/neutron/plugins/ml2/ml2_conf.ini & echo $! >/opt/stack/status/stack/q-svc.pid; fg || echo "q-svc failed to start" | tee "/opt/s'ack/status/stack/q-svc.failure"
2015-03-04 08:02:55.941 | + echo 'Waiting for Neutron to start...'
2015-03-04 08:02:55.941 | Waiting for Neutron to start...
2015-03-04 08:02:55.941 | + is_ssl_enabled_service neutron
2015-03-04 08:02:55.941 | + local services=neutron
2015-03-04 08:02:55.941 | + local service=
2015-03-04 08:02:55.941 | + '[' False == False ']'
2015-03-04 08:02:55.941 | + return 1
2015-03-04 08:02:55.941 | + timeout 60 sh -c 'while ! wget  --no-proxy -q -O- http://SERVICE_HOST:9696; do sleep 1; done'
2015-03-04 08:03:55.944 | + die 694 'Neutron did not start'
2015-03-04 08:03:55.944 | + local exitcode=0
2015-03-04 08:03:55.944 | [Call Trace]
2015-03-04 08:03:55.944 | ./stack.sh:1179:start_neutron_service_and_check
2015-03-04 08:03:55.944 | /home/opstack/devstack/lib/neutron:694:die
2015-03-04 08:03:55.999 | [ERROR] /home/opstack/devstack/lib/neutron:694 Neutron did not start
2015-03-04 08:03:57.047 | Error on exit
opstack@opstack-PU301LA:~/devstack$

Below is my local.conf

[[local|localrc]]
LOGFILE=/opt/stack/logs/stack.sh.log
SCREEN_LOGDIR=/opt/stack/logs
LOG_COLOR=False
RECLONE=yes
VERBOSE=True
#Service
disable all services
#core compute(glance+keystone+nova+vnc)
enable_service nova n-cpu n-cond n-novnc            
disable_service n-net

#dashboard
enable_service horizon

#network&opendaylight
enable_service q-svc q-dhcp q-l3 q-meta neutron 

#additional service
enable_service mysql tempest

#Message
#enable_service qpid
enabcle_service rabbit

#ODL
enable_service odl-server odl-compute

#Host
Q_HOST=SERVICE_HOST
HOST_IP=192.168.5.203
PHYSICAL_INTERFACE=eth0
MULTI_HOST=true

#OpendayLight ml2 vlan and gre tunnel
Q_PLUGIN-ml2
ODL_MGR_IP=192.168.5.23
Q_ML2_PLUGIN_MECHANISM_DRIVERS=opendaylight,logger
ENABLE_TENANT_TUNNELS=True

#NEUTRON_REPO=https://github.com/CiscoSystems/neutron.git 
#NEUTRIN_BRANCH=odl_ml2

VNCSERVER_PROXYCLIENT_ADDRESS=192.168.5.203
VNCSERVER_LISTEN=0.0.0.0

#Q_ML2_TENANT_NETWORK_TYPE=local
#Q_ML2_PLUGIN_TYPE_DRIVERS=local

HOST_NAME=stackcontroller
SERVICE_HOST_NAME=${HOST_NAME}
SERVICE_HOST=192.168.5.203

MYSQL_HOST=$SERVICE_HOST
RABBIT_HOST=$SERVICE_HOST
#QPID_HOST=$SERVICE_HOST
GLANCE_HOSTPORT=$SERVICE_HOST:9292
KEYSTONE_AUTH_HOST=$SERVICE_HOST
KEYSTONE_SERVICE_HOST=$SERVICE_HOST

MYSQL_PASSWORD=jizzbear
RABBIT_PASSWORD=jizzbear
#QPID_PASSWORD=jizzbear
SERVICE_TOKEN=service
SERVICE_PASSWORD=admin
ADMIN_PASSWORD=admin

#OVS_PHYSICAL_BRIDGE=br-int

NEUTRON_BRANCH=stable/juno

[[post-config|/etc/neutron/plugins/ml2/ml2_conf.ini]]
[ml2_odl]
url=http://192.168.5.23:8080/controller/nb/v2/neutron
username=admin
password=admin

[agent]
minimize_polling=True
2015-01-07 03:52:10 -0600 commented question Verify Create initial networks fail

network@network-desktop:~$ ip netns list

qrouter-e38b2ea3-49d9-4623-a3cc-f9871cc1d9f7
qdhcp-675dd2d9-b850-46be-a88b-a7e56495c743

hi, teju this is my ip netns list result so , my config is good? or something wrong?

2015-01-05 05:44:59 -0600 asked a question Verify Create initial networks fail

Sorry for my poor english. My OpenStack enviroment is three entity computers one for Controller node , one for Network node(for neutron), last one for compute node. I follow "OpenStack Installation Guide for Ubuntu 14.04-Juno" to build three node architecture when I work at Chap 6. , all network function install on compute, network and controller node is fine , but when I follow guide setup on "Create initial networks" at verify step , I failed , I can not ping the external network to Tenant network

anyone can help me with this problem??

below is my network node config

eth0 for Instance Tunnel IP , eth1 for Management IP , eth2 for External IP

network@network-desktop:~$ ifconfig
br-ex     Link encap:Ethernet  HWaddr 04:1e:64:fc:cb:05  
      inet6 addr: fe80::5492:eff:fe4a:2690/64 Scope:Link
      UP BROADCAST RUNNING  MTU:1500  Metric:1
      RX packets:11 errors:0 dropped:0 overruns:0 frame:0
      TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:0 
br-int    Link encap:Ethernet  HWaddr 9e:c3:a8:1f:1d:46  
      inet6 addr: fe80::4c03:f7ff:fe57:1c7d/64 Scope:Link
      UP BROADCAST RUNNING  MTU:1500  Metric:1
      RX packets:22 errors:0 dropped:0 overruns:0 frame:0
      TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:0 
      RX bytes:1780 (1.7 KB)  TX bytes:648 (648.0 B)
br-tun    Link encap:Ethernet  HWaddr c6:95:6b:c3:d6:41  
      inet6 addr: fe80::e473:cfff:fe34:eaf3/64 Scope:Link
      UP BROADCAST RUNNING  MTU:1500  Metric:1
      RX packets:1 errors:0 dropped:0 overruns:0 frame:0
      TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:0 
      RX bytes:90 (90.0 B)  TX bytes:648 (648.0 B)
eth0      Link encap:Ethernet  HWaddr 00:25:22:b4:87:f9  
      inet addr:10.0.1.21  Bcast:10.0.1.255  Mask:255.255.255.0
      inet6 addr: fe80::225:22ff:feb4:87f9/64 Scope:Link
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
      RX packets:9 errors:0 dropped:0 overruns:0 frame:0
      TX packets:75 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:762 (762.0 B)  TX bytes:9969 (9.9 KB)
eth1      Link encap:Ethernet  HWaddr 00:60:6e:b1:6e:0d  
      inet addr:10.0.0.21  Bcast:10.0.0.255  Mask:255.255.255.0
      inet6 addr: fe80::260:6eff:feb1:6e0d/64 Scope:Link
      UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
      RX packets:16399 errors:0 dropped:6861 overruns:0 frame:0
      TX packets:15316 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000 
      RX bytes:921178 (921.1 KB)  TX bytes:3339235 (3.3 MB)
eth2      Link encap:Ethernet  HWaddr 04:1e:64:fc:cb:05  
      inet6 addr: fe80::61e:64ff:fefc:cb05/64 Scope:Link
      UP BROADCAST MULTICAST  MTU:1500  Metric:1
      RX packets:0 errors:0 dropped:0 ...
(more)
2015-01-05 01:06:11 -0600 received badge  Supporter (source)