Ask Your Question

bryanjimenez's profile - activity

2014-03-30 23:45:16 -0600 received badge  Famous Question (source)
2013-12-12 23:39:31 -0600 received badge  Taxonomist
2013-11-15 07:55:05 -0600 received badge  Good Question (source)
2013-11-13 11:58:36 -0600 commented answer Horizon missing css styles

If I purge and reinstall openstack-dashboard shouldn't it restore to a working state? Do you think there is something else broken?

2013-11-12 13:39:58 -0600 received badge  Notable Question (source)
2013-11-05 13:44:09 -0600 received badge  Popular Question (source)
2013-11-01 09:10:58 -0600 asked a question Horizon missing css styles

Using debian wheezy and openstack folsom

Getting this when I load up the dashboard:

[09:49:47.488] GET https://localhost/static/dashboard/css/5107381d683a.css [HTTP/1.1 404 Not Found 1ms]

which results in a dashboard without css styles

When I try to log in then I get this:

[10:09:24.025] ReferenceError: $ is not defined @ https://localhost/auth/login/:175

I'm not sure but it seems to me jquery isn't found?

When I try to look for the css files ls /usr/share/openstack-dashboard/openstack_dashboard/static/dashboard/css results in no files.

I purged openstack-dashboard nodejs and reinstalled openstack-dashboard but there are still no files in the css folder. I have installed this before and the styles have worked fine.

2013-07-31 12:12:28 -0600 received badge  Teacher (source)
2013-07-31 12:12:28 -0600 received badge  Self-Learner (source)
2013-07-30 23:21:28 -0600 received badge  Famous Question (source)
2013-07-30 23:20:57 -0600 answered a question Openstack install guide for Debian 7

If anyone is interested in a single node folsom install in debian 7 check http://dachary.org/?p=1791

I created a git with some useful setup.

https://github.com/bryanjimenez/debian-folsom.git

2013-07-03 09:20:49 -0600 received badge  Notable Question (source)
2013-07-03 09:15:45 -0600 received badge  Nice Question (source)
2013-07-03 08:45:40 -0600 commented answer Openstack install guide for Debian 7

I went through this guide before, but it starts off by adding ubuntu archives to the sources which I am not sure if I should do under Wheezy. Either way they are setting up the nodes individually. I would like to have an all in one node. What would I have to do different?

2013-07-03 06:36:48 -0600 received badge  Popular Question (source)
2013-07-02 08:27:17 -0600 received badge  Student (source)
2013-07-01 14:19:01 -0600 commented answer Unable to Ping or SSH after installing RDO

Do you get this message in the log for the instance? https://lists.launchpad.net/openstack/msg22660.html

2013-07-01 13:45:03 -0600 received badge  Editor (source)
2013-07-01 13:38:21 -0600 answered a question Unable to Ping or SSH after installing RDO

I was getting no ssh or pings also and after finding this was able to get it working. The host was Ubuntu 12.04. This adds a rule to the iptables that modifies outgoing packets from the host.

https://wiki.ubuntu.com/SecurityTeam/TestingOpenStack#Making_OpenStack_available_to_the_LAN

 sudo /sbin/iptables -A POSTROUTING -t mangle -p udp --dport 68 -j CHECKSUM --checksum-fill
2013-07-01 13:27:43 -0600 asked a question Openstack install guide for Debian 7

Could some one point me to an install guide for OpenStack in Debian (preferably a complete from start to finish detailed one)? I would like to install a single node OpenStack. I have tried OpenStack in Ubuntu and the setup seems to be much more difficult (less documented) for Debian. So far I have a fresh wheezy install. Any suggestions are greatly appreciated.