Ask Your Question

arindamchoudhury's profile - activity

2016-03-14 09:10:43 -0500 marked best answer auto assignment of floating ip

How I can enable auto assignment of floating ip through devstack. I am using neutron.

I tried with:

EXTRA_OPTS=(auto_assign_floating_ip=True)

but it does not work?

2015-07-28 10:03:38 -0500 received badge  Famous Question (source)
2015-01-15 16:38:11 -0500 received badge  Nice Question (source)
2014-10-22 03:46:32 -0500 marked best answer what is provider:physical_network?

I am really blank on this parameter of quantum/neutron when setting up vlan? How to set this up? Where to find the value of provider:physical_network?

2014-08-11 01:50:36 -0500 received badge  Famous Question (source)
2014-08-07 12:09:12 -0500 received badge  Famous Question (source)
2014-07-29 19:28:02 -0500 received badge  Famous Question (source)
2014-07-22 20:31:30 -0500 received badge  Good Question (source)
2014-06-12 03:45:09 -0500 received badge  Teacher (source)
2014-06-03 15:26:30 -0500 received badge  Notable Question (source)
2014-06-03 03:29:04 -0500 received badge  Popular Question (source)
2014-06-02 10:51:11 -0500 asked a question How to control the data network while having three NIC

Hi,

I have three NIC.

eth0: 10.10.0.0/24
eth1: 192.168.0.0/24
eth2: 192.168.1.0/24

I want configure neutron with GRE. How to assign eth1 for GRE tunnelling as the data network for the VMs.

Regards, Arindam

2014-05-28 08:55:47 -0500 commented question forwarding and NAT rules not working on br-ex

Thanks a lot. I will try that.

2014-05-28 08:32:25 -0500 commented question forwarding and NAT rules not working on br-ex

I just leave blank this CONFIG_NEUTRON_OVS_TUNNEL_IF=eth1 as I dont have eth1

Okay, I understand your answer. Thats why I do not have any TUN Bridge with GRE port.

Thanks a lot.

2014-05-28 08:26:49 -0500 received badge  Famous Question (source)
2014-05-22 09:44:38 -0500 received badge  Enthusiast
2014-05-22 09:23:55 -0500 received badge  Notable Question (source)
2014-05-21 16:09:54 -0500 received badge  Notable Question (source)
2014-05-21 14:22:39 -0500 received badge  Popular Question (source)
2014-05-21 13:54:09 -0500 commented question forwarding and NAT rules not working on br-ex

no. i have not

2014-05-21 11:03:20 -0500 commented question forwarding and NAT rules not working on br-ex

I am confused about what really I have to do? sorry. should I follow this

2014-05-21 10:36:24 -0500 asked a question forwarding and NAT rules not working on br-ex

Hi,

I have installed openstack icehouse on fedora 20 using packstack. Its a all-in-one with neutron GRE following this.

I only have one NIC so I put the external network gateway address in br-ex and I can ping and ssh to my VM using floating IP (I am following this).

# iptables -A FORWARD -d 172.24.4.224/28 -j ACCEPT 
# iptables -A FORWARD -s 172.24.4.224/28 -j ACCEPT 
# iptables -t nat -I POSTROUTING 1 -s 172.24.4.224/28 -j MASQUERADE

but when I ran the above command to enable forwarding and NAT rules, I can not access my VMs anymore.

# sysctl -a | grep net.ipv4.ip_forward
net.ipv4.ip_forward = 1
net.ipv4.ip_forward_use_pmtu = 0

# ovs-vsctl show
0a5bfc1f-a948-4627-88d3-58ad5882dddb
    Bridge br-tun
        Port br-tun
            Interface br-tun
                type: internal
        Port patch-int
            Interface patch-int
                type: patch
                options: {peer=patch-tun}
    Bridge br-ex
        Port "qg-65b3fe96-a5"
            Interface "qg-65b3fe96-a5"
                type: internal
        Port br-ex
            Interface br-ex
                type: internal
    Bridge br-int
        Port br-int
            Interface br-int
                type: internal
        Port "qr-c408c223-9c"
            tag: 1
            Interface "qr-c408c223-9c"
                type: internal
        Port "tap8433daff-78"
            tag: 1
            Interface "tap8433daff-78"
                type: internal
        Port patch-tun
            Interface patch-tun
                type: patch
                options: {peer=patch-int}
    ovs_version: "2.0.1"

as suggested:

# iptables -A FORWARD -d 172.24.4.224/28 -j ACCEPT
# iptables -A FORWARD -s 172.24.4.224/28 -j ACCEPT
# iptables -t nat -I POSTROUTING 1 -s 172.24.4.224/28 -o  em1 -j MASQUERADE

with this, I can ping and SSH to my VM. But still no internet connectivity from VM.

Any help will be highly appreciated.

2014-05-20 04:34:29 -0500 received badge  Popular Question (source)
2014-05-19 09:30:01 -0500 asked a question Openstack icehouse in fedora 20 with one NIC and Neutron ml2 gre

Hi,

I am trying to install openstack icehouse on fedora20. I have only one NIC. I want to configure neutron with ml2 plugin and want to use gre tunnelling.

So, I changed my answer file following way:

CONFIG_NEUTRON_L2_PLUGIN=ml2
CONFIG_NEUTRON_ML2_TYPE_DRIVERS=gre
CONFIG_NEUTRON_ML2_TENANT_NETWORK_TYPES=gre
CONFIG_NEUTRON_ML2_TUNNEL_ID_RANGES=100:1000
CONFIG_NEUTRON_OVS_TENANT_NETWORK_TYPE=gre
CONFIG_NEUTRON_OVS_TUNNEL_RANGES=100:1000
CONFIG_NEUTRON_OVS_TUNNEL_IF=em1

CONFIG_HEAT_CLOUDWATCH_INSTALL=y
CONFIG_HEAT_CFN_INSTALL=y

The installation finishes without any error, but it does not add br-ex.

# ovs-vsctl show
14c348c7-9654-4b33-a9a9-c245c0189b57
    Bridge br-tun
        Port br-tun
            Interface br-tun
                type: internal
        Port patch-int
            Interface patch-int
                type: patch
                options: {peer=patch-tun}
    Bridge br-int
        Port patch-tun
            Interface patch-tun
                type: patch
                options: {peer=patch-int}
        Port "tap8651f69c-f3"
            tag: 3
            Interface "tap8651f69c-f3"
                type: internal
        Port br-int
            Interface br-int
                type: internal
    ovs_version: "2.0.1"

Any help will be highly appreciated.

2014-05-19 07:12:04 -0500 received badge  Famous Question (source)
2014-05-15 21:52:20 -0500 received badge  Notable Question (source)
2014-05-15 09:57:08 -0500 received badge  Popular Question (source)
2014-05-15 07:42:15 -0500 answered a question How to get ML2 plugin activated via answer-file within AIO IceHouse on CentOS 6.5 ?

I found a good blog about it. Though in Chinese. Hope it will help you.

http://www.chenshake.com/centos-insta...

2014-05-15 07:28:36 -0500 asked a question failed to start keystone

Hi,

I am using fedora 20. While I am running packstack I am getting this error:

Error: 

Could not start Service[keystone]: Execution of '/sbin/service openstack-keystone start' returned 1: Redirecting to /bin/systemctl start  openstack-keystone.service
Job for openstack-keystone.service failed. See 'systemctl status openstack-keystone.service' and 'journalctl -xn' for details.
Wrapped exception:
Execution of '/sbin/service openstack-keystone start' returned 1: Redirecting to /bin/systemctl start  openstack-keystone.service
Job for openstack-keystone.service failed. See 'systemctl status openstack-keystone.service' and 'journalctl -xn' for details.
Error: /Stage[main]/Keystone/Service[keystone]/ensure: change from stopped to running failed: Could not start Service[keystone]: Execution of '/sbin/service openstack-keystone start' returned 1: Redirecting to /bin/systemctl start  openstack-keystone.service
Job for openstack-keystone.service failed. See 'systemctl status openstack-keystone.service' and 'journalctl -xn' for details.

Keystone log says:

2014-05-15 14:18:47.155 20320 INFO keystone.common.openssl [-] openssl genrsa -out /etc/keystone/ssl/private/cakey.pem 2048
2014-05-15 14:18:47.245 20320 INFO keystone.common.openssl [-] openssl req -new -x509 -extensions v3_ca -key /etc/keystone/ssl/private/cakey.pem -out /etc/keystone/ssl/certs/ca.pem -days 3650 -config /etc/keystone/ssl/certs/openssl.conf -subj /C=US/ST=Unset/L=Unset/O=Unset/CN=www.example.com
2014-05-15 14:18:47.254 20320 INFO keystone.common.openssl [-] openssl genrsa -out /etc/keystone/ssl/private/signing_key.pem 2048
2014-05-15 14:18:47.333 20320 INFO keystone.common.openssl [-] openssl req -key /etc/keystone/ssl/private/signing_key.pem -new -out /etc/keystone/ssl/certs/req.pem -config /etc/keystone/ssl/certs/openssl.conf -subj /C=US/ST=Unset/L=Unset/O=Unset/CN=www.example.com
2014-05-15 14:18:47.342 20320 INFO keystone.common.openssl [-] openssl ca -batch -out /etc/keystone/ssl/certs/signing_cert.pem -config /etc/keystone/ssl/certs/openssl.conf -days 3650d -cert /etc/keystone/ssl/certs/ca.pem -keyfile /etc/keystone/ssl/private/cakey.pem -infiles /etc/keystone/ssl/certs/req.pem

journalctl -xn

-- Logs begin at Wed 2014-05-07 15:29:55 CEST, end at Thu 2014-05-15 16:27:53 CEST. -- May 15 16:27:53 aopcach.uab.es keystone-all[30542]: ImportError: cannot import name systemd May 15 16:27:53 aopcach.uab.es systemd[1]: openstack-keystone.service: main process exited, code=exited, status=1/FAILURE May 15 16:27:53 aopcach.uab.es systemd[1]: Failed to start OpenStack Identity Service (code-named Keystone).
-- Subject: Unit openstack-keystone.service has failed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- Unit openstack-keystone.service has failed.
-- 
-- The result is failed. May 15 16:27:53 aopcach.uab.es systemd[1]: Unit openstack-keystone.service entered failed state. May 15 16:27:53 aopcach.uab.es systemd[1]: openstack-keystone.service holdoff time over, scheduling restart. May 15 16:27:53 aopcach.uab.es systemd[1]: Stopping OpenStack Identity Service (code-named Keystone)...
-- Subject: Unit openstack-keystone.service has begun shutting down
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- Unit openstack-keystone.service has begun shutting down. May 15 16:27:53 ...
(more)
2014-05-02 01:56:19 -0500 received badge  Famous Question (source)
2014-05-01 06:09:28 -0500 received badge  Notable Question (source)
2014-04-30 23:25:51 -0500 received badge  Popular Question (source)
2014-04-30 09:21:55 -0500 asked a question OpenStack icehouse on a fresh installation of Fedora 20

Hi,

On a fresh Fedora 20, I want to install Openstack icehouse allinone.

So I followed the quickstart:

  1. sudo yum install -y http://rdo.fedorapeople.org/rdo-relea...
  2. sudo yum install -y openstack-packstack
  3. packstack --allinone

which gives me this error:

ERROR : Error appeared during Puppet run: 158.109.65.21_amqp.pp

Error: rpm --import http://www.rabbitmq.com/rabbitmq-sign... returned 1 instead of one of [0]

in amqp.pp.log:

Warning: Config file /etc/puppet/hiera.yaml not found, using Hiera defaults Notice: Compiled catalog for HOSTNAME in environment production in 1.31 seconds Notice: /Stage[main]/Rabbitmq::Repo::Rhel/Exec[rpm --import http://www.rabbitmq.com/rabbitmq-sign... : curl: (6) Could not resolve host: www.rabbitmq.com Notice: /Stage[main]/Rabbitmq::Repo::Rhel/Exec[rpm --import http://www.rabbitmq.com/rabbitmq-sign... : error: http://www.rabbitmq.com/rabbitmq-sign... : import read failed(2). Error: rpm --import http://www.rabbitmq.com/rabbitmq-sign... returned 1 instead of one of [0] Error: /Stage[main]/Rabbitmq::Repo::Rhel/Exec[rpm --import http://www.rabbitmq.com/rabbitmq-sign... : change from notrun to 0 failed: rpm --import http://www.rabbitmq.com/rabbitmq-sign... returned 1 instead of one of [0] Notice: /Stage[main]/Main/Enable_rabbitmq[rabbitmq]/Package[erlang]/ensure: created Notice: /Stage[main]/Rabbitmq::Install/Package[rabbitmq-server]: Dependency Exec[rpm --import http://www.rabbitmq.com/rabbitmq-sign... has failures: true Warning: /Stage[main]/Rabbitmq::Install/Package[rabbitmq-server]: Skipping because of failed dependencies Notice: /Stage[main]/Rabbitmq::Config/File[/etc/rabbitmq]: Dependency Exec[rpm --import http://www.rabbitmq.com/rabbitmq-sign... has failures: true Warning: /Stage[main]/Rabbitmq::Config/File[/etc/rabbitmq]: Skipping because of failed dependencies Notice: /Stage[main]/Rabbitmq::Config/File[rabbitmq.config]: Dependency Exec[rpm --import http://www.rabbitmq.com/rabbitmq-sign... has failures: true Warning: /Stage[main]/Rabbitmq::Config/File[rabbitmq.config]: Skipping because of failed dependencies Notice: /Stage[main]/Rabbitmq::Config/File[/etc/rabbitmq/ssl]: Dependency Exec[rpm --import http://www.rabbitmq.com/rabbitmq-sign... has failures: true Warning: /Stage[main]/Rabbitmq::Config/File[/etc/rabbitmq/ssl]: Skipping because of failed dependencies Notice: /Stage[main]/Rabbitmq::Config/File[rabbitmq-env.config]: Dependency Exec[rpm --import http://www.rabbitmq.com/rabbitmq-sign... has failures: true Warning: /Stage[main]/Rabbitmq::Config/File[rabbitmq-env.config]: Skipping because of failed dependencies Notice: /Stage[main]/Rabbitmq::Service/Service[rabbitmq-server]: Dependency Exec[rpm --import http://www.rabbitmq.com/rabbitmq-sign... has failures: true Warning: /Stage[main]/Rabbitmq::Service/Service[rabbitmq-server]: Skipping because of failed dependencies Notice: /Stage[main]/Rabbitmq/Anchor[rabbitmq::end]: Dependency Exec[rpm --import http://www.rabbitmq.com/rabbitmq-sign... has failures: true Warning: /Stage[main]/Rabbitmq/Anchor[rabbitmq::end]: Skipping because of failed dependencies Notice: /Stage[main]/Main/Packstack::Firewall[amqp_]/Firewall[001 amqp incoming amqp_]/ensure: created Notice: Finished catalog run in 210.40 seconds

Any help will be highly appreciated.

Thanks,