Ask Your Question

Thomas Li's profile - activity

2019-06-10 12:54:42 -0600 received badge  Taxonomist
2018-08-23 10:01:09 -0600 received badge  Famous Question (source)
2018-02-19 06:42:22 -0600 answered a question Glance how it is used? publish and run images?

just untart first, there is no compressed image support!

2018-02-15 06:06:05 -0600 commented question I am getting "Error:Unable to retrieve project list."

when "Error: Unable to retrieve the project." you probably created the image with old glance command or openstack command but unsufissient parameters, pike need projectid insted of owner to function

do to fix:

openstack image set --project projektname imagename

2018-02-05 11:38:04 -0600 received badge  Necromancer (source)
2018-02-05 11:38:04 -0600 received badge  Self-Learner (source)
2018-02-05 11:38:04 -0600 received badge  Teacher (source)
2018-02-05 11:30:58 -0600 received badge  Scholar (source)
2018-02-05 11:28:53 -0600 answered a question cant ping vRouter from other hosts: Destination Host Prohibited

It seems that Iptables in combination with openstack neutron pike on linuxbridge was corrupt in december '17. Line 4,5 wasnt set due iptables deamon false active state, update it, debug inactive state error, install additional iptables packages, rerun neutron installation, they sould be set and the vrouter should be available through ipv4!

iptables -L

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination
neutron-filter-top  all  --  anywhere             anywhere
neutron-linuxbri-FORWARD  all  --  anywhere             anywhere
2018-01-11 01:38:35 -0600 received badge  Notable Question (source)
2018-01-05 01:55:49 -0600 received badge  Popular Question (source)
2018-01-04 10:21:23 -0600 asked a question cant ping vRouter from other hosts: Destination Host Prohibited

Hey guys,

i stuck in an other wired problem. I set up pike rdo on latest centos 7, with ip tables because neutron hate firewalld, linuxbridge, 1 externalnet (public)1 internalnet (mgmt, data), 1 api node, 1 networknode and couple computes. I had it running on juno an kilo, but was using network-computenode hybrid in all the releases in between. Created a vrouter (44) and could ping it from the same host but not the others. I dit it in kilo on ovs instead linuxbridge and it worked fine. Doublechecked FW (devsetup)

[root@22 ~]# iptables -L

Chain INPUT (policy ACCEPT)
target     prot opt source               destination
neutron-linuxbri-INPUT  all  --  anywhere             anywhere
ACCEPT     udp  --  anywhere             anywhere             udp dpt:domain
ACCEPT     tcp  --  anywhere             anywhere             tcp dpt:domain
ACCEPT     udp  --  anywhere             anywhere             udp dpt:bootps
ACCEPT     tcp  --  anywhere             anywhere             tcp dpt:bootps
ACCEPT     all  --  anywhere             anywhere             state RELATED,ESTABLISHED
ACCEPT     icmp --  anywhere             anywhere
ACCEPT     all  --  anywhere             anywhere
ACCEPT     tcp  --  anywhere             anywhere             state NEW tcp dpt:ssh
ACCEPT     tcp  --  x.x.x.0/27       anywhere             state NEW tcp
ACCEPT     udp  --  x.x.x.0/27       anywhere
ACCEPT     tcp  --  10.1.1.0/24          anywhere             state NEW tcp
ACCEPT     udp  --  10.1.1.0/24          anywhere
REJECT     all  --  anywhere             anywhere             reject-with icmp-host-prohibited

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination
neutron-filter-top  all  --  anywhere             anywhere
neutron-linuxbri-FORWARD  all  --  anywhere             anywhere
ACCEPT     all  --  anywhere             192.168.122.0/24     ctstate RELATED,ESTABLISHED
ACCEPT     all  --  192.168.122.0/24     anywhere
ACCEPT     all  --  anywhere             anywhere
REJECT     all  --  anywhere             anywhere             reject-with icmp-port-unreachable
REJECT     all  --  anywhere             anywhere             reject-with icmp-port-unreachable
REJECT     all  --  anywhere             anywhere             reject-with icmp-host-prohibited

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination
neutron-filter-top  all  --  anywhere             anywhere
neutron-linuxbri-OUTPUT  all  --  anywhere             anywhere
ACCEPT     udp  --  anywhere             anywhere             udp dpt:bootpc

Chain neutron-filter-top (2 references)
target     prot opt source               destination
neutron-linuxbri-local  all  --  anywhere             anywhere

Chain neutron-linuxbri-FORWARD (1 references)
target     prot opt source               destination

Chain neutron-linuxbri-INPUT (1 references)
target     prot opt source               destination

Chain neutron-linuxbri-OUTPUT (1 references)
target     prot opt source               destination

Chain neutron-linuxbri-local (1 references)
target     prot opt source               destination

Chain neutron-linuxbri-sg-chain (0 references)
target     prot opt source               destination
ACCEPT     all  --  anywhere             anywhere

Chain neutron-linuxbri-sg-fallback (0 references)
target     prot opt source               destination
DROP       all  --  anywhere             anywhere             /* Default drop rule for unmatched traffic. */

but still:

From x.x.x.22 icmp_seq=1 Destination Host Prohibited
l3 is pretty much stock: https://docs.openstack.org/neutron/pi... but later i did and also tested many other configs:
[DEFAULT]
interface_driver = linuxbridge
external_network_bridge = br0
verbose = True
debug = True
use_syslog = True
syslog_log_facility = LOG_LOCAL0
use_namespaces = True
enable_metadata_proxy = True

tcpdump -i br0 |grep -v my_onw_host

15:36:54.608446 IP  11.mydomain >  44.mydomain: ICMP echo request, id 5079, seq 1225, length 64
15:36:54.609838 IP dns.mydomain.domain >  22.mydomain.46497: 57792* 1/4/8 PTR  44.mydomain. (347)
15:37:15.608414 IP  22.mydomain >  11.mydomain: ICMP host  44.mydomain unreachable - admin prohibited, length 92
15:37:15.608431 IP  11.mydomain >  44.mydomain: ICMP echo request, id 5079, seq 1246, length 64
15:37:15 ...
(more)
2017-08-22 09:13:40 -0600 received badge  Famous Question (source)
2017-05-07 15:03:26 -0600 received badge  Popular Question (source)
2017-05-03 08:45:01 -0600 asked a question Hack Neutron to add more IP addresses to an existing subnet

Is it still working or even supported? Anybody tried it?

https://cloudblog.switch.ch/2015/09/2...

2017-04-18 06:43:10 -0600 received badge  Popular Question (source)
2017-04-18 06:43:10 -0600 received badge  Famous Question (source)
2017-04-18 06:43:10 -0600 received badge  Notable Question (source)
2017-04-13 02:31:10 -0600 asked a question horizon ocata eclipse ide integration fails only on login

the integration https://chianingwang.blogspot.de/2015... works fine, but its not able to display the login promt. I tested it by performing a prelogin through apache (apache stop, login, apache stop, eclipse start, dashboard available without login) and the images panel crashes

Eclipse: Not Found: /dashboard/auth/login/ [13/Apr/2017 07:33:05] "GET /dashboard/auth/login/?next=/ HTTP/1.1" 404 4433

Browser: Page not found (404) Request Method: GET Request URL: http://X.X.X.X/dashboard/auth/login/?... Using the URLconf defined in openstack_dashboard.urls, Django tried these URL patterns, in this order: ^$ [name='splash'] ^api/ ^home/$ [name='user_home'] ^i18n/js/(?P<packages>\S+?)/$ [name='jsi18n'] ^i18n/setlang/$ [name='set_language'] ^i18n/ ^jasmine-legacy/$ [name='jasmine_tests'] ^jasmine/.</packages>?$ ^identity/ ^project/ ^settings/ ^admin/ ^auth/ ^dashboard\/static\/(?P<path>.)$ ^dashboard\/media\/(?P<path>.*)$ ^500/$ The current URL, dashboard/auth/login/, didn't match any of these.

2017-04-12 05:19:16 -0600 commented answer How do I debug OpenStack?

works fine with as horizon ocata integration with eclipse!!! https://chianingwang.blogspot.de/2015... but use from the link above Run Configurations -> Arguments -> ${workspace_loc:openstack-dashboard}

2017-04-12 04:58:32 -0600 commented question How to put horizon in debug mode in eclipse??

how you imported it in eclipse?

2017-04-12 04:57:26 -0600 received badge  Notable Question (source)
2017-04-04 13:28:16 -0600 received badge  Notable Question (source)
2017-04-04 13:28:16 -0600 received badge  Famous Question (source)
2017-03-23 13:41:53 -0600 received badge  Popular Question (source)
2017-03-03 06:37:19 -0600 asked a question Installguide for the in RDO packaged murano?

Is there an update Installguide for the in RDO packaged murano? every guide you find on the web is based on git/pip and mostly very old

yum list openstack-murano*
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
Installed Packages
openstack-murano-agent.noarch                                  3.0.0-1.el7                                  @centos-openstack-newton
openstack-murano-api.noarch                                    3.0.0-1.el7                                  @centos-openstack-newton
openstack-murano-cf-api.noarch                                 3.0.0-1.el7                                  @centos-openstack-newton
openstack-murano-common.noarch                                 3.0.0-1.el7                                  @centos-openstack-newton
openstack-murano-doc.noarch                                    3.0.0-1.el7                                  @centos-openstack-newton
openstack-murano-engine.noarch                                 3.0.0-1.el7                                  @centos-openstack-newton
openstack-murano-ui.noarch                                     3.0.0-1.el7                                  @centos-openstack-newton
openstack-murano-ui-doc.noarch                                 3.0.0-1.el7                                  @centos-openstack-newton
2017-02-09 20:35:04 -0600 received badge  Popular Question (source)
2017-02-07 04:12:18 -0600 commented question how do you prefer to install your custom openstack?

both off scope, openstack-ansible AIO builds aren’t recommended for large production deployments, they’re great for smaller proof-of-concept deployments. kolla-ansible is for container provisioning

2017-02-06 08:04:02 -0600 asked a question how do you prefer to install your custom openstack?

hey guys, i wanted to poll how you install and customize your opsnestck, nodecount, maybe with some nice hints/difficulties here and there and also like collect some advise if it is a really good idea to go for bifrost(ansible/ironic) when it comes to deploy 25-100 different(api/compute) Nodes, i also wanted to exclude devstack because there is no real "custom" about it.

  1. packstack
  2. ansible
  3. salt
  4. puppet
  5. chef
  6. bifrost (ansible/ironic)
  7. foreman (puppet)
  8. foreman (salt)
  9. custom bash script
  10. die hard (manual step by step inst. though the official guide)
  11. tripple O
2017-02-01 04:19:06 -0600 answered a question Can not ping outside world when using NAT-VM / VPN

2 additional approvals from me, but i cant help you, you should use sdn in the manner it should be use and dont look for intranparent workarounds, but vRouters do not support vpn so you need to forget about routers and establish a tunnel for each vm, when you got a better solution let me know

2017-01-29 18:48:51 -0600 received badge  Popular Question (source)
2017-01-29 18:48:51 -0600 received badge  Notable Question (source)
2016-12-23 07:19:51 -0600 received badge  Famous Question (source)
2016-12-23 06:08:17 -0600 asked a question Bifrost within a Devstack installation posible?

Hey guys,

i got no physical nodes free for checking out bifrost, i tryed to set it um on the same vm, devstack was running on, but during ansible dependencys check it says, it should not be executed on "virtualenv"

My devstack installation has 3 vm that are presented to ironic als baremetal, may i start it on them? One of the main problems is getting the ramdisk and the kernel in AKI format to let centos7 start up like cirros with all the precreated ramdisks and kernels. I cant cant even "connect" or "console" into those baremetal hosts

virsh # console node-2
error: Failed to reconnect to the hypervisor
error: no valid connection
error: no connection driver available for node-2

Finally is is actually possible to spin up OS with Bifrost within a Devstack Baremetal Node?

FYI: http://docs.openstack.org/developer/i...

#Create 3 virtual machines to pose as Ironic's baremetal nodes.

IRONIC_VM_COUNT=3
2016-12-01 06:36:20 -0600 answered a question [Devstack] Instance console keyboard error

works not, (CentOS7)

2016-11-29 09:54:50 -0600 commented answer How to properly reboot a machine running devstack.sh?

guess what, haha

2016-10-25 06:35:20 -0600 received badge  Notable Question (source)
2016-10-19 15:56:08 -0600 received badge  Popular Question (source)
2016-10-18 09:13:29 -0600 asked a question Rally for Experts: Putting true load on Openstack with Rally, "stress" and motitor it with "sysbench"

I have automated nearly everything possible with Rally. Its a great tool but putting load on openstack by letting Openstack deploy stuff all the time isnt the situation that admins will face in reality. So i started to think about how can i put true load on Openstack with Rally, "stress" VMs a motitor VM it with "sysbench" that need to run et least 10 Minutes due hhd benchmarks and maybe some 10% of the load my be generated by what Rally was originaly build for: "deploymenttests".

I faced several problems:

Config override: I watn to run it as a separate Rally development job with its own scenarios and not the production job, but that leads to the problem that you can only define timouts in one central file, rally.conf which will affect production jobs, that will lead to other problems that need to be solved. Is there an option to override the rally config just for one specific job?

Parallelization: I need to run "stress" on several VMs an motiotor the affects on the cluster with sysbench on a separate VM, that means i need to run at least 2 separate scenarios, that needs to be supported. I know it was promised in a presentation long ago, but is it released right now?

2016-04-21 04:30:53 -0600 commented answer Create a new dashboard Error

ridiculous

2016-04-14 06:00:16 -0600 commented answer No handlers could be found for logger "oslo_config.cfg"

confirmed .

2016-04-14 05:24:25 -0600 commented answer No handlers could be found for logger "oslo_config.cfg"

not working

2016-04-14 05:12:35 -0600 commented question Keystone: No handlers could be found for logger "oslo_config.cfg"

no, its not working

2016-04-14 05:12:35 -0600 received badge  Commentator