Ask Your Question

Yashpal Beppurana's profile - activity

2015-09-17 21:44:02 -0500 received badge  Nice Answer (source)
2015-04-21 12:56:40 -0500 received badge  Nice Answer (source)
2015-03-09 05:26:36 -0500 answered a question Recover image in pending delete status?

Hi, the glance service stores images in the local hard disk. Try to check the correct status by looking at the glance/images database and also you can check whether image exists in /var/lib/glance/image directory. Well, if the image exists, you can save that image and upload to glance repository. If suppose, that image does not exist, then you can try taking snapshort of an instance(instance launched with the same image you deleted) to recover that image.

2015-03-05 01:06:47 -0500 answered a question nodes to setup OpenStack

Well you can have the complete setup on single node. Or you can make every OpenStack components to run on individual boxes(this is where you see the feature of cloud, distributed architecture). No complusion on number of nodes. It all depends on what you want to extract from your setup.

2015-03-04 04:56:12 -0500 answered a question No handlers could be found for logger "oslo_config.cfg"

Hi Janki, can you check for the version of eventlet package? from the error I see utils file is missing from eventlet package. Post your eventlet version.

2015-03-03 09:08:58 -0500 edited question nova services go back to stop state

Hi I have 3 node architecture OpenStack setup. Everything was working till yesterday evening. Today all nova services on controller noe i.e. consoleauth, api, conductor, scheduler, and cert show stop status even after starting.

Only log file is nova-manage.log on controller node which is empty.

nova.conf file on controller node is

[DEFAULT]
dhcpbridge_flagfile=/etc/nova/nova.conf
dhcpbridge=/usr/bin/nova-dhcpbridge
logdir=/var/log/nova
state_path=/var/lib/nova
lock_path=/var/lock/nova
force_dhcp_release=True
iscsi_helper=tgtadm
libvirt_use_virtio_for_bridges=True
connection_type=libvirt
root_helper=sudo nova-rootwrap /etc/nova/rootwrap.conf
verbose=True
ec2_private_dns_show_ip=True
api_paste_config=/etc/nova/api-paste.ini
volumes_path=/var/lib/nova/volumes
enabled_apis=ec2,osapi_compute,metadata

rpc_backend = rabbit
rabbit_host = controller
rabbit_password = guest

my_ip = 10.107.0.131
vncserver_listen = 10.107.0.131
vncserver_proxyclient_address = 10.107.0.131

auth_strategy = keystone

glance_host = controller

network_api_class = nova.network.neutronv2.api.API
neutron_url = http://controller:9696
neutron_auth_strategy = keystone
neutron_admin_tenant_name = service
neutron_admin_username = neutron
neutron_admin_password = 123
neutron_admin_auth_url = http://controller:35357/v2.0
linuxnet_interface_driver = nova.network.linux_net.LinuxOVSInterfaceDriver
firewall_driver = nova.virt.firewall.NoopFirewallDriver
security_group_api = neutron

service_neutron_metadata_proxy = true
neutron_metadata_proxy_shared_secret = 123

[database]
connection = mysql://nova:123@controller/nova

[keystone_authtoken]
auth_uri = http://controller:5000
auth_host = controller
auth_port = 35357
auth_protocol = http
admin_tenant_name = service
admin_user = nova
admin_password = 123

on compute node, nova-compute.log says Timed out waiting for nova-conductor. Is it running? Or did this service start before nova-conductor? nova-manage.log file is empty.

I have reinstalled all nova services yet the services didnot start. OS is Ubuntu 14.04 lts and release is Icehouse.

2015-03-03 09:02:42 -0500 commented question Glance Commands: Invalid Credentials

The problem with respect to the above problem was, Mr. Steven unknowingly downloaded Havana packages and started configuring OpenStack with Juno installation guide

2015-03-03 06:09:24 -0500 commented question nova image-list gives error during installation

Hey Anil, it would be helpful if you can post glance conf, nova conf and log files of glance and nova. From your below answer, I think few of your services are not running.

2015-03-03 05:48:40 -0500 answered a question I need to have a single node installation of OpenStack Juno/IceHouse on Ubuntu 14.04 can someone help me in doing that

Hey Ramakrishnan, OpenStack doc's is very handy to start your installation. Everything is explained in very simple way. In case if you are struck somewhere, you can post your questions here. Start with non-devstack installation, as it provides clear picture of basic OpenStack components. Good Luck

2015-03-02 08:01:31 -0500 commented question nova image-list gives error during installation

Hey Anil, post your nova log files here

2015-03-02 07:33:01 -0500 commented answer devstack installation: Access denied for user 'root'@'localhost'

Hi Alon,

  1. Have you made appropriate changes in /etc/network/interfaces?
  2. OST_IP=132.72.111.144, H is misssing
  3. Are you able to login into mysql by $mysql -u root -p supersecret
2015-02-26 12:11:40 -0500 answered a question devstack installation: Access denied for user 'root'@'localhost'

Hey Alon, tell whether you have logged in as a root user?

How have you configured your local.conf file?

What is the host IP w.r.t your setup?

2015-02-26 11:49:36 -0500 commented answer Glance Commands: Invalid Credentials

3.keystone endpoint-list 4.keystone.conf 5.glance-api.conf 6.glance-registry.conf 7.glance-api.log 8.glance-registry.log 9.admin-openrc.sh file. Let us solve this together!!

2015-02-26 11:46:08 -0500 commented answer Glance Commands: Invalid Credentials

Hey Bell, Juno documentation is absolutely fine. No problem with it, I got confused with the things done w.r.t Icehouse and Juno. Sorry, I'm unable to get the status of your installation. Can you mail me @ yashpal@pthinks.com I need the following. 1.keystone user-list 2.keystone service-list

2015-02-26 04:35:51 -0500 answered a question keystone-nova ssl auth

Hi Liam, try UUID instead of PKI. Basically I feel the error is token mismatch, Set token_format=UUID in keystone.conf file, so that we use UUID instaed of PKI for identity.

2015-02-26 02:36:13 -0500 commented answer Glance Commands: Invalid Credentials

(continue) [database], also, i didn't find [glance_store] too. Well, if you can share your email-id with me, I will send you glance*.conf along with changes or another way is to purge glance packages and then to reinstall

2015-02-26 02:31:48 -0500 commented answer Glance Commands: Invalid Credentials

Hi Bell, I use Icehouse release. Thanks to you, I went through the Installation guide and glance configuration files in Juno. Your say on uncommenting those three lines is correct. Okay, by looking at your configuration files, I really didn't understand why there is [sql] header in place of

2015-02-25 00:04:18 -0500 commented answer Glance Commands: Invalid Credentials

Hey Bell, I guess the usage of command "keystone user-role-list" would do to list roles granted to a user. Also by just typing keystone or glance or nova etc and hitting enter key will give you a list command arguments and options. Hope that helps you.

2015-02-25 00:00:24 -0500 commented answer Glance Commands: Invalid Credentials

Can you post the contents of glance-api.conf, glance-registry.conf and their respective log files?

2015-02-24 23:59:09 -0500 commented answer Glance Commands: Invalid Credentials

Usage of HTTP/HTTPS doesn't matter. The only thing with your setup, you need some protocol to connect different OpenStack services.

2015-02-24 23:57:09 -0500 commented answer Glance Commands: Invalid Credentials

Okay Bell, I have few suggestions/questions for you.

  1. You have commented `#auth_host, #auth_port, #auth_protocol in glance-api.conf and glance-registry.conf, please uncomment them.
  2. I want know what keystone user-list says?
  3. Does glance database has tables, that is, did glance db-sync work
2015-02-24 01:42:38 -0500 commented question Nova Compute issues.

Hey Bikash, I think you have installed OpenStack services on two users, that is, virl and ubuntu

2015-02-24 01:28:58 -0500 edited question Nova Compute issues.

Hello,

I am facing issue with running the VM i.e it used to stuck with no error message. While I run the command nova-manage service list, I could see below output

 virl@virl:~$ nova-manage service list
 Binary           Host                                 Zone             Status     State Updated_At
 nova-conductor   virl                                 internal         enabled    :-)   2015-02-23 20:35:55
 nova-compute     virl                                 nova             enabled    :-)   2015-02-23 20:35:51
 nova-cert        virl                                 internal         enabled    :-)   2015-02-23 20:35:56
 nova-scheduler   virl                                 internal         enabled    :-)   2015-02-23 20:35:54
 nova-consoleauth virl                                 internal         enabled    :-)   2015-02-23 20:35:56

 nova-cert        ubuntu                               internal         disabled   XXX   2015-02-20 12:17:23
 nova-consoleauth ubuntu                               internal         disabled   XXX   2015-02-20 12:17:33
 nova-conductor   ubuntu                               internal         disabled   XXX   2015-02-20 12:17:39
 nova-scheduler   ubuntu                               internal         disabled   XXX   2015-02-20 12:17:49
 nova-compute     ubuntu                               nova             disabled   XXX   2015-02-20 12:17:56

So here all the services are showing two times one is enabled and one is disabled. Will it be a issue.

Thanks, Bikash

2015-02-23 23:24:43 -0500 answered a question Glance Commands: Invalid Credentials

Hi Bell,

  • Contents of glance log file will helpful in troubleshooting, can you post them over here?
  • With respect to the glance conf file, the header is [database]. I don't know how you have [sql] over there? May be this is new changes w.r.t Juno
  • I believe the problem is in the service endpoint. Do the following

Delete glance service endpoint and recreate the same, that is

$keystone endpoint-delete service-id

$keystone service-create --name glance --type image --description "OpenStack Image Service"

$keystone endpoint-create --service-id the-service-id --publicurl http://controller:9292 --internalurl http://controller:9292 --adminurl http://controller:9292 --region regionOne
2015-02-23 23:17:31 -0500 edited question Glance Commands: Invalid Credentials

Ok, so before I punch a hole into my laptop, let me open up a question for you all... I'll try to provide as much background, up front to prevent a long dialogue. I'm trying to run Openstack on one single device. I have keystone installed, and it's running fine. I can get tokens, add services, tenants, users etc... I went to install and configure glance, and it's giving me a ton of issues. I'm running Opensuse 13.1, trying to install the juno series of openstack.

I installed glance successfully, and configured the glance-api and glance-registry conf files according to the documentation. But everytime I run any glance based command such as ' glance index ' or ' glance image-list ' Basically any glance based command will give me the same error. So I can't create any images. Now before you jump to assume it's a username/password issue, let me give you the full logs and errors.

Ok so first off these are my environment variables:

OS_AUTH_URL="http://127.0.0.1:5000/v2.0"
OS_PASSWORD="<passwordforadmin>"
OS_TENANT_NAME="admin"
OS_USERNAME="admin"

My api / registry configs are pretty much mirrors of the auth_token section

This is the /etc/glance/glance-api.conf

[keystone_authtoken]
#auth_host = 127.0.0.1
#auth_port = 35357
#auth_protocol = http
auth_uri = http://localhost:5000/v2.0
identity_uri = http://localhost:35357
admin_tenant_name = service
admin_user = admin
admin_password = <passwordforglance>

Note which ones are commented out and which ones are active

Below is my /etc/glance/glance-registry.conf

[keystone_authtoken]
#auth_host = 127.0.0.1
#auth_port = 35357
#auth_protocol = http
identity_uri = http://localhost:35357
auth_uri = http://localhost:5000/v2.0
admin_tenant_name = service
admin_user = glance
admin_password = <passwordforglance>

Please note which ones are commented out and the the passwords, which differ from the environment variable. Hopefully it's correct so far.

Ok, so let's move onto a big question... in the documentation for Juno it says that the connection = mysql statement should be under the [database] header. Well the problem with that....is that there is NO [database] header. In both glance-api.conf and glance-registry.conf there is a [sql] header. Should I put my connection = mysql:// in the [sql] section, or create the [database] header and put the connection statement in there?

here's what my file looks like:

[sql]
connection = mysql://glance:csc3gadm@localhost/glance
#connection = sqlite:////var/lib/glance/glance.db

Note that I commented out the previous connection. Should I do this? Or should I add the connection = mysql:// and leave the connection = sqlite statement in as well?

Okay, so there's also the following error...whenever I try to do a glance db_sync, it sends and creates a file called. /var/lib/glance/glance.sqlite Should this happened? There is NOTHING inside the mysql glance table. But yet my glance confs have all of the default sqlite statements, commented out. How is this still happening? On both conf files i have my mysql commands set, yet it doesn't seem to matter.

So finally my main question ... (more)

2015-02-23 00:15:35 -0500 answered a question instance status is shutoff

Hi Amitabh, try to reset the state of an instance by,

nova reset-state server-name/id

then try to resume the instance.

2015-02-19 23:35:50 -0500 commented answer glance manage db_sync ImportError: No module named config

hey Sumesh, try installing python-oslo.config

sudo apt-get install python-oslo.config
2015-02-18 04:11:57 -0500 commented answer booting vm from iso file fails

I myself never tried booting an instance using ISO image. However, by looking at your question, I recollected my read on "boot from ISO" documentation. Well, I will try booting from an ISO image on my setup and let you know.

2015-02-18 03:48:18 -0500 answered a question Problem when suspend instances

Hey XicoLoco, from the error message above, I doubt on this line

unsupported configuration: host doesn't support invariant TSC to caller

The Time Stamp Counter (TSC) is a 64-bit register present on all x86 processors since the Pentium. It counts the number of cycles since reset. (source: wiki)

  1. Check whether /proc/cpuinfo talks about TSC
  2. I believe TSC falg is disabled on your host, check whether, is there any way to enable TSC
2015-02-17 23:45:11 -0500 answered a question booting vm from iso file fails

Yes boot from an ISO image is a straight forward process. The OpenStack documentation too talks about it.

2015-02-17 04:32:42 -0500 commented answer Instance Error: Launcing instance gives error

Okay Anil. From my understanding by looking at all comments over here is, you have two-node setup i.e, one controller and one compute. Your problem is that you are unable to connect from one box(controller) to another(compute) and vice versa.

2015-02-17 04:21:27 -0500 answered a question No network adapter after I convert .vmdk to qcow2 and launch it on Icehouse

Hey Luke, well you converted .vmdk image to .qcow2 file and then you uploaded .vmdk image to glance registry.

glance image-create --name="TESTBOX" --disk-format=qcow2 --container-format=bare  --is-public=true <  /home/charge/testbox.vmdk

The above should be changed to

glance image-create --name="TESTBOX" --disk-format=qcow2 --container-format=bare  --is-public=true <  /home/charge/testbox.qcow2
2015-02-16 12:06:42 -0500 commented answer Instance Error: Launcing instance gives error

Hey! your post of nova-compute.log doesn't say anything, my advise to you is, paste the complete nova-compute.log in paste.openstack.org . Look specifically at the areas that talks about your instance in the log file. Tell me, did you look at above mentioned link?

2015-02-16 03:30:16 -0500 answered a question Instance Error: Launcing instance gives error

Hi Anil,

  1. I would like to see what nova-compute.log file talking about.
  2. How about trying with other images? Is that yielding you the expected result?

Try this link. Hope this helps you.

2015-02-06 12:54:40 -0500 commented answer juno nova-compute.log: IncompatibleObjectVersion: Version 1.9 of InstanceList is not supported

My suggestion for you is,

  1. If possible, try to upgrade/downgrade the versions of nova services.
  2. Try to sync database version with nova services.
2015-02-06 12:53:39 -0500 commented answer juno nova-compute.log: IncompatibleObjectVersion: Version 1.9 of InstanceList is not supported

Hey hi, as per the OpenStack documentation-- each service has its set of objects, each with a version attached. When a client attempts to call an object method, the server checks to see if the version of that object matches (in a compatible way) its object implementation.

2015-02-06 12:44:46 -0500 answered a question Juno : nova IncompatibleObjectVersion: Version 1.9 of InstanceList is not supported

Hey hi, as per the OpenStack documentation-- each service has its set of objects, each with a version attached. When a client attempts to call an object method, the server checks to see if the version of that object matches (in a compatible way) its object implementation. If so, everything is fine, and if not, raises an exception. My suggestion for you is,

  1. If possible, try to upgrade/downgrade the versions of nova services.
  2. Try to sync database version with nova services.
2015-01-31 02:04:40 -0500 answered a question juno unable to retrieve instance flavors

Hey hi,

  1. Are you able to do the same from CLI?
  2. Have you tried launching instances with different flavors?
2015-01-31 01:57:30 -0500 answered a question dashboard can't retrieve anything or do anything

Hi Waid,

1. Ensure whether your database is working properly.
2. Enable the logs, and try to figure out the cause.

To enable log, add the following lines to the localrc file.

LOGFILE=/opt/stack/logs/stack.sh.log
SCREEN_LOGDIR=/opt/stack/logs/screen
2015-01-31 00:34:35 -0500 received badge  Necromancer (source)
2015-01-30 12:12:08 -0500 answered a question glance manage db_sync ImportError: No module named config

Hey hi, This link holds a discussion on the error same as yours. Hope this helps you.