Ask Your Question

ysnam's profile - activity

2014-12-02 10:38:49 -0600 received badge  Teacher (source)
2014-12-02 10:38:49 -0600 received badge  Necromancer (source)
2014-11-18 06:56:06 -0600 received badge  Editor (source)
2014-11-18 04:59:19 -0600 commented answer Ceilometer-api critical error OpenStack-IceHouse Ubuntu 14.04

@amic you can uninstall python-ceilometerclient and reinstall. 'pip uninstall python-ceilometerclient' and then you should check your command is really worked. see the '/usr/local/lib/python2.7/dist-packages' whether ceilometerclient folder exists or not. Note: carefully check the dependencies!

2014-11-18 04:59:17 -0600 answered a question ceilometer command line api error

Authorization may not be possible due to many reasons.

I got the same debug messages, but i can't find what's the real problem. I just guess some package dependencies are broken or messed up.
but i suggest a workaround.

In my case, running Ubuntu 14.04.1 and icehouse, i changed the authentication strategy configuration (auth_strategy) to 'noauth', although it is one of workarounds, but if you just wanna deploy and develop ceilometer's functionality on research propose, you can use 'no authentication' option.

2014-11-18 03:52:14 -0600 received badge  Supporter (source)