Ask Your Question

chrisc's profile - activity

2015-08-25 22:28:35 -0500 received badge  Nice Question (source)
2015-05-19 09:18:16 -0500 received badge  Student (source)
2014-12-10 10:51:33 -0500 received badge  Famous Question (source)
2014-12-10 10:51:29 -0500 received badge  Enthusiast
2014-12-08 09:14:06 -0500 commented answer How to change hostname of instance

I understand how to set the hostname when creating an instance from your explanation. Once an instance has been created, I can't see a way to add cloud-init scripts in horizon. Is there a way using the command line?

2014-12-08 09:10:51 -0500 received badge  Notable Question (source)
2014-12-08 07:52:40 -0500 commented answer How to change hostname of instance

thanks Prateek, that makes sense. What about an instance that has already been created? Can you add cloud-init scripts then?

2014-12-08 06:33:34 -0500 received badge  Popular Question (source)
2014-12-08 05:49:50 -0500 commented answer How to change hostname of instance

thanks for the reply. Where do the User data scripts go? Somewhere on the instance itself? If so, where does cloud-init get the original hostname from?

2014-12-08 04:35:46 -0500 received badge  Organizer (source)
2014-12-08 04:33:08 -0500 asked a question How to change hostname of instance

How can I change the hostname of an instance I've created through the horizon gui? I've tried changing /etc/hostname and rebooting, but the instance always comes back up with the original hostname. Also, changing the instance name in horizon doesn't affect the hostname. I assume that cloud-init is setting the hostname, but I don't know where it gets the information from or how to change it. I am using Juno release of openstack.

2014-11-05 03:04:56 -0500 commented answer Configure high available mysql inside my instances

Please can you give more details? I am trying to do something similar: I have a VIP managed by pacemaker on my cluster of Openstack instances (using the IPaddr2 resource), which can't be pinged. Running nova fixed-ip-reserve <ip> just gives "ERROR: Fixed IP <ip> not found (HTTP 404)".