Ask Your Question

yanar's profile - activity

2014-11-04 00:12:15 -0500 received badge  Self-Learner (source)
2014-11-04 00:12:15 -0500 received badge  Teacher (source)
2014-10-29 14:09:49 -0500 received badge  Famous Question (source)
2014-10-29 05:59:49 -0500 commented answer TripleO installation fails

I pasted some more logs after enabling debug in keystone . Is this the novaclient that is causing the issue ?

2014-10-28 21:33:03 -0500 commented answer TripleO installation fails

I added the heat cfn part as per the documentation. The conf file already had the changes . No success. I encountered the same error . Now i can see some more messages in the keystone.log . I pasted the keystone command out put as well as the log messages related to cannot find credentials.

2014-10-28 21:26:42 -0500 received badge  Notable Question (source)
2014-10-28 09:42:29 -0500 commented answer TripleO installation fails

I again updated the output of keystone service-list tothe end of the question. i do not see any heat cfn in the service list . Also, how do i know if i require both heat and heat CFN ? BTW , is there a way to update my lengthy command outputs in this area rather than to the end of the question,

2014-10-28 03:12:32 -0500 received badge  Student (source)
2014-10-28 03:10:56 -0500 received badge  Popular Question (source)
2014-10-28 00:04:36 -0500 commented answer TripleO installation fails

I updated the output of "keystone endpoint-list" at the end of the question since I could not paste the output as a comment. Keystone service status indicates its running successfully.

2014-10-27 08:46:13 -0500 asked a question TripleO installation fails

Hi ,

I use TripleO to deploy 2 baremetal nodes. I followed the instructions as per https://openstack.redhat.com/Deployin... . The baremetal nodes comes up but the heat stack-list shows CREATE_FAILED.

The nova-api.log shows the below message

 WARNING keystoneclient.middleware.auth_token [-] Authorization failed for token

The keystone.log contains the below message

2014-10-27 04:46:38.167 6603 DEBUG keystone.middleware.core [-] Auth token not in the request header. Will not build auth context. process_request /usr/lib/python2.7/site-packages/keystone/middleware/core.py:271
2014-10-27 04:46:38.169 6603 DEBUG keystone.common.wsgi [-] arg_dict: {} __call__ /usr/lib/python2.7/site-packages/keystone/common/wsgi.py:181
2014-10-27 04:46:38.170 6603 ERROR keystone.common.wsgi [-] object of type 'NoneType' has no len()
2014-10-27 04:46:38.170 6603 TRACE keystone.common.wsgi Traceback (most recent call last):
2014-10-27 04:46:38.170 6603 TRACE keystone.common.wsgi   File "/usr/lib/python2.7/site-packages/keystone/common/wsgi.py", line 212, in __call__
2014-10-27 04:46:38.170 6603 TRACE keystone.common.wsgi     result = method(context, **params)
2014-10-27 04:46:38.170 6603 TRACE keystone.common.wsgi   File "/usr/lib/python2.7/site-packages/keystone/token/controllers.py", line 98, in authenticate
2014-10-27 04:46:38.170 6603 TRACE keystone.common.wsgi     context, auth)
2014-10-27 04:46:38.170 6603 TRACE keystone.common.wsgi   File "/usr/lib/python2.7/site-packages/keystone/token/controllers.py", line 260, in _authenticate_local
2014-10-27 04:46:38.170 6603 TRACE keystone.common.wsgi     if len(username) > CONF.max_param_size:
2014-10-27 04:46:38.170 6603 TRACE keystone.common.wsgi TypeError: object of type 'NoneType' has no len()
2014-10-27 04:46:38.170 6603 TRACE keystone.common.wsgi
2014-10-27 04:46:38.173 6603 INFO eventlet.wsgi.server [-] 127.0.0.1 - - [27/Oct/2014 04:46:38] "POST /v2.0/tokens HTTP/1.1" 400 239 0.006413
2014-10-27 04:46:38.300 6603 WARNING keystone.middleware.core [-] RBAC: Invalid token
2014-10-27 04:46:38.300 6603 WARNING keystone.common.wsgi [-] The request you have made requires authentication.
2014-10-27 04:46:38.301 6603 INFO eventlet.wsgi.server [-] 127.0.0.1 - - [27/Oct/2014 04:46:38] "POST /v3/auth/tokens HTTP/1.1" 401 309 0.004014
2014-10-27 04:46:38.387 6603 WARNING keystone.middleware.core [-] RBAC: Invalid token
2014-10-27 04:46:38.387 6603 WARNING keystone.common.wsgi [-] The request you have made requires authentication.
2014-10-27 04:46:38.389 6603 INFO eventlet.wsgi.server [-] 127.0.0.1 - - [27/Oct/2014 04:46:38] "POST /v3/auth/tokens HTTP/1.1" 401 309 0.006582
2014-10-27 04:46:39.922 6603 DEBUG keystone.middleware.core [-] Auth token not in the request header. Will not build auth context. process_request /usr/lib/python2.7/site-packages/keystone/middleware/core.py:271
2014-10-27 04:46:39.926 6603 DEBUG keystone.common.wsgi [-] arg_dict: {} __call__ /usr/lib/python2.7/site-packages/keystone/common/wsgi.py:181

Can someone help me to understand why this is happening? Why ... (more)