Ask Your Question

unitiger's profile - activity

2015-10-20 03:41:27 -0500 received badge  Nice Question (source)
2015-07-31 05:32:15 -0500 received badge  Enthusiast
2015-07-30 22:31:50 -0500 received badge  Famous Question (source)
2015-07-30 16:47:32 -0500 commented answer Neutron router can't reach external network - Kilo

Hi Kiran, thanks for your help, I added more info per your analysis, please help review again, thanks!

2015-07-29 19:06:12 -0500 received badge  Notable Question (source)
2015-07-29 17:55:55 -0500 commented answer Neutron router can't reach external network - Kilo

Hi Rahul, I did some more testing based on your reply, please see the adding end to my original questions. Thanks! --Tiger

2015-07-29 17:55:05 -0500 received badge  Editor (source)
2015-07-29 08:12:39 -0500 received badge  Student (source)
2015-07-29 06:57:27 -0500 received badge  Popular Question (source)
2015-07-28 17:16:39 -0500 asked a question Neutron router can't reach external network - Kilo

Hi guys, it's not my first time to face with this issue - I had tried Juno before and now Kilo. I installed multi-node (3 nodes for controller, network and compute) openstack environment per Kilo installation instruction on my Mac via virtualbox. My Mac connected to internet via wifi and virtualbox's NAT network is 10.0.3.0/24, with DNS server assigned by company wifi network.

I've set up the neutron network according to the instruction, here is the network interface configuration on network node:

# The primary network interface
auto eth2
iface eth2 inet manual
#iface eth2 inet dhcp
up ifconfig $IFACE 0.0.0.0 up
up ip link set $IFACE promisc on
down ip link set $IFACE promisc off
down ifconfig $IFACE down

# The openvswitch network interface
auto br-ex
iface br-ex inet dhcp

eth2 is the external NIC of network node connecting to the NAT network of virtualbox. All 3 nodes have one NIC connected to this network (10.0.3.0/24), controller is 10.0.3.16, network 10.0.3.12 and compute 10.0.3.11. The private network (demo-subnet) I defined is 172.16.1.0/24, so the external gateway IP of demo-router is 10.0.3.101, the private gateway IP is 172.16.1.1.

I have looked up many similar questions but could not find the right solution for my case, so if you have any thoughts on that, pls be kind to share with me, thanks in advance!

---Appended based on Rahul's reply----

Hi Rahul, first thanks for your kind reply. Actually I forgot 1 point of what you mentioned - enabling IP forwarding on network node. But after the changes and all nodes rebooted, the controller still could not ping router gateway IP (10.0.3.101). I tried to ping controller from the router and got following findings: Testing command on network node - ip netns exec qrouter-9bbc99ea-69ca-4a23-8fb7-c0b2ef7425dc ping 10.0.3.16 note: 10.0.3.16 is the IP of controller within ext-net

Controller (10.0.3.16) received the ARP request from 10.0.3.101 and unicast the ARP reply with its MAC address to the MAC address of neutron router external interface; The interface br-ex on network node didn't see the ARP reply from controller to neutron router; The router external interface didn't see the ARP reply either; Compute node saw the ARP request from 10.0.3.101 and did nothing (expected behaviour).

So the question is why the ARP reply packets didn't arrive at the interface br-ex (I also tried the physical interface eth2 of network node and didn't see the ARP reply). I guess it may be caused by no layer 2 trunk between the virtualbox vswitch and ovs-vswitch. Any other thoughts?

---Adding more info about my configuration and testing Jul/31/2015, thanks for Kiran's comments--- start with output of "ovs-vsctl show"

root@network:/etc/neutron/plugins# ovs-vsctl show
2e906efa-87a8-46f4-99e4-4d8f299db833 ...
(more)
2015-07-28 10:04:48 -0500 commented question demo-router not pingable from external network (a promiscuous mode problem)

Hi Jazzsir, I have the same issue with Juno and Kilo, not sure if you have resolved the problem or not, if yes, would you please share your solution? Many thanks in advance!

2015-07-28 10:04:48 -0500 commented answer neutron router gateway can't be ping through except on neutron network node or nova instance

I have the same issue as your first try, and I also modified the l3_agent.ini file as your workaround, but seemed not working for me. Now only network node can ping the VM floating IP and neutron router gateway , the controller/compute node could not ping via the public IP. Any thoughts, Thanks!

2014-09-26 07:04:35 -0500 commented answer Problems with neutron-rootwrap

Hi Roy, I have the same issue, but I'm using the latest Ubuntu 14.04 desktop 64bit, network node still had the problem to locate the right rootwrap.cmd. Any idea?

Thanks, Tiger

2014-09-25 08:33:53 -0500 answered a question How can I fix neutron-rootwrap error "No module named rootwrap.cmd" ?

Hi, have you figured out the solution for the neutron-rootwrap issue you encountered? I have the same issue when trying to install openstack on Ubuntu per the installation guide from http://openstack.org . Thanks!