Ask Your Question

Thomas Chacko's profile - activity

2016-08-06 20:28:48 -0500 received badge  Good Question (source)
2015-01-28 03:27:28 -0500 received badge  Nice Question (source)
2014-12-04 22:15:10 -0500 commented answer OpenStack Juno using RDO fails installation: AMQP server closed the connection

Me too - this was a workaround solution. The new RDO packstack script for Juno resolved this bug with AMQP and Rabbit MQ start-up issue among others. I checked it out and it works fine.

2014-11-15 09:29:36 -0500 received badge  Taxonomist
2014-09-30 06:33:39 -0500 commented answer OpenStack Juno using RDO fails installation: AMQP server closed the connection

On system restarts, the neutron server cannot connect to the MQ and Sql . Require manual service restart for it to work. existing bug ? https://bugzilla.redhat.com/show_bug....

2014-09-29 22:24:57 -0500 received badge  Scholar (source)
2014-09-29 13:44:17 -0500 received badge  Teacher (source)
2014-09-29 13:44:17 -0500 received badge  Self-Learner (source)
2014-09-29 13:06:10 -0500 answered a question OpenStack Juno using RDO fails installation: AMQP server closed the connection

Fixed using a workaround. Here is the root cause of this issue. The packstack installer, puppet scripts is recreating the rabbitmq config file (/etc/rabbitmq/rabbitmq.config )as :

    [
      {rabbit, [
        {default_user, <<"guest">>},
        {default_pass, <<"guest">>}
      ]},
      {kernel, [
      ]}
    ].

% EOF

The rabbitmq 'guest' account is used in the all-in-one packstack setup. But, by default, the MQ 'guest' user is prohibited from connecting to the broker remotely. ( see : www.rabbitmq.com/access-control.html ). The workaround is to undo and reset this config file (on-the-go) while the packstack installer script is running.

$ packstack --allinone --provision-all-in-one-ovs-bridge=n --use-epel=y
...
...
(wait till the AMQP messaging pp script is run and and the RabbitMQ server service is started . 

// Then on another term window, manually stop the MQ service,
$  sudo service rabbitmq-server stop

//  overwrite the /etc/rabbitmq/rabbitmq.config file with the below config :
[{rabbit, [{loopback_users, []}]}].
% EOF

// and restart the service 
$  sudo service rabbitmq-server start

This set the loopback_users configuration item to [] and allows remote connection to the guest account. The nova compute service then should be able to use the guest account to connect to the MQ, configure and start itself. The rest of the installation goes fine -- if the RH/CentOS 7 EPEL repo is installed and indicated to the installer using the flag ( --use-epel=y ) or answer-file option.

The permanent resolution should be to fix the RDO packstack installer script to appropriately modify the MQ config file. My Openstack Juno all-in-one install is working fine now..further neutron configuration and testing when possible.

2014-09-29 07:22:43 -0500 received badge  Famous Question (source)
2014-09-28 08:20:36 -0500 commented question OpenStack Juno using RDO fails installation: AMQP server closed the connection

=ERROR REPORT==== 28-Sep-2014::11:39:35 === closing AMQP connection <0.664.0> (192.168.0.20:37420 -> 192.168.0.20:5672): {handshake_error,starting,0, {amqp_error,access_refused, "AMQPLAIN login refused: user 'guest' can only connect via localhost",

2014-09-28 00:52:24 -0500 received badge  Enthusiast
2014-09-26 19:12:15 -0500 received badge  Notable Question (source)
2014-09-26 14:56:53 -0500 received badge  Student (source)
2014-09-25 07:58:29 -0500 received badge  Popular Question (source)
2014-09-24 08:05:52 -0500 received badge  Editor (source)
2014-09-24 08:01:59 -0500 asked a question OpenStack Juno using RDO fails installation: AMQP server closed the connection

Ventured trying out Openstack Juno install using the info on http://docs.openstack.org/trunk/insta...

Used Centos x64 v7.0 minimal server , EPEL repo installed and set in packstack answer file ( CONFIG_USE_EPEL=y ), SELinux on permissive mode and manually installing basic required packages like puppet, mariadb-galeria server and whatever it complained .. Now stuck on the nova install stage ..with an error message indicating nova-compute.service cannot start.. Any ideas ?

-- packstack error log --

192.168.0.20_api_nova.pp:                            [ DONE ]       
Applying 192.168.0.20_nova.pp
192.168.0.20_nova.pp:                             [ ERROR ]     
Applying Puppet manifests                         [ ERROR ]

ERROR : Error appeared during Puppet run: 192.168.0.20_nova.pp
Error: Could not start Service[nova-compute]: Execution of '/usr/bin/systemctl start openstack-nova-compute' returned 1: Job for openstack-nova-compute.service failed. See 'systemctl status openstack-nova-compute.service' and 'journalctl -xn' for details.

--- tail nova-consoleauth.log -------------

2014-09-24 18:23:44.526 1662 ERROR oslo.messaging._drivers.impl_rabbit [req-17f065b9-a532-4c8e-8322-3ca776bb9238 ] AMQP server 192.168.0.20:5672 closed the connection. Check login credentials: Socket closed

---- tail nova-cert.log -------------

 2014-09-24 18:24:52.828 1665 ERROR oslo.messaging._drivers.impl_rabbit [req-81a513b8-6501-4e08-bfc2-314a4a9ab98a ] AMQP server 192.168.0.20:5672 closed the connection. Check login credentials: Socket closed

Other nova logs are all INFO msg..some issue with the RabbitMQ service login api credentials..not able to figure out..

I rechecked the nova-compute logs and they have the same error message :

2014-09-24 18:23:32.060 9594 ERROR oslo.messaging._drivers.impl_rabbit [req-1b152ce0-6298-487a-b6cc-149024692b34 ] AMQP server 192.168.0.20:5672 closed the connection. Check login