Ask Your Question

linuxmonk's profile - activity

2013-11-26 05:24:04 -0600 received badge  Famous Question (source)
2013-11-13 05:22:24 -0600 received badge  Notable Question (source)
2013-11-10 22:54:02 -0600 received badge  Enthusiast
2013-11-09 07:35:09 -0600 received badge  Popular Question (source)
2013-11-06 11:29:04 -0600 asked a question neutron network dnsmasq not reachable behind bridge

Am trying to setup an Neutron network environment that would allow my client machines be able to PXE boot using neutron DHCP PXE support.

  • I setup neutron with DHCP and PXE + TFTP options in my controller node.
  • I created a neutron network and a subnet.
  • I see that neutron created the network and the DNSMASQ is running under a namespace on a TAP interface under the OVS integration bridge.
  • To test this I run a dhclient from one of my client VMs and the client machine/VM don't get an IP.

However if I manually run a dnsmasq directly on my controller's NIC outside the integration bridge my clients can get an IP. The moment I attach the interface to a bridge my client machines can no longer communicate with the dnsmasq running on the interface. Can someone point out what am I missing ?

I also tried the following --

  • Assigning the integration bridge (br-int) a static IP in the subnet range as TAP interface.
  • Adding default gateway for bridge IP.
  • Adding default gateway for interface IP.
  • Disabling IP tables fully.

None of these seem to help.

2013-07-12 06:17:35 -0600 received badge  Famous Question (source)
2013-06-20 12:55:07 -0600 received badge  Notable Question (source)
2013-06-17 10:05:24 -0600 received badge  Popular Question (source)
2013-06-15 05:19:57 -0600 commented answer instance not starting with libvirt-type set to qemu

Thanks that was it. Thank you. I had to create a new flavor as I needed disk space. Now the VM is running.

2013-06-15 05:18:45 -0600 received badge  Scholar (source)
2013-06-14 12:59:47 -0600 asked a question instance not starting with libvirt-type set to qemu

Hello,

I've setup OpenStack Essex + MySQL on my Ubuntu 12.04 Server running on a VirtualBox VM. I've published an UEC image from (http://uec-images.ubuntu.com/releases/precise/release/ubuntu-12.04-server-cloudimg-i386.tar.gz) using cloud-publish-tarball. The publish was successful. I've configured nova to use qemu (nova-compute.conf --libvirt_type=qemu) to launch instances.

When I try to launch a VM/instance from my host using 'nova boot...' my instance fails to launch. The nova-compute.log has entries -

... 2013-06-14 13:27:45 TRACE nova.compute.manager [instance: a8acc7f4-e060-48fa-9d83-452c5df0ab69] File "/usr/lib/python2.7/dist-packages/nova/virt/libvirt/connection.py", line 1642, in _create_new_domain 2013-06-14 13:27:45 TRACE nova.compute.manager [instance: a8acc7f4-e060-48fa-9d83-452c5df0ab69] domain.createWithFlags(launch_flags) 2013-06-14 13:27:45 TRACE nova.compute.manager [instance: a8acc7f4-e060-48fa-9d83-452c5df0ab69] File "/usr/lib/python2.7/dist-packages/libvirt.py", line 581, in createWithFlags 2013-06-14 13:27:45 TRACE nova.compute.manager [instance: a8acc7f4-e060-48fa-9d83-452c5df0ab69] if ret == -1: raise libvirtError ('virDomainCreateWithFlags() failed', dom=self) 2013-06-14 13:27:45 TRACE nova.compute.manager [instance: a8acc7f4-e060-48fa-9d83-452c5df0ab69] libvirtError: internal error Process exited while reading console log output: char device redirected to /dev/pts/9 2013-06-14 13:27:45 TRACE nova.compute.manager [instance: a8acc7f4-e060-48fa-9d83-452c5df0ab69] qemu: at most 2047 MB RAM can be simulated 2013-06-14 13:27:45 TRACE nova.compute.manager [instance: a8acc7f4-e060-48fa-9d83-452c5df0ab69] ...

Any pointers to why this could be happening ?


Sai