Ask Your Question

cnkcb's profile - activity

2016-11-05 12:00:34 -0500 received badge  Nice Answer (source)
2015-05-28 07:12:25 -0500 received badge  Famous Question (source)
2015-05-28 07:12:25 -0500 received badge  Notable Question (source)
2014-10-16 06:48:37 -0500 received badge  Famous Question (source)
2014-10-15 08:58:37 -0500 received badge  Notable Question (source)
2014-10-15 08:45:33 -0500 commented question How to update an image using glance?

These other two indicate images are immutable.

2014-10-15 08:43:58 -0500 commented question How to update an image using glance?

Found a similar, but not identical question and it has no real answer.

2014-10-14 21:28:13 -0500 received badge  Popular Question (source)
2014-10-14 14:06:17 -0500 asked a question How to update an image using glance?

I have a rather old image of precise, and would like to update it from https://cloud-images.ubuntu.com/ so dist-upgrade on a new VM won't be so painful. I downloaded the image, and tried to update it using this command line;

glance image-update --file precise-server-cloudimg-amd64-disk1.img precise-server-cloudimg-amd64

The command completes immediately and dumps the image details, but neither the size or checksum have changed. Also, an immediate;

glance image-list

shows the Status as 'active'. So it seems the image-update really doesn't do what I'm expecting. I found a bug in launchpad that describes this as well.

I'm basing this on the docs, which say;

--file FILE            Local file that contains the disk image to be uploaded during the update.

I've checked /var/log/glance/api.log and there is no information there. The file is empty, and does not change when I run this command.

Am I doing something wrong, or is there a workaround?

2014-10-14 13:33:08 -0500 received badge  Popular Question (source)
2014-09-17 02:49:08 -0500 received badge  Famous Question (source)
2014-09-02 08:57:30 -0500 received badge  Scholar (source)
2014-08-31 03:47:32 -0500 received badge  Student (source)
2014-08-30 00:54:57 -0500 received badge  Necromancer (source)
2014-08-30 00:54:57 -0500 received badge  Teacher (source)
2014-08-29 15:12:06 -0500 received badge  Notable Question (source)
2014-08-29 12:11:24 -0500 answered a question igmp queries are blocked somewhere between bridge and tap?

Add a firewall rule to allow IGMP protocol;

In Havana/Horizon Access & Security, edit default rules and add a new rule;

  • Rule: Other Protocol
  • Direction: Ingress
  • IP Protocol: 2
  • Remote: CIDR
  • CIDR: 0.0.0.0/0
2014-08-29 12:09:40 -0500 answered a question IGMP snooping/query support in Openvswitch

Add firewall rule to allow IGMP protocol;

In Havana/Horizon Access & Security, edit default rules and add a new rule;

  • Rule: Other Protocol
  • Direction: Ingress
  • IP Protocol: 2
  • Remote: CIDR
  • CIDR: 0.0.0.0/0
2014-08-29 12:06:23 -0500 received badge  Editor (source)
2014-08-29 12:05:36 -0500 answered a question VMs on subnet suffer IGMP timeouts.

Thanks to @T-u-l for pointing me in the right direction. I figured out the firewall rule I needed to add.

In Havana/Horizon Access & Security, edit defauld rules and add a new rule;

  • Rule: Other Protocol
  • Direction: Ingress
  • IP Protocol: 2
  • Remote: CIDR
  • CIDR: 0.0.0.0/0
2014-08-29 11:33:36 -0500 commented question VMs on subnet suffer IGMP timeouts.

Duplicate: https://ask.openstack.org/en/question/26599/igmp-queries-are-blocked-somewhere-between-bridge-and-tap/ (Duplicate) - no answer...

2014-08-29 11:12:33 -0500 commented question IGMP snooping/query support in Openvswitch

@tcheung - any solution for this? I'm looking for the same answer.

2014-08-29 11:10:55 -0500 commented question VMs on subnet suffer IGMP timeouts.

Duplicate: https://ask.openstack.org/en/question/8466/igmp-snoopingquery-support-in-openvswitch/ (Duplicate) - though now answer there either.

2014-08-29 11:08:09 -0500 commented question VMs on subnet suffer IGMP timeouts.

Both VMs get the same default security group settings - so I don't know why one would work OK, and the other would block IGMP unless that is a feature of the neutron/vswitch software. What are the correct security group settings to allow IGMP? There's no selection for "All IGMP".

2014-08-29 06:36:40 -0500 received badge  Popular Question (source)
2014-08-28 17:04:42 -0500 asked a question VMs on subnet suffer IGMP timeouts.

Havana + neutron + vswitch:

Via Horizon dashboard, I created a network with a 10.16.1/24 subnet, disabled gateway, enabled dhcp with range 10.16.1.100,10.16.1.120. Then I launched 2 trusty instances, each with two NICS; eth0 for my regular public interface, and eth1 for the 10.16.1/24 subnet. I installed mgen and configured complementary mgen scripts to have the two exchange 1 multicast message per second for 360 seconds. One VM stops receiving packets after 260 seconds (the IGMP Snooping Group Timeout?). The other VM keeps receiving messages for the entire period.

Using wireshark, I captured the IGMP traffic at each VM (not enough points to attach images, yet). The successful VM sees and responds to IGMP Membership queries. The failing VM never sees those queries, hence the timeout, hence the missing data.

I'm guessing this is a firewall issue - keeping the failing VM from seeing the queries. If so, how can I open the firewall for all VMs, so I don't have to do this for each affected VM (many) of each affected tenant (also many)?

2014-08-28 16:37:43 -0500 received badge  Supporter (source)