Ask Your Question

Satyanarayana Patibandla's profile - activity

2018-08-07 14:45:07 -0500 received badge  Famous Question (source)
2017-10-18 08:37:49 -0500 received badge  Famous Question (source)
2017-10-16 04:30:23 -0500 received badge  Notable Question (source)
2017-08-22 00:32:27 -0500 received badge  Famous Question (source)
2017-06-04 09:19:19 -0500 received badge  Notable Question (source)
2017-06-04 09:19:19 -0500 received badge  Famous Question (source)
2017-05-17 06:37:05 -0500 received badge  Notable Question (source)
2017-03-15 03:32:41 -0500 received badge  Popular Question (source)
2017-02-27 14:18:34 -0500 received badge  Popular Question (source)
2017-02-24 06:23:52 -0500 answered a question neutron.agent.metadata.agent [-] Failed reporting state!

Are you able to fix this issue. I am also facing same issue. In my case the same error is appeared after running few rally tasks.

2016-12-30 12:12:59 -0500 asked a question Cinder volume rabbitmq connection is getting terminated

I am using newton openstack release code. Initially everything works fine. After few minutes the cinder volume and rabbitmq connection getting terminated with below error.

=ERROR REPORT==== 27-Dec-2016::19:36:05 ===
closing AMQP connection <0.11343.0> (x.x.x.x:39353 -> x.x.x.x:5672 - cinder-volume:63:db4b0016-15e2-486d-831f-2bce7e396a1b):
missed heartbeats from client, timeout: 60s
2016-12-30 02:23:08 -0500 asked a question how to analyze cinder volume service CPU utilizations

In my environment cinder volume service CPU utilization is more than 100%. i am using ceph as backend for cinder. I would like to know where exactly high cpu used in cinder volume. Is there any tool which can help me. And also cinder volume open TCP connections are keep on increasing at high rate with the time. Is there any way to see where exactly these connections are being created.

2016-10-27 02:38:51 -0500 received badge  Popular Question (source)
2016-10-19 12:57:24 -0500 asked a question In large scale deployment how public,overlay and tenant network maps to neutron node in both L3 HA and DVR scenarios

I am trying to understand how public,overlay and tenant network maps to neutron node in both L3 HA and DVR scenarios for mid scale deployment or large scale deployment.

2016-10-19 12:52:30 -0500 received badge  Notable Question (source)
2016-10-18 10:30:41 -0500 received badge  Popular Question (source)
2016-10-18 01:29:21 -0500 asked a question Openstack deployment using DVR

We are planning for Openstack deployment using DVR instead of L3 HA. It seems majority of large scale deployments or either using nova-network or neutron L3 HA. Does anyone is able to successfully deploy mid scale deployment using DVR. Please let me know if anybody has encountered any major issue during deployment or operations using DVR in production.

2016-08-02 14:34:57 -0500 received badge  Famous Question (source)
2016-07-08 15:16:12 -0500 received badge  Popular Question (source)
2016-07-08 15:16:12 -0500 received badge  Famous Question (source)
2016-07-08 15:16:12 -0500 received badge  Notable Question (source)
2016-04-18 15:26:20 -0500 asked a question In openstack kilo the instance network speed with external network is slow

we are using openstack kilo in our openstack cloud environment. When we try to download something we have observed that the network speed with external network is slow. We are getting network speed in kbps where as our network speed is in MBPS.

Before setting "ethtool --offload eth0 gro off" and "ethtool -K eth0 tso off" on VM eth0 interface and also on external network interface the speed was around 50 kbps. After setting the above values speed increased to 250 kbps but still it is far less than our network speed. We are using tGRE tenant network and The MTU size on vm interface is 1454. Can somebody help me on this issue.

2016-02-29 08:19:55 -0500 answered a question openstack HA: sometimes getting unable to establish connection error

There was some issue with my mysql and keystone set up. I have reinstalled the entire set up then it started working fine.

2016-02-28 02:19:59 -0500 received badge  Famous Question (source)
2016-02-27 23:16:58 -0500 received badge  Popular Question (source)
2016-02-27 23:16:58 -0500 received badge  Notable Question (source)
2016-02-27 23:16:58 -0500 received badge  Famous Question (source)
2016-01-29 10:45:48 -0500 received badge  Notable Question (source)
2016-01-19 05:37:40 -0500 received badge  Notable Question (source)
2016-01-19 03:33:03 -0500 received badge  Popular Question (source)
2016-01-18 12:36:48 -0500 received badge  Editor (source)
2016-01-18 12:34:59 -0500 asked a question openstack HA: sometimes getting unable to establish connection error

In My 2 controller openstack HA setup ( using a galera cluster with two mysql nodes) sometimes I am getting the below errors when I try to create heat stack (which is used to create a instance with floating IP).

1) ConnectionRefused: Unable to establish connection to http://controller-vip:9696/v2.0/ports...

I verified neutron port 9696 on both controller node they are in listening state.

2) keystoneauth1.exceptions.connection.ConnectFailure: Unable to establish connection to http://controller-vip:8004/v1/ca1d107...

I verified heat port 8004 on both controller node they are in listening state.

Every time I am not getting these errors. Only sometimes I am getting this error. When I looked at syslog I have observed below warnings. Not sure whether these are related to above error.

Warning] Aborted connection 102541 to db: 'keystone' user: 'keystone' host: 'controller01' (Unknown error)
[Warning] Aborted connection 103782 to db: 'nova' user: 'nova' host: 'controller01' (Unknown error)

Could you please help me in fixing this issue.

Thanks, Satya.P

2016-01-17 10:44:10 -0500 asked a question MariaDB Galera issue: (OperationalError) (1047, 'WSREP has not yet prepared node for application use')

We are trying to set up high availability with two controller nodes. For this a MariaDB Galera cluster is created with two controller nodes and status of cluster is Primary. All the openstack commands are working fine. But sometimes we can see the following error in log files. Error: (OperationalError) (1047, 'WSREP has not yet prepared node for application use') due to this some times heat stack creation is failing.

We are not able to debug the issue as it is not happening always. Could you please let us know if you have come across this kind of error.

The main wsrep parameter values on both the controller nodes are given below. The values are same on both the nodes,

MariaDB [(none)]> SHOW GLOBAL STATUS LIKE 'wsrep_cluster_state_uuid';
+--------------------------+--------------------------------------+
| Variable_name            | Value                                |
+--------------------------+--------------------------------------+
| wsrep_cluster_state_uuid | 6ded79f5-9e42-11e5-9c69-03398fb5134f |
+--------------------------+--------------------------------------+
1 row in set (0.01 sec)

MariaDB [(none)]> SHOW GLOBAL STATUS LIKE 'wsrep_cluster_conf_id';
+-----------------------+-------+
| Variable_name         | Value |
+-----------------------+-------+
| wsrep_cluster_conf_id | 89    |
+-----------------------+-------+
1 row in set (0.00 sec)

MariaDB [(none)]> SHOW GLOBAL STATUS LIKE 'wsrep_cluster_size';
+--------------------+-------+
| Variable_name      | Value |
+--------------------+-------+
| wsrep_cluster_size | 2     |
+--------------------+-------+
1 row in set (0.00 sec)

MariaDB [(none)]> SHOW GLOBAL STATUS LIKE 'wsrep_cluster_status';
+----------------------+---------+
| Variable_name        | Value   |
+----------------------+---------+
| wsrep_cluster_status | Primary |
+----------------------+---------+
1 row in set (0.00 sec)

MariaDB [(none)]> SHOW GLOBAL STATUS LIKE 'wsrep_ready';
+---------------+-------+
| Variable_name | Value |
+---------------+-------+
| wsrep_ready   | ON    |
+---------------+-------+
1 row in set (0.00 sec)

MariaDB [(none)]> SHOW GLOBAL STATUS LIKE 'wsrep_connected';
+-----------------+-------+
| Variable_name   | Value |
+-----------------+-------+
| wsrep_connected | ON    |
+-----------------+-------+
1 row in set (0.00 sec)

MariaDB [(none)]> SHOW GLOBAL STATUS LIKE 'wsrep_local_state_comment';
+---------------------------+--------+
| Variable_name             | Value  |
+---------------------------+--------+
| wsrep_local_state_comment | Synced |
+---------------------------+--------+

Thanks, Satya.P

2016-01-12 00:00:50 -0500 received badge  Popular Question (source)
2016-01-10 11:28:28 -0500 asked a question openstack kilo keystone active directory integration

I am trying to integrate openstack kilo with active directory. if I give a

specific OU path ( ex: ou=Users,DC=local, DC=in ) as my user_tree_dn

then the integration is working fine and I am able to fetch all the user information. If I give

entire domain ( ex: DC=local, DC=in ) as my user_tree_dn

then I am getting an error and i am not able to fetch all the user list. in the specific OU path there are 45 users and in my domain path there are many organization units and total user list is around 900. The below error I am getting.

openstack user list

Error: An unexpected error prevented the server from fulfilling your request: {'info': 'Referral:\nldap://local.in/CN=Configuration,DC=local,DC=in', 'desc': "Can't contact LDAP server"}

Could you please help me in fixing this issue.

2015-12-30 03:25:52 -0500 answered a question Can't contact LDAP server with keystone ldaps configuration

I had the same issue. I was using url = ldaps://OUR_LDAP_SERVER_IP:636, The issue got resolved when i used url = ldap://OUR_LDAP_SERVER_IP .

2015-11-12 06:54:43 -0500 commented answer Openstack high availability pacemaker or keepalived?

Hi Capsali, Thanks for your suggestions, After a detailed analysis we have decided to go with keepalived because of it's simple and easy to use functionality when compare to pacemaker.

2015-11-12 00:19:10 -0500 received badge  Enthusiast
2015-11-11 20:08:28 -0500 received badge  Famous Question (source)
2015-11-11 07:32:26 -0500 commented answer Openstack high availability pacemaker or keepalived?

Could you please let me know which version (juno or kilo) of openstack you are using in production?

2015-11-10 13:11:24 -0500 answered a question Openstack high availability pacemaker or keepalived?

Thanks for your suggestions. I will evaluate all the suggestions mentioned above. If we use DVR, I came to know that there are problems with the use of VLANs, IPv6, Floating IPs, high north-south traffic scenarios and large numbers of compute nodes. Could you please let me know whether you have used DVR in production? Did you face any issues mentioned above.

2015-11-10 08:00:23 -0500 received badge  Notable Question (source)
2015-11-09 23:04:10 -0500 received badge  Popular Question (source)
2015-11-09 09:59:42 -0500 asked a question Openstack high availability pacemaker or keepalived?

Hi,

I am planning to set up high availability for controller node, for that I am using haproxy. There are 2 options available. Either I can use haproxy/pacemaker/corosync or haproxy/keepalived. Could you please let me know which is the best option for production deployment.

2015-02-18 07:07:38 -0500 received badge  Notable Question (source)
2014-08-13 00:46:17 -0500 received badge  Popular Question (source)
2014-08-10 16:51:04 -0500 received badge  Notable Question (source)
2014-08-10 07:54:24 -0500 asked a question how to add a third party plugin ( which is written using ruby) to horizon

I know the procedure to add django based apps to Horizon. But my requirement is to add ruby based plugin to horizon. if anyone has done this could you please provide me the procedure?