Ask Your Question

JohnSmith's profile - activity

2014-08-16 01:39:54 -0500 commented question Network connectivity issue

Also, it only happens if I run 'packstack --allinone --provision-all-in-one-ovs-bridge=n' and manually edit the ifcfg files, and not if i omit the '--provision-all-in-one-ovs-bridge=n'' and just run 'packstack --allinone'. I guess thats because when you run packstack that way, it doenst attempt to modify your existing network ?

When I run packstack like that, I get this :

# ovs-vsctl show
bb042af4-1628-404e-8f5f-c8249a31a5a2
    Bridge br-int
        fail_mode: secure
        Port patch-tun
            Interface patch-tun
                type: patch
                options: {peer=patch-int}
        Port "qr-f2f2be7d-2e"
            tag: 1
            Interface "qr-f2f2be7d-2e"
                type: internal
        Port br-int
            Interface br-int
                type: internal
    Bridge br-tun
        Port br-tun
            Interface br-tun
                type: internal
        Port patch-int
            Interface patch-int
                type: patch
                options: {peer=patch-tun}
    Bridge br-ex
        Port br-ex
            Interface br-ex
                type: internal
        Port "qg-47249854-44"
            Interface "qg-47249854-44"
                type: internal
    ovs_version: "1.11.0"

# neutron net-list
+--------------------------------------+---------+------------------------------------------------------+
| id                                   | name    | subnets                                              |
+--------------------------------------+---------+------------------------------------------------------+
| b614a425-42fd-4623-aed6-5084dcf9b0a8 | private | 29319c25-d5bf-4a73-a53e-a0a614509833 10.0.0.0/24     |
| 52a4c4bf-31fa-42c6-ba04-2cc4711ff0e3 | public  | 34ffc759-4d68-44fa-96ce-6165d9e52f31 172.24.4.224/28 |
+--------------------------------------+---------+------------------------------------------------------+
2014-08-14 06:54:07 -0500 commented question Network connectivity issue

Yes 192.168.178.1 is functioning as the DNS server for the network.

2014-08-14 06:52:27 -0500 received badge  Famous Question (source)
2014-08-14 02:07:48 -0500 received badge  Student (source)
2014-08-14 01:14:25 -0500 received badge  Notable Question (source)
2014-08-13 15:37:32 -0500 received badge  Popular Question (source)
2014-08-13 12:01:25 -0500 received badge  Organizer (source)
2014-08-13 11:56:37 -0500 asked a question Network connectivity issue

Hi,

Im following this guide 1.) to set up Red Hat RDO packstack openstack with an existing network. It says to use the current ip of your eth0 interface for the br-ex device instead and remove it from eth0. But when I do this, I get weird connectivity issues where even a single ping to the default gateway fails 95% of the time, but not always: some pings come through alright. A simple network restart or reboot does not change anything.

The problem (temporarily) goes away (but returns later) when I use a previously unused ip in the same range for the br-ex device, but I wonder what the issue could be ? Could it be as simple as an arp cache entry somewhere (my internet cable modem ?) or something ?

Ive added the contents of ifcfg-br-ex and ifcfg-eth0, and the output of 'ovs-vsctl show'

1.) http://openstack.redhat.com/Neutron_with_existing_external_network (http://openstack.redhat.com/Neutron_w...)

# cat /etc/sysconfig/network-scripts/ifcfg-br-ex
DEVICE=br-ex
DEVICETYPE=ovs
TYPE=OVSBridge
BOOTPROTO=none
IPADDR=192.168.178.27 # Old eth0 IP since we want the network restart to not kill the connection, otherwise pick something outside your dhcp range
NETMASK=255.255.255.0  # your netmask
GATEWAY=192.168.178.1  # your gateway
DNS1=192.168.178.1     # your nameserver
ONBOOT=yes

# cat /etc/sysconfig/network-scripts/ifcfg-eth0
DEVICE=eth0
HWADDR=00:0C:29:5E:C4:5D
TYPE=OVSPort
DEVICETYPE=ovs
OVS_BRIDGE=br-ex
ONBOOT=yes

# ovs-vsctl show
c418fb29-4fb4-45ae-a3b4-ea86ff356135
    Bridge br-ex
        Port br-ex
            Interface br-ex
                type: internal
        Port "eth0"
            Interface "eth0"
    Bridge br-int
        Port br-int
            Interface br-int
                type: internal
        Port patch-tun
            Interface patch-tun
                type: patch
                options: {peer=patch-int}
    ovs_version: "1.11.0"
2014-08-11 10:02:57 -0500 commented answer Red Hat RDO: packstack --allinone: no 'mongodb-server' package

As a temporary workaround until this get fixed properly, you can work around the issue by not installing ceilometer. Run 'packstack --os-ceilometer-install=n', or if you are using an answers file, you can set CONFIG_CEILOMETER_INSTALL=n.

2014-08-11 09:34:22 -0500 commented answer Red Hat RDO: packstack --allinone: no 'mongodb-server' package

Looks like that first bug report got closed with : 'CANTFIX' https://bugzilla.redhat.com/show_bug.cgi?id=1128488 (https://bugzilla.redhat.com/show_bug....)

2014-08-11 05:29:47 -0500 commented answer Red Hat RDO: packstack --allinone: no 'mongodb-server' package

According to that bugzilla bug report, it was deliberately removed from the EPEL 6 repository due to unfixed/unfixable security issues.

2014-08-10 22:29:21 -0500 received badge  Famous Question (source)
2014-08-10 10:01:01 -0500 received badge  Notable Question (source)
2014-08-10 08:33:54 -0500 commented question Red Hat RDO: packstack --allinone: no 'mongodb-server' package

Maybe somebody messed up the RDO repository ?

2014-08-10 08:21:08 -0500 received badge  Popular Question (source)
2014-08-10 08:18:41 -0500 commented question Red Hat RDO: packstack --allinone: no 'mongodb-server' package

Thanks. But that doesnt work either, and for the same reason: yum cant find the 'mongodb-server' package. Doesnt matter whether i try to 'yum list' or 'yum install' it.

2014-08-10 04:22:34 -0500 received badge  Editor (source)
2014-08-10 04:20:53 -0500 asked a question Red Hat RDO: packstack --allinone: no 'mongodb-server' package

Hi,

Im trying out 'packstack --allinone' on Centos 6.5, but am getting this error:

Error: Execution of '/usr/bin/yum -d 0 -e 0 -y list mongodb-server' returned 1: Error: No matching Packages to list

When going through the documentation on 'mongodb.org', it looks like you have to enable an extra repository, and then the package is named 'mongodb-org-server' and not 'mongodb-server'. (1.)

Is this a bug ?

Thank,

John Smith.

  1. http://docs.mongodb.org/manual/tutorial/install-mongodb-on-red-hat-centos-or-fedora-linux (http://docs.mongodb.org/manual/tutori...)
2014-08-05 04:22:42 -0500 received badge  Famous Question (source)
2014-08-05 01:02:47 -0500 commented answer Red Hat RDO: All-in-One DIY Config with exisiting network

Thanks. I guess thats pretty much what is described in the 'PackStack All-in-One DIY Configuration' guide. Guess the major difference is in that guide you run packstack with these parameters: "--provision-demo=n --provision-all-in-one-ovs-bridge=n", so in that case there is no demo network to delete, and you manually have to create the tenant. Ill try this, and see how far that gets me.

2014-08-05 00:55:02 -0500 received badge  Notable Question (source)
2014-08-04 23:50:47 -0500 received badge  Popular Question (source)