Ask Your Question

ivica's profile - activity

2015-07-09 03:44:11 -0500 received badge  Famous Question (source)
2015-07-06 05:24:22 -0500 received badge  Famous Question (source)
2015-07-06 05:24:22 -0500 received badge  Notable Question (source)
2015-03-17 02:19:50 -0500 received badge  Notable Question (source)
2015-03-11 05:46:43 -0500 received badge  Popular Question (source)
2015-03-11 05:43:42 -0500 received badge  Popular Question (source)
2015-03-10 10:47:21 -0500 received badge  Famous Question (source)
2015-03-10 10:47:21 -0500 received badge  Notable Question (source)
2015-03-10 10:45:17 -0500 asked a question instances can't ping outside

Hey all,

I'm aware that this question was asked many times but...bear with me please. My network configuration looks like this: http://imgur.com/fHAmbdc .

192.168.0.0/24 is my LAN network (my PC is connected to it) 10.0.0.0/24 is a subnet I created using Openstack dashboard.

Router1 has interface on 10.0.0.0/24 network active, while gateway interface is DOWN. Every service is up and running with no errors in logs.

My deployment consists of 3 servers following the official centos 7 install guide for juno: http://docs.openstack.org/juno/install-guide/install/yum/content/ (http://docs.openstack.org/juno/instal...)

This is OVS-VSCTL output

 ovs-vsctl show
158b1140-29eb-436e-9218-f31160be1c65
    Bridge br-int
        fail_mode: secure
        Port br-int
            Interface br-int
                type: internal
        Port "qr-4856ff41-2d"
            tag: 3
            Interface "qr-4856ff41-2d"
                type: internal
        Port "tap69ce898f-47"
            tag: 4095
            Interface "tap69ce898f-47"
                type: internal
        Port patch-tun
            Interface patch-tun
                type: patch
                options: {peer=patch-int}
        Port "qr-a3efb45d-b0"
            tag: 1
            Interface "qr-a3efb45d-b0"
                type: internal
        Port "tap6344f8e2-f7"
            tag: 3
            Interface "tap6344f8e2-f7"
                type: internal
        Port int-br-ex
            Interface int-br-ex
                type: patch
                options: {peer=phy-br-ex}
    Bridge br-ex
        Port phy-br-ex
            Interface phy-br-ex
                type: patch
                options: {peer=int-br-ex}
        Port "qg-bb37d248-47"
            Interface "qg-bb37d248-47"
                type: internal
        Port "eth2"
            Interface "eth2"
        Port br-ex
            Interface br-ex
                type: internal
        Port "qg-0eec4ee3-cf"
            Interface "qg-0eec4ee3-cf"
                type: internal
    Bridge br-tun
        Port br-tun
            Interface br-tun
                type: internal
        Port "gre-0a00011f"
            Interface "gre-0a00011f"
                type: gre
                options: {df_default="true", in_key=flow, local_ip="10.0.1.21", out_key=flow, remote_ip="10.0.1.31"}
        Port patch-int
            Interface patch-int
                type: patch
                options: {peer=patch-tun}
    ovs_version: "2.1.3"

ip route output

ip route
default via 192.168.0.1 dev eth0
10.0.1.0/24 dev eth1  proto kernel  scope link  src 10.0.1.21
192.168.0.0/24 dev eth0  proto kernel  scope link  src 192.168.0.215
192.168.0.0/24 dev br-ex  proto kernel  scope link  src 192.168.0.217

ifcfg-br-ex interface

DEVICE=br-ex
DEVICETYPE=ovs
TYPE=OVSBridge
BOOTPROTO=static
IPADDR=192.168.0.217
NETMASK=255.255.255.0
GATEWAY=192.168.0.1
DNS1=192.168.0.200
ONBOOT=yes

ifcfg-eth2 interface

DEVICE=eth2
HWADDR="00:15:5D:00:66:d3"
TYPE=OVSPort
DEVICETYPE=ovs
OVS_BRIDGE=br-ex
ONBOOT=yes
NAME=System eth2

Instances can ping each other but are unable to ping 192.168.0.1 which is the default gateway for ext-net. If you need any more info, please ask, I'll be happy to provide it.

2015-03-05 06:03:50 -0500 commented answer flavor resource not found 404

Memcached is running on controller, installed it on compute (even thou the manual doesn't mention that) with no luck - instance won't start.

2015-03-05 05:08:14 -0500 commented answer flavor resource not found 404

Thank you for replying. I'm unable to reset the instance because there is no instance running, it won't start at all. Also, m1.medium is just an example - instances won't start with any flavor (tried with m1.tiny and m1.small)

2015-03-05 03:57:52 -0500 asked a question flavor resource not found 404

Hey,

I'm setting up a test lab for personal use following the official [CentOS 7 install guide] ( http://docs.openstack.org/juno/install-guide/install/yum/content/ (http://docs.openstack.org/juno/instal...) )

When I try to run an instance as the demo user (sourced demo-openrc.sh) with this command

nova --debug boot --flavor m1.medium --image cirros-0.3.3-x86_64 --nic net-id=bfc92b52-8202-4333-9aac-401407dd4184 --security-group default --key-name demo-key my-instance

an error states:

ClientException: The server has either erred or is incapable of performing the requested operation. (HTTP 500) (Request-ID: req-b12665bb-e140-4ef7-b29f-3a0361977118

Network list:

neutron net-list
+--------------------------------------+----------+--------------------------------------------------+
| id                                   | name     | subnets                                          |
+--------------------------------------+----------+--------------------------------------------------+
| bfc92b52-8202-4333-9aac-401407dd4184 | demo-net | cea18f08-34e1-4a85-a896-055d056a8a05 10.0.0.0/24 |
| 028f2186-154c-4b77-89c6-617e2e9e9b30 | ext-net  | fd640912-258b-4b96-976c-5ead96ce7c14             |
+--------------------------------------+----------+--------------------------------------------------+

Keypair list:

nova keypair-list
+----------+-------------------------------------------------+
| Name     | Fingerprint                                     |
+----------+-------------------------------------------------+
| demo-key | 8e:f2:de:cf:55:e4:5c:03:f2:7b:bc:f6:ee:fe:d1:d2 |
+----------+-------------------------------------------------+

Flavor list

nova flavor-list
+--------------------------------------+-----------+-----------+------+-----------+------+-------+-------------+-----------+
| ID                                   | Name      | Memory_MB | Disk | Ephemeral | Swap | VCPUs | RXTX_Factor | Is_Public |
+--------------------------------------+-----------+-----------+------+-----------+------+-------+-------------+-----------+
| 2                                    | m1.small  | 2048      | 20   | 0         |      | 1     | 1.0         | True      |
| 23dccaa1-9d44-43e9-a09c-3f926e2b2b87 | m1.tiny   | 64        | 1    | 0         |      | 1     | 1.0         | True      |
| 3                                    | m1.medium | 4096      | 40   | 0         |      | 2     | 1.0         | True      |
| 4                                    | m1.large  | 8192      | 80   | 0         |      | 4     | 1.0         | True      |
| 5                                    | m1.xlarge | 16384     | 160  | 0         |      | 8     | 1.0         | True      |
+--------------------------------------+-----------+-----------+------+-----------+------+-------+-------------+-----------+

Logs aren't showing anything useful other than successful RabbitMQ connections. I'm attaching nova --debug info for further debugging because it contains one 404 error regarding flavors. http://pastebin.com/2KXpht4V

2014-07-31 21:08:17 -0500 received badge  Popular Question (source)