Ask Your Question

samfrid's profile - activity

2017-05-12 18:12:56 -0500 received badge  Famous Question (source)
2016-07-23 12:50:14 -0500 received badge  Famous Question (source)
2015-01-04 09:14:53 -0500 answered a question icehouse on fedora21

However, there is warning

Fedora 21 is still in development and running RDO Juno on Fedora 21 is not recommended at this time. A separate announcement will be made on the rdo-list mailing list when RDO Juno on Fedora 21 is ready.

at https://openstack.redhat.com/Quickstart .

I would try to install Juno (just allinone) on F21, per larsks notice. Maybe there are some specific issues , not yet resolved.

2014-12-22 09:32:48 -0500 received badge  Notable Question (source)
2014-12-21 02:24:52 -0500 answered a question AMQP server on localhost:5672 is unreachable: socket closed

Troubleshooting steps here https://ask.openstack.org/en/question...
You have a problem with rabbitmq-server on Controller.

2014-12-12 00:43:52 -0500 commented answer windows qcow image is 0 length

Please, clarify why standard virt-install with loading Virtio Drivers might not help. It has been done thousands of times with no problems with correct drivers. If driver is a problem your suggestion won't help either.

2014-12-12 00:34:53 -0500 answered a question How to run OpenStack with both ESX and KVM hypervisors?

I would setup second Network Node as ML2,OVS,VXLAN and attached Compute node running KVM Hypervisor to second Network Node, splitting tenants sub-nets between two network nodes. br-ex bridges will have different IPs so routing to external network won't be a problem. Neutron agents configuration files on node 1 will be tuned to work with ESX, on node 2 to work with KVM. It might be expensive solution , but pretty simple from logical and tuning standpoint.
1. Create tenants sub-net.
2. Force new VM to be created on this sub-net on KVM Compute Node.
3 The last step should result creating qdhcp-namespace on Network Node 2 connected
to Compute node via VXLAN tunnel

2014-12-10 02:50:03 -0500 commented question Why Red Hat Virtio Driver/Windows is slow in Debian and fast in CentOS?

I would try Ubuntu Trusty as host box.

2014-12-07 23:57:02 -0500 commented question Error when try install openstack-neutron-openvswitch

Can you start neutron-openvswitch-agent service ?

2014-12-07 23:41:37 -0500 commented question Why Red Hat Virtio Driver/Windows is slow in Debian and fast in CentOS?

I would compare versions of Qemu and Libvirt on Ubuntu Trusty with versions Qemu, Libvirt on Debian you are running.

2014-12-05 17:28:37 -0500 received badge  Famous Question (source)
2014-12-04 00:53:48 -0500 received badge  Notable Question (source)
2014-12-03 18:58:41 -0500 received badge  Popular Question (source)
2014-12-03 15:45:59 -0500 received badge  Student (source)
2014-12-03 12:38:14 -0500 asked a question Is there any way anlyzing nova log files to make sure Juno doesn't force file injection when launching VM ?

Yes, testing value injection_partition (from -1 to - 2 ) in nova.conf on compute node as in the thread
https://ask.openstack.org/en/question...
it's possible to see that on CentOS 7 both options allow to boot instances. My question is : would it be possible to analyze Juno log files , most probably from /var/log/nova to verify that Juno doesn't force this feature and behaves here in the same way as IceHouse did. I was able to check nova/virt/libvirt/driver.py (on Juno) and make sure that updates done for 2014.1 release are in the same place, but nothing is present in nova logs, regarding this question.

2014-12-01 03:00:47 -0500 received badge  Famous Question (source)
2014-12-01 02:38:46 -0500 answered a question How many Multiple external network can we have

I believe that if you have 5 Ethernet cards on Network Node, maximum of external networks connected would be 5-2=3 . In general, N-2

2014-11-25 17:08:06 -0500 received badge  Notable Question (source)
2014-11-25 17:00:31 -0500 received badge  Popular Question (source)
2014-11-24 07:51:12 -0500 asked a question Mail system seems to be down since 11/21/2014

Also activity outputs are frozen since 11/21. Indicator of responses doesn't change to red , even thread has been already updated

2014-11-20 10:03:27 -0500 answered a question neutron public subnet wrong IP

RDO link providing an answer https://openstack.redhat.com/Neutron_...

NOTE: It is important to do the network restart before setting up the router gateway below, because a network restart takes destroys and recreates br-ex which causes the router's interface in the qrouter-* netns to be deleted, and it won't be recreated without clearing and re-setting the gateway.

# . keystonerc_admin
# neutron router-gateway-clear router1
# neutron subnet-delete public_subnet

You need to recreate the public subnet with an allocation range outside of your external DHCP range and set the gateway to the default gateway of the external network.

# neutron subnet-create --name public_subnet --enable_dhcp=False --allocation-pool=start=192.168.122.10,end=192.168.122.20 --gateway=192.168.122.1 public 192.168.122.0/24
# neutron router-gateway-set router1 public
2014-11-19 06:06:38 -0500 answered a question neutron agent-list not showing on controller node

You are not supposed to disable iptables rules, you have to update iptables rules to open port 5672. http://www.putorius.net/2011/05/basic...
https://help.ubuntu.com/community/Ipt...
Then

# netstat -lnpt | grep 5672

to make sure rabbitmq-server Openstack AMQP broker is listening at this port

2014-11-17 07:45:11 -0500 received badge  Teacher (source)
2014-11-16 02:05:43 -0500 answered a question tenant id and instance id in neutron schema

From CLI standpoint nova list provide instance-id for every instance listed
nova show instance-id has field tenant-id. I am not sure neutron is involved here.

2014-11-14 20:49:25 -0500 answered a question Need help setting up neutron networking

Switching to eth0 and eth1 using GRUB_CMDLINE_LINUX line append "net.ifnames=0 biosdevname=0" doesn't bind eth0 and eth1 to MAC ADDRESSES of physical network adapters, on next reboot they might be replaced, what is unacceptable for Juno ( for Openstack in general).

If you have multiple interfaces on CentOS 7 and want to control naming of each device rather than letting the kernel do in its own way, /etc/udev/rules.d/60-net.rules seems necessary to override /usr/lib/udev/rules.d/60-net.rules like the following.

SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="00:c0:f0:4c:f5:78", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth1"

SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*", ATTR{address}=="60:a4:4c:b5:26:48", ATTR{dev_id}=="0x0", ATTR{type}=="1", KERNEL=="eth*", NAME="eth0"

I would guess that attempt to install Juno on CentOS 7 with old style Ethernet names could make sense only with udev rules approach.

2014-11-13 17:24:18 -0500 received badge  Notable Question (source)
2014-11-07 07:53:56 -0500 received badge  Famous Question (source)
2014-11-07 00:01:13 -0500 answered a question how to setup neutron network using vlan and gre mode at the same time

Take a look at model neutron flat network http://docs.openstack.org/havana/inst...

2014-10-29 14:42:39 -0500 answered a question VM migration from vmware - Launch VM same way as virt-manager

See also this link.

2014-10-29 14:42:38 -0500 commented question VM migration from vmware - Launch VM same way as virt-manager

See for instance here.

2014-09-04 08:10:12 -0500 received badge  Popular Question (source)
2014-07-08 16:17:02 -0500 received badge  Notable Question (source)
2014-07-07 12:55:21 -0500 asked a question X client inside a browser‏
What would be on F20 command equavalent `apt-get install xinit e17 xterm firefox` ?
2014-07-04 22:40:00 -0500 received badge  Notable Question (source)
2014-07-01 00:55:52 -0500 received badge  Enthusiast
2014-06-28 05:08:09 -0500 asked a question Is there any way to install enlightenment 17 on fedora VM like on Ubuntu VM
Just one command on Ubuntu 
$ sudo apt-get install xorg e17 
sets e17 on Ubuntu VM 
I cannot find similar X11 packages to make working
$sudo yum install enlightenment
on fedora VM
2014-06-26 23:05:07 -0500 received badge  Popular Question (source)
2014-06-18 23:11:25 -0500 asked a question How to set up neutron_metadata_proxy_shared_secret in nova.conf on compute node
Are there any ini-file for neutron on Controller containing this password ?
2014-06-18 04:11:43 -0500 received badge  Famous Question (source)
2014-06-18 03:28:25 -0500 received badge  Popular Question (source)
2014-06-17 05:36:41 -0500 received badge  Popular Question (source)
2014-06-17 00:14:15 -0500 marked best answer Failure to add compute node following RDO instructions

I've attempted to add second node ( compute ) following http://openstack.redhat.com/Adding_a_compute_node (http://openstack.redhat.com/Adding_a_...) .

No luck.  Any help or advice would be highly appreciated.