Ask Your Question

NilsS's profile - activity

2016-05-12 03:55:18 -0600 received badge  Nice Answer (source)
2014-04-30 20:36:53 -0600 received badge  Famous Question (source)
2014-04-30 07:27:20 -0600 received badge  Teacher (source)
2014-04-30 07:27:20 -0600 received badge  Self-Learner (source)
2014-04-30 07:20:20 -0600 answered a question Keystone not working: No handlers could be found for logger "keystoneclient.httpclient"

Thank you for your help, it lead me into the right direction. I do not completly understand what was wrong but this is how I solved it:

situation:
- select * from keystone.service did not show an entry for keystone. Also no entry in keystone.endpoint table.
- all commands except keystone token-get did not work, no error message and no output, just a blank line.

solution:
- unset all OS_*
- export OS_SERVICE_TOKEN=$SERVICE_TOKEN
- export OS_SERVICE_ENDPOINT=$http://controller:35357/v2.0
- recreate the keystone service and endpoint: http://docs.openstack.org/icehouse/install-guide/install/yum/content/keystone-services.html (http://docs.openstack.org/icehouse/in...)

I think my problem may was that the service is created by debian package manager and this may failed without warning. So I followed http://docs.openstack.org/icehouse/install-guide/install/apt-debian/content/keystone-verify.html (http://docs.openstack.org/icehouse/in...) and unset OS_SERVICE_ENDPOINT and keystone did'nt know what to do after that.

So again many thanks for your help,
Nils Schröder

2014-04-30 04:22:25 -0600 received badge  Notable Question (source)
2014-04-28 20:00:10 -0600 received badge  Popular Question (source)
2014-04-28 09:54:35 -0600 asked a question Keystone not working: No handlers could be found for logger "keystoneclient.httpclient"

Hello,

I am installing openstack on debian for the first time. I am following Openstack installation - Debian guide. I have set the OS_* enviroment and keystone token-get works except that it also shows 'No handlers could be found for logger "keystoneclient.httpclient"' and is taking a long time (about 40 seconds).

But I can not fetch a userlist, it just don't reply anything:

root@cloudcontrol01:~# keystone user-list

No handlers could be found for logger "keystoneclient.httpclient"

root@cloudcontrol01:~#

But If I select all from table user of keystone database (mysql) I get one entry for admin.

Same behavior for registering services:

root@cloudcontrol01:~# keystone service-create --name=keystone --type=identity --description="OpenStack Identity"

No handlers could be found for logger "keystoneclient.httpclient"

root@cloudcontrol01:~#

No service is created and the command takes very long.

Any help would be very nice. Please tell me if you need any further informations.

Thanks and regards, Nils Schröder