Ask Your Question

elmiko's profile - activity

2015-06-13 11:38:19 -0500 answered a question sahara dashboard issue

those errors usually represent an error with the communication between the dashboard and the sahara controller. you will most likely want to ensure that the routes between dashboard controller and the sahara controller are clear, for example ensure that there are no iptables rules that may block traffic to the sahara controller.

you can see a list of the openstack ports here, http://docs.openstack.org/kilo/config...

2015-01-20 14:05:23 -0500 received badge  Enthusiast
2015-01-19 08:21:39 -0500 commented answer Sahara install problem

just one note about sqlite. it is deprecated in juno, i would recommend finding a more permanent solution(e.g. mysql, postgresql).

2015-01-05 05:46:29 -0500 received badge  Teacher (source)
2015-01-02 10:54:57 -0500 commented answer Storm as Openstack Data Processing

@navesta, looks like you've run into a bug in Sahara. the problem stems from the Storm entry point not being present in the setuptools configuration for the install. i've created a bug(https://bugs.launchpad.net/sahara/+bug/1407120) to address this, thanks!

2014-12-19 13:35:40 -0500 answered a question Openstack Juno Sahara error - "publicURL endpoint for data_processing service not found"

do you have the Sahara endpoint available in Keystone?

you can check for the service by issuing keystone service-list and looking for "sahara" in the name column and "data_processing" in the type column.

further, you can check the endpoints by issuing keystone endpoint-list, in this case you will need the service id from the previous command.

if it is not present i would recommend looking at the [Sahara installation docs] under the "Common installation steps".

2014-12-11 08:00:13 -0500 commented answer Storm as Openstack Data Processing

I don't think the Storm change has propagated to pypi yet, perhaps after the Kilo-1 release on Dec. 18.

As for Storm and Spark in the same image; i don't think they would conflict but you would need to manually construct the image. i don't think sahara-image-elements will create this type of image.

2014-12-10 09:07:42 -0500 commented answer Sahara cluster stuck in waiting state

thanks for the update, i wonder if there is a way for Sahara to determine if Nova has floating ips available?

2014-12-10 09:05:51 -0500 answered a question Storm as Openstack Data Processing

Storm support has recently been added to Sahara, to use it you will need to obtain a fairly recent(Storm was merged on Nov. 27) copy of Sahara. after install you will need to enable the Storm plugin by adding it to the plugin list in your configuration file. finally, you will need to ensure that the images you are using with Sahara have Storm installed. i don't think there is a Storm image hosted online currently, so you will need to build one using the sahara-image-elements tool which can be found at https://github.com/openstack/sahara-image-elements (https://github.com/openstack/sahara-i...) .

here is a reference to the review for the Storm integration, https://review.openstack.org/#/c/137699/

2014-12-02 13:47:55 -0500 answered a question Sahara cluster stuck in waiting state

You might try increasing the size of your cluster, i have experienced continual "waiting" status on a cluster when i attempt to make it too small. Unfortunately this seems to be under-documented as it is an idiosyncracy of Hadoop and Sahara. My recommendation is to attempt building a cluster within at least 4 nodes.

2014-11-26 21:53:11 -0500 commented question Sahara not visible in dashboard

you have the service catalog listed above, are the endpoints also registered with Keystone? they will need to be for Sahara to appear in the dashboard.

2014-04-15 12:18:03 -0500 commented answer icehouse - Virtual Interface creation failed

This worked for me as well. The only difference is that I am using a packstack --allinone configuration and I needed to use values from my keystonerc_admin file for the auth stuff. thanks!

2014-04-14 15:30:20 -0500 commented question icehouse - Virtual Interface creation failed

I've been having this issue for about a week now. I'm going to try the suggestion below.

2014-04-14 15:21:38 -0500 received badge  Supporter (source)