Ask Your Question

jan.krause's profile - activity

2016-11-05 12:00:25 -0500 received badge  Nice Question (source)
2014-11-11 04:27:58 -0500 received badge  Taxonomist
2014-04-20 20:06:23 -0500 received badge  Famous Question (source)
2014-04-09 09:54:30 -0500 received badge  Notable Question (source)
2014-04-09 05:36:34 -0500 received badge  Editor (source)
2014-04-09 02:48:15 -0500 received badge  Student (source)
2014-04-08 11:24:27 -0500 answered a question igmp queries are blocked somewhere between bridge and tap?

current state is, we see the traffic on the qbr interface, but the queries are blocked somehow. there are not forwarded to the tap device on the virtual machine.

we set the querier for the qbr to 1. and set the rules for libvirt netqork filter, but still no success.

2014-04-08 05:14:29 -0500 received badge  Popular Question (source)
2014-04-04 10:56:44 -0500 asked a question igmp queries are blocked somewhere between bridge and tap?

we have an virtual openswitch router, which we are using to communicate from our virtual vm“s to an external network, currently unicast based into the vms. now we wanna switch to multicast.

i was able to setup an multicast router in the netns, so that we are able to join an multicast group from the vms into the right switch over the router. but this runs into an timeout, because the impg queries are not available in the netns.

is there an way to manage this?

10.200.2.0/24 dev qg-552ffdec-c1  proto kernel  scope link  src 10.200.2.2 
10.200.3.0/24 dev qr-f46ee891-ec  proto kernel  scope link  src 10.200.3.1

is see:

 17:42:24.710978 IP 10.200.2.2 > 224.0.0.1: igmp query v2

but inside the vm there is no query, only initial three igmp reports

 15:53:37.084064 IP 10.200.3.17 > 238.2.48.3: igmp v2 report 238.2.48.3

We see the traffic on the qbr interface, but the queries are blocked somehow. there are not forwarded to the tap device on the virtual machine.

we set the querier for the qbr to 1. and set the rules for libvirt network filter, but still no success.

Edit:

Actually we broke down the problem to the igmp query part. when we send igmp queries from one virtual instance to the network we will not recieve them on the other instances:

we see the igmp queries on the linux bridge device:

 tcpdump -v -n -i qbrd4d83fa8-d5 igmp

but not on the tap device:

tcpdump -v -n -i tapd4d83fa8-d5 igmp

we are using kvm.

we added:

echo 1 >> /sys/devices/virtual/net/qbrd4d83fa8-d5/bridge/multicast_querier

on the bridge, and did no changes on the virsh network filter yet.

some system informations:

Linux compute007 3.8.0-29-generic #42~precise1-Ubuntu SMP Wed Aug 14 16:19:23 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

and

bridge-utils  1.5-2ubuntu7 Utilities for configuring the Linux Ethernet bridge

for any hint, i would be thankful.