Ask Your Question

rubik's profile - activity

2016-09-05 08:48:04 -0600 received badge  Good Question (source)
2015-10-07 08:34:46 -0600 received badge  Taxonomist
2014-12-03 07:10:32 -0600 received badge  Nice Question (source)
2014-08-26 02:30:38 -0600 received badge  Student (source)
2014-04-03 04:17:33 -0600 received badge  Famous Question (source)
2014-03-31 02:30:26 -0600 received badge  Notable Question (source)
2014-03-14 10:33:32 -0600 commented answer no ports available when associating floating ips for my new instance

I input "neutron quota-list" in demo user, the message says: "User does not have admin privileges.....". Then I source keystonerc_admin and execute "neutron quota-list" again. There is nothing output. I have tried "neutron quota-show" and output the following results: +---------------------+-------+ | Field | Value | +---------------------+-------+ | floatingip | 50 | | network | 10 | | port | 50 | | router | 10 | | security_group | 10 | | security_group_rule | 100 | | subnet | 10 | +---------------------+-------+ B.T.W. I found a strange thing. When I lauch another instance using image cirros which is prebuilt in openstack, I can associate floating ip (10.0.0.3,172.24.4.227) successfully. But the Fedora19 image still can not associate floating ip.

2014-03-12 05:54:25 -0600 received badge  Popular Question (source)
2014-03-11 08:11:44 -0600 commented answer no ports available when associating floating ips for my new instance

Yes, I am running 2013.2.2-1.el6. I checked my neutron policy file: /etc/neutron/policy.json. I found the following pairs are missing : "get_port:allowed_address_pairs": "rule:admin_or_owner", "get_port:fixed_ips": "rule:admin_or_owner", "get_port:mac_address": "rule:admin_or_owner", Then I added them to policy.json, reboot the server and logged into the dashboard again. But it remained the same situation....

2014-03-10 05:16:09 -0600 asked a question no ports available when associating floating ips for my new instance

I am a novice here.

I followed quick start(http://openstack.redhat.com/Quickstart) successfully and I am trying to run an instance as described in this page ( http://openstack.redhat.com/Running_an_instance (http://openstack.redhat.com/Running_a...) ).

I was stuck in step 6 Associate Floating IP. I have set floating IP range and this is what I get when I execute command "nova-manage floating list":

None 192.168.1.1 None nova eth0

None 192.168.1.2 None nova eth0

None 192.168.1.3 None nova eth0

None 192.168.1.4 None nova eth0

......

None 192.168.1.253 None nova eth0

None 192.168.1.254 None nova eth0

When I open "Manage Floating IP Associations" dialog, IP Address can be selected. But the option "port to be associated" remains "No ports available" then I can not associate successfully.

So what is the problem ?