Ask Your Question

mishra-rabi's profile - activity

2012-11-22 09:46:48 -0500 answered a question 3 nodes are involved: controller, network gateway, compute node. New instances are not communicating at all, no ip addresses.

Yeah I have connected the private network to a cisco 3650 switches. Not sure of commands for HP... I think ports are vlan tagged by default...

Switch(config)# interface xx

Switch(config-if)# switchport trunk encapsulation dot1q Switch(config-if)# switchport mode trunk

On Thu, Nov 22, 2012 at 3:01 PM, Aryan < question213459@answers.launchpad.net< p="">

wrote:

Question #213459 on quantum changed: https://answers.launchpad.net/quantum/+question/213459 (https://answers.launchpad.net/quantum...)

Aryan posted a new comment: Well done, I'll check it out.

Just a terminology question, by "trunk" you mean Cisco trunking, not HP trunking? So in HP term, you've tagged those ports, or just left them untouched?

Thanks Aryan


You received this question notification because you are a direct subscriber of the question.


Regards, Rabi Mishra

2012-11-22 09:14:39 -0500 answered a question 3 nodes are involved: controller, network gateway, compute node. New instances are not communicating at all, no ip addresses.

I did manage to fix it.. I have used vlans 2001:4094 in my ovs plugin 'physnet:2001:4094'. However, I have not created those VLANs on the switch. My ports in the switch are tunked for all VLANs '1:4094'. Once I created a few VLANs used by my logical networks (2001 and 2003), it worked like a charm.ch

The VLAN tages you see with 'ovs-vsctl show' on the compute nodes show 1,2 etc, but they get mapped to 2001 when go beyond the soft switch.

The other thing I have done is changed my vif drivers from what has been mentioned in many installation guides (libvirt_vif_driver=nova.virt.libvirt.vif.LibvirtHybridOVSBridgeDriver) to

libvirt_vif_driver=nova.virt.libvirt.vif.LibvirtOpenVswitchVirtualPortDriver .

Hope this helps you.

Thanks, Rabi

On Thu, Nov 22, 2012 at 1:45 PM, Aryan < question213459@answers.launchpad.net< p="">

wrote:

Question #213459 on quantum changed: https://answers.launchpad.net/quantum/+question/213459 (https://answers.launchpad.net/quantum...)

Aryan posted a new comment: Rabi,

Not yet, I'll continue working on it next week. I'll update the question in case of any success.


You received this question notification because you are a direct subscriber of the question.


Regards, Rabi Mishra

2012-11-19 17:44:36 -0500 answered a question 3 nodes are involved: controller, network gateway, compute node. New instances are not communicating at all, no ip addresses.

Hi Aryan,

Did u manage to find a solution to your issue? I am stuck with the same issue.

thanks, Rabi