Ask Your Question

JakeWarner's profile - activity

2015-06-11 13:24:32 -0500 received badge  Self-Learner (source)
2015-01-28 01:13:58 -0500 received badge  Good Question (source)
2014-04-01 08:42:36 -0500 received badge  Guru (source)
2014-04-01 08:42:36 -0500 received badge  Great Answer (source)
2014-01-24 11:00:32 -0500 received badge  Good Question (source)
2014-01-23 18:41:54 -0500 marked best answer CRITICAL [quantum] 'NoneType' object has no attribute 'rpartition'

After a fresh install of OpenStack Grizzly on Fedora 18, I received this while starting the L3-agent on my Network Node.

[root@vsw1 ~]# systemctl restart quantum-l3-agent
[root@vsw1 ~]# systemctl status quantum-l3-agent
quantum-l3-agent.service - OpenStack Quantum Load Balancing as a Service Agent
      Loaded: loaded (/usr/lib/systemd/system/quantum-l3-agent.service; enabled)
      Active: failed (Result: exit-code) since Sun 2013-05-12 15:30:45 CDT; 1s ago
     Process: 5848 ExecStart=/usr/bin/quantum-lbaas-agent --config-file /etc/quantum/quantum.conf --config-file /etc/quantum/l3_agent.ini --log-file /var/log/quantum/lbaas-agent.log (code=exited, status=1/FAILURE)

May 12 15:30:44 vsw1 systemd[1]: Starting OpenStack Quantum Load Balancing as a Service Agent...
May 12 15:30:44 vsw1 systemd[1]: Started OpenStack Quantum Load Balancing as a Service Agent.
May 12 15:30:45 vsw1 quantum-lbaas-agent[5848]: 2013-05-12 15:30:45 CRITICAL [quantum] 'NoneType' object has no attribute 'rpartition'
May 12 15:30:45 vsw1 systemd[1]: quantum-l3-agent.service: main process exited, code=exited, status=1/FAILURE
May 12 15:30:45 vsw1 systemd[1]: Unit quantum-l3-agent.service entered failed state

When run in verbose mode, I get:

[root@vsw1 ~]# /usr/bin/quantum-lbaas-agent --config-file /etc/quantum/quantum.conf --config-file /etc/quantum/l3_agent.ini --log-file /var/log/quantum/lbaas-agent.log --debug --verbose
2013-05-12 15:32:16     INFO [quantum.common.config] Logging enabled!
2013-05-12 15:32:16 CRITICAL [quantum] 'NoneType' object has no attribute 'rpartition'
Traceback (most recent call last):
  File "/usr/bin/quantum-lbaas-agent", line 26, in <module>
    main()
  File "/usr/lib/python2.7/site-packages/quantum/plugins/services/agent_loadbalancer/agent/__init__.py", line 61, in main
    mgr = manager.LbaasAgentManager(cfg.CONF)
  File "/usr/lib/python2.7/site-packages/quantum/plugins/services/agent_loadbalancer/agent/manager.py", line 125, in __init__
    self._vip_plug_callback
  File "/usr/lib/python2.7/site-packages/quantum/openstack/common/importutils.py", line 41, in import_object
    return import_class(import_str)(*args, **kwargs)
  File "/usr/lib/python2.7/site-packages/quantum/openstack/common/importutils.py", line 29, in import_class
    mod_str, _sep, class_str = import_str.rpartition('.')
AttributeError: 'NoneType' object has no attribute 'rpartition'

I modified /usr/lib/python2.7/site-packages/quantum/openstack/common/importutils.py and added

print import_str;
exit();

So that I could see what object was trying to be referenced, which when ran, yielded:

[root@vsw1 ~]# /usr/bin/quantum-lbaas-agent --config-file /etc/quantum/quantum.conf --config-file /etc/quantum/l3_agent.ini --log-file /var/log/quantum/lbaas-agent.log --debug --verbose
2013-05-12 15:34:51     INFO [quantum.common.config] Logging enabled!
quantum.agent.linux.interface.OVSInterfaceDriver

Which exists in my /etc/quantum/l3_agent.ini:

[root@vsw1 ~]# cat /etc/quantum/l3_agent.ini|grep interface
# L3 requires that an interface driver be set.  Choose the one that best
interface_driver = quantum.agent.linux.interface.OVSInterfaceDriver
#interface_driver = quantum.agent.linux.interface.BridgeInterfaceDriver

Does anyone have any ideas?

2014-01-21 07:21:04 -0500 received badge  Good Answer (source)
2014-01-21 07:21:04 -0500 received badge  Enlightened (source)
2013-12-20 16:30:19 -0500 received badge  Nice Answer (source)
2013-12-20 16:30:14 -0500 received badge  Nice Question (source)
2013-10-25 07:56:08 -0500 received badge  Nice Answer (source)
2013-10-24 16:52:48 -0500 received badge  Critic
2013-10-24 16:21:20 -0500 answered a question Quantum (neutron) gre slow performance

I had this issue too and spent almost two months debugging it. I tried tweaking MTUs, enabling jumbro frames and everything. The issue ended up being with GRO where the server was offloading network processing off to the NIC. I disabled that, restarted the interface and my speeds increased by 8x.

Disable gro for an interface (temporary, if the machine restarts, this will be lost) with:

ethtool -K <interface> gro off

You can disable it permanently (on CentOS/RHEL at least) by adding this to the respective interface's network script:

ETHTOOL_OPTS="gro off"

The script (on RHEL/CentOS) is found at:

/etc/sysconfigs/network-scripts/ifcfg-<interface>
2013-06-24 03:24:39 -0500 marked best answer "Unable to authenticate to any available projects."

I wrote an installation script for OpenStack Grizzly on Ubuntu 13.04. Occasionally when I run this script, I'll get the error "Unable to authenticate to any available projects." when logging into Horizon even though the script may have worked perfectly the previous time. Does anyone have any suggestions for where to begin with this?

I know the error has to do with a lack of tokens based on the actual code: http://django-openstack-auth.readthedocs.org/en/latest/_modules/openstack_auth/backend.html (http://django-openstack-auth.readthedocs.org/en/latest/modules/openstackauth/backend.html)

Thanks in advance!

2013-06-24 03:24:39 -0500 received badge  Self-Learner (source)
2013-06-16 22:59:00 -0500 received badge  Taxonomist
2013-05-31 10:44:40 -0500 answered a question "[Errno 113] No route to host" when VNCing into an instance

The issue ended up being that I had only allowed 5900 through iptables, not 5900-5999 as the other server was trying to use 5902.

2013-05-31 10:43:02 -0500 received badge  Famous Question (source)
2013-05-31 10:42:26 -0500 received badge  Famous Question (source)
2013-05-30 06:43:28 -0500 received badge  Self-Learner (source)
2013-05-30 06:43:28 -0500 received badge  Teacher (source)
2013-05-24 10:11:50 -0500 received badge  Famous Question (source)
2013-05-23 06:20:43 -0500 received badge  Notable Question (source)
2013-05-20 11:08:11 -0500 received badge  Famous Question (source)
2013-05-20 06:27:09 -0500 received badge  Popular Question (source)
2013-05-20 01:53:20 -0500 received badge  Nice Question (source)
2013-05-20 01:52:02 -0500 received badge  Notable Question (source)
2013-05-18 22:47:58 -0500 commented answer "[Errno 113] No route to host" when VNCing into an instance

My configuration already reflects the things that you suggested. :(

2013-05-18 22:47:38 -0500 received badge  Popular Question (source)
2013-05-18 16:55:38 -0500 received badge  Popular Question (source)
2013-05-18 16:55:38 -0500 received badge  Notable Question (source)
2013-05-18 16:54:58 -0500 received badge  Scholar (source)
2013-05-18 16:22:56 -0500 commented question "[Errno 113] No route to host" when VNCing into an instance

Yes and that didn't work either.

2013-05-18 14:38:37 -0500 asked a question "[Errno 113] No route to host" when VNCing into an instance

After setting up my OpenStack cloud and getting everything to work, I bought another compute2 node and provisioned it using the automated script I wrote. Everything worked except for VNC which I get when trying to connect to an instance on that node:

Redirecting to /bin/systemctl status  openstack-nova-novncproxy.service
openstack-nova-novncproxy.service - OpenStack Nova NoVNC Proxy Server
   Loaded: loaded (/usr/lib/systemd/system/openstack-nova-novncproxy.service; enabled)
   Active: active (running) since Sat 2013-05-18 11:55:43 CDT; 2h 35min ago
 Main PID: 10212 (python)
   CGroup: name=systemd:/system/openstack-nova-novncproxy.service
           └─10212 python /usr/bin/nova-novncproxy --web /usr/share/novnc/
May 18 11:57:15 controller.cloud1 nova-novncproxy[10212]: 4: <home ip>: Plain non-SSL (ws://) WebSocket connection
May 18 11:57:15 controller.cloud1 nova-novncproxy[10212]: 4: <home ip>: Version hybi-13, base64: 'True'
May 18 11:57:15 controller.cloud1 nova-novncproxy[10212]: 4: <home ip>: Path: '/websockify'
May 18 11:57:15 controller.cloud1 nova-novncproxy[10212]: 4: connecting to: 192.168.1.202:5900
May 18 11:57:15 controller.cloud1 nova-novncproxy[10212]: 4: handler exception: [Errno 113] No route to host

I can ping the node just fine:

--- 192.168.1.202 ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2000ms
rtt min/avg/max/mdev = 0.256/0.271/0.292/0.024 ms

And my /etc/nova/nova.etc files have the following regarding VNC:

[root@controller httpd]# cat /etc/nova/nova.conf|grep vnc
novnc_enable = true
novncproxy_port = 6080
novncproxy_host = 0.0.0.0
vncserver_listen = 0.0.0.0
novncproxy_base_url = http://<controller public ip>:6080/vnc_auto.html

[root@compute2 ~]# cat /etc/nova/nova.conf|grep vnc
vnc_enabled = true
vncserver_proxyclient_address = 192.168.1.202
novncproxy_base_url = http://<controller public ip>:6080/vnc_auto.html
vncserver_listen = 0.0.0.0

Note: Compute 1 works fine and I can VNC any instance on it and both compute nodes are listening:

[root@compute1 ~]# netstat -vtan|grep 5900
tcp        0      0 192.168.1.201:5900      0.0.0.0:*               LISTEN  
[root@compute2 ~]# netstat -vtan|grep 5900
tcp        0      0 192.168.1.202:5900      0.0.0.0:*               LISTEN
2013-05-18 01:55:29 -0500 commented question 401 on "glance image-list"

Yup, please see my 'Edit'. :)

2013-05-18 01:47:46 -0500 asked a question 401 on "glance image-list"

Hello all,

When running 'glance image-list', I get a 401. This issue only appears about 48 hours after my cloud is up and running.

[root@controller ~]# glance image-list
Request returned failure status.
Invalid OpenStack Identity credentials.

With debug:

[root@controller ~]# glance --debug image-list
curl -i -X GET -H 'X-Auth-Token: <stripped token for sake of readability>' -H 'Content-Type: application/json' -H 'User-Agent: python-glanceclient' http://192.168.1.100:9292/v1/images/detail?sort_key=name&sort_dir=asc&limit=20

HTTP/1.1 401 Unauthorized
date: Sat, 18 May 2013 06:38:38 GMT
content-length: 253
content-type: text/plain; charset=UTF-8

401 Unauthorized

This server could not verify that you are authorized to access the document you requested. Either you supplied the wrong credentials (e.g., bad password), or your browser does not understand how to supply the credentials required.



Request returned failure status.
Invalid OpenStack Identity credentials.

With debug enabled in /etc/glance/glance.conf, the log shows:

[root@controller ~]# tail /var/log/glance/api.log
2013-05-18 01:38:38.541 16020 DEBUG glance.api.middleware.version_negotiation [-] Matched version: v1 process_request /usr/lib/python2.7/site-packages/glance/api/middleware/version_negotiation.py:71
2013-05-18 01:38:38.541 16020 DEBUG glance.api.middleware.version_negotiation [-] new uri /v1/images/detail process_request /usr/lib/python2.7/site-packages/glance/api/middleware/version_negotiation.py:72
2013-05-18 01:41:32.206 16020 DEBUG glance.api.middleware.version_negotiation [-] Determining version of request: GET //v1/images/detail Accept:  process_request /usr/lib/python2.7/site-packages/glance/api/middleware/version_negotiation.py:46
2013-05-18 01:41:32.207 16020 DEBUG glance.api.middleware.version_negotiation [-] Using url versioning process_request /usr/lib/python2.7/site-packages/glance/api/middleware/version_negotiation.py:59
2013-05-18 01:41:32.207 16020 DEBUG glance.api.middleware.version_negotiation [-] Matched version: v1 process_request /usr/lib/python2.7/site-packages/glance/api/middleware/version_negotiation.py:71
2013-05-18 01:41:32.207 16020 DEBUG glance.api.middleware.version_negotiation [-] new uri /v1/images/detail process_request /usr/lib/python2.7/site-packages/glance/api/middleware/version_negotiation.py:72
2013-05-18 01:41:32.371 16020 DEBUG glance.api.middleware.version_negotiation [-] Determining version of request: GET //v1/images/detail Accept:  process_request /usr/lib/python2.7/site-packages/glance/api/middleware/version_negotiation.py:46
2013-05-18 01:41:32.372 16020 DEBUG glance.api.middleware.version_negotiation [-] Using url versioning process_request /usr/lib/python2.7/site-packages/glance/api/middleware/version_negotiation.py:59
2013-05-18 01:41:32.372 16020 DEBUG glance.api.middleware.version_negotiation [-] Matched version: v1 process_request /usr/lib/python2.7/site-packages/glance/api/middleware/version_negotiation.py:71
2013-05-18 01:41:32.372 16020 DEBUG glance.api.middleware.version_negotiation [-] new uri /v1/images/detail process_request /usr/lib/python2.7/site-packages/glance/api/middleware/version_negotiation.py:72

Does anyone have any ideas why this is happening after 48 hours?

Thanks!

Edit: I know my environment variables aren't the problem as other commands ("nova flavor-list", "nova hypervisor-list", etc) all work.

2013-05-16 16:27:48 -0500 commented answer novnc - Horizon iFrame refuses to update novnc address

Did this solve your problem?

2013-05-16 16:27:25 -0500 answered a question novnc - Horizon iFrame refuses to update novnc address

Make sure you restart nova-api and nova-novncproxy service after changing the config. :)

2013-05-14 13:49:16 -0500 edited question "Error: Unable to retrieve security groups."

After a fresh install of OpenStack Grizzly, I get "Error: Unable to retrieve security groups." when attempting to create an instance via Horizon.

I also get the following via CLI:

[root@controller ~]# nova secgroup-list
ERROR: The server has either erred or is incapable of performing the requested operation. (HTTP 500)

When viewing /var/log/nova/api.log (with debug enabled), I get:

2013-05-11 01:50:32.890 17172 TRACE nova.api.openstack   File "/usr/lib/python2.7/site-packages/nova/network/security_group/quantum_driver.py", line 126, in list
2013-05-11 01:50:32.890 17172 TRACE nova.api.openstack     security_groups = quantum.list_security_groups(**search_opts).get(
2013-05-11 01:50:32.890 17172 TRACE nova.api.openstack AttributeError: 'Client' object has no attribute 'list_security_groups'

My /etc/nova/nova.conf contains (related to Quantum):

[root@controller ~]# cat /etc/nova/nova.conf|grep quantum && cat /etc/nova/nova.conf|grep firewall
quantum_url = http://192.168.1.100:9696
network_api_class = nova.network.quantumv2.api.API
quantum_auth_strategy = keystone
quantum_admin_tenant_name = service
quantum_admin_username = quantum
quantum_admin_password = QUANTUMPASS
quantum_admin_auth_url = http://192.168.1.100:35357/v2.0
security_group_api = quantum
quantum_metadata_proxy_shared_secret = METADATAPASS
service_quantum_metadata_proxy = true
firewall_driver = nova.virt.firewall.NoopFirewallDriver

I made sure to modify the firewall driver in the ovs plugin

[root@controller ~]# cat /etc/quantum/plugins/openvswitch/ovs_quantum_plugin.ini|grep firewall
firewall_driver = quantum.agent.linux.iptables_firewall.OVSHybridIptablesFirewallDriver

I also noticed that I do not have the functionality for security groups in quantum (I am using Grizzly), yet all of the documentations suggest to set 'security group api=quantum' in /etc/nova/nova.conf

[root@controller ~]# quantum security-group-list
Unknown command ['security-group-list']

http://docs.openstack.org/trunk/openstack-network/admin/content/securitygroup_workflow.html

Quantum Versions:

[root@controller ~]# yum list installed|grep quantum
openstack-quantum.noarch               2013.1-0.6.rc2.fc19           @fedora-openstack-grizzly
openstack-quantum-openvswitch.noarch   2013.1-0.6.rc2.fc19           @fedora-openstack-grizzly
python-quantum.noarch                  2013.1-0.6.rc2.fc19           @fedora-openstack-grizzly
python-quantumclient.noarch            2:2.1-1.fc18                  @updates