Ask Your Question

rafadurancastaneda's profile - activity

2016-03-28 04:01:40 -0500 received badge  Popular Question (source)
2014-12-22 00:51:54 -0500 received badge  Famous Question (source)
2014-12-22 00:51:54 -0500 received badge  Popular Question (source)
2014-12-22 00:51:54 -0500 received badge  Notable Question (source)
2012-03-14 09:12:18 -0500 answered a question 'AnonymousUser' object has no attribute 'tenant_id'

Hi,

Do you have 'horizon.middleware.HorizonMiddleware' in your MIDDLEWARE_CLASSES?? This middleware sets the user class, so it will have tenant_id=None for unanthenticated user.

HTH, Rafael

2012-03-08 07:53:39 -0500 answered a question VNC console ? does it support for KVM instance ?

You are using packaging repository not the code, you are better with https://github.com/cloudbuilders/noVNC and you can run it using something like that: $ cd /path/to/noVNC/utils $ ./launch.sh --vnc localhost:6080

2012-02-28 08:56:29 -0500 answered a question Error loading MySQLdb module: No module named MySQLdb

Hi,

I think you didn't install MySQL-python on your virtualenv, If I'm right you can install just doing:

$ source .venv/bin/activate $ pip install MySQL-python

or:

$ tools/with_venv.sh pip install MySQL-python

2011-10-19 10:04:59 -0500 answered a question github problems

From openstack list:

Hello all,

Milestones and feature roadmaps are now available at:

https://blueprints.launchpad.net/openstack-dashboard

Also we have chosen the official project codename, Horizon. We will be moving the official repo to the OpenStack GitHub account.

In the interim, we have renamed the currently official repo. This is temporary while we make the transition.

https://github.com/4P/horizon

In the next few days we will be migrating to the Gerrit workflow as well.

More updates soon as we make this migration.

Thanks,

Devin

2011-09-16 20:39:05 -0500 answered a question Authentication issue with Keystone

Hi,

Check bugs page since the problems you I think are related to some of the reported bugs. In addition I link the bug I think is affecting you.

Bye

2011-06-19 11:51:03 -0500 answered a question How can I run dashboard as a service, not from terminal

Hello,

I suppose you are using django default server. If I'm right, it doesn't make sense to me running it as service since default server is just for development and run it each time you want test something isn't a great problem. Of course you can write your own init.d script, you can found a lot useful information on internet : ubuntu pages: https://help.ubuntu.com/community/UbuntuBootupHowto (https://help.ubuntu.com/community/Ubu...) tiny example: http://www.linuxforums.org/forum/newbie/38834-how-get-service-run-startup-ubuntu.html (http://www.linuxforums.org/forum/newb...)

And you can also check your scripts in init.d. However if you want dashboard for something else more than just testing, you could deploy it using apache or any other, getting the init.d script among many other useful things.

Bye

2011-04-26 09:28:35 -0500 answered a question I can't get vnc console

Ok, I will open a bug report

2011-04-26 09:17:13 -0500 answered a question I can't get vnc console

Thanks Edouard Thuleau, that solved my question.

2011-04-21 14:58:45 -0500 answered a question VNC console ? does it support for KVM instance ?

I'm sorry I can't help you longer, but I think I shared all I know with you. Your questions now would fit better in openstack nova answers, you can use the link I give you before or try to open another answer. And my final clue is if you are going to check stack before going back once more to dashboard, you need to run nova-direct-api too.

Bye

2011-04-21 09:16:02 -0500 answered a question VNC console ? does it support for KVM instance ?

I'm still stuck getting VNC console, but I can give you some clues: - As you already know, you need merge vnc_console branch in dashboard - You also need to get openstack nova source code, you can try: bzr branch lp:nova/cactus - You'll get a nova dir where you can find bin dir. Now you have all bin you need. - In addition, you can use all nova componenets from packages and just run nova-vncproxy - Check nova-vncproxy code to know how to set up flagfile - nova-vncproxy needs custom noVNC, you can download from git://github.com/openstack/noVNC.git - And here is where I'm stuck, you can check for updates here: https://answers.launchpad.net/nova/+question/153266 (https://answers.launchpad.net/nova/+q...)

2011-04-21 08:23:54 -0500 answered a question vnc console isn't working

I've got it from source code.

2011-04-20 08:40:17 -0500 answered a question I can't get vnc console

As you told me I've checked running machines with virsh dumpxml. Virtual machines are using ports 5900 and 5901 as expected. When I tried curl http://127.0.0.1:5900/5901 I got: RFB 003.008. So that isn't the problem, it occurs only when I use nova-vncproxy, as I explain before I can get VNC console from noVNC server and any other VNC clients, only when I try to reach virtual machines via proxy I get error. In addition I noticed an error in vnc_auto.html when I'm using noVNC, nova-vncproxy and chrome. In my first attempt I didn't get noVNC screen and after inspect the given url (via chrome debugger) I got: Uncaught ReferenceError: token is not defined in window.onload: vnc_auto.html: 98. After this I changed vnc_auto.html:92

var host, port, password; --> var host, port, password, token;

After this I got noVNC scrren and sever disconnected error.

Any other suggestion?

2011-04-19 19:31:22 -0500 answered a question I can't get vnc console

I'm testing all on a single machine installation, I'll check again, but I haven't had any network problem so far. I can connect via ssh, using noVNC server directly, using others VNC clients,.. but I can't connect neither via chrome nor firefox using nova-vncproxy + noVNC.

Thanks for answering

2011-04-19 18:48:23 -0500 answered a question I can't get vnc console

I'm using https://github.com/sleepsonthefloor/noVNC (https://github.com/sleepsonthefloor/n...) noVNC version, and I'm testing all in localhost. Do I need test from another computer? Any ohter suggestion?

2011-04-19 13:36:23 -0500 answered a question vnc console isn't working

I solved it myself, nova-vncproxy wasn't running and dashboard keep waiting for its answer.

2011-04-19 13:34:31 -0500 answered a question VNC console ? does it support for KVM instance ?

You need https://code.launchpad.net/~sleepsonthefloor/openstack-dashboard/vnc_console (https://code.launchpad.net/~sleepsont...) branch to get VNC console support.

2011-04-19 07:35:23 -0500 answered a question I can't get vnc console

Yes I'm running nova-api, nova-compute, nova-network, nova-objestore, nova-scheduler, nova-direct-api and nova-vncproxy. Any other suggesstion?

Anyway thanks for your answer

2011-04-18 10:49:45 -0500 asked a question I can't get vnc console

Hi,

I need some support in order to get VNC console from running instances. I'm using stack get_vnc_cosole:

stack --user=rafael --project=myproject compute get_vnc_console instance_id=4 {u'url': u'http://127.0.0.1:6080/vnc_auto.html?token=090929ea-f573-45e0-9efa-efe68b72af49&host=hostignore&port=portignore'}

Then I've tried the given url in both chrome and firefox, getting two different errors. In chrome I've got noVNC screen and a 'Server disconnected' error. In firefox I've also got noVNC screen but error message is now 'Connect timeout', in addition when firefox is used I get this output from command line:

localhost.localdomain - - [18/Apr/2011 12:41:48] code 400, message Bad request syntax ('<policy-file-request/>\x00') localhost.localdomain - - [18/Apr/2011 12:41:48] "<policy-file-request/>" 40

I'd appreciate some help a lot

2011-04-12 16:06:31 -0500 asked a question vnc console isn't working

I've got ~sleepsonthefloor/openstack-dashboard/vnc_console code in order to get VNC console option, however it isn't working. After clicking VNC console button a new tab is open but nothing is shown. In server output I can see HTTP connection neither fails nor succes:

Tue, 12 Apr 2011 14:13:57 GMT /services/Cloud/services/Cloud/ DEBUG:boto:Method: GET DEBUG:boto:Path: /services/Cloud/?AWSAccessKeyId=2cc070a6-7fdb-4fc1-9232-4ba64d53b5c3%3Amiproyecto&Action=GetVNCConsole&InstanceId=i-00000015&SignatureMethod=HmacSHA256&SignatureVersion=2& Timestamp=2011-04-12T14%3A13%3A57&Version=2009-11-30&Signature=nT75C0LuzpJFyias/6e6masUpKxzspAYuaUwk5gN2I8%3D DEBUG:boto:Data: DEBUG:boto:Headers: {'Date': 'Tue, 12 Apr 2011 14:13:57 GMT', 'Content-Length': '0', 'Authorization': u'AWS 2cc070a6-7fdb-4fc1-9232-4ba64d53b5c3:miproyecto:amMngnn7DQ6++k0dA9v8c+VMQ6Q=', 'User-Agent': 'Boto/1.9b (linux2)'} DEBUG:boto:Host: None DEBUG:boto:establishing HTTP connection

The server gets stuck there and stop working anymore.

Any suggestion?

2011-04-11 15:06:39 -0500 answered a question Delete a creating status volume

Thanks Everett Toews, that solved my question.

2011-04-11 08:20:51 -0500 asked a question Delete a creating status volume

Hi,

I tried without result create two volumes, I think I know why neither of them were created, but the problem now is that I can't delete them:

euca-describe-volumes VOLUME vol-00000001 1 nova creating (miproyecto, None, None, None) 2011-04-08T10:17:22Z VOLUME vol-00000002 1 nova creating (miproyecto, None, None, None) 2011-04-08T10:24:00Z

euca-describe-volumes | grep vol- | cut -f2 | xargs -n1 euca-delete-volume ApiError: ApiError: Volume status must be available ApiError: ApiError: Volume status must be available

Any suggestion will be much appreciated

Bye