Ask Your Question

gyliu's profile - activity

2017-07-26 06:08:37 -0500 received badge  Famous Question (source)
2017-07-26 06:08:37 -0500 received badge  Notable Question (source)
2016-03-30 01:32:28 -0500 received badge  Popular Question (source)
2016-02-10 06:21:49 -0500 received badge  Famous Question (source)
2016-02-10 06:21:49 -0500 received badge  Notable Question (source)
2015-05-11 22:01:40 -0500 received badge  Popular Question (source)
2015-01-20 21:19:56 -0500 received badge  Popular Question (source)
2011-08-16 01:29:32 -0500 answered a question glance does not work when working with swift

Thanks Everett for the comments, the problem have been resolved with the help of Jay ;-)

What I need do is install python-swift on my Glance Box.

2011-08-10 14:21:40 -0500 answered a question glance does not work when working with swift

Thanaks Jay, after re-install a ubuntu OS and re-install glance, it works well with swift.

You are right, we need to install python-swift in Glance box to make this works.

Thanks for your great help!

root@glance-node2:~# glance show 2 URI: http://0.0.0.0/images/2 Id: 2 Public: Yes Name: swift1 Status: active Size: 0 Location: swift+https://test:tester:testing@172.17.1.125:443/auth/v1.0//glance/2 Disk format: raw Container format: ovf

2011-08-10 13:07:44 -0500 answered a question glance does not work when working with swift

Thanks Jay for the quick response ;-), the following are my ubuntu version. Any comments?

root@glance-node:~/test# cat /etc/*release DISTRIB_ID=Ubuntu DISTRIB_RELEASE=10.04 DISTRIB_CODENAME=lucid DISTRIB_DESCRIPTION="Ubuntu 10.04.3 LTS" root@glance-node:~/test# apt-get install python-swift Reading package lists... Done Building dependency tree
Reading state information... Done E: Couldn't find package python-swift root@glance-node:~/test#

2011-08-10 12:32:31 -0500 answered a question glance does not work when working with swift

Thanks Jay, may I ask how can I install python-swift?

I try the command "apt-get install python-swift", but failed.

Thanks.

2011-08-10 10:28:39 -0500 answered a question Failed to get Get an X-Storage-Url and X-Auth-Token

Can anyone give a help? Thanks!

2011-08-10 09:04:39 -0500 answered a question glance does not work when working with swift

Even if I set "swift_store_auth_address = https://172.17.1.125:443/auth/v1.0/%22 (https://172.17.1.125:443/auth/v1.0/") still does not work.

2011-08-10 08:52:40 -0500 answered a question glance does not work when working with swift

Clarify something:

The "curl" and "swift" command works well on swift node: root@saio:/home/swiftdemo# export ST_AUTH=https://172.17.1.125:443/auth/v1.0 root@saio:/home/swiftdemo# export ST_USER=test:tester root@saio:/home/swiftdemo# export ST_KEY=testing root@saio:/home/swiftdemo# swift list builders gholt myfiles root@saio:/home/swiftdemo# swift stat -v StorageURL: https://172.17.1.125:443/v1/AUTH_3852a9fd-b1e5-4498-8aa4-3a557cebff2e (https://172.17.1.125:443/v1/AUTH_3852...) Auth Token: AUTH_tk1a85a0af81364aa3ad104c9e035027c6 Account: AUTH_3852a9fd-b1e5-4498-8aa4-3a557cebff2e Containers: 3 Objects: 1 Bytes: 0 Accept-Ranges: bytes root@saio:/home/swiftdemo# root@saio:/home/swiftdemo# curl -k -v -H 'X-Storage-User: test:tester' -H 'X-Storage-Pass: testing' https://172.17.1.125:443/auth/v1.0 * About to connect() to 172.17.1.125 port 443 (#0) * Trying 172.17.1.125... connected * Connected to 172.17.1.125 (172.17.1.125) port 443 (#0) * successfully set certificate verify locations: * CAfile: none CApath: /etc/ssl/certs * SSLv3, TLS handshake, Client hello (1): * SSLv3, TLS handshake, Server hello (2): * SSLv3, TLS handshake, CERT (11): * SSLv3, TLS handshake, Server finished (14): * SSLv3, TLS handshake, Client key exchange (16): * SSLv3, TLS change cipher, Client hello (1): * SSLv3, TLS handshake, Finished (20): * SSLv3, TLS change cipher, Client hello (1): * SSLv3, TLS handshake, Finished (20): * SSL connection using AES256-SHA * Server certificate: * subject: C=CH; ST=SHANXIN; L=XIAN; O=Platform; OU=DEV; CN=172.17.1.125; emailAddress=gyliu@platform.com * start date: 2011-08-08 03:29:29 GMT * expire date: 2011-09-07 03:29:29 GMT * common name: 172.17.1.125 (matched) * issuer: C=CH; ST=SHANXIN; L=XIAN; O=Platform; OU=DEV; CN=172.17.1.125; emailAddress=gyliu@platform.com * SSL certificate verify result: self signed certificate (18), continuing anyway.

GET /auth/v1.0 HTTP/1.1 User-Agent: curl/7.19.7 (x86_64-pc-linux-gnu) libcurl/7.19.7 OpenSSL/0.9.8k zlib/1.2.3.3 libidn/1.15 Host: 172.17.1.125 Accept: / X-Storage-User: test:tester X-Storage-Pass: testing

< HTTP/1.1 200 OK < X-Storage-Url: https://172.17.1.125:443/v1/AUTH_3852a9fd-b1e5-4498-8aa4-3a557cebff2e (https://172.17.1.125:443/v1/AUTH_3852...) < X-Storage-Token: AUTH_tk1a85a0af81364aa3ad104c9e035027c6 < X-Auth-Token: AUTH_tk1a85a0af81364aa3ad104c9e035027c6 < Content-Length: 115 < Date: Wed, 10 Aug 2011 08:51:41 GMT < * Connection #0 to host 172.17.1.125 left intact * Closing connection #0 * SSLv3, TLS alert, Client hello (1):

{"storage": {"default": "local", "local": "https://172.17.1.125:443/v1/AUTH_3852a9fd-b1e5-4498-8aa4-3a557cebff2e"}}

Just make minor change on glance.conf, set log level to DEBUG,

========glance-api.conf================== default_store = swift swift_store_auth_address = 172.17.1.125:443/v1.0/ swift_store_user = test:tester swift_store_key = testing swift_store_container = glance swift_store_create_container_on_put = True

swift_enable_snet = False

root@glance-node:~# glance add name="s2" is_public=true < /tmp/test.iso Failed to add image. Got error: 400 Bad Request

The server could not comply with the request since it is either malformed or otherwise incorrect.

Error uploading image: global name 'swift_client' is not defined
Note: Your image metadata may still be in the registry, but the image's status will likely be 'killed'.

Log file of api.log: 2011-08-10 ... (more)

2011-08-10 08:26:20 -0500 answered a question glance does not work when working with swift

Thanks Dzung for the answer, but I'm still have some trouble to configure. Can you give more help?

On Swift host: root@saio:/home/swiftdemo# export ST_AUTH=https://172.17.1.125:443/auth/v1.0 root@saio:/home/swiftdemo# export ST_USER=test:tester root@saio:/home/swiftdemo# export ST_KEY=testing root@saio:/home/swiftdemo# swift stat -v StorageURL: https://172.17.1.125:443/v1/AUTH_3852a9fd-b1e5-4498-8aa4-3a557cebff2e (https://172.17.1.125:443/v1/AUTH_3852...) Auth Token: AUTH_tk1a85a0af81364aa3ad104c9e035027c6 Account: AUTH_3852a9fd-b1e5-4498-8aa4-3a557cebff2e Containers: 3 Objects: 1 Bytes: 0 Accept-Ranges: bytes

On Glance node:

vi /etc/glance/glance-api.conf

Which backend store should Glance use by default is not specified

in a request to add a new image to Glance? Default: 'file'

Available choices are 'file', 'swift', and 's3'

default_store = swift

============ Swift Store Options =============================

Address where the Swift authentication service lives

swift_store_auth_address = 172.17.1.125:443/v1.0/

User to authenticate against the Swift authentication service

swift_store_user = test:tester

Auth key for the user authenticating against the

Swift authentication service

swift_store_key = AUTH_tk1a85a0af81364aa3ad104c9e035027c6

Container within the account that the account should use

for storing images in Swift

swift_store_container = CONTAINER

Do we create the container if it does not exist?

swift_store_create_container_on_put = True

Whether to use ServiceNET to communicate with the Swift storage servers.

(If you aren't RACKSPACE, leave this False!)

#

To use ServiceNET for authentication, prefix hostname of

swift_store_auth_address with 'snet-'.

Ex. https://example.com/v1.0/ -> https://snet-example.com/v1.0/

swift_enable_snet = False

Then on glance node, try to add an image. root@glance-node:~# glance add name="swift2" is_public=true < /tmp/test.iso Failed to add image. Got error: 400 Bad Request

The server could not comply with the request since it is either malformed or otherwise incorrect.

Error uploading image: global name 'swift_client' is not defined
Note: Your image metadata may still be in the registry, but the image's status will likely be 'killed'.

2011-08-09 15:36:16 -0500 asked a question glance does not work when working with swift

My swift server is working well, and also glance server also works well when using file "default_store = file", but when I change to "default_store = swift", "glance add" will not work, can any of you help check why?

Thanks in advance!

root@glance-node:/tmp# glance add name="swift2" is_public=true < /tmp/test.iso Failed to add image. Got error: 400 Bad Request

The server could not comply with the request since it is either malformed or otherwise incorrect.

Error uploading image: global name 'swift_client' is not defined
Note: Your image metadata may still be in the registry, but the image's status will likely be 'killed'. root@glance-node:/tmp# cat /etc/glance/glance-api.conf [DEFAULT]

Show more verbose log output (sets INFO log level output)

verbose = True

Show debugging output in logs (sets DEBUG log level output)

debug = False

Which backend store should Glance use by default is not specified

in a request to add a new image to Glance? Default: 'file'

Available choices are 'file', 'swift', and 's3'

default_store = swift

Address to bind the API server

bind_host = 0.0.0.0

Port the bind the API server to

bind_port = 9292

Address to find the registry server

registry_host = 0.0.0.0

Port the registry server is listening on

registry_port = 9191

Log to this file. Make sure you do not set the same log

file for both the API and registry servers!

log_file = /var/log/glance/api.log

============ Filesystem Store Options ========================

Directory that the Filesystem backend store

writes image data to

filesystem_store_datadir = /var/lib/glance/images/

============ Swift Store Options =============================

Address where the Swift authentication service lives

swift_store_auth_address = 172.17.1.125:443/v1.0/

User to authenticate against the Swift authentication service

swift_store_user = tester

Auth key for the user authenticating against the

Swift authentication service

swift_store_key = tk361dc384f1214cae898e8271109dad3f

Container within the account that the account should use

for storing images in Swift

swift_store_container = CONTAINER

Do we create the container if it does not exist?

swift_store_create_container_on_put = True

Whether to use ServiceNET to communicate with the Swift storage servers.

(If you aren't RACKSPACE, leave this False!)

#

To use ServiceNET for authentication, prefix hostname of

swift_store_auth_address with 'snet-'.

Ex. https://example.com/v1.0/ -> https://snet-example.com/v1.0/

swift_enable_snet = False

============ S3 Store Options =============================

Address where the S3 authentication service lives

s3_store_host = 127.0.0.1:8080/v1.0/

User to authenticate against the S3 authentication service

s3_store_access_key = <20-char AWS access key>

Auth key for the user authenticating against the

S3 authentication service

s3_store_secret_key = <40-char AWS secret key>

Container within the account that the account should use

for storing images in S3. Note that S3 has a flat namespace,

so you need a unique bucket name for your glance images. An

easy way to do this is append your AWS access key to "glance".

S3 buckets in AWS must be lowercased, so remember to lowercase

your AWS access key if you use it in your bucket name below!

s3_store_bucket = <lowercased 20-char="" aws="" access="" key="">glance

Do we create the bucket if it does not ...

(more)
2011-08-09 02:39:05 -0500 asked a question Install Multi-node of swift failed

Hi, I was now trying to install multi-node swift, but failed to start up proxy-server.

I was using swauth, and I can create a single node successfully, but failed to create multi-node, can anyone give some help?

Thanks in advance!

/usr/bin/swift-proxy-server /etc/swift/proxy-server.conf /usr/lib/pymodules/python2.6/paste/deploy/loadwsgi.py:8: UserWarning: Module netifaces was already imported from /usr/lib/pymodules/python2.6/netifaces.so, but /usr/lib/pymodules/python2.6 is being added to sys.path import pkg_resources Traceback (most recent call last): File "/usr/bin/swift-proxy-server", line 22, in <module> run_wsgi(conf_file, 'proxy-server', default_port=8080, *options) File "/root/swift/trunk/swift/common/wsgi.py", line 122, in run_wsgi File "/usr/lib/pymodules/python2.6/paste/deploy/loadwsgi.py", line 204, in loadapp return loadobj(APP, uri, name=name, *kw) File "/usr/lib/pymodules/python2.6/paste/deploy/loadwsgi.py", line 224, in loadobj global_conf=global_conf) File "/usr/lib/pymodules/python2.6/paste/deploy/loadwsgi.py", line 248, in loadcontext global_conf=global_conf) File "/usr/lib/pymodules/python2.6/paste/deploy/loadwsgi.py", line 278, in _loadconfig return loader.get_context(object_type, name, global_conf) File "/usr/lib/pymodules/python2.6/paste/deploy/loadwsgi.py", line 405, in get_context global_additions=global_additions) File "/usr/lib/pymodules/python2.6/paste/deploy/loadwsgi.py", line 503, in _pipeline_app_context for name in pipeline[:-1]] File "/usr/lib/pymodules/python2.6/paste/deploy/loadwsgi.py", line 409, in get_context section) File "/usr/lib/pymodules/python2.6/paste/deploy/loadwsgi.py", line 431, in _context_from_use object_type, name=use, global_conf=global_conf) File "/usr/lib/pymodules/python2.6/paste/deploy/loadwsgi.py", line 361, in get_context global_conf=global_conf) File "/usr/lib/pymodules/python2.6/paste/deploy/loadwsgi.py", line 248, in loadcontext global_conf=global_conf) File "/usr/lib/pymodules/python2.6/paste/deploy/loadwsgi.py", line 285, in _loadegg return loader.get_context(object_type, name, global_conf) File "/usr/lib/pymodules/python2.6/paste/deploy/loadwsgi.py", line 561, in get_context object_type, name=name) File "/usr/lib/pymodules/python2.6/paste/deploy/loadwsgi.py", line 587, in find_egg_entry_point possible.append((entry.load(), protocol, entry.name)) File "/usr/lib/python2.6/dist-packages/pkg_resources.py", line 1948, in load entry = __import__(self.module_name, globals(),globals(), ['__name__']) ImportError: No module named middleware.healthcheck

root@proxy-node:/etc/swift# cat proxy-server.conf [DEFAULT] bind_port = 443 bind_ip = 172.17.27.230 cert_file = /etc/swift/cert.crt key_file = /etc/swift/cert.key user = swiftdemo log_facility = LOG_LOCAL1

[pipeline:main] pipeline = healthcheck cache swauth proxy-server

[app:proxy-server] use = egg:swift#proxy allow_account_management = true

[filter:swauth] use = egg:swauth#swauth super_admin_key = swauthkey default_swift_cluster = local#https://172.17.27.230:443/v1

[filter:healthcheck] use = egg:swift#healthcheck

[filter:cache] use = egg:swift#memcache

2011-08-09 02:35:56 -0500 answered a question Failed to get Get an X-Storage-Url and X-Auth-Token

Hi, I was able to create a single node swift and it runs well with swauth, but when run multi-node, I got into the following errors, can someone give any help? Thanks.

/usr/bin/swift-proxy-server /etc/swift/proxy-server.conf /usr/lib/pymodules/python2.6/paste/deploy/loadwsgi.py:8: UserWarning: Module netifaces was already imported from /usr/lib/pymodules/python2.6/netifaces.so, but /usr/lib/pymodules/python2.6 is being added to sys.path import pkg_resources Traceback (most recent call last): File "/usr/bin/swift-proxy-server", line 22, in <module> run_wsgi(conf_file, 'proxy-server', default_port=8080, *options) File "/root/swift/trunk/swift/common/wsgi.py", line 122, in run_wsgi File "/usr/lib/pymodules/python2.6/paste/deploy/loadwsgi.py", line 204, in loadapp return loadobj(APP, uri, name=name, *kw) File "/usr/lib/pymodules/python2.6/paste/deploy/loadwsgi.py", line 224, in loadobj global_conf=global_conf) File "/usr/lib/pymodules/python2.6/paste/deploy/loadwsgi.py", line 248, in loadcontext global_conf=global_conf) File "/usr/lib/pymodules/python2.6/paste/deploy/loadwsgi.py", line 278, in _loadconfig return loader.get_context(object_type, name, global_conf) File "/usr/lib/pymodules/python2.6/paste/deploy/loadwsgi.py", line 405, in get_context global_additions=global_additions) File "/usr/lib/pymodules/python2.6/paste/deploy/loadwsgi.py", line 503, in _pipeline_app_context for name in pipeline[:-1]] File "/usr/lib/pymodules/python2.6/paste/deploy/loadwsgi.py", line 409, in get_context section) File "/usr/lib/pymodules/python2.6/paste/deploy/loadwsgi.py", line 431, in _context_from_use object_type, name=use, global_conf=global_conf) File "/usr/lib/pymodules/python2.6/paste/deploy/loadwsgi.py", line 361, in get_context global_conf=global_conf) File "/usr/lib/pymodules/python2.6/paste/deploy/loadwsgi.py", line 248, in loadcontext global_conf=global_conf) File "/usr/lib/pymodules/python2.6/paste/deploy/loadwsgi.py", line 285, in _loadegg return loader.get_context(object_type, name, global_conf) File "/usr/lib/pymodules/python2.6/paste/deploy/loadwsgi.py", line 561, in get_context object_type, name=name) File "/usr/lib/pymodules/python2.6/paste/deploy/loadwsgi.py", line 587, in find_egg_entry_point possible.append((entry.load(), protocol, entry.name)) File "/usr/lib/python2.6/dist-packages/pkg_resources.py", line 1948, in load entry = __import__(self.module_name, globals(),globals(), ['__name__']) ImportError: No module named middleware.healthcheck

2011-08-05 14:38:02 -0500 answered a question Failed to get Get an X-Storage-Url and X-Auth-Token

BTW: I was using http://swift.openstack.org/howto_installmultinode.html (http://swift.openstack.org/howto_inst...) for my multi node configuration. Thanks

2011-08-05 14:35:05 -0500 answered a question Failed to get Get an X-Storage-Url and X-Auth-Token

Thanks Anne for the quick response, after I update proxy-server, I got the previous error in /var/log/syslog:

Aug 5 22:30:44 proxy-node proxy-server UNCAUGHT EXCEPTION#012Traceback (most recent call last):#012 File "/usr/bin/swift-proxy-server", line 22, in <module>#012 run_wsgi(conf_file, 'proxy-server', default_port=8080, *options)#012 File "/usr/lib/pymodules/python2.6/swift/common/wsgi.py", line 126, in run_wsgi#012 app = loadapp('config:%s' % conf_file, global_conf={'log_name': log_name})#012 File "/usr/lib/pymodules/python2.6/paste/deploy/loadwsgi.py", line 204, in loadapp#012 return loadobj(APP, uri, name=name, *kw)#012 File "/usr/lib/pymodules/python2.6/paste/deploy/loadwsgi.py", line 224, in loadobj#012 global_conf=global_conf)#012 File "/usr/lib/pymodules/python2.6/paste/deploy/loadwsgi.py", line 248, in loadcontext#012 global_conf=global_conf)#012 File "/usr/lib/pymodules/python2.6/paste/deploy/loadwsgi.py", line 278, in _loadconfig#012 return loader.get_context(object_type, name, global_conf)#012 File "/usr/lib/pymodules/python2.6/paste/deploy/loadwsgi.py", line 405, in get_context#012 global_additions=global_additions)#012 File "/usr/lib/pymodules/python2.6/paste/deploy/loadwsgi.py", line 503, in _pipeline_app_context#012 for name in pipeline[:-1]]#012 File "/usr/lib/pymodules/python2.6/paste/deploy/loadwsgi.py", line 363, in get_context#012 object_type, name=name)#012 File "/usr/lib/pymodules/python2.6/paste/deploy/loadwsgi.py", line 528, in find_config_section#012 self.filename))#012LookupError: No section 'auth' (prefixed by 'filter') found in config /etc/swift/proxy-server.conf

I searched this problem and found the logger by resolving the problem using auth instead of tempauth: https://answers.launchpad.net/swift/+question/164132 (https://answers.launchpad.net/swift/+...)

BTW: I'm going to first create a POC env and later might put into producton, so it would be great if I can get a solution for this.

So can you please give more help on this? Again, thanks very much for your help. ;-)

2011-08-05 10:53:24 -0500 answered a question Failed to get Get an X-Storage-Url and X-Auth-Token

/var/log/syslog report the following:

Aug 5 18:44:01 proxy-node proxy-server - 172.17.1.121 05/Aug/2011/10/44/01 GET /auth/v1.0 HTTP/1.0 401 - curl/7.19.7%20%28x86_64-pc-linux-gnu%29%20libcurl/7.19.7%20OpenSSL/0.9.8k%20zlib/1.2.3.3%20libidn/1.15 - - - - tx0d3c87d4-c21d-49d7-bd88-89b9c57c5d58 - 0.0005 Aug 5 18:50:12 proxy-node proxy-server - 172.17.1.121 05/Aug/2011/10/50/12 GET /auth/v1.0 HTTP/1.0 401 - curl/7.19.7%20%28x86_64-pc-linux-gnu%29%20libcurl/7.19.7%20OpenSSL/0.9.8k%20zlib/1.2.3.3%20libidn/1.15 - - - - tx03fb2b60-163f-43db-ad37-689bcf189975 - 0.0004

2011-08-05 10:10:33 -0500 answered a question Failed to get Get an X-Storage-Url and X-Auth-Token

It would be highly appreciated if some one can give some on-time help!

2011-08-05 10:08:56 -0500 asked a question Failed to get Get an X-Storage-Url and X-Auth-Token

Hi All,

I'm currently trying to create a swift environment for some test, but got the following error when getting an X-Storage-Url and X-Auth-Token using test command.

root@proxy-node:/etc/swift# curl -k -v -H 'X-Storage-User: system:root' -H 'X-Storage-Pass: testpass' https://$PROXY_LOCAL_NET_IP:8080/auth/v1.0 * About to connect() to 172.17.1.121 port 8080 (#0) * Trying 172.17.1.121... connected * Connected to 172.17.1.121 (172.17.1.121) port 8080 (#0) * successfully set certificate verify locations: * CAfile: none CApath: /etc/ssl/certs * SSLv3, TLS handshake, Client hello (1): * SSLv3, TLS handshake, Server hello (2): * SSLv3, TLS handshake, CERT (11): * SSLv3, TLS handshake, Server finished (14): * SSLv3, TLS handshake, Client key exchange (16): * SSLv3, TLS change cipher, Client hello (1): * SSLv3, TLS handshake, Finished (20): * SSLv3, TLS change cipher, Client hello (1): * SSLv3, TLS handshake, Finished (20): * SSL connection using AES256-SHA * Server certificate: * subject: C=CH; ST=SHANXI; L=XIAN; O=Platform; OU=Computing; CN=Guangya; emailAddress=gyliu@platform.com * start date: 2011-08-05 09:36:55 GMT * expire date: 2011-09-04 09:36:55 GMT * common name: Guangya (does not match '172.17.1.121') * issuer: C=CH; ST=SHANXI; L=XIAN; O=Platform; OU=Computing; CN=Guangya; emailAddress=gyliu@platform.com * SSL certificate verify result: self signed certificate (18), continuing anyway.

GET /auth/v1.0 HTTP/1.1 User-Agent: curl/7.19.7 (x86_64-pc-linux-gnu) libcurl/7.19.7 OpenSSL/0.9.8k zlib/1.2.3.3 libidn/1.15 Host: 172.17.1.121:8080 Accept: / X-Storage-User: system:root X-Storage-Pass: testpass

< HTTP/1.1 401 Unauthorized < Content-Length: 358 < Content-Type: text/html; charset=UTF-8 < Date: Fri, 05 Aug 2011 09:57:37 GMT < <html> <head> <title>401 Unauthorized</title> </head> <body>

401 Unauthorized

This server could not verify that you are authorized to access the document you requested. Either you supplied the wrong credentials (e.g., bad password), or your browser does not understand how to supply the credentials required.

</body> * Connection #0 to host 172.17.1.121 left intact * Closing connection #0 * SSLv3, TLS alert, Client hello (1): </html>root@proxy-node:/etc/swift# vi proxy-server.conf

root@proxy-node:/etc/swift# cat proxy-server.conf [DEFAULT] cert_file = /etc/swift/cert.crt key_file = /etc/swift/cert.key bind_port = 8080 workers = 8 user = swift

[pipeline:main] pipeline = healthcheck cache auth proxy-server

[app:proxy-server] use = egg:swift#proxy allow_account_management = true

[filter:auth] use = egg:swift#auth user_system_root = testpass .admin https://172.17.1.121:8080/v1/AUTH_system

[filter:healthcheck] use = egg:swift#healthcheck

[filter:cache] use = egg:swift#memcache memcache_servers = 172.17.1.121:11211

I was using multi-node configuration, the steps that I followed is get from: http://swift.openstack.org/howto_installmultinode.html (http://swift.openstack.org/howto_inst...)

Thanks,

Guangya Liu gyliu@platform.com