Ask Your Question

Server Support's profile - activity

2014-05-01 01:07:58 -0500 received badge  Famous Question (source)
2014-04-07 01:19:27 -0500 received badge  Famous Question (source)
2014-03-04 03:15:26 -0500 received badge  Notable Question (source)
2014-02-26 03:46:18 -0500 received badge  Enthusiast
2014-02-21 15:42:47 -0500 received badge  Notable Question (source)
2014-02-21 11:12:43 -0500 received badge  Popular Question (source)
2014-02-21 01:09:14 -0500 received badge  Popular Question (source)
2014-02-20 20:02:53 -0500 received badge  Editor (source)
2014-02-20 10:04:46 -0500 asked a question Confused on assigning ip ranges

Hi,

We have an issue on installing the openstack. Mainly we are struggling on the network of the openstack installation. We have 5 servers and installed each service in seperate servers ie.,
1st server: Controller, glance, keystone, dashboard
2nd Server: Nova compute
3rd " : Block storage (Cinder)
4th " : Object (Swift)
5th " : Network (neutron)

When we tried to configure the openswitch VLAN, we have stucked an area that is DATA_INTERFACE. Pleas have a look at the configuration mentioned below:

===========================================================
1. Configure OVS to use VLANS. Edit the /etc/neutron/plugins/openvswitch/ovs_neutron_plugin.ini file:
[ovs]
tenant_network_type = vlan
network_vlan_ranges = physnet1:1:4094
bridge_mappings = physnet1:br-DATA_INTERFACE

2.Create the bridge for DATA_INTERFACE and add DATA_INTERFACE to it:
ovs-vsctl add-br br-DATA_INTERFACE
ovs-vsctl add-port br-DATA_INTERFACE DATA_INTERFACE

3.Transfer the IP address for DATA_INTERFACE to the bridge in the same way that you transferred the EXTERNAL_INTERFACE IP address to br-ex. However, do not turn on promiscuous mode.

==============================================================

Please tell me which type of ip shall we assign here (public ip or private ip). We have ips on the range given below

========================================================
Public subnet: 31.x.y.0/27
31.x.y.0 Network
31.x.y.1 Gateways
31.x.y.2 to 31.x.y.30 Available ips

Private subnet: 10.xx.yy.0/24
10.xx.yy.0 Network Address
10.xx.yy.1 gateway Address
10.xx.yy.2 to 10.xx.y.254 Available ips

31.xxx.yyy.0/24
31.xxx.yyy.0 Network
31.xxx.yyy.1 Gateway Address
31.xxx.yyy.2 to 31.xxx.yyy.254 Available ips

185.xxxx.yyyy.0/25
185.xxxx.yyyy.0 Network
185.xxxx.yyyy.1 Gateway
185.xxxx.yyyy.2 to 185.xxxx.yyyy.126 IPs
185.xxxx.yyyy.127 Broadcast

=======================================================
These are my ranges. Please suggest me which one we assign as DATA_INTERFACE, MGMT_INTERFACE and EXTERNAL_INTERFACE.??
We are waiting for your valuable updates.

2014-02-20 09:59:49 -0500 asked a question Bridge configured in network node - But ip not allocate in VMs

Hi,

Im trying to setup an openstack multinode installation for a private cloud setup in centos platform. I'm struggling to setting up the neutron in the server. I've completed the installation of the service in the network node,compute and controller by following the havana doc of openstack.

There are 5 servers and installed each service in separate servers ie.,
1st server: Controller, glance, keystone, dashboard
2nd Server: Nova compute
3rd " : Block storage (Cinder)
4th " : Object (Swift)
5th " : Network (neutron)

We have 3 NIC in the network server, we have tried to configure the network part on this server. Now we have configured a bridge br-eth2 with the interface eth2 ip as the external interface. Now we can see the eth2 ip on the bridge br-eth2. Here is our current ifconfig in the network node:

br-eth2 Link encap:Ethernet HWaddr 00:XX:XX:XX:XX:XX
inet addr:31.x.y.z Bcast:31.x.y.31 Mask:255.255.255.224
inet6 addr: fe80::xxxx.xxx.xxx.xxxx/64 Scope:Link
.....
...

br-int Link encap:Ethernet HWaddr 86:xx:xx:xx:xx
inet6 addr: fe80:xxxx.xxxx.xxxx.xxxx/64 Scope:Link
....
...

br-tun Link encap:Ethernet HWaddr 76:xx.xx.xx.xx
inet6 addr: fe80:xxxx.xxxx.xxxx.xxxx/64 Scope:Link
....
..

eth0 Link encap:Ethernet HWaddr 00:xx.xx.xx.xx.xx
inet addr:31.x.y.z1 Bcast:31.x.y.31 Mask:255.255.255.224
.....
..

inet6 addr: fe80::xxx.xxx.xxx.xxx/64 Scope:Link
eth1 Link encap:Ethernet HWaddr 00:xx.xx.xx.xx.xx
inet addr:10.x.y.z Bcast:10.x.y.255 Mask:255.255.255.0
......
..

eth2 Link encap:Ethernet HWaddr 00:xx.xx.xxx..xxx
inet6 addr: xxx.xxx.xxx.xxxx/64 Scope:Link

int-br-eth2 Link encap:Ethernet HWaddr 16:xx.xx.xx.xx
inet6 addr: fe80::xxxx.xxx.xxxx.xxxx/64 Scope:Link

My doubt is that according to the docs it says when you port a bridge to a device, then the device ip will not ping. Is that true? First time when i did i too faced this issue.
Then i some how managed the bridge ip to ping and get it displayed under the bridge device. Is this should be done like this way ?

Please could advise me whether i'm going wrong!!! :(

After this I installed the openvswitch plugin and enabled the GRE Tunneling as the network type. Then followed the step: creating base neutron network and configured a external network, internal network and integrated this two networks with a router too.

Is that all to do, now is it ready to launch an instance ?

I tried one instance to launch but unfortunately it will not get an ip and the launch fails. :( In the subnet created we can see floating ip's created but the status is down.

I hope you have a got an idea about the issue im facing. Please kindly go through advice me whether I'm missing ...




















































(more)