rajcoumar's profile - activity

2015-04-28 13:46:05 -0600 received badge  Famous Question (source)
2015-04-16 04:48:57 -0600 received badge  Favorite Question (source)
2015-04-15 03:33:40 -0600 marked best answer All nova services throw same error while start the service

I am Working on Openstack Havana Installations. I installed Keystone, Cinder, Glance, nova-novncproxy, novnc, nova-api, nova-ajax-console-proxy, nova-cert, nova-conductor, nova-consoleauth nova-doc nova-scheduler and python-novaclient in one Virtual machine (Ubuntu 12.04 server ).

I installed nova-compute-kvm, nova-network and nova-api-metadata in the KVM machine. While starting the services I got common errors in all the service logs.

nova-scheduler log,

   2014-07-06 13:30:38.612 22579 ERROR nova.openstack.common.threadgroup [-] (ProgrammingError) (1146, "Table 'nova.services' doesn't exist") 'SELECT services.created_at AS services_created_at, services.updated_at AS services_updated_at, services.deleted_at AS services_deleted_at, services.deleted AS services_deleted, services.id AS services_id, services.host AS services_host, services.`binary` AS services_binary, services.topic AS services_topic, services.report_count AS services_report_count, services.disabled AS services_disabled, services.disabled_reason AS services_disabled_reason \nFROM services \nWHERE services.deleted = %s AND services.host = %s AND services.`binary` = %s \n LIMIT %s' (0, 'osservices', 'nova-scheduler', 1)

nova-cert log,

   2014-07-06 13:32:01.263 22654 ERROR nova.openstack.common.threadgroup [-] (ProgrammingError) (1146, "Table 'nova.services' doesn't exist") 'SELECT services.created_at AS services_created_at, services.updated_at AS services_updated_at, services.deleted_at AS services_deleted_at, services.deleted AS services_deleted, services.id AS services_id, services.host AS services_host, services.`binary` AS services_binary, services.topic AS services_topic, services.report_count AS services_report_count, services.disabled AS services_disabled, services.disabled_reason AS services_disabled_reason \nFROM services \nWHERE services.deleted = %s AND services.host = %s AND services.`binary` = %s \n LIMIT %s' (0, 'osservices', 'nova-cert', 1)

2014-07-06 13:32:01.263 22654 TRACE nova.openstack.common.threadgroup Traceback (most recent call last):

nova-conductor log,

  2014-07-06 13:32:52.371 22706 ERROR nova.openstack.common.threadgroup [-] (ProgrammingError) (1146, "Table 'nova.services' doesn't exist") 'SELECT services.created_at AS services_created_at, services.updated_at AS services_updated_at, services.deleted_at AS services_deleted_at, services.deleted AS services_deleted, services.id AS services_id, services.host AS services_host, services.`binary` AS services_binary, services.topic AS services_topic, services.report_count AS services_report_count, services.disabled AS services_disabled, services.disabled_reason AS services_disabled_reason \nFROM services \nWHERE services.deleted = %s AND services.host = %s AND services.`binary` = %s \n LIMIT %s' (0, 'osservices', 'nova-conductor', 1)

nova-consoleauth log,

  2014-07-06 13:33:33.769 22756 ERROR nova.openstack.common.threadgroup [-] (ProgrammingError) (1146, "Table 'nova.services' doesn't exist") 'SELECT services.created_at AS services_created_at, services.updated_at AS services_updated_at, services.deleted_at AS services_deleted_at, services.deleted AS services_deleted, services.id AS services_id, services.host AS services_host, services.`binary` AS services_binary, services.topic AS services_topic, services.report_count AS services_report_count, services.disabled AS services_disabled, services.disabled_reason AS services_disabled_reason \nFROM services \nWHERE services.deleted = %s AND services.host = %s AND services.`binary` = %s \n LIMIT %s' (0, 'osservices', 'nova-consoleauth', 1)

nova-network logs,

2014-07-06 15:37:22.158 7756 TRACE nova.openstack.common.threadgroup ProgrammingError: (ProgrammingError) (1146, "Table 'nova.networks' doesn't exist") 'SELECT networks.created_at AS networks_created_at, networks.updated_at AS networks_updated_at, networks.deleted_at AS networks_deleted_at, networks.deleted AS networks_deleted, networks.id AS networks_id, networks.label AS networks_label, networks.injected AS networks_injected, networks.cidr AS networks_cidr, networks.cidr_v6 AS networks_cidr_v6, networks.multi_host AS networks_multi_host, networks.gateway_v6 AS networks_gateway_v6, networks.netmask_v6 AS networks_netmask_v6, networks.netmask AS networks_netmask, networks.bridge AS networks_bridge, networks.bridge_interface AS ...
(more)
2015-02-19 21:43:00 -0600 commented question Nova-compute not showing on nova service-list(controller)

Could you paste nova.conf file of compute node. Where did you installed rabbitmq server. Whether rabbitmq server is running ? Add your rabbitmq server ip address, username and password in nova.conf file on compute node

2015-02-11 07:17:20 -0600 commented question How to setup dns in Cloud init for openstack instances

@jtaguinerd ssh openstack@ubuntu-cloud-init001 ssh: Could not resolve hostname ubuntu-cloud-init001: Name or service not known

2015-02-11 07:16:34 -0600 commented question How to setup dns in Cloud init for openstack instances

I can able to ssh using ip address of instance vm but unable to ssh the instance vm

2015-02-11 06:40:10 -0600 commented question How to set nova network gateway and dns

Could you provide the document to setup dnsmasq for instances using cloud init in nova network

2015-02-11 06:15:27 -0600 commented answer Instance hostname not match with dns

@don how to setup dnsmasq for the instances ? could you guide me

2015-02-11 03:12:55 -0600 received badge  Famous Question (source)
2015-02-10 13:16:27 -0600 received badge  Notable Question (source)
2015-02-10 08:25:35 -0600 received badge  Popular Question (source)
2015-02-10 02:58:53 -0600 asked a question How to setup dns in Cloud init for openstack instances

Right now I am working on Openstack Havana. For internal networks we are using nova-network not neutron. My setup details are Controller node ( Keystone, Cinder, Glance, rabbitmq server and Nova) and Compute node (nova Compute, nova api metadata and nova network)

Everything working fine. Now I want to dns setup for instances only internal networks. I dont want dns for floating ip. I want dns setup for internal networks

How can we setup dns for instances ?

2015-01-14 07:31:59 -0600 received badge  Famous Question (source)
2015-01-14 07:31:59 -0600 received badge  Popular Question (source)
2015-01-14 07:31:59 -0600 received badge  Notable Question (source)
2015-01-09 23:43:20 -0600 received badge  Scholar (source)
2015-01-08 00:58:18 -0600 received badge  Famous Question (source)
2015-01-06 03:36:49 -0600 received badge  Famous Question (source)
2015-01-06 02:58:46 -0600 commented answer lbaas members inactive, http service unavailable

20.20.20.2 is internal network.

2015-01-06 00:48:33 -0600 commented answer lbaas members inactive, http service unavailable

now lb member status as active unable to get the curl command output. ip netns exec qrouter-3d3af3dd-92c4-4080-a18e-ceb252cb3550 curl http://20.20.20.2

curl: (7) couldn't connect to host

2015-01-06 00:46:18 -0600 marked best answer how to setup fwaas in openstack icehouse

3 Node setup : Controller, Compute and Neutron network nodes.

  1. Controller node : Installed the Cinder, Glance, Nova api and horizon packages.

  2. Compute node : Installed nova compute and neutron server packages

  3. Network node : Installed neutron packages.

Everything working fine. Now I want to setup the FWAAS. How to setup fwaas in openstack icehouse. Could anyone provide me the configuration details.

2015-01-02 01:45:56 -0600 commented answer lbaas members inactive, http service unavailable

Nmap is failed. ip netns exec qrouter-3d3af3dd-92c4-4080-a18e-ceb252cb3550 nmap 20.20.20.8 -p 80

exec of nmap failed: No such file or directory

2015-01-01 02:03:29 -0600 commented answer lbaas members inactive, http service unavailable

@ foexle like this way i have to do,

neutron lb-healthmonitor-create --http-method HTTP --url-path http://20.20.20.8 --delay 3 --type HTTP --max-retries 3 --timeout 3

2015-01-01 01:06:00 -0600 commented answer lbaas members inactive, http service unavailable

like this way i have to do,

neutron lb-healthmonitor-create --http-method HTTP --url-path http://20.20.20.8 --delay 3 --type HTTP --max-retries 3 --timeout 3

2014-12-31 22:49:13 -0600 received badge  Notable Question (source)
2014-12-30 23:36:51 -0600 commented question lbaas members inactive, http service unavailable

anybody is there

2014-12-30 22:53:51 -0600 received badge  Notable Question (source)
2014-12-30 18:41:29 -0600 received badge  Popular Question (source)
2014-12-30 08:35:05 -0600 edited question lbaas members inactive, http service unavailable

Hi, I am working on openstack Icehouse. I taken 3 nodes setup

  1. Controller node: Keystone, Cinder packages, Glance packages, Rabbitmq and Nova packages are nova-api, nova-cert, nova-conductor, nova-consoleauth, nova-novncproxy, nova-scheduler & python-novaclient

  2. Compute node: Nova compute package and Neutron packages are neutron-common, neutron-plugin-ml2, neutron-plugin-openvswitch-agent & openvswitch-datapath-dkms

  3. Neutron Network node: Neutron packages are installed in this node. External and internal networks configured. Instance getting ip address everything working fine. Now i configured LBAAS. So installed neutron-lbaas-agent.

/etc/neutron/neutron.conf

service_plugins = router,firewall,lbaas
service_provider=LOADBALANCER:Haproxy:neutron.services.loadbalancer.drivers.haproxy.plugin_driver.HaproxyOnHostPluginDriver:default

/etc/neutron/lbaas_agent.ini

[DEFAULT]
debug = True
verbose = True
interface_driver = neutron.agent.linux.interface.OVSInterfaceDriver
ovs_use_veth = True
device_driver = neutron.services.loadbalancer.drivers.haproxy.namespace_driver.HaproxyNSDriver
[haproxy]

And I created lb pool (subnet-id c7666b81-18ea-4b86-9b76-61f5ef35bfee -- internal subnet = 20.20.20.0/24):

 # neutron lb-pool-create --lb-method ROUND_ROBIN --name lbaaspool01 --protocol HTTP --subnet-id c7666b81-18ea-4b86-9b76-61f5ef35bfee

Neutron LB member:

# neutron lb-member-create --address 20.20.20.8 --protocol-port 80  lbaaspool01
# neutron lb-member-create --address 20.20.20.6 --protocol-port 80  lbaaspool01

Neutron LB Health monitor:

# neutron lb-healthmonitor-create --delay 3 --type HTTP --max-retries  3 --timeout 3
# neutron lb-healthmonitor-associate  0743aa0a-e28a-4bb7-831a-07682027c244 lbaaspool01

Neutron LB VIP :

# neutron lb-vip-create --name myvip --protocol-port 80 --protocol HTTP --subnet-id c7666b81-18ea-4b86-9b76-61f5ef35bfee lbaaspool01

Then I created the floating ip address and add this floating ip address to the neutron vip port id.

# neutron floatingip-associate 7a372206-8008-46d2-ad07-556aeb100474  3d93ab3b-7ce4-48e3-8bc5-831123e5919f

While executing this command

 # neutron lb-member-list
+--------------------------------------+------------+---------------+----------------+----------+
| id                                   | address    | protocol_port | admin_state_up | status   |
+--------------------------------------+------------+---------------+----------------+----------+
| 10abaac3-3ee5-4619-a091-b61889fd281e | 20.20.20.8 |            80 | True           | INACTIVE |
| d6abb2da-2e42-4174-91b2-6618a5e690cc | 20.20.20.6 |            80 | True           | INACTIVE |
+--------------------------------------+------------+---------------+----------------+----------+

Member list is INACTIVE only.

And I tried the curl command using vip floating ip address

           # curl -w "\n" 10.192.1.134
             <html><body><h1>503 Service Unavailable</h1>
             No server is available to handle this request.
             </body></html>

           # curl http://10.192.1.134
             <html><body><h1>503 Service Unavailable</h1>
             No server is available to handle this request.
             </body></html>

          # ip netns exec qrouter-3d3af3dd-92c4-4080-a18e-ceb252cb3550 curl http://20.20.20.8
             curl: (7) couldn't connect to host

How to work in LBAAS. I am getting the loadbalancer member status as INACTIVE. If it is right means what's the next step to do ?

2014-12-30 07:11:51 -0600 received badge  Popular Question (source)
2014-12-30 04:44:35 -0600 received badge  Notable Question (source)
2014-12-30 04:44:35 -0600 received badge  Famous Question (source)
2014-12-30 04:44:35 -0600 received badge  Popular Question (source)
2014-12-30 03:48:57 -0600 commented question LBaas, How do we assign floating IP to the VIP
2014-12-30 03:48:52 -0600 commented answer LBaas, How do we assign floating IP to the VIP
2014-12-30 03:48:44 -0600 commented question VPNaaS, FWaaS and LBaaS on Openstack Icehouse
2014-12-30 03:48:27 -0600 commented question what is a vip, what is the use of it?