Ask Your Question

Akshat's profile - activity

2016-04-04 01:04:49 -0500 received badge  Famous Question (source)
2014-12-10 19:28:17 -0500 received badge  Notable Question (source)
2014-10-27 08:06:02 -0500 received badge  Popular Question (source)
2014-06-26 12:23:48 -0500 commented question Problem with dnsmasq getting killed.

Unfortunately there is no error in the logs....yes, we are using a single subnet which has multiple cidrs.

2014-06-26 10:08:48 -0500 asked a question Problem with dnsmasq getting killed.

Hi,

We have a openstack environment with 1 controller , 1 network node and many computes, there are multiple such environments some running grizzly and some running havana.

We are facing a common problem everywhere, the dnsmasq process dies on it own and we have to restart the dhcp agent or add the network back to the dhcp agent in case it dies.

We have a lease period of 4 hours and running a load of approx. 800+ VMs.

Has someone faced a similar problem if not any suggestions/pointers will really be helpful.

2014-06-26 10:04:39 -0500 commented answer VM loosing SSH

Nope, the setup has 2 controllers running nova,glance and quantum/neutron server, 2 network nodes running the neutron agents(dhcp,l3,metadata,ovs) and computes running nova-compute and ovs-agent. VMs are running in compute node.

2014-06-25 23:51:41 -0500 received badge  Popular Question (source)
2014-06-25 11:54:13 -0500 commented answer VM loosing SSH

Thanks for replying Shankar,

I did checked the dump flows and I see a normal flow , so the flows look proper. Also I do not see any errors in logs.

Please let me know which log files you want, I will post them.

2014-06-25 09:45:24 -0500 asked a question VM loosing SSH

Hi,

I am facing a strange problem, where a perfectly running VM becomes unreachable all of a sudden and I have to restart openvswitch agent on the compute to fix it.

This happens in both grizzly and havana with openvswitch networking.

Has anybody faced a similar problem, any pointers will be helpful.

2014-06-25 09:42:39 -0500 received badge  Famous Question (source)
2014-02-24 02:46:24 -0500 received badge  Notable Question (source)
2014-02-15 05:17:47 -0500 received badge  Popular Question (source)
2014-02-12 00:35:05 -0500 asked a question Connectivity breaks between compute and controller

Hi All,

I have a openstack setup(Grizzly) with 1 controller and multiple compute nodes. I am facing an issue where the connectivity of controller and one of the compute nodes breaks. The nova service-list command shows that compute as down.

I see the below error in the compute logs at the same time:

2014-02-11 03:06:16.216 28879 ERROR nova.servicegroup.drivers.db [-] model server went away
2014-02-11 03:06:16.216 28879 TRACE nova.servicegroup.drivers.db Traceback (most recent call last):
2014-02-11 03:06:16.216 28879 TRACE nova.servicegroup.drivers.db   File "/usr/lib/python2.6/site-packages/nova/servicegroup/drivers/db.py", line 88, in _report_state
2014-02-11 03:06:16.216 28879 TRACE nova.servicegroup.drivers.db     report_count = service.service_ref['report_count'] + 1
2014-02-11 03:06:16.216 28879 TRACE nova.servicegroup.drivers.db TypeError: 'NoneType' object is unsubscriptable

Also, restarting the nova-compute service on the compute node fixes the connectivity back.

Any pointers to debug this will be helpful.