Ask Your Question

KP's profile - activity

2017-08-11 00:37:29 -0500 received badge  Famous Question (source)
2017-08-11 00:37:29 -0500 received badge  Notable Question (source)
2017-08-11 00:37:29 -0500 received badge  Popular Question (source)
2017-04-25 20:01:13 -0500 answered a question Horizon could not import openstack_dashboard.settings

NOT a complete ANSWER:

The dependancies went away after doing a sudo -E pip install -r requirements.txt in horizon/.

Now the error is:

2017-04-25 17:27:00.717 | IOError: [Errno 13] Permission denied: '/usr/lib/python2.7/site-packages/openstack_dashboard/local/_usr_lib_python2.7_site-packages_openstack_dashboard_local_.secret_key_store.lock'

Any tips?

2017-04-25 13:00:37 -0500 commented question Horizon could not import openstack_dashboard.settings

When i manually installed xstatic_jquery the above error went away. Now, horizon is giving an error in jquery_migrate. ...| ImportError: Could not import settings 'openstack_dashboard.settings' (Is it on sys.path? Is there an import error in the settings file?): No module named jquery_migrate

2017-04-25 12:25:58 -0500 asked a question Horizon could not import openstack_dashboard.settings

Hello, The Base OS is CentOS 7.3.1611. I am trying to install stable/ocata using devstack. This is a new setup, didn't have any previous Openstack installed.

I was earlier getting the error about the horizon..egginfo, not found. I manually ran setup in the horizon directory and then stacked it. Now, i am getting the following error. Looks like i have posted a similar question earlier and IIRC i abandoned that setup and proceeded with my work in a different base OS and devstack installation went through. Is there a dependency issue with the base apache package or similar?

2017-04-25 10:06:57.040 | +functions-common:_safe_permission_operation:2170 sudo chown -R localadmin /opt/stack/horizon/horizon.egg-info 2017-04-25 10:06:57.056 | +lib/horizon:configure_horizon:84 cd /opt/stack/horizon 2017-04-25 10:06:57.062 | +lib/horizon:configure_horizon:84 /usr/bin/python manage.py compilemessages 2017-04-25 10:06:57.754 | Warning: Could not import Horizon dependencies. This is normal during installation. 2017-04-25 10:06:57.755 | WARNING:root:No local_settings file found. 2017-04-25 10:06:57.756 | Traceback (most recent call last): 2017-04-25 10:06:57.756 | File "manage.py", line 23, in <module> 2017-04-25 10:06:57.756 | execute_from_command_line(sys.argv) 2017-04-25 10:06:57.756 | File "/usr/lib/python2.7/site-packages/django/core/management/__init__.py", line 399, in execute_from_command_line 2017-04-25 10:06:57.756 | utility.execute() 2017-04-25 10:06:57.756 | File "/usr/lib/python2.7/site-packages/django/core/management/__init__.py", line 392, in execute 2017-04-25 10:06:57.756 | self.fetch_command(subcommand).run_from_argv(self.argv) 2017-04-25 10:06:57.756 | File "/usr/lib/python2.7/site-packages/django/core/management/__init__.py", line 261, in fetch_command 2017-04-25 10:06:57.756 | commands = get_commands() 2017-04-25 10:06:57.756 | File "/usr/lib/python2.7/site-packages/django/core/management/__init__.py", line 107, in get_commands 2017-04-25 10:06:57.756 | apps = settings.INSTALLED_APPS 2017-04-25 10:06:57.756 | File "/usr/lib/python2.7/site-packages/django/conf/__init__.py", line 54, in __getattr__ 2017-04-25 10:06:57.756 | self._setup(name) 2017-04-25 10:06:57.756 | File "/usr/lib/python2.7/site-packages/django/conf/__init__.py", line 49, in _setup 2017-04-25 10:06:57.756 | self._wrapped = Settings(settings_module) 2017-04-25 10:06:57.756 | File "/usr/lib/python2.7/site-packages/django/conf/__init__.py", line 132, in __init__ 2017-04-25 10:06:57.756 | % (self.SETTINGS_MODULE, e) 2017-04-25 10:06:57.756 | ImportError: Could not import settings 'openstack_dashboard.settings' (Is it on sys.path? Is there an import error in the settings file?): No module named xstatic.pkg.jquery 2017-04-25 10:06:57.790 | +lib/horizon:configure_horizon:1 exit_trap 2017-04-25 10:06:57.797 | +./stack.sh:exit_trap:487 local r=1 2017-04-25 10:06:57.805 | ++./stack.sh:exit_trap:488 jobs -p 2017-04-25 10:06:57.812 | +./stack.sh:exit_trap:488 jobs= 2017-04-25 10:06:57.819 | +./stack.sh:exit_trap:491 [[ -n '' ]] 2017-04-25 10:06:57.826 | +./stack.sh:exit_trap:497 kill_spinner 2017-04-25 10:06:57.833 ... (more)

2016-05-09 19:35:16 -0500 commented question Invalid resource type oslo::log - Pupper Error while installing Undercloud

Did you get it resolved? I am having the exact same issue. My undercloud is a VM.

Thanks.

2016-05-01 23:43:27 -0500 received badge  Famous Question (source)
2016-04-19 03:01:20 -0500 received badge  Notable Question (source)
2016-03-26 14:26:41 -0500 received badge  Popular Question (source)
2016-03-24 14:17:28 -0500 asked a question devstack installation failure: Discovering versions from the identity service

Hello, My latest openstack installation using devstack from master branch fails with the following error:

2016-03-24 18:12:08.515 | 2016-03-24 11:12:08.514 3355 INFO keystone.cmd.cli [req-ec2ff80e-427a-4cb3-ac92-201b619054b6 - - - - -] Created public endpoint http://172.28.12.92:5000/v2.0
2016-03-24 18:12:10.514 | Discovering versions from the identity service failed when creating the password plugin. Attempting to determine version from URL.
2016-03-24 18:12:10.514 | Could not determine a suitable URL for the plugin
2016-03-24 18:12:10.558 | Error on exit
2016-03-24 18:12:10.902 | df: '/run/user/114/gvfs': Permission denied

This seems similar to:
ttps://bugs.launchpad.net/openstack-manuals/+bug/1454049
https://ask.openstack.org/en/question...

But, i don't see the solution there. This setup was earlier running the juno release which i unstacked and also ran ./clean.sh. Server was rebooted as well.

My local.conf is as follows:

HOST_IP=172.28.12.92
RABBIT_PASSWORD=guest
RABBIT_USERID=guest
SERVICE_TOKEN=abc123
SERVICE_PASSWORD=abc123
ADMIN_PASSWORD=abc123
MYSQL_PASSWORD=abc123
DATABASE_TYPE=mysql
SERVICE_HOST=$HOST_IP
MYSQL_HOST=$SERVICE_HOST
RABBIT_HOST=$SERVICE_HOST
KEYSTONE_AUTH_HOST=$SERVICE_HOST
KEYSTONE_SERVICE_HOST=$SERVICE_HOST

# Enable/Disable services
enable_service n-sch
disable_service n-net
enable_service q-svc
enable_service q-agt
enable_service neutron
enable_service q-dhcp
enable_service q-l3
disable_service tempest

[keystone_authtoken]
auth_host=$SERVICE_HOST
admin_tenant_name=service
admin_user=neutron
admin_password=$ADMIN_PASSWORD

Any help on this would be great.

Thanks, KP

2015-03-30 12:29:26 -0500 received badge  Nice Question (source)
2014-08-25 12:21:51 -0500 received badge  Famous Question (source)
2014-05-23 20:22:12 -0500 received badge  Popular Question (source)
2014-05-23 20:22:12 -0500 received badge  Notable Question (source)
2014-04-07 02:37:47 -0500 asked a question Launch VM fails on Compute when VXLAN ML2 type driver is used

I have two Openstack nodes (controller & Compute and a Compute). VM's are getting launched fine on the node that also acts as the controller. But, the VM's that are scheduled on the compute node seems to go to error state and the error I see on Nova screen is attached at the end. I am running Icehouse version and my ML2 type driver is VXLAN. I used devstack for my installation. If I use non-tunnel mode and change it to VLAN, I don't see this error and VM's are launched fine in compute nodes as well.

My nova.conf in compute does have the following: neutron_url = http://192.28.10.149:9696 neutron_admin_auth_url = http://192.28.10.149:35357/v2.0

Ofcourse, the above IP addresses of controller are reachable from compute.

This is what I have in my ml2_conf.ini in my controller. [ml2] tenant_network_types = vxlan type_drivers = vxlan mechanism_drivers = openvswitch

I assume this file on compute is not needed.

2014-04-06 10:49:45.906 TRACE nova.compute.manager [instance: efede8e5-6bdb-4c2d -8e77-24a45dc7f652] File "/opt/stack/python-neutronclient/neutronclient/v2_0/c lient.py", line 1315, in _pagination 2014-04-06 10:49:45.906 TRACE nova.compute.manager [instance: efede8e5-6bdb-4c2d-8e77-24a45dc7f652] res = self.get(path, params=params) 2014-04-06 10:49:45.906 TRACE nova.compute.manager [instance: efede8e5-6bdb-4c2d-8e77-24a45dc7f652] File "/opt/stack/python-neutronclient/neutronclient/v2_0/client.py", line 1288, in get 2014-04-06 10:49:45.906 TRACE nova.compute.manager [instance: efede8e5-6bdb-4c2d-8e77-24a45dc7f652] headers=headers, params=params) 2014-04-06 10:49:45.906 TRACE nova.compute.manager [instance: efede8e5-6bdb-4c2d-8e77-24a45dc7f652] File "/opt/stack/python-neutronclient/neutronclient/v2_0/client.py", line 1280, in retry_request 2014-04-06 10:49:45.906 TRACE nova.compute.manager [instance: efede8e5-6bdb-4c2d-8e77-24a45dc7f652] raise exceptions.ConnectionFailed(reason=_("Maximum attempts reached")) 2014-04-06 10:49:45.906 TRACE nova.compute.manager [instance: efede8e5-6bdb-4c2d-8e77-24a45dc7f652] ConnectionFailed: Connection to neutron failed: Maximum attempts reached 2014-04-06 10:49:45.906 TRACE nova.compute.manager [instance: efede8e5-6bdb-4c2d-8e77-24a45dc7f652]

Pls let me know if you need more information.

My localrc on Controller is (relevant ones that i thought):

enable_service q-l3

enable_service quantum

Q_PLUGIN=ml2

Q_ML2_PLUGIN_MECHANISM_DRIVERS=openvswitch

Q_ML2_TENANT_NETWORK_TYPE=vxlan

Q_ML2_PLUGIN_TYPE_DRIVERS=vxlan

Q_PLUGIN_EXTRA_CONF_PATH=/home/user1/ML2/devstack

ENABLE_TENANT_VLANS=False

PHYSICAL_NETWORK=physnet2

OVS_PHYSICAL_BRIDGE=br-eth3

ENABLE_TENANT_TUNNELS=True

localrc on compute is:

Q_PLUGIN=ml2

Q_ML2_TENANT_NETWORK_TYPE=vxlan

ENABLE_TENANT_TUNNELS=True

Thanks, Paddu

2013-07-02 14:33:01 -0500 received badge  Famous Question (source)
2013-07-02 14:33:01 -0500 received badge  Notable Question (source)
2013-05-16 08:00:55 -0500 received badge  Famous Question (source)
2013-05-15 02:47:36 -0500 received badge  Notable Question
2013-05-13 21:39:18 -0500 received badge  Popular Question (source)
2013-05-08 14:03:40 -0500 received badge  Popular Question
2013-05-07 01:24:17 -0500 asked a question ENABLE_TENANT_TUNNELS, OVS Version check in Compute fails

I have two servers, one running control and compute in the same node and another running just compute. Intention is to communicate between VM's running in different servers (in turn hypervisors) using tunnels. I am using Grizzly branch and i use devstack for installation. My localrc has ENABLE_TENANT_TUNNELS=TRUE in both control and compute.

When i run stack.sh in the compute node, i get an error:

 [ERROR] ./stack.sh:54 You are running OVS version 1.11.90. OVS 1.4+ is required for tunneling between multiple hosts.

In Folsom branch, i have seen the same error, and stack.sh had the code as follows. But, in Grizzly, it's probably moved to some python library and i don't know where the code is:

The stack.sh had the following comparison. Either the OVS versioning is not right (after 1.9, it should be 2.0?) or the comparison is wrong. Is that right? Then, is this a bug? Any workarounds?

     if [[ "$OVS_ENABLE_TUNNELING" = "True" ]]; then
         # Verify tunnels are supported
         # REVISIT - also check kernel module support for GRE and patch ports
         OVS_VERSION=`ovs-vsctl --version | head -n 1 | awk '{print $4;}'`
         if [ $OVS_VERSION \< "1.4" ] && ! is_service_enabled q-svc ; then
             echo "You are running OVS version $OVS_VERSION."

Thanks, KP

2013-05-07 01:14:28 -0500 answered a question Floating IP in localrc. My default GW is changed thus losing connectivity

I came to now that this was a bug in Folsom..sigh... Went away after i moved to Grizzly.

2013-05-07 01:08:53 -0500 received badge  Famous Question (source)
2013-05-06 07:14:02 -0500 received badge  Notable Question (source)
2013-05-01 08:17:44 -0500 received badge  Popular Question (source)
2013-04-25 01:20:12 -0500 received badge  Notable Question (source)
2013-04-23 16:32:33 -0500 asked a question Floating IP in localrc. My default GW is changed thus losing connectivity

I am using devstack to install openstack in a Ubuntu 12.04 physical server. It's Folsom release and my plugin is OVS.

Say, i am located on 172.28.12.0 subnet. My default GW is 172.28.12.1. I have eth0 connected for my GW access. If I comment out FLOATING_IP in localrc, it's setting my default gateway to 172.24.4.225, and my network connectivity after running ./stack.sh is lost.

My understanding is the floating IP is to to reach the VM from outside and so the IP should be a publicly reachable one. Right? If i specify a unused range in the subnet like: "FLOATING_RANGE=172.28.12.192/26"

Then my default GW is made to 172.28.12.193 and again my connectivity is lost.

So, what value should I set here?

    $ route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         172.24.4.225    0.0.0.0         UG    0      0        0 qg-7c93dce4-36
0.0.0.0         172.28.12.1     0.0.0.0         UG    100    0        0 eth0
10.0.0.0        0.0.0.0         255.255.255.0   U     0      0        0 tapa2296d23-ad
10.0.0.0        0.0.0.0         255.255.255.0   U     0      0        0 qr-5f2a00e1-e2
172.24.4.224    0.0.0.0         255.255.255.240 U     0      0        0 qg-7c93dce4-36
172.28.12.0     0.0.0.0         255.255.255.0   U     0      0        0 eth0

My localrc is:

#OFFLINE=True
#RECLONE=yes
disable_service n-net
enable_service q-svc
enable_service q-agt
enable_service q-dhcp
enable_service q-l3
enable_service quantum
#enable_service rabbit n-cpu quantum q-agt
#enable_service ryu
HOST_NAME=$(hostname)
SERVICE_HOST_NAME=${HOST_NAME}
SERVICE_HOST=172.28.12.128
#FLOATING_RANGE=172.28.12.192/26
Q_PLUGIN=openvswitch
#LIBVIRT_FIREWALL_DRIVER=nova.virt.firewall.NoopFirewallDriver
Q_HOST=$SERVICE_HOST
Q_USE_NAMESPACE=False
ENABLE_TENANT_TUNNELS=True
MYSQL_HOST=$SERVICE_HOST
RABBIT_HOST=$SERVICE_HOST
GLANCE_HOSTPORT=$SERVICE_HOST:9292
KEYSTONE_AUTH_HOST=$SERVICE_HOST
KEYSTONE_SERVICE_HOST=$SERVICE_HOST
MYSQL_PASSWORD=admin
RABBIT_PASSWORD=admin
SERVICE_TOKEN=admin
SERVICE_PASSWORD=admin
ADMIN_PASSWORD=admin
SCHEDULER=nova.scheduler.simple.SimpleScheduler
LOG_DIRS=/logs/
SCREEN_DIR=/logs/screen
LOGFILE=/logs/stack.sh.log
# compute service
NOVA_BRANCH=stable/folsom
# volume service
CINDER_BRANCH=stable/folsom
# image catalog service
GLANCE_BRANCH=stable/folsom
# unified auth system (manages accounts/tokens)
KEYSTONE_BRANCH=stable/folsom
# quantum service
QUANTUM_BRANCH=stable/folsom
# django powered web control panel for openstack
HORIZON_BRANCH=stable/folsom
VERBOSE=True
DEBUG=True
#ENABLED_SERVICES=g-api,g-reg,key,n-api,n-crt,n-obj,n-cpu,n-cond,cinder,c-sch,c-api,c-vol,n-sch,n-novnc,n-xvnc,n-cauth,horizon,rabbit,mysql

Thanks, KP

2013-04-23 15:44:50 -0500 commented answer Devstack failure Folsom: error in gnutlshandshake and HTTP 500

Thanks for the reply, arosen. Even after i checked out "python-keystoneclient" to folsom-1, i get the same "gnutlshandshake()" error.

2013-04-23 04:05:51 -0500 received badge  Popular Question (source)
2013-04-21 20:35:59 -0500 received badge  Student (source)
2013-04-19 11:57:33 -0500 received badge  Editor (source)
2013-04-19 11:52:36 -0500 answered a question Devstack failure Folsom: error in gnutlshandshake and HTTP 500

[Sorry this is Not a answer, but reply to 'flaper87's comment. ]

Thanks for the reply. Here's my localrc file. I am trying to run control/compute in the same server. Since i am running in a lab m/c, i have installed TSocks and have aliases for git and wget as 'tsocks git' and 'tsocks wget'. If i don't have a httpproxy specified, i get a timeout, when setup is run under glance. If i specify my httpproxy, i get the above error.

disable_service n-net

enable_service q-svc

enable_service q-agt

enable_service q-dhcp

enable_service q-l3

enable_service quantum

enable_service rabbit n-cpu quantum q-agt

HOST_NAME=$(hostname)

SERVICEHOSTNAME=${HOST_NAME}

SERVICE_HOST=172.28.12.128

Q_PLUGIN=openvswitch

QHOST=$SERVICEHOST

QUSENAMESPACE=False

ENABLETENANTTUNNELS=True

MYSQLHOST=$SERVICEHOST

RABBITHOST=$SERVICEHOST

GLANCEHOSTPORT=$SERVICEHOST:9292

KEYSTONEAUTHHOST=$SERVICE_HOST

KEYSTONESERVICEHOST=$SERVICE_HOST

MYSQL_PASSWORD=hello

RABBIT_PASSWORD=hello

SERVICE_TOKEN=hello

SERVICE_PASSWORD=hello

ADMIN_PASSWORD=hello

SCHEDULER=nova.scheduler.simple.SimpleScheduler

LOG_DIRS=/home/devstack/logs/

SCREEN_DIR=/home/devstack/logs/screen

LOGFILE=/home/devstack/logs/stack.sh.log

NOVA_BRANCH=stable/folsom

CINDER_BRANCH=stable/folsom

GLANCE_BRANCH=stable/folsom

KEYSTONE_BRANCH=stable/folsom

QUANTUM_BRANCH=stable/folsom

HORIZON_BRANCH=stable/folsom

VERBOSE=True

DEBUG=True

2013-04-17 22:34:14 -0500 asked a question Devstack failure Folsom: error in gnutlshandshake and HTTP 500

I am trying to install Openstack using devstack. I am installing it in a server running Ubuntu 12.04. My localrc file has the branch set to "stable/folsom" and the following is present:

"disableservice n-net" "enableservice q-svc" "enableservice q-agt" "enableservice q-dhcp" "enableservice q-l3" "enableservice quantum" "enable_service rabbit n-cpu quantum q-agt" "

I see the following error and finally (stack.sh) installation fails.

2013-04-16 00:52:19 + cd /opt/stack/glance

2013-04-16 00:52:19 + python setup.py egginfo 2013-04-16 00:58:38 error: gnutlshandshake() failed: A TLS packet with unexpected length was received. while accessing https://github.com/openstack/glance.git/info/refs
....

…..
2013-04-17 12:47:21 + /home/devstack/devstack/tools/create_userrc.sh -PA --target-dir /home/devstack/devstack/accrc
2013-04-17 12:47:22 ERROR: The server has either erred or is incapable of performing the requested operation. (HTTP 500)
2013-04-17 12:47:22 Failed to update the root certificate: /home/devstack/devstack/accrc/cacert.pem

I saw some similar problem and followed these instructions:

Then, now i am getting:

/opt/stack/glance$ python setup.py egg_info
error: Unknown SSL protocol error in connection to github.com:80 while accessing https://github.com/openstack/glance.git/info/refs
fatal: HTTP request failed
fatal: Invalid object name 'meta/openstack/release'.
running egg_info    
writing requirements to glance.egg-info/requires.txt writing glance.egg-info/PKG-INFO

I didn't see similar failures when "setup.py" was run from other directories like /opt/stack/horizon, /opt/stack/keystone etc.

I am trying to run control/compute in the same server. Since i am running in a lab m/c, i have installed TSocks and have aliases for git and wget as 'tsocks git' and 'tsocks wget'. If i don't have a httpproxy specified, i get a timeout, when setup is run under glance. If i specify my httpproxy, i get the above error.

My localrc file:

disable_service n-net
enable_service q-svc
enable_service q-agt
enable_service q-dhcp
enable_service q-l3
enable_service quantum
enable_service rabbit n-cpu quantum q-agt
HOST_NAME=$(hostname)
SERVICEHOSTNAME=${HOST_NAME}
SERVICE_HOST=172.28.12.128
Q_PLUGIN=openvswitch
QHOST=$SERVICEHOST
QUSENAMESPACE=False
ENABLETENANTTUNNELS=True
MYSQLHOST=$SERVICEHOST
RABBITHOST=$SERVICEHOST
GLANCEHOSTPORT=$SERVICEHOST:9292
KEYSTONEAUTHHOST=$SERVICE_HOST
KEYSTONESERVICEHOST=$SERVICE_HOST
MYSQL_PASSWORD=hello
RABBIT_PASSWORD=hello
SERVICE_TOKEN=hello
SERVICE_PASSWORD=hello
ADMIN_PASSWORD=hello
SCHEDULER=nova.scheduler.simple.SimpleScheduler
LOG_DIRS=/home/devstack/logs/
SCREEN_DIR=/home/devstack/logs/screen
LOGFILE=/home/devstack/logs/stack.sh.log
NOVA_BRANCH=stable/folsom
CINDER_BRANCH=stable/folsom
GLANCE_BRANCH=stable/folsom
KEYSTONE_BRANCH=stable/folsom
QUANTUM_BRANCH=stable/folsom
HORIZON_BRANCH=stable/folsom
VERBOSE=True
DEBUG=True