Ask Your Question

sivasamyk's profile - activity

2014-05-09 23:02:19 -0500 received badge  Famous Question (source)
2014-04-29 13:09:14 -0500 received badge  Famous Question (source)
2014-04-27 09:39:19 -0500 received badge  Notable Question (source)
2014-04-27 09:39:19 -0500 received badge  Popular Question (source)
2014-03-31 01:14:48 -0500 received badge  Popular Question (source)
2014-03-31 01:14:48 -0500 received badge  Notable Question (source)
2014-03-31 01:14:47 -0500 received badge  Famous Question (source)
2014-03-30 23:35:31 -0500 received badge  Famous Question (source)
2014-03-14 10:29:40 -0500 received badge  Famous Question (source)
2014-03-03 22:04:54 -0500 received badge  Notable Question (source)
2014-02-24 05:51:04 -0500 received badge  Popular Question (source)
2014-02-12 13:19:10 -0500 received badge  Editor (source)
2014-02-12 13:00:16 -0500 commented question Fedora instance failed to start

The log should have more details about the resource. Please grep for ERROR in the compute log file for more information.

2014-02-12 12:28:08 -0500 asked a question instance boot up hangs in multi-node setup
  • Setup : devstack multi node configuration with 1 Controller+compute and 1 Compute node.
  • Images : Cirros & CentOS 6.5
  • Hypervisor : kvm

  • Launching an instance in Controller node with Cent OS - success & reachable

  • Launching an instance in Compute node with Cirros - success & reachable
  • Launching an instance in Compute node with Cent OS - Fail - Dashboard show the instance is active - instance not reachable

Let me know how to further debug this issue or places to look for more clues.

Observations:

  • In case of CentOS instance the ramdisk& kernel file is not present at /opt/stack/data/nova/instances/<id>

libvirtd.log

2014-02-13 01:53:21.556+0000: 7883: error : virNWFilterDHCPSnoopEnd:2131 : internal error ifname "vnet0" not in key map
2014-02-13 01:53:21.557+0000: 7883: error : virNetDevGetIndex:653 : Unable to get index for interface vnet0: No such device

Console log:

  [1;256r[256;256H[6n
Google, Inc.
Serial Graphics Adapter 12/07/11
SGABIOS $Id: sgabios.S 8 2010-04-22 00:03:40Z nlaredo $ (mockbuild@c6b18n1.dev.centos.org) Wed Dec  7 17:04:47 UTC 2011
Term: 80x24
4 0
[2JSeaBIOS (version seabios-0.6.1.2-28.el6)
Machine UUID 69d2575e-2ce0-4109-9cab-a082712f953c
gPXE (http://etherboot.org) - 00:03.0 C100 PCI2.10 PnP BBS PMM07E0@10 C100
Press Ctrl-B to configure gPXE (PCI 00:03.0)...                                                                               
Booting from Hard Disk...
[2J
2014-02-11 07:20:31 -0500 received badge  Notable Question (source)
2014-02-07 00:45:53 -0500 received badge  Notable Question (source)
2014-02-07 00:45:28 -0500 received badge  Enthusiast
2014-02-06 23:49:23 -0500 commented answer How to get latest openstack code using devstack?

@harry My question is 1) Assume I clone devstack using the mentioned commands (git clone) on date x and run stack.sh 2) This clones all openstack git repos at /opt/stack dir 3) Now on date x+20, when I run stack.sh again, it does not update my openstack repos @ /opt/stack. Is there an option to stack.sh to update openstack repos cloned @ /opt/stack to the latest?

2014-02-06 10:28:16 -0500 received badge  Popular Question (source)
2014-02-05 13:01:14 -0500 asked a question How to get latest openstack code using devstack?

I have installed openstack using devstack. What is the procedure to update my openstack code at /opt/stack to latest from git and launch a devstack with latest code?

2014-02-05 11:26:48 -0500 commented question newbie : only one screen terminal after installing devstack

Did you try clean.sh?

2014-02-05 00:25:22 -0500 received badge  Popular Question (source)
2014-02-04 23:16:02 -0500 asked a question devstack instance not reachable on VirtualHost with NAT

My devstack instance not reachable on Virtual Host with NAT

The instance is shown active in the Horizon dashboard, but not reachable. I am able to launch a console from dashboard.

As per the below console log of instance, no instance ID or IP address is assigned to the instance.

The floating IP assigned to the instance is 10.0.2.226. This IP is not reachable from the Ubuntu machine.

The instances are reachable when I start the Virtual Host with bridge configuration

Following is my configuration:

Host : Windows 7 Guest : Ubuntu 12.04 (using Virtual Box) with NAT networking with IP : 10.0.2.15

Devstack started in Ubuntu with following localrc file:

DATABASE_PASSWORD=mydevstack
RABBIT_PASSWORD=mydevstack
SERVICE_TOKEN=mydevstack
SERVICE_PASSWORD=mydevstack
ADMIN_PASSWORD=mydevstack
SCREEN_LOGDIR=$DEST/log/screen
VERBOSE=True
HOST_IP=10.0.2.15
FLAT_INTERFACE=eth0
FIXED_RANGE=192.168.0.1/24
FIXED_NETWORK_SIZE=256
FLOATING_RANGE=10.0.2.224/27

Console log of the instance:

Starting network... 
udhcpc (v1.18.5) started 
Sending discover... 
Sending select for 10.0.2.16... 
Lease of 10.0.2.16 obtained, lease time 86400 
deleting routers 
route: SIOCDELRT: No such process 
adding dns 10.220.0.12 
adding dns 10.100.98.21 
adding dns 10.220.0.11 
cloud-setup: checking http://169.254.169.254/2009-04-04/meta-data/instance-id 
wget: can't connect to remote host (169.254.169.254): No route to host 
cloud-setup: failed 1/30: up 10.25. request failed 
wget: can't connect to remote host (169.254.169.254): No route to host 
cloud-setup: failed 2/30: up 14.59. request failed 
wget: can't connect to remote host (169.254.169.254): No route to host 
cloud-setup: failed 3/30: up 17.59. request failed 
wget: can't connect to remote host (169.254.169.254): No route to host 
cloud-setup: failed 4/30: up 21.66. request failed 
wget: can't connect to remote host (169.254.169.254): No route to host 
cloud-setup: failed 5/30: up 24.66. request failed 
wget: can't connect to remote host (169.254.169.254): No route to host 
cloud-setup: failed 6/30: up 28.75. request failed 
wget: can't connect to remote host (169.254.169.254): No route to host 
cloud-setup: failed 7/30: up 31.76. request failed 
wget: can't connect to remote host (169.254.169.254): No route to host 
cloud-setup: failed 8/30: up 35.87. request failed 
wget: can't connect to remote host (169.254.169.254): No route to host 
cloud-setup: failed 9/30: up 38.88. request failed 
wget: can't connect to remote host (169.254.169.254): No route to host 
cloud-setup: failed 10/30: up 43.00. request failed 
wget: can't connect to remote host (169.254.169.254): No route to host 
cloud-setup: failed 11/30: up 47.10. request failed 
wget: can't connect to remote host (169.254.169.254): No route to host 
cloud-setup: failed 12 ...
(more)
2014-01-31 10:49:47 -0500 received badge  Student (source)
2014-01-29 12:18:19 -0500 commented question packstack installation fails with mysql access denied error

@sgordon it is all-in-one installation @cloudssky I have already tried packstack uninstallation but to no avail. For now I have started packstack without all-in-one and mysql with 127.0.0.1 as IP address. It seems to work fine so far.

2014-01-29 11:38:05 -0500 asked a question Error mounting libguestfs - Cannot resize. is_image_partitionless

Installed latest openstack on CentOS 6.4 using packstack. After launching an instance successfully , ssh login to the instance with key pair prompts for password.

In compute.log file, I found the following error:

2014-01-29 22:38:26.450 1655 DEBUG nova.virt.disk.api [req-998b3e4d-3b5c-4dc5-9f95-e157ca43aa4b 43aee95769bf4173b61909192a46e129 184538a7e1fa456783ce5bef3efa1b02] Unable to mount image /var/lib/nova/instances/86e9d2c5-52ae-433c-a0f2-c56456471b09/disk with error Error mounting /var/lib/nova/instances/86e9d2c5-52ae-433c-a0f2-c56456471b09/disk with libguestfs (mount_options: /dev/sda on / (options: ''): mount: you must specify the filesystem type). Cannot resize. is_image_partitionless /usr/lib/python2.6/site-packages/nova/virt/disk/api.py:183

I am able to use guestfish command to see the above filesystem and libguestfs-test-tool output showed "TEST FINISHED OK".

How to recover from this error?

Note : Will the patch mentioned at https://bugs.launchpad.net/nova/+bug/1246852 work? If so let me know how apply this patch in my openstack installation (just changing the respective python files does not seem to work)

2014-01-28 11:32:49 -0500 asked a question packstack installation fails with mysql access denied error

While installing packstack in CentOS 6.4 I am getting following error :

2014-01-28 13:40:05.135 9318 CRITICAL keystone [-] (OperationalError) (1045, "Access denied for user 'keystone_admin'@'CENT-LINUX-DT' (using password: YES)") None None

Command used to install packstack :

packstack --allinone

I tried deleting the mysql installation (as mentioned in http://openstack.redhat.com/forum/discussion/238/resolved-install-error-with-nagios/p1 ), clearing /var/lib/mysql and reinstalling mysql, with no effect.

If I try to login into mysql using " mysql -u keystone_admin -p" with password as mentioned in /etc/keystone.conf file login is sucessful. If I use "mysql -u keystone_admin -h IP_ADDRESS -p" login fails.

Let me know how I can resolve this issue or if more informatoin/logs is required.