Choco's profile - activity

2014-10-16 16:42:29 -0600 received badge  Teacher (source)
2014-04-08 05:40:55 -0600 answered a question ping google.com getting late response in VM instance

Hello,

There are a lot of reason which can cause this. When I tried to ping google from my instance on our XEN-Server (in Germany) he tried to go to "173.194.70.94". It took each request around 6 ms. Quite Okay. But if I try to ping your google server (74.125.236.164) it takes each request 300 to 400 ms.

The simplest solution could be that you just connected to a google server which is very far away or that your network is overloaded. So just try to connect to near hosts (maybe local, then one where you now that it is in the same city/country). You can also try tracepath to see on which hop it takes so long.

Otherwise we need more Information about your Environment you are working in: e.g. which host do you use, how did you setup network, configs etc.

2014-04-07 05:03:56 -0600 commented answer Cannot ping external network from VM

I have to say that I seem to ignored to a few facts from your first post. It's not normal that you can't ping external IPs (e.g. www.google.de ). I tought that you can't ping other instances with their respective floating ip from another instance. But you seem to have found the solution!

2014-03-31 05:56:30 -0600 received badge  Supporter (source)
2014-03-31 05:53:45 -0600 answered a question Cannot ping external network from VM

I face the same things since a few months but i really don't know if this is a bug or intended. The floating ips are routed with NAT from your Openstack node so instances shouldn't be able to know which floating ip is allocated to them.

It's like in your local network. Your PC doesn't know which ports on your router he gets to talk with the rest of the internet, does he? Just because we are using now full IPs instead of IP+Ports doesn't mean NAT-behaviour will change.

I'm just using internal IPs and told all my colleagues to do the same. But perhaps I'm wrong and someone will post a solution and I can make my colleagues happy again.

2013-06-28 09:55:25 -0600 received badge  Taxonomist
2013-06-09 03:19:10 -0600 received badge  Famous Question (source)
2013-04-25 14:39:35 -0600 commented answer Nova is caching and using a wrong IP

Thanks a lot! I added export OS_NO_CACHE=true to my credential files.

But this can't be the long term solution for the problem!?

2013-04-24 05:16:56 -0600 received badge  Notable Question (source)
2013-04-16 23:28:01 -0600 received badge  Popular Question (source)
2013-04-12 19:39:09 -0600 received badge  Student (source)
2013-04-12 10:52:25 -0600 commented question Why Nova Services appear in XXX state?

If you have restarted/started the services and they are not running they probably shutdown themself. Look into the nova-logs and look for errors or post them.

2013-04-10 13:05:04 -0600 received badge  Editor (source)
2013-04-10 12:53:42 -0600 asked a question Nova is caching and using a wrong IP

Hello Everyone,

My task ist to install OpenStack(folsom: Keystone, Glance, Nova) on one node with Xen and Ubuntu 12.04 as Dom0. After installing and configuring everything with a manual I experienced following problem.

First: I had a mistake in the endpoint table of keystone which linked to 192.168.206.130 (it was an example IP of the manual)... I changed those to localhost later but nova seems to have cached the example IP. When I run $nova --debug image-list with the right credentials for a non-administrator user on port 5000 and he responded with: REQ: curl -i http:// 192.168.206.130:8774/v2/<..........> and a 404 simply because of a wrong IP. That's why I tried to add the --no-cache-option and he responded with the right curl and the right table. It's the same with the other glance-related nova commands (e.g. nova list)

So someone can give me a solution to fix the cache or give me a hint?