shnkc's profile - activity

2014-06-05 08:38:21 -0500 received badge  Famous Question (source)
2014-04-15 10:54:37 -0500 received badge  Famous Question (source)
2014-04-10 01:14:58 -0500 received badge  Notable Question (source)
2014-02-17 15:26:42 -0500 received badge  Popular Question (source)
2014-02-17 13:20:31 -0500 received badge  Popular Question (source)
2014-02-17 13:20:31 -0500 received badge  Notable Question (source)
2014-02-08 23:25:09 -0500 commented question Unable to create a tenant for an administrative user. Please help me

Remove prefix `OS_`. Just SERVICE_TOKEN and SERVICE_ENDPOINT. It should work if they have initial values. The error is not exactly clear. Are you still getting credentials error, or just `unable to establis..` error? Did you make changes on your configuration files? Bec problem seems changed

2014-02-08 23:08:47 -0500 commented question Unable to create a tenant for an administrative user. Please help me

Set SERVICE_TOKEN to "ADMIN". Give it a try. Let us know the result.

2014-02-08 23:04:58 -0500 received badge  Supporter (source)
2014-02-08 23:03:55 -0500 answered a question how to solve keystone error"Expecting an auth URL via either --os-auth-url or env[OS_AUTH_URL]" on havana

Copy following lines into a bash script and run it:

export SERVICE_TOKEN="ADMIN"
export SERVICE_ENDPOINT="http://controller:35357/v2.0" 
keystone tenant-create --name=admin

The script should successfully complete the process.

2014-02-05 03:47:44 -0500 received badge  Student (source)
2014-02-05 02:33:22 -0500 asked a question How to upgrade quantum to neutron

In havana release notes, before upgrading openstack network service to neutron, it specifies some ways to follow. However, I have an issue with this guide. First of all, these are the points given:

- Ensure that the database is stamped for Grizzly prior to stopping service.quantum-db-manage --config-file /path/to/quantum.conf --config-file /path/to/plugin/conf.ini stamp grizzly
- Stop quantum-server and deploy the Neutron code Do not start the neutron-server at this time.
- Run Havana Migration neutron-db-manage --config-file /path/to/quantum.conf --config-file /path/to/plugin/conf.ini upgrade havana
- Start neutron-server

My problem is how to deploy neutron code without starting it. If I install it, it is automatically started. However, eventually, I will run neutron-db-manage. Should I run it from neutron package before installation? Or is there another way to do it? Thanks.

2014-01-31 06:57:34 -0500 received badge  Enthusiast
2014-01-28 04:16:37 -0500 received badge  Scholar (source)
2014-01-28 04:16:35 -0500 commented answer Uncompatibility of openstack-havana projects with python six library

I understand. I have found the issue and solved it. But it is important that this error log continues to be printed. If it is not problematic, then log should not be printed. Right?

2014-01-27 09:09:21 -0500 received badge  Editor (source)
2014-01-27 09:07:44 -0500 asked a question Uncompatibility of openstack-havana projects with python six library

I have installed openstack-havana and tried to create first instance. It stucks in 'scheduling' phase. In nova logs, (logs of almost all nova services) I have seen the following error:

ERROR stevedore.extension [-] Could not load 'file': (six 1.4.0 (/usr/local/lib/python2.7/dist-packages), Requirement.parse('six<1.4.0'))

six version is 1.4.0. With latest version, I have got the same error line. Then, I downgraded the version to 1.3.0 and , I have got following error:

ERROR stevedore.extension [-] Could not load 'file': (six 1.3.0 (/usr/local/lib/python2.7/dist-packages), Requirement.parse('six>1.4.0'))

Is this a bug, or what is it about? Any ideas?